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1 Welcome 

Developing applications for a EH-HMI panel is quick and painless when using EH-View 
software. The common functionality found among many Windows  applications can also be 
found in EH-View. This familiar interface style helps new users to quickly learn the EH-View 
software. 
  
A completed project file of format *.dpr contains all the information needed to display your 
page images and controller data values in the formats you selected while creating your project 
file. The panel hardware will handle all of the underlying communications necessary to 
transfer data to and from the controller, leaving you free to concentrate on the appearance and 
functionality of your data and display pages. 
  
Note: Depending on the particular configuration of your project, one or more additional files 
may be necessary to convey all the necessary information about a project. These additional 
files may contain information about Keypad Designer, UniSSFDC, Font Editor, Nice Font 
Editor, etc. The project file itself may, in certain cases, not be sufficient to contain all the 
information necessary to reproduce the application. 
  
EH-View makes it possible to work in a natural and intuitive way using the logic behind your 
control application to guide you through development. You can use EH-View to create one or 
more display pages that outline and control your applications. The multiple page capability of 
each panel allows any application to be broken down into as many pages as you want, 
depending only on the amount of memory in your target system. Completed projects can be 
recalled from disk or from the panel itself for further modification. 
  
For information regarding hardware operation, please see the EH-HMI Installation & 
Operation Guide 
  
  
  
(Internal Manual Code: 05.005) 

2 Quick Start 

2.1 Quick Start Tutorial Introduction 

The Quick Start Tutorial shows how the EH-View software is used to develop applications 
for the EH-HMI panel. 
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Though the chosen example is very simple, it goes through all the steps that are normally used 
to develop normal applications, even the most complex ones.  
  
At the end of the tutorial you will not be able to perform the single steps in detail, you will not 
know all the EH-View features, how and when to use them. What you will have is a general 
feeling of what is required to develop an application, which tasks have to be performed and 
how easy is their execution thanks to the EH-View software. 
  
Note: The tutorial assumes that you have already installed the software. 
  

2.1.1 Development Environment Setup 

 
  
The above figure shows a typical, complete setup for the development of applications. 
  
Users develop their applications with the EH-View software and download them into the EH-
HMI panel.  The panel in turn is connected to one or more Controllers (PLCs).  
  
The developed applications can display the Controller(s) I/Os on the EH-HMI panel and also 
can send commands to the connected Controller(s). 
  
The EH-HMI contains a software simulated Demo Controller that allows the development 
and testing of applications even when real Controllers are not available. 
  
  
To the Quick Start Tutorial 
  

2.2 Quick Start Tutorial 

o Connect the programming cable from the PC to the panel. 
  

o Connect the controller's communication cable to the panel. 
  

o Locate the EH-View icon on your PC desktop and click on it. 
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o Once the EH-View is open, create a new project file by selecting New from the File 
menu. 
  

o Give the new project a name, select a file location, 
 

 
 
 and click OK. 
  

o Select Project - Configure Controller. 
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 The currently selected controller is displayed. 
  

o Click on the "..." button to select a different driver, if necessary. 
 

 
   

o Press the Controller Setup button to select the particular controller model being used. For 
this first example it is better to select the DEMO Controller. 
 

 
   

o If required, set up the panel-to-controller communication parameters by pressing the 
PLC/Drive Comm button (you don't need to perform this step if you selected the DEMO 
Controller). 
  

o Set the parameters, then click on OK to confirm your selections and close the open 
dialog boxes. 
  

o Select Project - Panel Setup. Select the type of display representative of your EH-HMI 
panel. 
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 This step could be eliminated by placing the panel in Configuration Mode and selecting 
Get Panel Resources from the Transfers menu. 
 

 
   

o You are now ready to begin designing the project page. Click somewhere on the project 
page and, using the PC keyboard, type the words "This is a data value =" on the first 
page of the project. 
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o Select Insert - Data Fields - Numeric/ASCII. The cursor will turn into crosshairs. Use the 
cursor to define the boundaries of a small box following the phrase you typed on the 
page. 
  

o The Properties dialog box will appear on the screen. 
 

 
 
 Click the "…" button under Reference. 
   

o The Data Field Properties dialog box will appear on the screen. 
 

 
 
 Fill in the Data Field Properties dialog box with the appropriate data. The data reference 
MUST already exist in the controller. Keep in mind that this dialog box is controller 
specific. 
  

o Click on the OK button in order to confirm the controller information. 
  

o Click on the OK button in order to confirm the numeric field properties and create the 
data field. The following figure shows the resulting screen. 



EH-VIEW (en) - July 2005 - 05/005 

Page 12 

 

 
   

o Select Save from the File menu. 
  

o Select Transfers - Options - Serial Ports 
 

 
 
 Choose the communications port that EH-View will use to communicate with the panel. 
Ports that are unavailable will be grayed out. Under normal circumstances, use the 
following parameters to communicate with a panel: 38400 baud, no parity, and 1 stop bit. 
  

o Power up the EH-HMI panel and make sure it is in Configuration Mode. The panel must 
be in Configuration Mode to communicate with the EH-View software! When the unit is 
in Configuration Mode, the words CONFIGURATION MODE will appear on the panel. 
If you do not see the words CONFIGURATION MODE displayed on the panel: 
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o Hold down the Enter key or touch an empty spot on the screen until the command 
menu appears. 
  

o Use the arrow keys to highlight CONFIG or CFG and press Enter again. 
  

o Select Transfers - Download from EH-View to send the project to the panel. 
 

 
 
 If the default setup of the EH-View software has not been changed, the project will start 
automatically after being downloaded. 
  

o After a short pause, check the display: 
  
o The text that was typed in previous step should be visible, along with the data value 

read from the controller. 
  

o The Fault light should be off. 
  

o The Com and Run lights (if present) should be on. A blinking Com light indicates a 
communications error. 

  

3 Installation 

3.1 Overview 

This section provides: 
  
o the assumptions and conventions used in this documentation, 

  
o system requirements for using EH-View, 

   
o software installation instructions, 

  
o instructions for solving installation problems, 
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o basic instructions for connecting a EH-HMI panel to the PC, 
  

o contact information, 
  

o technical support contacts, 
  

o instructions for reporting a bug, 
  

o compatibility information for previous versions and 
  

o software license and disclaimer. 

3.2 Assumptions 

We assume that those reading this manual are using the EH-View software to design control 
panel applications to run on EH-HMI panels. 
  
We also assume that you have a basic understanding of PCs, Microsoft Windows , and the 
type of network environment in which you will run the application.  
  
  

3.3 Conventions 

Names of menus and commands on menus are shown in bold type, as are the names of dialog 
boxes. For example, "A new project may be created by selecting New from the File menu." If 
the name of the command or menu is highlighted, it is linked to another topic in the help text. 
For example, "Select Get Panel Resources from the Transfers menu." 
  
Keyboard keys that you should press are shown in bold, as in "Press Enter." If two keyboard 
keys are to be pressed at the same time, they are shown in bold with a plus sign (+) between 
them, as in "Press Ctrl+F2." 
  
Text that you are to type into a box appears in bold in a different font (Courier), for example, 
"Type D:\setup in the box." 
  
  

3.4 System Requirements 

The following hardware / software is required to use EH-View. 

3.4.1 Free hard disk space 

EH-View, once installed, takes around 70 MB of hard disk space. The installation procedure 
(only at installation time) requires twice as much (i.e. 140 MB). 
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3.4.2 RAM Memory 

EH-View runs on systems with at least 32 MB RAM memory. 

3.4.3 Supported Operating Systems: 

o Windows 98  
  

o Windows NT  version 3.51 and above 
  

o Windows ME  
  

o Windows 2000  
   

o Windows XP  
  

3.5 Previous Versions 

It is not necessary to remove previous versions of EH-View from your PC.  
  
EH-View does not write over previous versions. Any previous versions will remain on your 
PC alongside the new version. 
  
Note: Previous versions of EH-View used the file format .prj. This version of EH-View 
generally uses the file format .dpr. However, this version of EH-View can also open and use 
.prj files to maintain compatibility with previous versions of the software. 
  

3.6 Software Installation 

Note: Microsoft Windows  must be installed before installing the EH-View software. 
  
To install EH-View: 
  
o Close all other programs. 

  
o Insert the CD-ROM into CD-ROM drive. If your system has Autorun enabled, the EH-

View installation will start automatically. If so, skip to step 5. 
  
o Click on the Start button and select Run from the popup menu. 

  
o Type D:\setup in the box (if your CD-ROM drive is not drive D, substitute the 

appropriate letter). 
  
o  Follow the on screen prompts. 
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The default location for the EH-View software is "c:\Hitachi\EH-View 6". If you prefer to 
have the software at a different location on your hard drive, you have that option. 
  

 
  
There are two types of setup available with the EH-View software. They are: 
  

o Typical - The EH-View software is installed with the most common options. This is 
recommended for most users. 
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o Custom - You may choose the options that you want to install. This is recommended 
for advanced users. 

  
The installation procedure will create a program group entitled "EH-View" within 
Windows . A EH-View icon will be added to your desktop. EH-View also appears on the 
Windows  start menu under Start-Programs-EH-View. 

3.7 Connecting the Panel to the PC 

Your EH-HMI panel should be set up according to the instructions in the EH-HMI 
Installation & Operation Guide. However, most panels are quite simple to set up. General 
setup instructions include: 
  
o Place the panel on a stable surface. 

  
o Connect one end of an appropriate connection cable to the appropriate port on the panel. 

  
o Connect the other end of the connection cable to the appropriate port on the computer. 

  
o Connect one end of the power cable to the panel. 

  
o Connect the other end of the power cable to the power source. 

  
o If the panel was never programmed before, it should power up in Configuration Mode. 

  
See Panel Setup for information on how to initialize and set up the panel. 
  
  

3.8 Solving Installation Problems 

The installer will report various types of errors if it encounters any during the installation. 
  
If necessary, contact Technical Support to determine the cause of these errors. 
  

3.9 How to Report a Bug 

The EH-View development team is proud to present a high quality program with minimal 
bugs. Despite their best efforts, however, bugs do occasionally appear in the software. Should 
you notice a problem with the software that you think may be a bug, please report it to: 
  
info@hitachi-ds.com 
  
Please include as much information as possible, including a description of the irregularity, the 
type of PC and panel that you have, any other software that was running when the problem 
occurred, and the sequence of steps that led to the problem. 
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3.10 Technical Support 

For questions about the EH-View software, contact Hitachi by sending an email to the 
following address: 
  
info@hitachi-ds.com 
  
  

3.11 Contact Information 

Hitachi can be found on the Internet at the following address: 
  
Hitachi Europe GmbH  
Am Seestern 18 
D-40547 Duesseldorf 
P.O. Box 110536 D-40505 Duesseldorf 
Phone: +49 (211)52830 
Fax: +49(211)5283649  
  
http://www.hitachi-ds.com 
  

4 Reference 

4.1 File Menu 

4.1.1 File Menu 

The File menu contains familiar Windows  commands for managing files and printing. 
  
o New 

  
o Open 

  
o Close 

  
o Save 

  
o Save As 

  
o Print 

  
o Print Preview 

  
o Print Setup 
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o Export to TagDB 

  
o Export Strings 

  
o Import Strings 

  
o Recent Files 

  
o Exit 

  

4.1.2 New 

A new project may be created by selecting New from the File menu, by clicking the New File 
icon, or by pressing the Ctrl+N keys. This opens the New Project dialog box.  
  

 
  
Enter a name for the new project and select the file location on the PC where the project file is 
to be stored. Click on an icon to identify the type of project file to be created. Unless 
otherwise specified, EH-View files are assumed to have the .dpr extension. 
  
When a new Project file is created, the current project configuration is carried over for use 
with the new project. This approach relieves you from having to reset the panel and controller 
parameters each time a new project is created. The latest configuration is saved on exit for use 
the next time EH-View is started. 
  
When you switch between two projects with different configurations, the latest project to be 
opened overrides the previous and becomes the new default state for the EH-View. 
  
To prevent accidental reset of the configuration parameters, you are prompted to confirm the 
New operation if there are pending modifications that have not been saved. 
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4.1.3 Open 

To open an existing project, select Open from the File menu, click the Open icon on the 
toolbar, or press the Ctrl+O keys. The Open Project  dialog box will appear, providing a list 
of the file names in each directory. 
  

 
  
Enter the name of the file to be loaded or use the list box to select from the existing files. If an 
extension is not specified, .dpr is assumed. 
  

4.1.4 Close 

To close a currently open file, select Close from the File menu. 
  
Files may also be closed by clicking on the lower of the two "X"s in the upper right-hand 
corner of the EH-View window, by selecting Close from the EH-View menu, or by pressing 
Ctrl+F4. 
  

4.1.5 Save 

To save a project, select Save from the File menu, click on the Save file icon on the toolbar, 
or press the Ctrl+S keys. 
  
The cursor may be momentarily replaced with an hourglass while the file is saved. 
  
If the application has not been named, the Save As dialog box will appear instead.  
  

4.1.6 Save As 

If an application to be saved has not been named, the Save Project As dialog box appears. Or, 
you may select Save As from the File menu. This option can also be used to save a project 
under a different name. 
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The Save Project As dialog box shows the current directory path and the current file name. A 
new name and path may be entered or the ones presented may be accepted. 
  
Files may be saved as file format "*.dpr" (EH-View files) or "*. rom" (EH-View ROM files). 
If no extension is specified, "*.dpr" is assumed. 
  
If the file already exists in the selected directory, you are prompted to confirm the Save As 
operation in order to overwrite the existing file. 
  
Note: Previous versions of EH-View used the file format .prj. This version of EH-View 
generally uses the file format .dpr. So when opening a .prj file EH-View will not 
automatically save the corresponding .dpr file but will prompt the user upon closing the 
application. 
  

4.1.7 Print 

The Print command in the File menu refers to printing from the EH-View software, whereas 
the print items in the Project menu are used to set up print functionality in the EH-HMI 
panels. 
  
Selecting Print from the File menu (or pressing the Ctrl+P keys) brings up the Designer Print 
Setup dialog box, from which the EH-View project information may be printed. 
  

4.1.8 Print Preview 

Selecting Print Preview from the File menu brings up the Designer Print Setup dialog  box,   
from which the EH-View project information may be previewed for printing. 
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4.1.9 Print Setup 

Selecting Print Setup from the File menu brings up the familiar Windows  Print Setup 
dialog box, from which printer properties may be selected. 
  
Note:  The Print Setup command in the File menu refers to printing from the EH-View 
software, whereas Project - Report on Panel Printer - Printer Setup is used to set up print 
functionality in the EH-HMI panels. 
  

4.1.10 EH-View Print Setup 

EH-View contains a vastly improved printing routine for printing project file information.  
This new module is able to print graphical previews of the project pages, variable cross-
references and much more! 
  
This new printing routine is enabled automatically whenever EH-View is installed.  
   
Selecting File -Print or File-Print Preview will bring up the following dialog box.  
   

 
    
Print (or Print Preview) 
Start (or view) the print operation. 
  
Printer Setup 
Open the standard Windows Printer Setup dialog box.  Printer to use, page size, page 
orientation, etc. can be selected from this dialog box. 
  
Cancel 
Close the dialog box without executing the print operation. 
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EH-HMI Page Range 
Define which panel pages need to be included in the printout. 
  
All pages All data on all panel pages are printed.  
Pages Only the data that is inside the selected pages are printed.  

To specify the panel pages to print, the user needs to enter the page sequence 
to print.  A page sequence is a page range separated by commas (i.e. 4-5, 8, 
13-20). Valid ranges are a single page only, i.e. 8, or consecutive pages, i.e. 4-
5.  

  
Without page breaks 
Any new data section starts a new page.  By selecting this checkbox, all data will be 
compressed on as little number of pages as possible. 
  
Suppress all cover pages 
This checkbox should be selected if the user wants to suppress the cover pages. 
  
Hide empty tables 
Use this checkbox if the user wants to avoid printing tables relative to data sections that were 
not configured inside the project. 
  
Save change on exit 
When this checkbox is marked, the selected Report Data Set will be saved for future use. 
  
Report data sets 
This section of the print dialog box contains the list of project data that could be printed.  For 
any items that are listed, a checkbox gives the user the possibility to enable or disable the 
table printout. 
  
Project information 
Generic project information.  It contains the project name, panel type and name of the 
controller being used. 
  
Project Summary 
Contains some statistical information such as the project file size, number of pages, number 
of used pictures, etc. 
  
EH-HMI page layout description data 
List of page objects. 
  
EH-HMI Page description 
Description of the pages in the project. 
  
Panel Key Macros 
Local macro keys. 
  
Pictures 
Static images. 
  
Touch Cells 
List of graphic components: Object-oriented touch cells, Trends, Gauges. 
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Data Fields 
List of PLC data field items. 
  
Recipes 
Recipe data set values. 
  
Global Key Macros 
Global macro keys. 
  
Trend Buffers 
Trend buffer parameters. 
  
Recipes 
Table with list of recipes that have the Multipage flag set. 
  
Data Transfer 
Data transfer jobs. 
  
Reserved Data Area 
RDA parameters. 
  
Alarms 
Alarm table with messages. 
  
EH-View Setup 
  
Panel Printer and Reports 
Printer setting and print report table parameters. 
  
Panel Setup 
List of panel capabilities and setup configuration 
  
Controller and Network Setup 
List of controller drivers connected on the panel network. 
  
Remote Pass through 
Remote Pass through parameters. 
  
Password 
Table with list of all defined passwords and their parameters. 
  
Cross Reference 
List of Pages, Pictures and Controller references with page references. 
  
Report Contents 
Table of the Report Contents with  page numbers 
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4.1.11 Export to tag database 

This option is used to export all the tags defined in the currently opened project to a database 
specified by the user. If the project doesn't have any tags associated with it, this option will be 
disabled.  

4.1.12 Export Strings 

Strings used in a project can be exported into a CSV (Comma Separated Values, a data format 
used by various applications, e.g. Microsoft ExcelTM) file by selecting Export Strings from 
the File menu.  
  
This opens the Export Strings dialog box.  
  

 
  
  
The information stored in the file has the following format: 
#------------------------------------------------------------------- 
# Filename: DemoFul2.csv 
# Created:  Friday, May 03, 2002 - 10:49 
# Project:  C:\EH-View Projects\DemoFul2.dpr 
#------------------------------------------------------------------- 
2,"""English - Default""","""French""" 
PG-1,"""Main Menu""","""Menù Pri.""" 
ST-1-1,"""Created by Hitachi""","""Créé par Hitachi""" 
ST-1-2,"""EH-HMI Project Functionality""","""""" 
ST-1-3,"""Tech Support Tel. ...""","""Tech Support Tel. ...""" 
  
The first section contains information about the exported file: its name, the date of creation 
and the original project file. 
  
The second section specifies the number of languages and their names. 
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The third section contains a line for each string in the project. Each line contains a string 
identifier (not to be modified), then the string value for each one of the different languages 
supported by the project.  
  
This way it is possible to modify the strings stored in a given project.  
  
  
ANSI / Unicode Encoding is supported.  
  
Using Unicode feature characters of different languages can be added in the projects page by 
editing the string value of the exported file.  
  
Restrictions 
 Unicode character is defined using two bytes, this means we can have until 65.536 different 
characters. EH-HMI panel, instead, can manage 256 characters code. Using the Unicode 
feature you have the possibility to mapping a subset of 256 Unicode characters inside the EH-
HMI panel. 
  
Typical application 
 To enable Unicode support it is necessary modify the panel font file to have some Unicode 
characters inside. For example you can use ANSI characters inside the first 128 bytes and 
Russian (Unicode) characters inside the other 128 bytes. Then you have to configure the new 
2unicode parameter inside the display32.ini file to define the ANSI code (256) <-> UniCode 
(65.536) character correspondence. Example is shown below:  
[RUSSO Font] 
BargraphStart=226 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
BigCharStart=128 
Linefeed=127 
2Unicode=0x8F,0x0444;0x90,0x0438;0x91,0x0441;0x92,0x0432; 
  
  
Note: Modifying the string length has an effect on the real state occupied by that string on the 
screen. 
  

4.1.13 Import Strings 

It is possible to upload to a project the strings previously saved in a CSV (Comma Separated 
Values, a data format used by various applications, e.g. Microsoft ExcelTM) file by selecting 
Import Strings from the File menu. 
  
This opens the Import Strings dialog box.  
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Note: the Import Strings operation may upload a set of strings into the project that are either 
incompatible or  have problems. Before attempting this operation it is recommended to 
save/backup the strings currently in use by calling the Export Strings function. 
  

4.1.14 Recent Files 

The most recently opened files are listed under the File menu as a shortcut. Click on the name 
of a file to reopen it. 
  

4.1.15 Exit 

Selecting Exit from the File menu can be used to terminate the EH-View program. You are 
prompted to confirm the operation if the current application has not been saved. 
  

4.2 Edit Menu 

4.2.1 Edit Menu 

This section provides information about the Edit menu. The Edit menu contains many 
familiar Windows  commands for working with text and objects on the page. 
  
o Cut 

   
o Copy 

   
o Paste 

   
o Align 
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o Make Same Size 
   

o Select All 
   

o Fonts 

4.2.2 Undo 

The Undo command reverses the last action. This action can also be activated by pressing the 
Ctrl+Z keys. 

4.2.3 Redo 

The Redo command reapplies the actions that were previously canceled by the Undo 
command. This action can also be activated by pressing the Ctrl+Y keys. 

4.2.4 Cut 

The Cut command removes the selected item from the current page and places it on the 
Windows  clipboard. This action can also be activated by pressing the Ctrl+X keys. 
  

4.2.5 Copy 

The Copy command makes a copy of the selected item from the current page and places it on 
the Windows  clipboard. This action can also be activated by pressing the Ctrl+C keys. 
  

4.2.6 Paste 

The Paste command places items from the Windows  clipboard onto the current page at the 
current position of the cursor. This action can also be activated by pressing the Ctrl+V keys. 
  

4.2.7 Select All 

The Select All command selects all of the various items on a page. This makes it easy to cut, 
copy, or paste a group of objects. 
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4.2.8 Align 

Align 

Use the Align commands on the Edit menu to arrange objects/items on a page.  
  
Select an object or item by single -clicking on it, then hold down the Shift key while clicking 
on other objects or items to be aligned with it. When all of the objects or items to be aligned 
are selected, choose one of the commands in the Align submenu. 
  
o Left 

  
o Horiz Center 

   
o Right 

  
o Top 

  
o Vert Center 

   
o Bottom 

  
  
Note:  Objects/items are aligned with the last created or inserted object/item. 
  

Left 

Aligns the left sides of the objects/items with the left edge of whichever object/item was 
selected first. 

Horiz Center 

Aligns the horizontal center points of the objects/items with the horizontal center point of 
whichever object/item was selected first. 

Align Right 

Aligns the right sides of the objects/items with the right edge of whichever object/item was 
selected first. 

Align Top 

Aligns the top edges of the objects/items with the top edge of whichever object/item was 
selected first. 
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Align Vert Center 

Aligns the vertical center points of the objects/items with the vertical center point of 
whichever object/item was selected first. 

Align Bottom 

Aligns the bottom edges of the objects/items with the bottom edge of whichever object/item 
was selected first. 

4.2.9 Make Same Size 

Make Same Size 

Use the Make Same Size commands from the Edit menu to match the size of objects/items on 
a page. 
  
Select an object or item by single -clicking on it, then hold down the Shift key while clicking 
on other objects or items to be resized. When all of the objects or items to be resized are 
selected, choose one of the commands in the Make Same Size submenu. 
  
o Width 

  
o Height 

  
o Both 

Note:  Objects/items are resized to match the size of the last created or inserted object/item. 
  
  

Make Same Size Width 

Resizes objects/items so that the width matches the width of whichever object/item was 
selected first. 

Make Same Size Height 

Resizes objects/items so that the height matches the height of whichever object/item was 
selected first. 

Make Same Size Both 

Resizes objects/items so that both the width and height matches the width and height of 
whichever object/item was selected first. 
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4.2.10 Fonts 

Fonts 

EH-View makes it easy to select a font that will appear to advantage in a particular project. 
  
There are two types of fonts in EH-View: Panel Fonts and Objects Fonts. 
  
Panel fonts are character based type of fonts and are supported by all type of panels. 
  
Object Fonts are based on bit maps and are supported only by graphics panels. 
  
  

Panel Font 

Panel Fonts 

 
  
It is possible to have up to four (4) different panel fonts on certain EH-HMI panels. The 
Select Font dialog box lets you select a font for onscreen text from a pull-down list.  
  
Note:  If a project file contains panel font components, switching to a standard font (not an 
enhanced font) will erase all of the panel font components in the project. 
  
o Font Name 

   
o Font Size 

Font Name 

Select a panel font for the on-screen text from the pull-down list. 
  
o Font Editor 

  
o Installing New Panel Fonts 
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Font Size 

The Font Size buttons can be used to change the character size of any text or variable field. 
  
Font size choices include Regular, Regular, Large or Extra Large. Regular characters are 
simply a single character. 
  
Double characters are twice the size of a regular character (2x2). Large characters are four 
times the size of a regular character (4x4). 
  
Extra large characters are eight times the size of a regular character (8x8).  
  
Note:  When the area defined for a text box is too small, only the sizes that can fit inside the 
selected area are enabled. 
  

Objects Font 

Objects Font 

 
  
The Font dialog box lets you select the default  font for all graphic objects (meters, trends) 
and the touch cells. 
  
o Font 

  
o Font Style  

  
o Size 
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o Effects 
  

o Sample 
  

o Script 

Objects Font Font 

Choose a font from the pull-down list. New fonts may be added just like any other True-Type 
font; by opening Fonts from the Windows  Control Panel and using the Install New Font 
command from the File menu. (This is the Windows  Control Panel File menu, not the EH-
View File menu.) 

Objects Font Style 

Text may be bold, italic, or both. 

Objects Font Size 

Select a font size, in points. 

Objects Font Effects 

Text may be displayed as strikeout or underlined. It is also possible to display text in various 
colors. 

Objects Font Sample 

The sample window gives a preview of the selected text settings. 

Objects Font Script 

Western and various other scripts (Hebrew, Greek. Cyrillic, etc.) are available. 

4.3 View Menu 

4.3.1 View Menu 

This section provides information about the View menu. The View menu lets you set the 
screen to view the project in the most comfortable manner for various tasks. Commands on 
the View menu include: 
  
Zoom In 
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Zoom Out 
   
Status Bar 
   
Toolbars 
   
Workspace 
   
Full Screen 
   
Graphics Library Manager 
   
Layers 

4.3.2 Zoom In 

Zoom In enlarges items on the screen, although the whole project page may no longer be 
visible. 
  
This is useful for checking fine details. You can also access this feature by pressing the Ctrl 
key with the + key of the numeric keypad. 
  
  

 
  
Users can define the  view size as a % of the panel size as shown in the above figure. They 
can pick the percentage from the combo box or pick the best fit or specify any % (within valid 
range). Zoom size will be changed to best fit once the Panel setup is changed.  
  

4.3.3 Zoom Out 

Zoom Out makes more of the screen area visible, although items on the screen will appear 
smaller. This is useful for getting an overall view of the page. You can also access this feature 
by pressing the Ctrl key with the - key of the numeric keypad. 
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4.3.4 Status Bar 

The status bar across the bottom of the EH-View screen provides interactive information on 
various screen items. 
  

 
  
If Status Bar is checked in the View menu, the status bar will be visible across the bottom of 
the screen. To hide the status bar, uncheck it under the View menu. To make it visible again, 
simply check it again. 
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4.3.5 Toolbars 

Toolbars 

 
  
Lists the various toolbars displayed for the current project. These may include the following: 
  
o Primary toolbar - typically provides shortcuts to commonly used Windows -type 

commands. 
  
o Secondary toolbar - typically provides shortcuts to EH-View project-level commands 

  
o Full Screen toolbar - typically provides shortcuts to viewing preferences 

  
o Tools toolbar - typically provides shortcuts to user-specified tools 

  
o TouchScreen toolbar - typically provides shortcuts to touchscreen-specific commands 

  
Commands available from the Toolbars dialog box include: 
  
o Toolbar Name 

   
Shows the name of the selected toolbar. 
  
  
o Show Tooltips 

   
Provides a short description of a toolbar icon when the cursor pauses above the icon. 
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o Cool Look 

   
Gives the buttons on the toolbars an invisible edge, making for a smoother appearance on the 
toolbars. 
  
  
o Large Buttons 

   
Makes the buttons appear twice as large as normal for easier viewing and use. 
  
  
o New 

   
o Reset/Delete 

   
The Reset button returns the toolbars to their default state. 
  
If you have added any toolbars, the Reset button becomes a Delete button so that user-added 
toolbars can be removed. 
  
  
o Default 

  
Click the Default button to align and dock the toolbars to the installed state. It also reloads all 
buttons on the toolbar. 
  

New 

The New button brings up the New Toolbar dialog box, where you may enter the name of a 
new toolbar to be created. 
  

 
  
The new toolbar may then be placed in a location of your choice in the toolbar section of the 
EH-View screen. 

4.3.6 Workspace 

The status bar to the left of the main EH-View screen provides information on project pages 
and lists various graphics and objects that can be placed in a project. If Workspace is checked 
in the View menu, the workspace will be visible. 
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The default position of the workspace is to the left of the main EH-View screen, however the 
workspace can be moved anywhere on the EH-View screen. To hide the workspace, uncheck 
it under the View menu. To make it visible again, simply check it again. 
  
Note:  Right-clicking in the frame of the workspace box brings up a number of options for 
viewing the workspace. Select Allow Docking to dock the workspace against any of the four 
sides of the application. If the check box is removed, then the workspace will act as a mini-
window, which can be placed anywhere and resized. On the other hand, clicking Float in 
main window causes the workspace to occupy the entire application window and minimize 
the graphics view. 
  

4.3.7 Full Screen 

The Full Screen command in the View menu (and the Full Screen icon) enlarges the EH-View 
screen to occupy the full screen size.  
  
A small toolbar remains on the screen with Full Screen, Zoom In, and Zoom Out icons to let 
you easily select other viewing options. 
  
Clicking on the Full Screen icon again takes EH-View out of Full Screen view. 
  

4.3.8 Graphics Library 

Graphics Library Manager 

The Graphics Library Manager dialog box provides an easy way to work with graphics 
libraries. 
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The dialog box has three tabs: 
  
o Project - shows the graphics libraries currently used in the project 

  
o Library - shows the graphics libraries currently installed and accessible to EH-View 

  
o Disk - allows to work with file system to load, save  graphic files. 
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Project 

 
  
This tab allows the user to see how many graphic symbols are present in the project and, if 
needed,  to change  their names. 
  
The button Import puts the currently selected graphic symbol into the Project Screen area.  
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Library 

 
  
This tab allows to modify/update the contents of the graphics library. 
  
The tab contains a toolbar providing access to the familiar Windows  commands of cut, 
copy, paste, rename, delete, and insert folder for graphics management. A Properties icon 
leading to a dialog box with the properties of the currently selected graphic symbol is also 
available. 
  
Users, if needed, can change the name of the graphic symbols used in the project. 
  
The button Import puts the currently selected graphic symbol into the Project Screen area.  
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Disk 

 
  
This tab allows to select a new graphic symbol (a new picture) from the file system. 
  
The button Import puts the currently selected graphic symbol into the Project Screen area.  
  

4.3.9 Layers 

Layers 

Each EH-HMI page is actually divided into layers. Layers define a set of planes, stacked 
along the Z-axis of the screen, i.e. the axis that goes form the screen to the eye of the 
user/observer. Thanks to layers it is possible to control in an easy way the Z-ordering (that is 
the position along the Z-axis) of a group of objects and graphics. For instance, by changing 
the position of a layer relative to the others, also the position of all the objects and lines 
belonging to that layer are modified.  
  
Objects and graphics are inserted into the currently active layer. The active layer can be 
selected by using the layers toolbar (usually positioned at the bottom of the work area). 
  

 
  
  
The layers dialog controls how layers are displayed, allows to create new layers, delete them 
and change their reciprocal order. 
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These are the available commands: 
  
o Insert 

  
o Delete 

  
o Move Item Up 

  
o Move Item Down 

  
o Show and Lock Active Layers 

  
o Only Show Active Layers 

  
  
Note: Layers are a EH-View feature introduced to easily configure the Z-ordering of objects 
and graphics on the  panel screen. The EH-HMI panel only supports the relative Z-ordering of 
objects and graphics (no layers). 
  

Insert 

 
  
Inserts a new layer. 
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Delete 

 
  
Deletes the selected layer. 
  

Move Item Up 

 
  
Moves the layer occupied by an item forward. 
  

Move Item Down 

 
  
Moves the layer occupied by an item downward. 
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Show and Lock Active Layers 

 
  
The Show option controls if a given layer can be displayed or not. 
  
The (Un)Lock option controls if a layer can be moved.  
  

Only Show Active Layers 

 
  
This option makes EH-View show only the active layers. 
  

4.4 Insert Menu 

4.4.1 Insert Menu 

This section provides information about the Insert menu. The Insert menu gives you the 
means to easily place text and/or objects onto a project page. Some of these objects, such as 
numeric fields or bar graphs display information from the controller. Other objects, such as 
the various types of touch cells, allow a panel user to interact with the panel. 
  
o Text 

   
o Bitmap 
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o Data Fields 
   

o Touch Cells 
   

o Shapes 
   

o Trend Window 
   

o Meter Instrument 
   

o Trend Time Field 
   

o Recipe Menu 
   

o Special Characters 
   

o Import Bitmap Graphics 

4.4.2 Text 

To insert a Text Field, either click on the Text icon in the toolbar or select Text from the 
Insert menu. Use the cursor to specify the location of the text box. Once a text box is created, 
click to place the cursor inside the text box and type the text that is to be inserted. 
  
Note:  The text uses the font selected in the Select Font dialog box. This dialog box can be 
accessed by clicking on the Font icon in the toolbar or by selecting Edit - Fonts - Panel Font. 
The font must be specified before the text is created. If the font is too large for the selected 
area, EH-View will not allow the text to be entered. 
  
To edit a text field, select the field by left-clicking on it, then right-click on the text field to 
bring up an edit menu for the text field. Text can be cut, copied, or pasted, edited, foreground 
and background colors can be set, or text can be resized. 
  

4.4.3 Bitmap 

To insert a custom bitmap image, either click on the Bitmap icon in the toolbar or select 
Bitmap from the Insert menu. Use the cursor to specify the location of the bitmap image. The 
Bitmap Editor dialog box then appears. 
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A sliding bar lets you zoom in or out for easier editing. Familiar Windows  drawing tools 
are available to create a custom bitmap image. 
  
On invoking the Foreground color and Transparency color button of Bitmap editor dialog will 
popup a  palette with 16 colors and a  "More Colors ... " button as shown in the below figures. 
  
  

                                  

 
  
On invoking the More Colors button a 256 color palette (If 256 colors are supported) dialog is 
shown. From the this the user can select the required palette. When the mouse is over a 
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particular color box RGB values of the same is shown as tooltip as shown in the following 
figure. 
  

  
  

4.4.4 Data Fields 

Data Fields 

Data fields are those items that the EH-View software uses to display information from the 
controller.  
  
These dynamic data items come in the form of numeric fields (which can be displayed in 
numeric format or in ASCII format), bargraphs, message fields, attributes, dynamic graphics, 
time, and date fields. 
  
These fields can be created by either selecting one of the seven types of fields from the Data 
Fields submenu in the Insert menu or by clicking on the various data field icons in the toolbar. 
This brings up the data Field Properties dialog box for the appropriate data field type. 
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Numeric/ASCII 

Numeric/ASCII Data Fields 

This option is used to add a numeric data field or an ASCII data field to the current page. A 
numeric data field reflects a numeric value read from the controller. An ASCII data field 
displays a character string read from the controller. (An ASCII data field differs from a plain 
text field in that an ASCII data field interacts with the controller whereas pla in text is a static 
screen item.) 
  
A numeric/ASCII data field can be created by either clicking on the Numeric Field icon in the 
toolbar or by selecting Insert - Data Fields - Numeric/ASCII. Use the cursor to specify the 
location of the item. 
Once the numeric/ASCII field is created, the Numeric Field Properties dialog box will appear. 
  

 
  
A number of items can be configured from this dialog box. They are grouped in the following 
tabs: 
  
o General 

  
o Text 

  
o Range 

  
o Scaling 

  
o Attributes 

   
  
An external small window allows to Preview the data files. A placeholder of 9's is used to 
indicate the presence of an numeric data field in EH-View, while a placeholder of A's 
indicates an ASCII data field. 
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Preview 

 
  
If a numeric format is chosen, the field will be represented by 9's the panel. If an ASCII 
format is chosen, the field will be shown as A's on the display. If Reference is set to Variable, 
the field is shown as C's on the display. If Reference is set to Recipe, the field is shown as R's 
on the display. 
  

General 

General tab 

The Style, Format, and Size portions of this dialog box are not controller specific. These areas 
are used to instruct the panel in the manner in which to display the data. 
  

 
  
The Reference area is controller specific.  
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Style 

 
  
You can choose a numeric data field that displays numbers or an ASCII data field that 
displays ASCII characters. 
  

Format 

Format 

The Format area allows you to format the data field. These choices will vary according to the 
capabilities of your controller. 
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Format choices for Numeric/ASCII data fields include  
  
o Decimal/Hexadecimal 

  
o Signed/Unsigned 

  
o Fixed Point Placement. 

Decimal Hexadecimal Base 

You can choose between a decimal base (base 10) or a hexadecimal base (base 16). 
  
Note:  When the Reference is set to Recipe, the initial values entered for a particular Recipe 
data field will be in the format specified for that data item. For example, if a numeric format 
of Hexadecimal is entered for a  Recipe data field, then all the values entered in the Recipe 
Configuration dialog box for this Recipe data field will be in hexadecimal. A value of 10 
entered in a Recipe Configuration dialog box under these circumstances will be interpreted as 
10 hexadecimal. 

Signed / Unsigned 

Options are Signed or Unsigned data format. Supposing the variable's data area has a length 
of N bits, if the Unsigned option is chosen the variable is interpreted as an integer ranging 
from 0 to 2N - 1. If the Signed option is chosen the variable is interpreted as a two 
complement integers ranging from - 2N-1 to 2N-1 - 1. These choices are only active when the 
specified controller supports signed/unsigned data format. 

Fixed Point Placement 

The fixed point option permits you to select how many decimal points, if any, are displayed 
on the panel. This feature parallels with scaling. Enter the number of decimal places to be 
displayed in the Placement box. 
  
Note:  Keep in mind that the decimal point will take up one position in the fie ld (i.e., a field 
with a width of four and a placement of 1 can display at most the number 99.9). 
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Size 

 
  
This is the width and height of the field. Each number or letter is one unit wide. Numbers are 
one unit high as well. 
  
Note:  The field width/height cannot exceed the width/height of remaining panel from the 
current cursor row/column position. 
  
Note:  Size is adjusted depending on the current font size. Double font takes twice the 
width/height of regular font size, etc. 
  

Reference 

Reference 

The Reference area is the memory location in the controller to be used, and is dependent upon 
the type of controller selected. The field data type, data format, and address reference are all 
configured in this area. Only the items pertaining to the controller type and file type will be 
configurable. 
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Reference choices for numeric data fields include PLC, Variable, Recipe, and Index. Index 
references are not available for ASCII data fields. 
  

Data Field Properties 

This feature can be accessed by selecting the "…" button whenever a PLC, Variable, or 
Recipe reference is set. (If Index is selected, a similar box named Indirect Addressing Fields 
appears.) 
  
The contents of the Data Field Properties dialog box will vary depending upon the type of 
controller being used and the type of reference specified. Elements to be configured may 
include the File or Data Type, the Data Format, File or Page Number, Element, Offset, and 
Left/Right Byte. These options let you configure responses to the controller memory location. 
  

PLC 

To configure the PLC data field properties, either click on the appropriate icon in the toolbar 
or select Numeric/ACSII, Bargraph, Message, Attribute, or Dynamic Graphics from Insert - 
Data Fields, then use the cursor to specify the location of the item. In the Properties dialog 
box click the PLC radio button under Reference and then click on the "…" button. 
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See Data Field Properties for more information regarding the configuration of data field 
properties. 
  

Variable 

Variable 

Control variables are special data items stored in the EH-HMI panel memory that offer a 
means of controlling and monitoring recipes. You can control certain operations of the panel 
by modifying the values held in these internal variables. Elements to be configured include 
the data type, the data format, page number, and address. These options allow you to 
configure responses to the controller memory location. 
  
To configure Variable data field properties, select Numeric/ACSII, Bargraph or Message 
under Insert - Data Fields, then use the cursor to specify the location of the item. The 
Properties dialog box appears. Click the Variable button under Reference and then click on 
the "..." button to configure the data field properties for control variables.  
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Note:  To change properties of an existing variable data field, right-click on the data field and 
select  
Properties. 
  
There are various types of control variables: 
  
o Recipe File Status 

   
o Recipe Parameter Set Selection 

   
o Recipe Action 

   
o Data Entry Status 

   
o Data Entry Field Number 

   
o Language 

   
o Password 

   
o Recipe Key 

   
o Recipe Page for Selection 

   
o Passthrough Status 

   
o Internal Variable  

   
o Recipe/Event Backup 

   
o PLC Port Mode 

   
o PC/Printer Port Mode 

   
o PLC Port Module Number 

   
o PC/Printer Port Module Number 
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Recipe File Status 

 
  
In the EH-HMI panel memory there is a single memory location that is used to store the status 
of the entire recipe data in the panel. This memory location is called the Recipe File Status. 
  
The Recipe File Status cannot be modified by the panel's user; it is controlled by the internal 
logic in the panel.  
  
The Recipe File Status can take on only 2 values, 0 or 1. A value of 0 indicates that all of the 
recipe data for every page in the project is valid. A value of 1 indicates that an error in some 
part of the recipe data was found. This means that the integrity of the recipe data is 
compromised. It is very rare for this to happen, but it can feasibly occur if the EH-HMI panel 
is powered off while the user is modifying the value of a recipe data field.  
  
If the Recipe File Status has a value of 1, the panel's user must physically change the value of 
one of the recipe data items to reset the Recipe File Status to 0. Until this occurs, the user will 
not be able to perform recipe transfers. 
  

Recipe Parameter Set Selection 

 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 58 

The EH-HMI panel reserves a separate memory location for the Recipe Parameter Set 
Selection for each recipe page. The Recipe Parameter Set Selection memory location stores 
the numeric identifier of the currently selected recipe parameter set for the recipe page. 
  
Recipe Parameter Set Selection data fields can be used to visually display the currently 
selected recipe parameter sets of the various recipes in the project. When these data fields are 
added to a project, they must specify which recipe is to be monitored by the data fields. This 
is done by specifying the page number that contains the required recipe in the Data Field 
Properties dialog box. 
  
For example, a project might contain three recipes, one on page 2, one on page 3 and the other 
on page 7. To monitor the currently selected recipe parameter sets of these three different 
recipes, three Recipe Parameter Set Selection data fields must be added to the project. One of 
these data fields will be used to monitor the recipe on page 2, one to monitor the recipe on 
page 3 and the third to monitor the recipe on page 7. These three Recipe Parameter Set 
Selection data fields could all be placed on any page of the project. Regardless of where they 
are placed in the project, the address of the first data field would be Recipe Parameter Set 
Selection 2, the address of the second data field would be Recipe Parameter Set Selection 3 
and the address of the third data field would be Recipe Parameter Set Selection 7. 
  
You can also change the parameter set of a recipe on a particular page by modifying the value 
held in the Recipe Parameter Set Selection variable. This is done in the same way as changing 
the value of a normal controller data field. For example, to make recipe parameter set number 
3 the current parameter set, enter a value of 3 in the appropriate Recipe Parameter Set 
Selection variable. In order to do this, the Recipe Parameter Set Selection variable must be set 
as a Read/Write variable on the Range tab of the Properties dialog box under Insert - Data 
Fields - Numeric/ASCII, Bargraph, or Message. 
  

Recipe Action 

 
  
For each page that contains a recipe, the EH-HMI panel reserves a separate memory location 
for the Recipe Action for that recipe page. The Recipe Action memory location stores the 
current status of operation of the recipe for the page. 
  
Recipe Action data fields can be added to the project. These data items can then be used to 
visually display the current state of the various recipes in the project.  
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When these data items are added to the project, they must specify which recipe is to be 
monitored by the data item. This is done by specifying the page number that contains the 
required recipe in the Data Field Properties dialog box.   
  
  
A Recipe Action data field can take on only 3 values: 0, 1 or 2. 
  
A value of 0 indicates that the recipe is in its normal state of operation. In this mode of 
operation, the values of the recipe data fields are displayed on the screen of the panel and the 
values of the recipe data fields can be modified. 
  
A value of 1 indicates that the recipe data for the currently selected parameter set is being 
transferred to the controller. When the transfer is complete the value is automatically reset to 
0. 
  
A value of 2 indicates that the recipe data for the currently selected parameter set is being 
transferred to the panel. When the transfer is complete the value is automatically reset to 0. 
  
You can start a recipe transfer by entering a value of 1 or 2 for the Recipe Action data item. 
By entering a value of 1, you can force the EH-HMI panel to send the recipe data for the 
currently selected parameter set to the controller. By entering a value of 2, you can force the 
controller to transfer the recipe data for the currently selected parameter set to the panel. 
  

Data Entry Status 

 
  
This control variable will be set to a 1 while the EH-HMI panel is in Data Entry Mode. In all 
other modes it will be set to 0. 
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Data Entry Field Number 

 
  
This control variable  simply contains the field number of the selected data entry field 
whenever the panel is in Data Entry Mode. 
  
  

Language 

 
  
In order to change the language that the project file uses once it has been downloaded to the 
EH-HMI panel, you can create a control variable with a data type of Language.  Make sure 
that this field is created as read/write so that it can be edited. 
  
To change the language that is being used, you will need to increment or decrement this field. 
This can be done in one of two ways. One way is to simply edit the field and enter the number 
of the language that you want to use The other way is to program a key or a touchcell using 
the macro command Step Control Variables. You could program one key (or touchcell) to 
step up the value of the language control variable field, and another key (or touchcell) to step 
down the value of the language control variable field. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 61 

Password 

 
  
The Password field is an ASCII field, and is only available under Insert - Data Fields - 
Numeric/ASCII when ASCII is chosen as the Style.  
  
  
  

Recipe Page for Selection 

 
  
The purpose of the Recipe Page For Selection field is to show the number of the page 
containing the actual recipe data referred to by the Recipe Menu. 
  
It can be placed on the same page with a Recipe Menu field to show the recipe page number. 
It can also be edited to change the page for which the Recipe Menu field displays information. 
If the Recipe Page For Selection contains the page number of a page without a defined Recipe 
Name field, the Recipe Menu field will display asterisks ("*"). After powering up the EH-
HMI, the Recipe Page For Selection is set to zero. 
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Recipe Key 

 
  
The Recipe Key field is an ASCII field, and is only available under Insert - Data Fields - 
Numeric/ASCII when ASCII is chosen as the Style. The Recipe Key field displays the 
currently selected Recipe Parameter Set name for the referred page. 
  
Note:  The page to which a Recipe Key field refers in the Data Field Properties dialog box 
must have a defined Recipe Name field. This is done by adding a Recipe data field with an 
ASCII display format on the page where the recipe is located and filling the Recipe Item 
values in the Recipe Configuration box with an ASCII name for each parameter set. This 
ASCII field is called a Recipe Name field. If the referred page has no Recipe Name field 
defined, the Recipe Key field will display asterisks ("*"). 
  

Passthrough Status 

 
  
When passthrough mode has been activated, the EH-HMI panel does not communicate with 
the controller and the dynamic data displayed on the screen may no longer be correct. It may 
be useful to inform the user when the passthrough option is active. 
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A new control variable has been defined for this purpose. The control variable name is 
Passthrough Status. This variable can take on two values; zero, meaning that passthrough is 
not active, or one, meaning that passthrough is active. 
  

Internal Variable 

 
  
The internal panel control variables associated with trending can be defined and used from the 
trend viewer. Alphanumeric values of these variables can be displayed on the EH-HMI. 
  
To access these variables, it is necessary to create a numeric data field with a reference type 
Variable. 
  
Select the EH-HMI variable from the Data Field Properties Type list box. This will show the 
list of variables that have already been defined. The meaning of these variables can be found 
inside the trend viewer. 
  

Recipe/Event Backup 
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On some  EH-HMI panels, it is possible to back up recipe data and the event list into flash 
memory inside the EH-HMI. Even if the EH-HMI panel loses power AND the backup battery 
is discharged or missing, the recipe data and the event list will be preserved. 
  
Please note that selecting this feature uses memory within the EH-HMI panel that is normally 
reserved for the project file.  Therefore, the amount of memory available for the project file is 
reduced by the amount of memory reserved for the entire backup of both recipe data and the 
event list, which is 128 KB. 
  
When this feature is enabled, recipes are copied to flash memory automatically from the EH-
HMI after any recipe backup or recipe upload operation. The event list is copied to flash 
memory any time one event happens. A new macro can be used to perform a manually 
backup operations. 
  
During the write operation to flash memory the panel LED #65 will flash to indicate that a 
write operation is in progress. Some EH-HMI panels do not have this LED.  For those EH-
HMI panels that do not have this LED, the control variable Recipe/Event Backup can be used 
to give feedback to the operator on the status of the backup operation.  This control variable  
can assume the values listed below. 
    
Recipe/Event Backup: 
0 = Standby 
1 = Backup operation in progress 
  
The S12 bit of the RDA area is used to communicate to the controller when a backup 
operation to flash memory is in process. The EH-HMI will set this bit to 1 just before the 
backup operation begins. When the backup operation is complete, EH-HMI will set this bit to 
0. 
  

Recipe 

Data may be stored inside a panel in data retentive memory. The amount of data retentive 
memory available varies depending on the panel model. This data retentive memory can be 
used to permanently store data for use by an attached controller. This data can be written to 
the controller, and, conversely, the data can be read from the controller and then placed in the 
data retentive memory. This concept is termed "Recipes" and offers a powerful way to extend 
the capabilities of the controller. This is especially true for controllers that have a limited 
amount of internal memory. Some panel models do not support non-volatile recipe storage; 
please refer to specific product datasheets for more information. Einige Panelmodelle haben 
keinen Nicht-Flüchtigen Rezepturspeicher. Bitte schauen Sie im Datenblatt des jeweiligen 
Panel für weitere Details 
  
Recipes are configured by adding the required controller data items to a page as recipe data 
fields. A recipe can be associated with a particular page and is composed of all the recipe data 
items on that page. Recipe data items contain all the information associated with normal 
controller data items, but rather than the data being read and written directly to the controller 
during the course of normal operation, the data is instead read from and written to the panel 
memory that is reserved for the data item. Only when you explicitly ask the panel to write 
data to the controller is the data sent to the controller. Similarly, only when you explicitly ask 
the panel to read data from the controller is the data actually read from the controller. 
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To configure recipe data field properties, either click on the appropriate icon in the toolbar or 
select Numeric/ACSII, Bargraph or Message from Insert - Data Fields, then use the cursor to 
specify the location of the item. In the Properties dialog box click the Recipe radio button 
under Reference and then click on the "..." button. See Data Field Properties for more 
information regarding the configuration of data field properties. 
  

 
  
Note:  In order to create a recipe for a data field, the Reference for that data field must be set 
to Recipe. 
  
The Interlock MailBox offers a powerful way to control the operation of recipes from the 
controller. There are seven mailbox commands available to function with recipes: 
  
o Start Recipe Download 

   
o Start Recipe Upload 

   
o Recipe Status 

   
o Get Parameter Set Number 

   
o Set Parameter Set Number 

   
o Get Recipe Transfer Priority 

   
o Set Recipe Transfer Priority 

  
  
The mailbox commands allow the choice of the recipe page and also of the parameter set. All 
mailbox commands rela ted to recipes return a completion code describing the results of the 
operation. The mailbox interface to recipes is particularly useful if it is necessary to transfer a 
sequence of recipes to and/or from the panel. 
  
A simple recipe example and a more complex recipe example are provided. Additional 
information about recipes is available. 
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Index 

Index 

Indexed addressing mode lets you reference many controller memory locations from a single 
numeric field. This enables you to monitor the values of many memory locations while using 
only one field. An example of using indexed addressing is given. 
  
To configure the indexed data field properties, either click on the appropriate icon in the 
toolbar or select Numeric/ACSII, Bargraph or Message under Insert - Data Fields, then use 
the cursor to specify the location of the item. In the Properties dialog box click the Index 
radio button under Reference and then click on the "..." button.  
  
The Indirect Addressing Fields dialog box appears. 
  

Indirect Addressing Fields 

 
  
The Selector area lets you specify which controller memory location's contents will be 
displayed when a particular value is written. Please note that the memory locations are 
controller specific. 
  
The Count determines the total number of locations listed, and Min (minimum) is the value of 
the first location listed. 
  
The Reference section is similar to the Data Field Properties dialog box. 
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Indexed Addressing Example 

Indexed Addressing Example 

For this example, assume we have a plant in which industrial equipment is washed. The wash 
process is comprised of three stages. We want to be able to monitor the water temperature, the 
water pressure, the amount of time the equipment is in a particular stage, and the stage the 
process is in as shown in the figure below; all without pressing a key on the panel. 
  
The numeric values will be written into the controller by the machine and will change 
constantly. The controller memory locations and their contents that we will use for this 
example are as follows: 
  
  
DB10 DW0 Temperature in Stage 1 (ranges between 0 and 9999) 
DB10 DW1 Temperature in Stage 2 (ranges between 0 and 9999) 
DB10 DW2 Temperature in Stage 3 (ranges between 0 and 9999) 
DB10 DW3 Pressure in Stage 1 (ranges between 0 and 9999) 
DB10 DW4 Pressure in Stage 2 (ranges between 0 and 9999) 
DB10 DW5 Pressure in Stage 3 (ranges between 0 and 9999) 
DB10 DW6 Time in Stage 1 (ranges between 0 and 9999) 
DB10 DW7 Time in Stage 2 (ranges between 0 and 9999) 
DB10 DW8 Time in Stage 3 (ranges between 0 and 9999) 
DB10 DW9 The stage the process is currently in (ranges between 1 and 3) 
  
  
Note:  The memory locations are controller specific; those listed above are done so only to be 
able to more easily explain the procedure of using indexed addressing. This example assumes 
that we have a Simatic S5 controller (set under Project - Configure Controller). 
  
This example can be broken down into four basic steps: 
  
o Creating the Stage numeric field, 

  
o Creating the Temperature indexed addressing field, 

  
o Creating the Pressure indexed addressing field, and 

  
o Creating the Time indexed addressing field. 

  
These fields are all related in that the values that are displayed within them are dependent 
upon the stage of the process. The indexed fields will be addressed in such a manner that 
whenever the field number is written into the Stage numeric field location (DB10 DW9), the 
corresponding information will be displayed in each of the indexed fields. For example, when 
a value of 2 is written into DB10 DW9, each of the indexed fields will display the 
corresponding data: the temperature in stage 2, the pressure in stage 2, and the amount of time 
spent in stage 2. 
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Creating the Stage Numeric Data Field 
   

o Type the text labels (shown in black) onto a blank project page to resemble the figure 
above. 
  

o To insert the Stage, we must create a numeric data field on the screen to display the stage 
number. Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon 
in the toolbar. 
  

o Use the cursor to define an area where the data field will be placed next to the text Stage 
Number. 
  

o The Numeric Field Properties box appears. 
  

o Under Size on the General tab set the field width to 1, since this field only needs to 
display a single digit. 
  

o Set the Reference as PLC and click the "…" button to specify the controller location. 
  

o In the Data Field Properties dialog box, set the address to DB10 DW9. 
  

o Click OK to return to the Numeric Field Properties dialog box. 
  

o Click OK to close the dialog box and return to the project page where a single 9 now 
appears next to Stage Number as a placeholder. 

Creating the Temperature Indexed Field 

o Next we need to create a field on the screen where the temperature information for the 
process can be displayed. Select Insert - Data Fields - Numeric/ASCII, or click on the 
Numeric Field icon in the toolbar. 
  

o Use the cursor to define an area where the data field will be placed below the Temp 
label. 
  

o The Numeric Field Properties box appears. 
  

o Under Size on the General tab set the field width to 4, since the maximum value of this 
field is 9999. 
  

o Set the Reference as Index and click the "…" button to specify the controller location. 
  

o The Indirect Addressing Fields dialog box appears. Since there are three temperature 
values that we wish to monitor, enter the Count as 3. In the Selector list box on the left 
side of the Indirect Addressing Fields dialog box, three memory locations will be listed 
with the values 0, 1, and 2 (since we left the Min value as 0). They will all initially show 
the same memory location of DB10 DW0. 
  

o Since we want the first value to display the temperature in stage 1 (with value located in 
DB10 DW0), the value of entry 0 is referenced to the default value of DB10 DW0. 
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o Since we want the second value to display the temperature in stage 2 (with value located 
in DB10 DW1), the value of entry 1 (the second entry) is referenced to the value of 
DB10 DW1. Enter the address DB10 DW1 into the Address Reference portion of the 
dialog box. 
  

o Click on entry 1 in the Selector list. The memory location for entry 1 changes to DB10 
DW1. 
  

o To display the temperature in stage 3, enter the address DB10 DW2 into the Address 
Reference portion of the dialog box. 
  

o Click on entry 2 in the Selector list. The memory location for entry 2 changes to DB10 
DW2. The dialog box will resemble that shown below. 
  

 
  
o Click OK to return to the Numeric Field Properties dialog box. 

  
o Click OK to close the dialog box and return to the project page where “Is” now appears 

under the Temp label placeholders. 

Creating the Pressure Indexed Field 

o Next we need to create a field on the screen where the pressure information for the 
process can be displayed. Select Insert - Data Fields - Numeric/ASCII, or click on the 
Numeric Field icon in the toolbar. 
  

o Use the cursor to define an area where the data field will be placed below the Pressure 
label. 
  

o The Numeric Field Properties box appears. 
  

o Under Size on the General tab set the field width to 4, since the maximum value of this 
field is 9999. 
  

o Set the Reference as Index and click the "…" button to specify the controller location. 
  

o The Indirect Addressing Fields dialog box appears. Since there are three pressure values 
that we wish to monitor, enter the Count as 3. In the Selector list box on the left side of 
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the Indirect Addressing Fields dialog box, three memory locations will be listed with the 
values 0, 1, and 2 (since we left the Min value as 0). They will all initially show the same 
memory location. 
  

o To display the pressure in stage 1, enter the address DB10 DW3 into the Address 
Reference portion of the dialog box. 
  

o Click on entry 0 in the Selector list. The memory location for entry 0 changes to DB10 
DW3. 
  

o To display the pressure in stage 2, enter the address DB10 DW4 into the Address 
Reference portion of the dialog box. 
  

o Click on entry 1 in the Selector list. The memory location for entry 1 changes to DB10 
DW4. 
  

o To display the pressure in stage 3, enter the address DB10 DW5 into the Address 
Reference portion of the dialog box. 
  

o Click on entry 2 in the Selector list. The memory location for entry 2 changes to DB10 
DW5. The dialog box will resemble that shown below. 
  

 
  
o Click OK to return to the Numeric Field Properties dialog box. 

  
o Click OK to close the dialog box and return to the project page where “Is” now appears 

under the Pressure label placeholders. 

Creating the Time Indexed Field 

o Finally, we need to create a field on the screen where the time information for the 
process can be displayed. Select Insert - Data Fields - Numeric/ASCII, or click on the 
Numeric Field icon in the toolbar. 
  

o Use the cursor to define an area where the da ta field will be placed below the Time label. 
  

o The Numeric Field Properties box appears. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 71 

o Under Size on the General tab set the field width to 4, since the maximum value of this 
field is 9999. 
  

o Set the Reference as Index and click the "…" button to specify the controller location. 
  

o The Indirect Addressing Fields dialog box appears. Since there are three time values that 
we wish to monitor, enter the Count as 3. In the Selector list box on the left side of the 
Indirect Addressing Fields dialog box, three memory locations will be listed with the 
values 0, 1, and 2 (since we left the Min value as 0). They will all initially show the same 
memory location. 
  

o To display the time in stage 1, enter the address DB10 DW6 into the Address Reference 
portion of the dialog box. 
  

o Click on entry 0 in the Selector list. The memory location for entry 0 changes to DB10 
DW6. 
  

o To display the time in stage 2, enter the address DB10 DW7 into the Address Reference 
portion of the dialog box. 
  

o Click on entry 1 in the Selector list. The memory location for entry 1 changes to DB10 
DW7. 
  

o To display the time in stage 3, enter the address DB10 DW8 into the Address Reference 
portion of the dialog box. 
  

o Click on entry 2 in the Selector list. The memory location for entry 2 changes to DB10 
DW8. The dialog box will resemble that shown below. 
  

 
  
o Click OK to return to the Numeric Field Properties dialog box. 

  
o Click OK to close the dialog box and return to the project page where “Is” now appears 

under the Time label placeholders. 
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Text tab 

 
  
The Text tab allows you to set the font size and color, and the background color and 
transparency of a data item. EH-View will not let you select a size that is too large to be 
displayed in the designated area. If Transparent is selected then text background colors are not 
available. 
  
  

Range 

Range tab 
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The Range tab lets you specify whether access to the project will be read only, or if read/write 
access will be allowed. If read/write access is allowed, then you can also specify the 
minimum and maximum value range. 

Access 

This determines if the data field is to be read only or read/write. Keep in mind that if read 
only is selected, the field can only monitor the data in the controller. If read/write is selected, 
you can monitor data in the controller, as well as write data to the controller. 
  

Range 

Minimum and maximum values can be configured for the read/write field only. These are 
lower and upper bounds to the data. If a value occurs outside of this range, asterisks will 
appear on the panel, and the previous value of the field will be displayed. 
  
It is possible to attach the minimum and maximum values to memory locations in the 
controller. When dynamic references are required for the minimum/maximum values, then 
select Reference under Range. Upon doing so, the Data Field Properties dialog box appears, 
allowing you to specify the memory location.   
  
Note:  Once you have decided to use dynamic variable references for the min/max values, all 
the variables associated with the dynamic references must be assigned to memory locations in 
the controller.   
  
When using dynamic variable references for the min/max limit settings, you can select how 
the EH-HMI panel retrieves these values. Selecting Project - Panel Setup and clicking on the 
Settings index tab will reveal a checkbox called Update PLC References. If this checkbox is 
marked, the dynamic variable references will be updated on a continuous basis. If this 
checkbox is unmarked, the dynamic variable references will be updated only after a page 
change when the destination page contains variable reference fields. 
  
Note:  When the continuous mode is used to get dynamic variable references from the 
controller, communication performance can be reduced due to the increasing number of 
variables being transmitting through the communication channel between the EH-HMI panel 
and the controller. 
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Scaling 

Scaling tab 

 
  
Scaling lets you change the appearance of the values being displayed onto the panel. For 
example, if the controller is reporting values in Celsius but the operator is familiar with 
Fahrenheit, performing a scaling operation on the data can convert it, with the result being 
displayed in Fahrenheit. With this option, any data from the controller can be manipulated 
however you wish. 
  
The scaling equation is defined as: 
  
y =   (A1 / A2 ) x + B 
  
Where,                                                          
  
y = Scaled value displayed 
x = Controller data value 
A1, A2, B = Scaling operators (these are the three entry boxes located within the scaling 
equation) 
  
There are two important concepts to understand about scaling. First and foremost, the scaling 
operators (A1, A2, and B) are 16 bit integers. Internal calculations are done using 32 bit 
arithmetic, which allows the panel to report a more precise result than if it were using only 16 
bit arithmetic. 
  
Secondly, the maximum and minimum fields refer to the scaled value, not the value that is in 
the controller. 
  
Two examples of using scaling are provided. The first is an example in which a user has a 
Celsius temperature in the controller and wishes to display a Fahrenheit temperature on the 
EH-HMI panel. The second is an example in which a user has a controller memory location 
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that can range in value from 0 to 4095. Depending upon the value in the controller, you may 
wish to display that value as a percentage of the maximum possible value on the panel. 
  

Scaling Examples 

Scaling Example 1 

Assume that we have a controller that displays the temperature of a motor in Celsius. The 
person operating the EH-HMI panel is only familiar with temperatures in the Fahrenheit 
scale. By using scaling, we can have the Celsius temperature from the controller appear as a 
Fahrenheit temperature on the display panel. 
  
o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon in the 

toolbar. 
  

o Use the cursor to define an area where the data field will be placed. 
  

o The data field Properties box appears. 
  

o On the General tab, select the Reference as PLC and click the "…" button to specify the 
controller location. 
  

o Click OK to return to the data field Properties dialog box. 
  

o Click the Scaling tab. 
  

o We know that to convert a value from Celsius to Fahrenheit, we need to multiply the 
Celsius temperature by 9/5 and add 32 to the result. Consider the scaling equation: y = 
(A1/A2) x + B. Since x is the Celsius temperature in the controller, this is the value we 
want to multiply by 9/5. To do this, we would need to set A1 equal to 9 and A2 equal to 
5. Make sure that the Constant button is checked for all values, and enter the value 9 for 
A1 and the value 5 for A2. 
  

o Adding 32 to this value can be done by setting B equal to 32, so enter 32 as the value for 
B. 
  

o Click OK to confirm this operation. The value displayed on the panel will be in 
Fahrenheit, while the controller data will be in Celsius. 

Scaling Example 2 

Assume that we have a controller memory location for which the numeric value can range 
from 0 to 4095. We want to display the actual value in the controller as a percentage of the 
maximum value. 
  
o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon in the 

toolbar. 
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o Use the cursor to define an area where the data field will be placed. 
  

o The data field Properties box appears. 
  

o On the General tab, select the Reference as PLC and click the "…" button to specify the 
controller location. Click OK to return to the data field Properties dialog box. 
  

o Click the Scaling tab. 
  

o Since we want to display the actual value in the controller as a percentage of the 
maximum value, we need to use scaling. If the actual value in the controller is 0, then the 
panel should display 0. If the actual value in the controller is 4095, the panel should 
display 100. Simply divide the value in the controller by the maximum possible value 
and multiply this result by 100 to turn it into a percentage. Make sure that the Constant 
button is checked for all values, and enter the value 100 for A1, 4095 for A2, and 0 for 
B. 

  
o Click OK to confirm this operation. The value displayed on the panel will be a 

percentage of the actual numeric value. 

Attributes 

 
  
Use this tab to control the display / print attribute of the Numeric/ASCII Data Field. 
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Numeric Data Field Example 

o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon in the 
toolbar. 
  

o Use the cursor to define an area where the data field will be placed. 
  

o The Numeric Field Properties box appears. 
  

o On the General tab, select the Reference as PLC and click the "…" button to specify the 
controller location. Click OK to return to the Numeric Field Properties dialog box. 
  

o Click OK. 
  

o A placeholder of 9's appears. 

ASCII Data Field Example 

o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon in the 
toolbar. 
  

o Use the cursor to define an area where the data field will be placed. 
  

o The Numeric Field Properties box appears. 
  

o Under Style select ASCII. 
  

o On the General tab, select the Reference as PLC and click the "…" button to specify the 
controller location. Click OK to return to the Numeric Field Properties dialog box. 
  

o Click OK. 
  

o A placeholder of A's appears. 
o   

Bargraph 

Bargraph Data Fields 

Bargraphs provide a visual representation of a controller value. To create a bargraph field, 
either select the Bargraph icon from the toolbar or select Insert - Data Fields - Bargraph. Then 
use the cursor to define the area in which the message field is to be placed. The Bargraph 
Field Properties dialog box will appear. 
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A number of items can be configured from this dialog box. These include: 
  
o Style (vertical or horizontal) 

  
o Display format 

  
o Field dimensions 

  
o Reference 

  
o Text properties 

  
o Data access (read only, read/write field) 

  
o Min. & max. values (read/write field only) 

  
o Data scaling 

  
The Bargraph dialog box lets you create a bargraph and specify the controller memory 
location that the bargraph is to monitor. The maximum value of the field is represented when 
the bargraph is full. Likewise, the minimum value is represented when the bargraph is empty. 
  
An external small window allows to Preview the Bargraph. 
  

Bargraph Preview 
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The bargraph Preview dialog box displays a basic bargraph of the appropriate orientation 
(horizontal or vertical) and size (width and height). 
  

General 

General tab 

 
  
The Style, Format, and Size portions of this dialog box are not controller specific. These areas 
are used to instruct the panel in the manner in which to display the data. The Reference area is 
controller specific.  
  

Style 

Bargraphs can be presented either vertically or horizontally. 
  

Format 

The Format area allows you to format the data field. The availability of Format options will 
vary according to the capabilities of your controller. 
  
Options are Signed or Unsigned data format. Supposing the variable's data area has a length 
of N bits, if the Unsigned option is chosen the variable is interpreted as an integer ranging 
from 0 to 2N - 1. If the Signed option is chosen the variable is interpreted as a two 
complement integers ranging from - 2N-1 to 2N-1 - 1. These choices are only active when the 
specified controller supports signed/unsigned data format. 
  

Size 

These entry boxes define the size of the bargraph field. 
  
Note:  The field width/height cannot exceed the width/height of remaining panel from the 
current cursor row/column position. 
  
Note:  Size is adjusted depending on the current font size. Double font takes twice the 
width/height of regular font size, etc. 
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Reference 

The Reference area is the memory location in the controller to be used, and is dependent upon 
the type of controller selected. The field data type, data format, and address reference are all 
configured in this area. Only the items pertaining to the controller type and file type will be 
configurable. 
  
The address chosen in the Reference section is dynamically linked to the bargraph. In other 
words, the value of the register corresponds to the fill level of the bargraph. 
  
Reference choices for bargraph data fields include PLC, Variable, Recipe, and Index. 
  

Bargraph Example 

Assume we want to simulate the fill level of a tank. In this case, a transparent graphic of a 
tank could be used along with a bargraph to simulate the fill level. The procedure is as 
follows: 
  
o Click on the Graphics tab in the workspace. 

  
o Select Tanks from the pull-down list at the top of the workspace. 

  
o Click on the image of a tank and drag it to the project page. 

  
o Select Insert - Data Fields - Bargraph. 

  
o Use the cursor to outline an area on top of the tank for the bargraph. 

  
o Select Vertical as the bargraph Style. 

  
o Select PLC as the Reference type and click on the "…" button to set the memory location 

for the fill level value in the Data Field Properties dialog box. 
  

o Click OK to return to the Bargraph Field Properties dialog box. 
  

o Click on the Text tab and make sure that Transparent is selected. 
  

o Click OK. 
  
The bargraph now appears on top of the tank and will reflect the fill level value. 
  

Message 

Message Data Fields 

Message fields can be used instead of numerical values to inform the user that an event is 
occurring.  For example, assume the message "Voltage too high" is attached to the value 32. 
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Whenever the value of the register in the controller reaches 32, the message will be displayed. 
In this manner, a text message is displayed on the panel, which is often more beneficial and 
meaningful to the operator than displaying a numerical value. 
  
Note:  The maximum number of messages that can be displayed is 1024. 
  
Message fields can be created in one of two ways. Either select the Text Message icon from 
the toolbar or select Insert - Data Fields - Message, then use the cursor to define the area in 
which the message field is to be placed. Once the message field is created the Text Message 
Properties dialog box will appear. 
  

 
  
A number of items can be configured from this dialog box. These include: 
  
o Style 

  
o Field dimensions 

  
o Reference configuration 

  
o Text properties, and 

  
o Messages 

  
An external small window allows to Preview the Message. 
  

Preview 
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The message field is represented by M's in the panel. 
  

General 

General tab 

 
  
The Style and Size portions of this dialog box are not controller specific. These areas are used 
to instruct the panel in the manner in which to display the data. The Reference area is 
controller specific.  
  

Style 

Message is the only style choice available. 
  

Size 

These entry boxes define the size of the message field. The width and height of the field is 
equivalent to the maximum number of characters the message field can contain. 
  
Note:  The field width/height cannot exceed the width/height of remaining panel from the 
current cursor row/column position. 
  
Note:  Size is adjusted depending on the current font size. Double font takes twice the 
width/height of regular font size, etc. 
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Reference 

The Reference area is the memory location in the controller to be used, and is dependent upon 
the type of controller selected. The field data type, data format, and address reference are all 
configured in this area. Only the items pertaining to the controller type and file type will be 
configurable. 
Reference choices for message data fields include PLC, Variable, Recipe, and Index. 
  

Messages 

Messages tab 

 
  
Message parameters (minimum and number of messages) can be configured on the Messages 
tab, and the messages can be entered. 
  
The Minimum setting determines the Value of the initial message. Once the parameters are 
configured, begin entering messages for the different data values. 
  

Minimum 

The Minimum setting determines the Value of the initial message.  
  

Number of Messages 

The number of messages to be displayed is set by the Messages value. 
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Message Table  

Once the parameters (minimum and number of messages) are configured, begin entering 
messages for the different data values. 
  

Toolbar Options 

Message Toolbar 

 
  
Various icons on the messages toolbar keep tools within easy reach. They include Copy, 
Paste, Special Characters, and Languages. 
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Copy 

 
  
The familiar Windows  features Copy and Paste are available for use in editing messages. If 
you have several messages that are similar, you can use the Copy and Paste features to copy 
messages and then make any necessary changes. 
  
Simply select which messages to copy by highlighting them. If you want to copy several 
messages that are in successive order, click on the first one and drag the mouse down until the 
last one is highlighted and release the mouse button. If you have several messages to copy 
that are not in successive order, hold down the Ctrl key, click on each of the messages that 
you want to copy, and release the Ctrl key. All of these methods will select the text to be 
copied. Next, click on the Copy icon to copy the messages into Windows  Clipboard. Then 
use the Paste feature to copy the messages into their new locations. 
  
You can also use a Windows -based text editor, such as Notepad, to create a list of 
messages. To do this, place each message on a separate line. Use the copy function of the 
editor to copy the text to the clipboard and then use the paste feature to copy the messages 
into their new locations. 
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Paste 

 
  
The familiar Windows  features Copy and Paste are available for use in editing messages. If 
you have several messages that are similar, you can use the Copy and Paste features to copy 
messages and then make any necessary changes. 
  
First Copy a message as described in the Copy section. Highlight the message number where 
you want to paste the first message and click on Paste to copy the message into its new 
location. 
  

Special Characters 
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Special characters may be added to text by clicking on the Special Characters button. This 
will bring up the Special Characters dialog box in which you can select the character(s) to be 
used by double clicking on them or by single clicking on them and pressing Insert. The 
characters will appear in the last position the cursor was in before entering the special 
characters dialog box. 
  

Select Language 

 
  
Select a language from the pull-down list. If the language you wish to use is not in the list, it 
may be created by clicking the Languages icon on the toolbar or by selecting Languages from 
the Project menu. 
  

Message Example 

o Select Insert - Data Fields - Message. 
   

o Use the cursor to outline an area for the message. 
  

o Select PLC as the Reference type and click on the "…" button to set the memory location 
for the messages in the Data Field Properties dialog box.  
  

o Click OK to return to the Message Field Properties dialog box. 
  

o Click on the Text tab and set the fonts and colors. 
  

o Click on the Messages tab. Set the number of messages. 
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o Enter the messages. 
  

o Click OK. 

Attribute 

Attribute Data Fields 

Occasionally it is necessary to draw attention to a particular part of the screen or to indicate 
the increased importance of a message or data field. For these instances, dynamic and static 
attributes are provided. 
To create an Attribute field, either select the Attribute icon from the toolbar or select Insert - 
Data Fields - Attribute. Then use the cursor to define the area in which the attribute field is to 
be placed. The Attribute Properties dialog box will appear. 
  

 
  
A number of items can be configured from this dialog box. These include: 
  
o Style (static or dynamic) 

  
o Static Attributes (static attributes only) 

  
o Field dimensions 

  
o PLC Reference (dynamic attributes only) 

Style 

Static attributes and dynamic attributes are the two choices available. 
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Static Attributes 

If Static is selected as the Style, any combination of the blink, reverse, and highlight attributes 
may be used. These attributes let you make an area of the screen stand out by highlighting the 
area, reversing the area, or making the area blink. 
  

Dynamic Attributes 

If Dynamic is selected as the Style, the screen attribute will be fixed to a value of a word or 
bit in the controller. 
  
The address of the controller's memory location can be entered in the PLC Reference area. 
  
If the attribute is referenced to a word, the attribute will be dependent upon the three least 
significant bits in the controller's memory location. 
  
Decimal Value Bit 2 Bit 1 Bit 0 Attribute 
0 0 0 0 Normal 
1 0 0 1 Blinking 
2 0 1 0 Highlight 
4 1 0 0 Reverse 
  
If the attribute is referenced to a bit, there will be no attribute displayed when the bit has the 
value of 0. The blink attribute will be displayed whenever the bit has a value of 1. 
  
Note:  Keep in mind that not all attributes are supported on every panel. 

4.5 Color Attributes 

All color panels support a new type of dynamic attribute field that will allow the user to 
dynamically control the color of an area on the display. The color attributes have been 
introduced as an extension to the existing monochrome dynamic attributes (blink, reverse and 
highlight). 
  
The word in the controller memory referenced by the dynamic attribute will be interpreted as 
shown in the table below. 
  
Bit 0, 1, 2 Monochrome Attribute  
Bit 3 C (this enables color attribute mode) 
Bit 4, 5, 6, 7 Not used  
Bit 8, 9, 10, 11 = B0-B3 Background color 
Bit 12, 13, 14, 15 = F0-F3 Foreground color  
  
C is the bit that enables the color attribute mode. The Color attributes are interpreted 
according to the table below. 
  
o C=0, Color Attributes Disabled 
o C=1, Color Attributes Enabled 

  



EH-VIEW (en) - July 2005 - 05/005 

Page 90 

  
Decimal Value Bit 3      Bit 2 Bit 1 Bit 0  Color  
0 0 0 0 0 Black 
1 0 0 0 1 Dark Red 
2 0 0 1 0 Dark Green 
3 0 0 1 1 Dark Yellow 
4 0 1 0 0 Dark Blue 
5 0 1 0 1 Dark Magenta 
6 0 1 1 0 Dark Cyan 
7 0 1 1 1 Dark Gray 
8 1 0 0 0 Light Gray 
9 1 0 0 1 Red 
10 1 0 1 0 Green 
11 1 0 1 1 Yellow 
12 1 1 0 0 Blue 
13 1 1 0 1 Magenta 
14 1 1 1 0 Cyan 
15 1 1 1 1 White 
  
Note that the Foreground color and the Background color can be independently controlled.  
  
EH-HMI firmware 4.20 or later is required to support dynamic color attributes. 
  

Size 

These entry boxes define the size of the static or dynamic data field. 
  
Note:  The field width/height cannot exceed the width/height of remaining panel from the 
current cursor row/column position. 
  
Note:  Size is adjusted depending on the current font size. Double font takes twice the 
width/height of regular font size, etc. 
  

PLC Reference 

The Reference area is the memory location in the controller to be used, and is dependent upon 
the type of controller selected. The field data type, data format, and address reference are all 
configured in this area. Only the items pertaining to the controller type and file type will be 
configurable. PLC is the only reference option. 
  

Attribute Example 

o Select Insert - Data Fields - Attribute. 
   

o Use the cursor to outline an area for the attribute. 
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o Select Dynamic as the Style. 
   

o Click on the "…" button under PLC Reference to set the memory location in the Data 
Field Properties dialog box. 
  

o Click OK to return to the Attribute Properties dialog box. 
  

o Click OK. 

Dynamic Graphics 

Dynamic Graphics Data Fields 

This feature lets you display graphics based upon a numeric value in the controller. For 
example, a user may want to display two graphics, one when a blower is on and one when a 
pump is on. Depending upon which machine is on, the respective graphic will be displayed at 
a single screen location. If neither machine is on, then no graphic will be displayed. In another 
scenario, a user may wish to have a graphic appear at a different location on the screen, 
depending upon which machine is on. Examples of both situation 1 and situation 2 described 
above are given. 
  
It is possible to position dynamic graphics fields over static background bitmaps to create 
animated images. Transparent and three-dimensional touch cells can be defined over static 
bitmap images. To place a dynamic graphic over a static bitmap image, import a static bitmap 
image into a project, then create the dynamic graphic fields over the static bitmap. 
  
Dynamic graphics may be inserted by either selecting Insert - Data Fields - Dynamic 
Graphics or by selecting the Dynamic Graphics icon from the toolbar. Use the cursor to 
specify the location of the item. 
Once the dynamic graphics field is created, the Dynamic Graphics Properties dialog box will 
appear. 
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A number of items can be configured from this dialog box. These include: 
  
o Style, 

  
o Field dimensions, 

  
o PLC Reference, and 

  
o Frames properties. 

  
An external small window allows to Preview of the Dynamic Graphic  
  
Note:  Dynamic graphics cannot fully overlap static bitmaps. The first columns cannot 
overlap at all. 
  
Note:  Dynamic graphics fields and the bitmaps under them must snap to the page's character-
based grid. 
  
Note:  It is not possible to overlap two dynamic objects, since both items are dynamically 
changed by the controller. For example, a numeric field cannot be placed over a dynamic 
graphic field. 
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Preview 

 
  
Provides a snapshot view of an individual dynamic graphic frame. 
  

General 

General tab 

 
  
The Style and Size portions of this dialog box are not controller specific. These areas are used 
to instruct the panel in the manner in which to display the data. The Reference area is 
controller specific.  
  

Style 

Dynamic Graphic is the only possible choice. 
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Size 

The width and height of the graphic box, in pixels. 
  
Note:  The field width/height cannot exceed the width/height of remaining panel from the 
current cursor row/column position. 
  
Note:  Size is adjusted depending on the current font size. Double font takes twice the 
width/height of regular font size, etc. 
  

Frames 

Frames Properties 

 
  
The Frames tab of the Dynamic Graphic Properties dialog box lets you configure the 
individual frames that comprise the dynamic graphic. 
  
Enter a number in the Min box to establish the number of the first frame. Set the total number 
of frames in the Frames box. Users may toggle through the frames by using Display Previous 
Frame / Display Next Frame. To see the frames in a continuous loop, click the Play button. 
The play speed may be set by sliding the indicator or by entering a value in the box. Click the 
Stop button to stop the Play display. 
  
Click the Edit button to edit the individual dynamic graphic frames. 
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Edit Dynamic Graphics 

Edit Dynamic Graphics 

 
  
The Dynamic Graphics dialog box allows users to edit dynamic graphic frame. This box can 
be accessed by clicking the Edit button from the Frames tab of the Dynamic Graphics 
Properties dialog box. 
  
Dynamic graphics may be selected from either the library of graphics provided with EH-View 
as shown on the Library tab, or from another file on your system as shown on the Disk tab. 
An image selected from either source will appear on the Panel / Original tabs, where it may 
be renamed if necessary using the Name field. The Original tab displays the image in its 
original form for reference purposes, while the Panel tab displays the image as it will appear 
on the panel. 
  
The various frames making up the dynamic graphic are displayed on the right side of the box. 
Three commands are available.  
  
Modify Dynamic Graphic Frame is enabled when a user clicks on a frame that contains a 
dynamic graphic. 
Replace Dynamic Graphic Frame is enabled when a dynamic graphic has been selected and is 
displayed in the Panel / Original tabs. When the Replace Dynamic Graphic Frame icon is 
clicked, the dynamic graphic currently displayed in the Panel / Original tabs is inserted into 
the currently selected frame to replace the current contents of the frame. 
Delete Dynamic Graphic Frame is enabled when a user selects a non-empty dynamic graphic 
frame. Clicking on the Delete Dynamic Graphic Frame icon removes the dynamic graphic 
from that frame. 
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A number of familiar Windows  commands are available in the Dynamic Graphics dialog 
box. These include Cut, Copy, Paste, Rename, Delete, and Insert Folder. An additional icon is 
available to edit the Properties of dynamic graphics, including Image and Panel properties. 
  

Image 

The Image tab of the dynamic graphics Properties box lets you change image properties such 
as the type of dither, the contrast and brightness, to smooth, sharpen or blur the image, to 
invert, flip or mirror the image, or to size the image to fit the preview box. Close the box by 
clicking on the X in the upper right corner to accept the changes. The Reset button returns the 
graphic to the default settings. 
  

Panel 

The Panel tab of the dynamic graphics Properties box lets you set panel color preferences. 
Close the box by clicking on the X in the upper right corner. 
  

Dynamic Graphics Examples 

Dynamic Graphics Example 1 

In this example, assume a situation in which there are three possible occurrences in the same 
area of the screen:  a blower can be on, a pump can be on, or neither can be on. A graphic will 
be displayed on the panel to reflect the situation. This can be accomplished by referencing the 
graphics to a single register in the controller. A value of 0 in this register indicates that neither 
the blower nor the pump is on. A value of 1 in this register indicates that the blower is on. A 
value of 2 in this register indicates that the pump is on. 
  
o Select Insert - Data Fields - Dynamic Graphics, or click on the Dynamic Graphics icon in 

the toolbar. 
  

o Use the cursor to define a box where the graphic is to be displayed. 
  

o The Dynamic Graphic Properties dialog box appears. 
  

o Click on the "…" button under PLC Reference to set the memory location in the Data 
Field Properties dialog box. 
  

o Set the data field properties, then click OK to return to the Dynamic Graphic Properties 
box. 
  

o Select the Frames index tab. 
  

o We have three different values being written into the controller:  0, 1, or 2. Therefore, 
our minimum value is 0 and the number of frames is 3. Enter 0 in the Min box and 3 in 
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the Frames box. 
  

o Click on the Edit button. 
  

o This will bring up another dialog box in which you can associate a graphic with a value. 
The three frames are shown on the right of the dialog box, with their assigned values (0, 
1, and 2). 
  

o Since we do not need a graphic for the value of 0 (remember, a 0 indicates that neither 
the pump nor the blower is operating), leave this frame blank. 
  

o Frame 1 needs to have a graphic associated with it to indicate that the blower is on. Click 
in frame 1 to select it. Since we are using graphics that are available from the Graphics 
Library Manager, click on the Library tab. If the graphics were not located in the 
Graphics Library Manager, we would need to click on the Disk tab and select the proper 
location of the graphic, as well as its filename. 
  

o Click on the graphics folders to open them, and select a graphic to represent the blower. 
(You can preview the various graphics by clicking on their filenames in the list. The 
image will appear in the preview window in the center of the dialog box, with the 
graphic name listed below. The Panel tab in the preview window shows how the graphic 
will appear on your panel, while the Original tab shows the appearance of the original 
file graphic.) Click on the Replace Dynamic Graphic Frame icon above the list of frames 
to select a graphic to represent the highlighted frame (frame 1). The graphic will be 
shown in the frame for frame 1. 
  

o Repeat Step 11 for frame 2, and select a graphic to represent a pump. Click on OK to 
return to the dialog box in which the address and number of frames were selected. 
  

o Click on OK from within this dialog box to complete the procedure and return to the 
project page. 

Dynamic Graphics Example 2 

In this example, we want to have a graphic appear in one of three different locations on the 
screen, depending upon what is happening. Assume there are four possible occurrences:  a 
blower can be on, a pump can be on, both can be on, or neither can be on. If there is nothing 
on, the display screen will be blank. If the blower is on, the graphic of the blower will appear 
in the second screen location. If the pump is on, the graphic of the pump will appear in the 
third screen location. This can be accomplished by using a different memory location for each 
graphic that is to be displayed. If both the blower and the pump are on, then both will appear 
in their respective screen locations. 
  
Since there is to be nothing displayed on the screen when neither the pump nor the blower is 
on, we only need to create two dynamic graphics fields in the project file - one field for the 
graphic of the blower and the other field for the graphic of the pump. 
   
o To create the first dynamic graphic field for the blower, select Insert - Data Fields - 

Dynamic Graphics, or click on the Dynamic Graphics icon in the toolbar. 
  

o Use the cursor to define a box where the graphic is to be displayed. 
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o The Dynamic Graphic Properties dialog box appears. 
  

o Click on the "…" button under PLC Reference to set the memory location in the Data 
Field Properties dialog box. 
  

o Select the Frames index tab. 
  

o There are two different values that may be written into the controller:  0, 1. (Either the 
blower is off or it is on.) Therefore, our minimum value is 0 and the number of frames is 
2. Enter 0 in the Min box and 2 in the Frames box. 
  

o Click on the Edit button. 
  

o This will bring up another dialog box in which you can associate a graphic with a value. 
The two frames are shown on the right of the dialog box, with their assigned values (0 
and 1). 
  

o Since we do not need a graphic for the value of 0 (remember, a 0 indicates that neither 
the blower nor the pump is operating), leave this frame blank. 
  

o Frame 1 needs to have a graphic associated with it to indicate that the blower is on. Click 
in frame 1 to select it. Since we are using graphics that are available from the Graphics 
Library Manager, click on the Library tab. (Note that if the graphics were not located in 
the Graphics Library Manager, we would need to click on the Disk tab and select the 
proper location of the graphic, as well as its filename.) 
  

o Click on the graphics folders to open them, and select a graphic to represent the blower. 
(You can preview the various graphics by clicking on their filenames in the list. The 
image will appear in the preview window in the center of the dialog box, with the 
graphic name listed below. The Panel tab in the preview window shows how the graphic 
will appear on your panel, while the Original tab shows the appearance of the original 
file graphic.) Click on the Replace Dynamic Graphic Frame icon above the list of frames 
to select a graphic to represent the highlighted frame (frame 1). The graphic will be 
shown in the frame for frame 1. 
  

o Click on OK to return to the dialog box in which the address and the number of frames 
were selected. 
  

o Click on OK from within this dialog box to complete the procedure and return to the 
project page. 
  

o Repeat Steps 1-12 for the pump in a different location on the page. 

Time 

Time Data Field 

This option is used to add a time data field to the current page in the format HH:MM:SS. To 
insert a time data field click on the Time Field icon from the toolbar, select Insert - Data 
Fields - Time, or use the Ctrl+T keys, then use the cursor to define the area in which the time 
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field is to be placed. Once the time field is created a dialog box will appear where the text 
may be configured for displaying the time data field. 
  

 
  

 
  
To change the time display from 12-hour format to 24-hour format, or vice versa, choose 
Panel Setup from the Project menu. Under the Settings tab there is a Time Format field where 
this setting may be changed. 
  

Time Data Field Example 

o Select Insert - Data Fields - Time. 
   

o Use the cursor to outline an area for the time data field. 
  

o Set the fonts and colors. 
  

o Click OK. 
   

o The time data field appears on the project page. 
  

o If you wish to change the time format, choose Panel Setup from the Project menu, and 
select the Settings tab. Make a selection from the Time Format list. 
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Date 

Date Data Field 

This option is used to add a date data field to the current page. To insert a date data field click 
on the Date Field icon on the toolbar, select Insert - Data Fields - Date, or use the Ctrl+D 
keys, then use the cursor to define the area in which the date field is to be placed. Once the 
date field is created a dialog box will appear where the text may be configured for displaying 
the date data field. 
  

 
  

 
  
This field may be displayed in one of two formats: month/day/year or day/month/year. To 
change the date display format, choose Panel Setup from the Project menu. Under the Settings 
tab there is a Date Format field where this setting may be changed. 
  

Date Data Field Example 

o Select Insert - Data Fields - Date. 
   

o Use the cursor to outline an area for the date data field. 
  

o Set the fonts and colors. 
  

o Click OK. 
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o The date data field appears on the project page. 
  

o If you wish to change the date format, choose Panel Setup from the Project menu, and 
select the Settings tab. Make a selection from the Date Format list. 

4.5.1 Touch Cells 

Touch Cells 

A touch cell allows a panel user to interact with the panel. The user is able to touch a panel in 
an indicated position and receive a visual cue. The various types of touch cells available and 
their functionality are: 
  
Panel Key Button:  Used for creating a touch cell as a panel key (i.e., Enter). Panel keys 
represent all of the function keys, numeric keys, and arrow keys, as well as the help key, the 
clear key, the enter key, the +/- key, and the decimal point key. 
  
ASCII Key Button:  Used for creating a touch cell as an ASCII character. 
  
Push Button:  Used for creating a touch cell as a push button. These push buttons mimic 
mechanical push buttons in that one logic value represents open contacts and another logic 
value represents closed contacts. 
  
Illuminated Push Button:  Used for creating a touch cell as an illuminated push button. The 
only difference between an illuminated pushbutton and a pushbutton is that the face of the 
illuminated pushbutton can reflect the status of a bit in the PLC. 
  
Selector Switch:  Used for creating a touch cell as a 2, 3 or 4 position selector switch. 
  
Indicator Light:  Used for creating an indicator lamp. 
  
Generic Command Button:  Used for creating a touch cell as a panel key (i.e., Enter), macro 
command (i.e., show alarm list), or ASCII character. 
  
To insert a touch cell click the appropriate touch cell icon on the toolbar or select a type of 
touch cell from the Touch Cells submenu in the Insert menu, then use the cursor to define the 
area in which the touch cell is to be placed. A dialog box will appear where the touch cell 
may be configured. 
  
An example of using a touch cell to write to a controller is provided. 
  
Note:  To aid in programming, whenever a user touches a read/write numeric field, a keypad 
will appear, allowing them to enter data. 
  
Note:  Transparent and three-dimensional touch cells can be defined over static bitmap 
images. 
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Touch Cell Preview Window 

The Preview window lets you see how the touch cell will look before it is actually created and 
placed into a project file. 
  
Clicking the left mouse button on the touch cell in the preview window simulates pressing the 
touch cell. 
  

Touch Cell / Keyboard Macro Editor Example 

In this example, we will configure a touch cell to write a value to the controller. For this 
example, we will create a touch cell to simulate panel key F21. Then we will use the 
Keyboard Macro Editor to program the panel to write a value to the controller when panel key 
F21 is pressed. 
  
Note:  It is suggested that touch cells be programmed with a reversed attribute when they are 
pressed so that the operator will have immediate feedback. 
  
o Select Insert - Touch Cells - Panel Key Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Panel Key Button Properties dialog box, select Rectangle as the Style. 

   
o Under Action, click on the "…" button to identify the Key that will control the touch cell 

action. 
  

o Click on key F21 to select it. 
  

o Click OK. 
   

o Select the Attributes tab and select Reverse to have the touch cell reverse color when it is 
pressed. 
  

o Select the Layout tab and select Red as the color for On, and Yellow as the color for Off. 
   

o In the Label box, type Write to Controller. 
   

o Click OK. 
   

o Select Keyboard Macro Editor from the Project menu. 
  

o On the Page n tab, select key F21. This will allow the touch cell to perform its assigned 
function only on this page in the project. 
  

o Make sure that Pressed is selected as the Key State. 
   

o Select the Attribute icon from within the Commands toolbar. Select the Reverse 
attribute. Since we already highlighted the area in which this attribute is to occur, the 
dimensions are set automatically. 
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o Click OK. 
   

o The command "Attribute reverse at (location)" is listed for panel key F21. 
  

o It is necessary to set a small delay before turning off the attribute in order to give the 
panel user time to see the attribute. Select Wait from the Commands toolbar. 
  

o Enter a 3 in the dialog box that appears. This will add a 3/10 second delay. 
  

o The command "Wait for a 3/10 of a second" is listed. 
  

o Now we need to turn the attribute off. From the Commands toolbar, select Attribute 
again. Make sure that none of the attributes (Reverse, Highlight, Blink) are checked. 
  

o Click OK. 
   

o The command "Attribute clear at (location)" is listed. 
  

o From the Commands toolbar, select Write to Controller. 
   

o Specify the memory address in the Data Field Properties dialog box. 
  

o Click OK. 
   

o Enter a value to be written to the controller. 
  

o Click OK. 
   

o The command "Write value to Controller memory" is listed. 
  

o The macro screen should appear similar to that shown below. 
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o Click OK. 

  
The result should resemble the figure below. When the panel user presses this touch cell, the 
value 25 will be written to the controller. 
  

 
  

Panel Key Button 

Panel Key Button 

Panel keys represent all of the function keys, numeric keys, and arrow keys, as well as the 
help key, the clear key, the Enter key, the +/- key, and the decimal point key.  
To insert a panel key touch cell, click on the Panel Key Button icon from the toolbar or select 
Insert - Touch Cells - Panel Key, then use the cursor to define the area in which the touch cell 
is to be placed. The Panel Key Button Properties dialog box will appear where panel key 
button touch cells may be configured. 
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There are four tabs in the Panel Key Button Properties dialog box. They are: General, Layout, 
Attributes and Custom. 
  
The General tab lets you select the style of panel button and the panel key that is to be 
represented. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Attributes tab lets you indicate the attributes to be associated with the panel key button. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It enables you to create a custom button. 
  
A panel key touch cell example is provided. 
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General 

General 

 
  
The General tab of the Panel Key Button Properties dialog box lets you select the style of 
panel button and the panel key that is to be represented. 
  

Style 

Within the General index tab, you can specify the appearance of the touch cell by making a 
selection from the Style list. Selections include round and rectangular buttons, whether flat or 
3D. It is also possible to insert a Windows button (a touch cell with a look similar to the 
standard buttons you find in a typical Windows  application) or to create and insert a 
Custom button. Selecting the Custom style activates the Custom tab. 
  

Action 

The panel key that the touch cell is to represent is indicated in the Key box under Action. To 
select a panel key, click on the "…" button to bring up the Change/View Panel Key 
Assignment dialog box. 
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Layout 

Note: This page is used to show the Layout tab for all the Touch Cells. 
  

 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The upper Toolbar portion of the box contains a Special Characters icon, a Languages icon, 
and label placement buttons. 
  
Clicking on the Special Characters icon brings up the Special Characters dialog box that can 
be used to enter a special character into the touch cell label. 
  
It is possible to integrate multiple languages within the same touch cell. Clicking on the 
Languages button brings up the Languages dialog box that lets you choose the language in 
which you wish to work. 
The label placement icons lets you place the label either above the touch cell or centered on 
the touch cell. 
  
Note:  Fixed font text may only be placed above a touch cell. 
  
The top portion of the Layout box includes commands to create and customize a label on the 
touch cell. For instance, rather than displaying the label F1, a panel key could read Pressure. 
A toolbar includes icons to customize the label on the touch cell by inserting a special 
character or by selecting a particular language, and label placement. 
  
The Label box lets you specify the text that is placed either on or on top of the touch cell. 
  
Note:  The label must be entered after the key has been selected under the General tab, 
otherwise the default key label will override any label entered in the Label box. 
  
Clicking on the Font button lets you select the font to be used for a particular touch cell. Once 
a font is selected, it will continue to be used for all touch cells that are subsequently created. 
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Note:  This font is not a global font and may be changed at any time without affecting any of 
the previously created touch cells. It is possible to use different fonts on all of the touch cells 
in a single project file. 
  
Text indicates the color of the touch cell text. Text Bkgd indicates the background color of the 
touch cell text. This color will only be seen when the Transparent checkbox is not marked, 
otherwise the background of the touch cell text will appear either in On or in Off color for 
centered text and in the Background color if the text is on top. 
  
The bottom portion of the Layout box lets you choose the colors to be displayed on the touch 
cell. 
Line color is the color of the lines in the touch cell. Background color is the color of the touch 
cell background. The touch cell background is a part of the rectangle around the circular or 
elliptical touch cell not covered by the cell. Rectangular touch cells have no background if the 
touch cell text is centered, but if it is positioned on top, a strip of background appears above 
the cell. 
  
On shows the color that the touch cell will be when it is pressed, while Off indicates the color 
that the touch cell will be when it is in the not-pressed state. 
  

Attributes 

Note: This page is used to show the Attribute tab for all the Touch Cells. 
  

 
  
When the button is pressed you can set it to Blink, or for the colors to Reverse. 
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Custom 

Note: This page is used to show the Custom tab for all the Touch Cells. 
  

 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It enables you to create a custom button. 
  
Custom buttons can be created for both Off and On states. Click the Load button to import a 
graphic from the Graphics Library Manager. 
  
Clicking on the Edit button brings up the Enter Bitmap Dimensions dialog box. The button 
width and height can be specified. Color options may also be selected, according to the 
selected panel's support of colors. 
  
The Enable Indicator checkbox is available with Custom buttons. This checkbox allows you 
to place an indicator light on the button. 
  

Panel Key Button Touch Cell Example 

In this example, we will create a touch cell to simulate panel key F21. 
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Note:  It is suggested that touch cells be programmed with a reversed attribute when they are 
pressed so that the operator will have immediate feedback. 
  
o Select Insert - Touch Cells - Panel Key Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Panel Key Button Properties dialog box, select Rectangle as the Style. 

   
o Under Action, click on the "…" button to identify the Key that will control the touch cell 

action. 
  

o Click on key F21 to select it. 
  

o Click OK. 
   

o Select the Attributes tab and select Reverse to have the touch cell reverse color when it is 
pressed. 
  

o Select the Layout tab and select Red as the color for On, and Yellow as the color for Off. 
   

o Click OK. 

ASCII Key Button 

ASCII Key Button 

The ASCII Key Button Properties dialog box is used to create touch cells as ASCII 
characters. To insert an ASCII button touch cell, click the ASCII Key Button icon from the 
toolbar or select Insert - Touch Cells - ASCII Key Button, then use the cursor to define the 
area in which the touch cell is to be placed. A dialog box appears where an ASCII button 
touch cell may be configured. 
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There are four tabs in the ASCII Key Button Properties dialog box. They are: General, 
Layout, Attributes and Custom. 
  
The General tab allows you to select the style of button and the ASCII key that is to be 
represented. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Attributes tab lets you indicate the attributes to be associated with the ASCII panel key 
button. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It lets you create a custom button. 
  
An ASCII touch cell example is provided. 
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General 

General tab 

 
  
The General tab of the ASCII Key Button Properties dialog box lets you select the style of 
ASCII Key Button and the ASCII key character that is to represent the action. 
  

Action 

The ASCII character that is to be transmitted when the touch cell is pressed is entered in the 
Character box under Action. 
  

Touch Cell Panel Key Button Example 

In this example, we will configure an ASCII key as a touch cell. 
  
Note:  It is suggested that touch cells be programmed with a reversed attribute when they are 
pressed so that the operator will have immediate feedback. 
  
o Select Insert - Touch Cells - ASCII Key Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the ASCII Key Button Properties dialog box, select 3D Rectangle as the Style. 

   
o Under Action, enter the character that will control the touch cell action. 
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o Select the Attributes tab and select Reverse to have the touch cell reverse color when it is 
pressed. 
  

o Select the Layout tab and select Red as the color for On, and Yellow as the color for Off. 
   

o In the Label box, type ASCII Key. 
   

o Adjust the Font if necessary. 
  

o Click OK. 
   

o The screen should appear similar to the figure below. 
  

 
  
  

Push Button 

Push Button 

The Push Button Properties dialog box is used to create touch cells as push buttons. These 
push buttons mimic mechanical push buttons in that one logic value represents open contacts 
and another logic value represents closed contacts.  
  
To insert a push button touch cell, click the Push Button icon on the toolbar or select Insert - 
Touch Cells - Push Button, then use the cursor to define the area in which the push button 
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touch cell is to be placed. A dialog box will appear where the appearance and action of a push 
button touch cell may be configured. 
  

 
  
There are four tabs in the Push Button Properties dialog box. They are: General, Layout, 
Attributes, and Custom. 
  
The General tab lets you select the style of push button and the action that is to be 
represented. 
  
The Layout tab lets you choose the colors, font, languages, etc., to be used. 
  
The Attributes tab lets you indicate the attributes to be associated with the push button. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It lets you create a custom push button. 
  
A push button touch cell example is provided. 
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General 

General tab 

 
  
The General tab of the Push Button Properties dialog box allows you to select the style of 
push button, the push action, and the button reference location. 
  

Push Action 

The Push Action section allows you to select the action of the touch cell button. The different 
radio buttons within this group box represent the attribute that the touch cell will have 
whenever it is pressed. 
  
Note:  The press indicator can be used with touch cells that have graphics associated with 
them; however, attributes can best be seen on touch cells that are not associated with graphics. 
  
Note:  When Off is selected as the push action there will be no attribute associated with the 
touch cell when it is pressed. You will not be able to tell when the key has been pressed. 
Therefore, this option should be used only when there are graphics associated with a touch 
cell. 
  

Button 

The memory location that the push button affects can be set up in the Button section. The Ref 
entry box shows the currently selected memory location. Clicking on the "…" button brings 
up the Data Field Properties dialog box, which lets you select the exact memory location to be 
written to. You also have the option to disable the cyclic refresh. 
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Push Button Touch Cell Example 

In this example, we will configure a push button touch cell. 
  
Note:  It is suggested that touch cells be programmed with a reversed attribute when they are 
pressed so that the operator will have immediate feedback. 
  
o Select Insert - Touch Cells - Push Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Push Button Properties dia log box, select 3D Round as the Style. 

   
o Under Push Action, select the desired push button action. 

  
o Click on the "…" button to identify the controller reference location that will be mapped 

to the touch cell. 
  

o Select the Attributes tab and select Reverse to have the touch cell reverse color when it is 
pressed. 
  

o Select the Layout tab and select Red as the color for On, and Yellow as the color for Off. 
   

o In the Label box, type Push Button. 
  

o Adjust the Font if necessary. 
  

o Click OK. 
   

o The screen should appear similar to the figure below. 
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Illuminated Push Button 

Illuminated Push Button 

The Illuminated Push Button Properties dialog box is used to create a touch cell as an 
illuminated push button. The only difference between an illuminated push button and a push 
button is that the face of the illuminated push button can reflect the status of a bit in the PLC. 
  
To insert an illuminated push button touch cell, click the Illuminated Push Button icon from 
the toolbar or select Insert - Touch Cells - Illuminated Push Button, then use the cursor to 
define the area in which the illuminated push button touch cell is to be placed. The 
Illuminated Push Button Properties dialog box will appear where the appearance and action of 
an illuminated push button touch cell may be configured. 
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There are four tabs in the Illuminated Push Button Properties dialog box. They are: General, 
Layout, Attributes and Custom. 
  
The General tab allows you to select the style of push button, the action that is to be 
represented, and the memory location that has its status shown on the face of the button. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Attributes tab lets you indicate the attributes to be associated with the illuminated push 
button. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It enables you to create a custom button. 
  
An illuminated push button touch cell example is provided. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 119 

General 

General 

 
  
The General tab allows you to select the style of push button, the action that is to be 
represented, and the memory location that has its status shown on the face of the button. 
  

Button 

The memory location that the illuminated push button affects when it is pressed can be set up 
in the Button section. The Ref entry box shows the currently selected memory location. 
Clicking on the "…" button brings up the Data Field Properties dialog box, where you can 
select the exact memory location to be affected. You also have the option to disable the cyclic 
refresh. 
  

Light 

The Light section enables you to set the colors for On and Off stages of the illuminated push 
button. The Ref entry box shows the memory location that is reflected by the Light. Clicking 
on the "…" button brings up the Data Field Properties dialog box, which allows you to select 
the exact memory location to be reflected. 
  

Illuminated Push Button Example 

In this example, we will configure a push button touch cell  
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Note:  It is suggested that touch cells be programmed with a reversed attribute when they are 
pressed so that the operator will have immediate feedback. 
  
o Select Insert - Touch Cells - Illuminated Push Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Illuminated Push Button Properties dialog box, select 3D Round as the Style. 

   
o Under Push Action, click on the "…" button to identify the controller reference location 

that will be mapped to the touch cell push action. 
  

o Under Light, click on the "…" button to identify the controller reference location that 
will be mapped to the touch cell light. 
  

o Select Red as the color for On, and Green as the color for Off. 
   

o Select the Attributes tab and select Reverse to have the touch cell reverse color when it is 
pressed. 

o Select the Layout tab and in the Label box, type Illuminated Push Button. 
   

o Adjust the Font if necessary. 
  

o Click OK. 
   

o The screen should appear similar to the figure below. 
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Selector Switch 

Selector Switch 

The Selector Switch Properties dialog box is used to create a selector switch of N states 
(where N represents an integer from 2 through 4). 
  
To insert a selector switch touch cell, click the Selector Switch icon from the toolbar or select 
Insert - Touch Cells - Selector Switch, then use the cursor to define the area in which the 
touch cell is to be placed. A dialog box will appear where the appearance and action of a 
selector switch touch cell may be configured. 
  

 
  
There are three tabs in the Selector Switch Properties dialog box. They are: General, Layout, 
and Custom. 
  
The General tab allows you to select the style of selector switch, the number of states and the 
memory location in the controller that is affected by each state. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It lets you create a custom button. 
  
A selector switch touch cell example is provided. 
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General 

General 

 
  
The General tab of the Selector Switch dialog box allows you to select the Style of selector 
switch and the Action. 
  

Style 

Within the General index tab, you can specify the appearance of the touch cell by making a 
selection from the Style list. Selections include round and rectangular buttons, both flat and 
3D. It is also possible to create and insert a Custom button. Selecting the Custom style 
activates the Custom tab. 
  

Action 

In the Action section you can set the number of states. The minimum number of states is two 
(2), and the maximum number of states is four (4). You can also configure which memory 
location in the controller is affected by each state of the selector switch, as well as the color 
scheme for each state. 
The Ref entry box shows the currently selected memory location. Clicking on the "…" button 
brings up the Data Field Properties dialog box, which allows you to select the exact memory 
location to be written to. 
You also have the option to disable the cyclic refresh. 
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Layout 

The Layout tab of the Selector Switch Properties dialog box lets you select the colors, font, 
languages, etc., to be used. Select the tab with the number of the state to be configured. 
The upper Toolbar portion of the box contains a Special Characters icon, a Languages icon, 
and label placement buttons. 
  
Clicking on the Special Characters icon brings up the Special Characters dialog box that can 
be used to enter a special character into the touch cell label. 
It is possible to integrate multiple languages within the same touch cell. Clicking on the 
Languages button brings up the Languages dialog box that lets you choose the language in 
which you wish to work. 
The label placement icons lets you place the label either above the touch cell or centered on 
the touch cell. 
  
Note:  Fixed font text may only be placed above a touch cell. 
  
The top portion of the Layout box includes commands to create and customize a label on the 
touch cell. For instance, rather than displaying the label F1, a panel key could read Pressure. 
A toolbar includes icons to customize the label on the touch cell by inserting a special 
character or by selecting a particular language, and label placement. 
The Label box lets you specify the text that is placed either on or on top of the touch cell. 
  
Note:  The label must be entered after the key has been selected under the General tab, 
otherwise the default key label will override any label entered in the Label box. 
Clicking on the Font button lets you select the font to be used for a particular touch cell. Once 
a font is selected, it will continue to be used for all touch cells that are subsequently created. 
  
Note:  This font is not a global font and may be changed at any time without affecting any of 
the previously created touch cells. It is possible to use different fonts on all of the touch cells 
in a single project file. 
  
Text indicates the color of the touch cell text. Text Bkgd indicates the background color of the 
touch cell text. This color will only be seen when the Transparent checkbox is not marked, 
otherwise the background of the touch cell text will appear either in On or in Off color for 
centered text and in the Background color if the text is on top. 
  
The bottom portion of the Layout box lets you choose the colors to be displayed on the touch 
cell. 
Line color is the color of the lines in the touch cell. Background color is the color of the touch 
cell background. The touch cell background is a part of the rectangle around the circular or 
elliptical touch cell not covered by the cell. Rectangular touch cells have no background if the 
touch cell text is centered, but if it is positioned on top, a strip of background appears above 
the cell. 
On shows the color that the touch cell will be when it is pressed, while Off indicates the color 
that the touch cell will be when it is in the not-pressed state. 
  

Custom 

The Custom tab is only selectable when the Custom style is selected on the General tab. It 
enables you to create a custom selector switch. 
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Custom selector switches can be created for multiple states, defined under the Action section 
of the General tab. Click the Load button to import a graphic from the Graphics Library 
Manager. 
Clicking on the Edit button brings up the Enter Bitmap Dimensions dialog box. The width 
and height can be specified. Color options may also be selected, according to the selected 
panel's support of colors. 
  

Selector Switch Touch Cell Example 

In this example, we will configure a selector switch with two (2) states.  
  
o Select Insert - Touch Cells - Selector Switch. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Selector Switch Properties dialog box, select 3D Round as the Style. 

   
o Under Action, set the number of states to 3. 

  
o For state 1, click on the "…" button to identify the controller reference location that will 

be mapped to state 1. Set the color for the first state to Red. 
   

o Click on the tab for state 2, and click on the "…" button to identify the controller 
reference location that will be mapped to the state 2. Set the color for the second state to 
Yellow. 
   

o Click on the tab for state 3, and click on the "…" button to identify the controller 
reference location that will be mapped to the state 3. Set the color for the third state to 
Green. 
   

o Select the Layout tab and in the Label box for state 1, type State 1. 
   

o Click the tab in the Label box for state 2 and type State 2. 
   

o Click the tab in the Label box for state 3 and type State 3. 
   

o Adjust the Font if necessary. 
  

o Click OK. 
   

o The screen should appear similar to the figure below. 
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Indicator Light 

Indicator Light 

The Indicator Light Properties dialog box is used to create a touch cell as an indicator light. 
  
To insert an indicator light touch cell, click the Indicator Light icon from the toolbar or select 
Insert - Touch Cells - Indicator Light, then use the cursor to define the area in which the touch 
cell is to be placed. A dialog box will appear where the appearance and action of an indicator 
light touch cell may be configured. 
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There are three tabs in the Indicator Light Properties dialog box. They are: General, Layout, 
and Custom. 
  
The General tab allows you to select the style of indicator light, the number of states and the 
memory location in the controller that the indicator light is to reflect. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Custom tab is only selectable when a Custom style button is selected on the General tab. 
It enables you to create a custom button. 
  
An indicator light touch cell example is provided. 
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General 

General 

 
  
The General tab of the Indicator Light Properties dialog box lets you select the style of panel 
button, the number of states, and the memory location for each state. 
  

Style 

Within the General index tab, you can specify the appearance of the touch cell by making a 
selection from the Style list. Selections include round and rectangular buttons, whether flat or 
3D. It is also possible to insert a Custom button. Selecting the Custom style activates the 
Custom tab. 
  

Action 

In the Action section you can set the number of states. The minimum number of states is two 
(2), and the maximum number of states is four (4). You can also define the color scheme for 
each state. Note that the indicator light can be configured to handle up to four (4) different 
states. A different color can be assigned to each state in order to reflect the contents of the 
memory location in the controller. 
  

Assign 

You can also configure which memory location in the controller is reflected by each state of 
the indicator light. The Ref entry box in the Assign section shows the currently selected 



EH-VIEW (en) - July 2005 - 05/005 

Page 128 

memory location. Clicking on the "…" button brings up the Data Field Properties dialog box, 
which allows you to select the exact memory location to be reflected. 
  

Layout 

The Layout tab lets you select the colors, font, languages, etc., to be used. 
The upper Toolbar portion of the box contains a Special Characters icon, a Languages icon, 
and label placement buttons. 
  
Clicking on the Special Characters icon brings up the Special Characters dialog box that can 
be used to enter a special character into the touch cell label. 
  
It is possible to integrate multiple languages within the same touch cell. Clicking on the 
Languages button brings up the Languages dialog box that lets you choose the language in 
which you wish to work. 
The label placement icons lets you place the label either above the touch cell or centered on 
the touch cell. 
  
Note:  Fixed font text may only be placed above a touch cell. 
  
The top portion of the Layout box includes commands to create and customize a label on the 
touch cell. For instance, rather than displaying the label F1, a panel key could read Pressure. 
A toolbar includes icons to customize the label on the touch cell by inserting a special 
character or by selecting a particular language, and label placement. 
  
The Label box lets you specify the text that is placed either on or on top of the touch cell. 
  
Note:  The label must be entered after the key has been selected under the General tab, 
otherwise the default key label will override any label entered in the Label box. 
  
Clicking on the Font button lets you select the font to be used for a particular touch cell. Once 
a font is selected, it will continue to be used for all touch cells that are subsequently created. 
  
Note:  This font is not a global font and may be changed at any time without affecting any of 
the previously created touch cells. It is possible to use different fonts on all of the touch cells 
in a single project file. 
  
Text indicates the color of the touch cell text. Text Bkgd indicates the background color of the 
touch cell text. This color will only be seen when the Transparent checkbox is not marked, 
otherwise the background of the touch cell text will appear either in On or in Off color for 
centered text and in the Background color if the text is on top. 
  
The bottom portion of the Layout box lets you choose the colors to be displayed on the touch 
cell. 
Line color is the color of the lines in the touch cell. Background color is the color of the touch 
cell background. The touch cell background is a part of the rectangle around the circular or 
elliptical touch cell not covered by the cell. Rectangular touch cells have no background if the 
touch cell text is centered, but if it is positioned on top, a strip of background appears above 
the cell. 
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Custom 

The Custom tab is only selectable when the Custom style is selected on the General tab. It 
enables you to create a custom indicator light. 
Custom indicator lights can be created for multiple states, defined under the Action section of 
the General tab. Click the Load button to import a graphic from the Graphics Library 
Manager. 
Clicking on the Edit button brings up the Enter Bitmap Dimensions dialog box. The width 
and height can be specified. Color options may also be selected, according to the selected 
panel's support of colors. 
  

Indicator Light Touch Cell Example 

In this example, we will configure a selector switch with two (2) states. 
  
o Select Insert - Touch Cells - Indicator Light. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Indicator Light Properties dialog box, select 3D Round as the Style. 

   
o Under Action, set the number of states to 3. 

   
o Set the color for the first state to Red. 

   
o Click on the tab for state 2, and set the color for the second state to Yellow. 

   
o Click on the tab for state 3, and set the color for the third state to Green. 

   
o Under Assign, click on the "…" button to identify the controller reference location that 

will be mapped to the indicator light. Select the Layout tab and in the Label box, type 
Indicator Light. 
   

o Adjust the Font if necessary. 
  

o Click OK. 
   

o The screen should appear similar to the figure below. 
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Generic Command Button 

Generic Command Button 

The Generic Command Button dialog box is used to create a touch cell as a generic 
command. 
  
To insert a selector switch touch cell, click the Generic Button icon from the toolbar or select 
Insert - Touch Cells - Generic Command Button, then use the cursor to define the area in 
which the touch cell is to be placed. The Generic Button Properties dialog box will appear 
where the appearance and action of a generic command button touch cell may be configured. 
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There are four tabs in the Generic Button Properties dialog box. They are: General, Layout, 
Attributes and Custom. 
  
The General tab allows you to select the style of generic command button, and the action to 
be reflected. 
  
The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
The Attributes tab lets you indicate the attributes to be associated with the generic push 
button. 
  
The Custom tab is only selectable when a Custom or Windows Custom style button is 
selected on the  
General tab. It enables you to create a customized button. 
  
A generic command button touch cell example is provided. 
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General 

General 

 
  
The General tab of the Generic Button Properties dialog box lets you select the style of button 
and the action that is to be represented. 
  

Style 

Within the General index tab, you can specify the appearance of the touch cell by making a 
selection from the Style list. Selections include flat or 3D round and rectangular buttons, no 
graphics, Windows and Windows Custom buttons, and Custom buttons. Selecting the Custom 
or Windows Custom style activates the Custom tab. 
  
The option No Graphics can create a touch cell that is entirely invisible. For example, you 
may have a graphic that encompasses the entire screen of a control process in a factory. It 
contains images of flow control valves, motors, and blowers. You can create touch cells on 
the separate images and configure them to perform certain tasks. For instance, if you press the 
touch cell that is on the image of the motor, the motor may turn on. If you press the touch cell 
that is on the image of a valve, the valve may close, etc. All that will be seen on the screen is 
the image of the process; the touch cells will be invisible. 
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Action 

To define the functionality of the touch cell, select one of the three radio buttons under the 
Action portion of the dialog box. The action can be a Panel Key, an ASCII Key, or a Macro 
Command. 
If Panel Key is selected, clicking on the "…" button brings up the Change / View Panel Key 
Assignment dialog box where you have a list of panel keys to choose from.  
If ASCII Key is chosen, simply enter the character to be sent in the box beside of the ASCII 
key radio button. 
  
Macro commands represent all of the elementary macro commands that are available from the 
Keyboard Macro Editor. The touch cells can be programmed using the Keyboard Macro 
Editor to perform a vast array of functions, such as changing pages of the project file, 
scrolling down a line, entering Data Entry Mode, and writing a value to the controller. If 
Macro Command is chosen the Macro button brings up the Define / Edit Macro Command 
dialog box where Keyboard Macro Editor commands are available. 
  

Enable Indicator 

The Enable Indicator checkbox is available with Windows, Windows Custom, and Custom 
style touch cell buttons. This checkbox allows you to place an indicator light on the button. 
  

Custom 

By choosing Custom, you can select the source of the graphic that is to be used on the face of 
the touch cell. This feature gives you the ability to import separate graphics for the pressed 
and not pressed states. These graphics can be imported either from an external file or from a 
library. 
  

Generic Command Button Touch Cell Example 

In this example, we will configure a custom generic touch cell button.  
  
o Select Insert - Touch Cells - Generic Command Button. 

   
o Use the cursor to outline an area on the page where the touch cell will appear. 

  
o In the Generic Button Properties dialog box, select Windows Custom as the Style. 

   
o Under Action, set the Action as Panel Key. 

   
o Click on the "…" button to select a panel key to associate with the button. 

  
o Check the Enable Indicator box to place an indicator light on the button. 

  
o Identify the controller reference location that will be mapped to the button. 
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o From the Layout tab, enter a label for the button, adjust the Font if necessary, and select 
colors for the Off and On states. 
  

o On the Attributes tab check Reverse. 
   

o On the Custom tab (visible only when a Custom button style is chosen) you can either 
press the Edit button and create your own button face, or press the Load button and load 
an image from a file. 
  

o Create a button face, then click OK. 
   

o The screen should appear similar to the figure below. 
  

 
  

4.5.2 Shapes 

Shapes 

It is quite easy to add simple shapes using the EH-View software, including SVG line, lines, 
SVG rectangle,  rectangles, and ovals. The Shapes submenu under the Insert menu offers 
these options, or you may click on the individual shape icons in the toolbar. 
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Line / SVG Line 

To insert a line / SVG Line, click on the Line / SVG Line icon in the toolbar, or select Insert - 
Shapes - Line / SVG Line. Place the cursor where the line is to begin, click once, then move 
the cursor to where the line is to end and click again. The line will appear. SVG Line can be 
drawn in any angle. 
  
SVG Line icon is enabled only for firmware version 4.50 and above. The 'Pixel and Vector 
graphics' option should be enabled under the Panel Setup -> Settings tab. 
  

Rectangle / SVG Rectangle 

To insert a rectangle / SVG rectangle, click on the Rectangle / SVG Rectangle icon in the 
toolbar, or select Insert - Shapes - Rectangle. Place the cursor at one corner of the rectangle, 
click once, then move the cursor to the opposite corner of the rectangle and click again. The 
rectangle will appear. 
  
SVG Rectangle icon is enabled only for firmware version 4.50 and above. The 'Pixel and 
Vector graphics' option should be enabled under the Panel Setup -> Settings tab. 
  
Note:  A rectangle can be used to place a border around a bargraph. 
  

Oval 

To insert an oval, click on the Oval icon in the toolbar, or select Insert - Shapes - Oval. Place 
the cursor at one side of the oval, click once, then move the cursor to the opposite side of the 
oval and click again. The oval will appear. 
  
Oval icon is enabled only for firmware version 4.50 and above. The 'Pixel and Vector 
graphics' option should be enabled under the Panel Setup -> Settings tab. 

4.5.3 Trend Window 

Trend Window 

The trend window displays the trend buffer. 
  
Note:  Before creating a trend window you must define the Trend Buffer. 
  
To create a trend viewer, select the Trend Viewer icon from the toolbar, or select Trend 
Window from the Insert menu. Use the cursor to define an area for the trend window. Once 
the trend window is defined, double -clicking on the trend window brings up the Trend 
Window Properties dialog box. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 136 

 
  
The Trend Window Properties dialog box may also be accessed by right-clicking on the trend 
field area and selecting Properties. 
  
Within the Trend Viewer Properties dialog box you can define the main trend viewer 
properties for the X-Axis, the Y-Axis, and the overall layout. 
  
A list of trend window limitations is provided. 
  

Trend Window Limitations 

Max number of trend windows inside the same page 10 
Max number of curves inside the same trend window 10 
Total number of curves that can be use inside the same page 20 
Max number of global trend buffers sampled in background 20 
Cyclical sampling period 1-9999 sec 
The total memory reserved for trend buffer 20 KB 
Available memory area in the PLC for storing trend buffers 60 bytes 
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Preview 

The Preview window allows you to see how the trend window will look before it is actually 
created and placed into a project file. 
  

Y-Axis 

Y-Axis 

 
  
Selecting the Y-Axis index tab will allow you to select the trend buffers (curves) to be 
displayed inside the trend viewer. You can also set the appearance of the Y-Axis and 
configure the trend cursor. 
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Curves 

Selecting the Y-Axis index tab will allow you to select the trend buffers (curves) to be 
displayed inside the trend viewer. Use the Add and Delete buttons to add or remove trend 
buffers. The Add button opens a dialog box that contains a list of all the active trend buffers 
that can be used. To remove a previously inserted curve, select it from the Curves list and 
click the Delete button. 
  
Note:  Once a curve is added to the trend viewer, you will only be able to add additional 
curves of the same sampling method to that particular trend viewer. 
  

Appearance 

Appearance 

For any curve, you can choose the appearance properties such as   
  
o Line Type. 

  
o Line Style. 

  
o Line Size. 

  
o Line Color. 

Type 

Curve type. Can be Line, Step or Filled bar graph. 

Style 

Curve style. Can be Solid, Dotted, Dashed, Dash Dot or Dash Dot Dot. 
  
Note:  The style type is applicable only when curve is line type. 

Size 

Curve size. Can be Thin, Medium or Thick. 

Color 

Curve color. The basic 16 colors are supported. 
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Cursor 

Cursor 

This variable can be used to display the value of the curve at a point on the Y-axis. The Y-
Cursor can be activated, and the Y-Axis Minimum and Maximum values can be set. 
Use the trend macros to activate the trend cursor. 
  

Y Cursor 

This variable can be used to display the value of the curve at a point on the Y-axis. Use the 
trend macros to activate the trend cursor. 
  

Y Axis Minimum 

The minimum value of the defined Y-axis. To the right of the dialog box you can define the 
default value (Y-axis range) that will be used when the trend viewer is displayed.  If you put 
this internal panel control variable on the EH-HMI as a read/write field its value can be 
modified on-line, allowing you to dynamically change the Y-axis range. 
  

Y Axis Maximum 

The maximum value of the defined Y-axis. To the right of the dialog box you can define the 
default value (Y-axis range) that will be used when the trend viewer is displayed.  If you put 
this internal panel control variable on the EH-HMI as a read/write field its value can be 
modified on-line, allowing you to dynamically change the Y-axis range. 
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X-Axis 

X-Axis 

 
  
Use this index tab to define the X-axis properties (Style, Scrolling and Cursor) of the trend 
viewer. 
  
Note:  A single X-Axis exists for all of the curves that have been inserted inside the same 
trend viewer window. 
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Style 

Style 

The format of the X-Axis (Time, Samples or On PLC) is defined from the curves that are 
inside the trend viewer. When no curves are defined, all of these radio buttons are disabled. 
After adding one or more curves, only the appropriate radio button is enabled. 
  

Time 

The X-axis range is time defined.  This will be enabled when the trend buffers inside the trend 
viewer are sampled cyclically from the panel. 
  

Samples 

The X-axis range is defined by a maximum number of samples. This will be enabled when the 
trend buffers inside the trend viewer are sampled on PLC events. 
  

On PLC 

The X-axis range is defined by a maximum number of samples. The number of samples must 
be defined inside the PLC memory. 
  

Scrolling 

Scrolling 

The scroll parameters (direction and auto scroll control) defines how much the trend viewer 
will be shifted upon each scroll operation. The scroll parameter can be a fixed amount of time 
or a fixed number of samples. 
  

Scroll Direction 

This parameter defines the direction of the curve. The curve can be drawn Left to Right, Right 
to Left, Up to Down or Down to Up. 
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Enable Auto Scroll Control 

Use this checkbox to enable a trend viewer shift when the trend viewer becomes full. 
  

Cursor 

Cursor 

This variable can be used to display the value of the curve at a point on the X-axis. The X-
Cursor can be activated, and the X-Axis Minimum and Maximum values and color can be set. 
Use the trend macros to activate the trend cursor. 
  

X Cursor 

This variable can be used to display the value of the curve at a point on the X-axis. Use the 
trend macros to activate the trend cursor. 
  

X Axis Minimum 

This variable contains the minimum value of the defined X-axis. You can put this variable on 
the panel by selecting the Time/Date icons located on the toolbar.  
  

X Axis Maximum 

This variable contains the maximum value of the defined X-axis. You can put this variable on 
the panel by selecting the Time/Date icons located on the toolbar.  
  

Cursor Color 

Color used to draw the X-axis cursor. 
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Layout 

Layout 

 
  
Options in the Layout section define the visual appearance of the trend viewer window, such 
as the title and window. A layout toolbar is also available. 
  

Layout Toolbar 

Layout Toolbar 

The layout toolbar contains icons to keep frequently used commands easily accessible. These 
include the following commands 
  
o Special Characters 
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Clicking on the Special Characters icon brings up the Special Characters dialog box that can 
be used to enter a special character. 
  
  
o Select Language 

  
It is possible to integrate multiple languages. Clicking on the Select Language button brings 
up the Languages dialog box that allows you to choose the language in which you wish to 
work. 
  
  
o Alignment. 

  
Title alignment. Can be Left, Right or Center. 
  

Special Characters 

Clicking on the Special Characters icon brings up the Special Characters dialog box that can 
be used to enter a special character. 

Select Language 

It is possible to integrate multiple languages. Clicking on the Select Language button brings 
up the Languages dialog box that allows you to choose the language in which you wish to 
work. 

Alignment 

Title alignment. Can be Left, Right or Center. 

Title  

Title  

In the Title section you can enter title text and format the appearance of the title by setting the 
font, foreground and background colors, and title height. 
  

Text 

The text that will be the trend window title or label. 
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Font 

Title font. 
  

Height 

Height of the area reserved for the trend viewer title, as a percentage of the trend viewer. 
  

Foreground (FG) 

Title foreground color. 
  

Background (BG) 

Title background color. 
  

Window 

Window 

In the Window section you can format the appearance of the window by setting the frame 
color and width, the background color, and to enable a horizontal or vertical grid, set the 
horizontal grid color or vertical grid color, and set the horizontal grid marks or vertical grid 
marks. 
  

Frame 

Trend frame color. 
  

Width 

Trend frame width as a percentage of the trend window. Set to 0 for no frame. 
  

Background Color 

Trend frame window background color. 
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X Grid 

Check the box to enable a horizontal grid in the viewer window. 
  

X Grid Color 

Color of the horizontal grid. 
  

X Grid Marks 

Number of horizontal grid lines. 
  

Y Grid 

Check the box to enable a vertical grid in the viewer window. 
  

Y Grid Color 

Color of the vertical grid. 
  

Y Grid Marks 

Number of vertical grid lines. 
  

Trend Window Example 

o A trend buffer must be created before a trend window can be created. Select Trend 
Buffers from the Project menu. 
  

o Click on the Insert Item button above the buffers list. 
  

o Name the new buffer. 
  

o Click OK to accept the default settings for the trend buffer and return to the project page. 
  

o Select Trend Window from the Insert menu. 
  

o Use the cursor to define an area for the trend window. 
  

o In the Trend Window Properties dialog box click on the Add button. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 147 

o From the Choose Trend Buffer list select the trend buffer that you created in steps 1-4. 
  

o Click OK to return to the Trend Window Properties dialog box. 
  

o Select the Layout tab. 
  

o Enter a label for the trend window in the Text box. 
  

o Click OK to accept the trend window settings and return to the project page where the 
trend window is now displayed. 

4.5.4 Meter Instrument 

Meter Instrument 

Meter instruments are simple instruments, such as gauges, that display numerical values by 
moving a needle to the appropriate position over a labeled scale. The look of a meter 
instrument can be changed to suit your the needs. Up to ten (10) meter instruments can be 
displayed on a single page within a project. 
  
To insert a gauge in EH-View, click on the Meter Instrument icon and use the cursor to define 
an area where the gauge is to appear, or select Meter Instrument from the Insert menu. The 
Meter Instrument Properties dialog box will appear where the appearance and action of a 
meter instrument may be configured. 
  

 
  
  
There are five tabs in the Meter Instrument Properties dialog box. They are: General, Layout, 
Gauge, Needle, and Background. 
  
The General tab allows you to select the style and range of the meter gauge, the memory 
location that is to be represented, and scale the output if necessary. 
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The Layout tab lets you select the colors, font, languages, etc., to be used. 
  
On the Gauge tab you can set the rotation direction, format the ticks on the dial, and set the 
arc colors. 
  
The Needle tab allows you to customize the color and size of the gauge indicator needle. 
  
The Background tab lets you insert a custom background if you wish. 
  
An external small window allows to Preview the Meter Instrument. 
  

Preview 

 
  
The Preview window allows you to see how the gauge will look before it is actually created 
and placed into a project file. 
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General 

General 

 
  
Within this index tab, you can enter the main properties that define the gauge, such as the 
style, range, reference location and any necessary scaling. 
  

Style 

The style of gauge to be inserted (full circle, half circle, etc.). Custom gauges may also be 
created. 
  

Range 

Range 

The minimum and maximum scale values, the number of value labels to be shown on the 
gauge, and the gauge precision. 
  

Minimum 

Minimum and value on the gauge scale. 
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Maximum 

Maximum value on the gauge scale. 
  

Count 

The number of values (in addition to zero) to be shown on the gauge. The values shown will 
be computed by dividing the maximum value by the count. 
  

Precision 

The precision, or number of digits to the right of the decimal point that are to be displayed on 
the gauge. A value of zero means that only integer values will be displayed. 
  

Reference 

Defines the variable that is to be graphically represented. Variables can be PLC references or 
internal panel variables. Clicking on the "…" button for PLC references brings up the Data 
Fields Properties dialog box where the reference location may be set. 
  

Scale 

The scaling parameter may be used to perform a linear transformation on the value to be 
displayed. Specify the scaling operators A1, A2, and B for the equation Y=A1/A2*X+B in 
the boxes. 
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Layout 

Layout 

 
  
The parameters within this index tab are used to define the layout of the gauge. 
  
These include the Title text, the Title X size, the Title Y size, the Labels, the Gauge X size, 
the Gauge Y size, the overall gauge Size, the Title color and Font, the Labels color color and 
Font, the Frame color, the Rim color, and the Background color. 
  
A Layout Toolbar keeps the Special Characters and Languages commands handy. 
  

Layout Toolbar 

The Layout Toolbar keeps the Special Characters and Languages commands handy. 
  

Layout Properties 

Title  

This is the title for the gauge.  
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Title X 

The position of the title on the x-axis. A value of 50% is in the middle of the box area, 0% is 
on the left border and 100% on the right border. 
  

Title Y 

The position of the title on the y-axis. A value of 50% is in the middle of the box area, 0% is 
on the upper border and 100% on the bottom border. 
  

Labels 

The position of the numeric labels on the gauge. A value of 100% is on the gauge scale circle. 
Greater than 100% is outside the scale and less than 100% is inside the scale. 
  

Gauge X 

The position of the gauge on the x-axis. A value of 50% is in the middle of the box area, 0% 
is on the left border and 100% is on the right border. 
  

Gauge Y 

The position of the gauge on the y-axis. A value of 50% is in the middle of the box area, 0% 
is on the upper border and 100% is on the lower border. 
  

Size 

The size of the gauge as a percentage (0-100%) of the smallest side of the box.  
  

Title Color 

The color in which the title text will be displayed. 
  

Title Font 

The font in which the gauge title will be displayed. (Can be selected from installed 
Touchscreen fonts). 
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Labels Color 

The color in which the title text will be displayed. 
  

Labels Font 

The font in which the numeric labels on the gauge will be displayed. (Can be selected from 
installed Touchscreen fonts). 
  

Frame 

The color of the box frame around the gauge. 
  
Note:  A frame color is not used when the background is a custom bitmap. 
  

Rim 

The color of the gauge scale and ticks. 
  
Note:  A rim color is not used when the background is a custom bitmap. 
  

Background 

The background color of the gauge box. 
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Gauge 

Gauge 

 
  
On the Gauge tab you can format the Rotation and Ticks on the dial, and set the Arc Colors. 
  

Rotation 

Rotation 

Under the Rotation section you can set the rotation direction, the origin point, start position, 
and range. 
  

Direction 

The rotation direction of the gauge needle. Can be clockwise or counterclockwise. 
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Origin 

The position of the gauge origin point (zero). Choices are East, North, West and South. 
  

Start 

Scale start angle. It can be from 0° to 360°. 
  

Range 

Scale range. It can be from 0° to 360°, with 0° being a single point and 360° a full circle. 
  

Ticks 

Ticks 

In the Ticks section you can set the style for the ticks, the number of major and minor ticks, 
and the size of the ticks. 
  

Style 

The position of the ticks on the gauge scale. Can be Outside or in the Middle of the scale. 
  

Major 

Number of major ticks on the scale. 
  
Note:  If a number less than the Range count is entered, the Range count becomes the default 
value. 
  

Minor 

Number of minor ticks (ticks between major ticks) on the scale. 
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Size 

Size, in percentage of the gauge circle, of major ticks. Minor ticks are generally half the size 
of major ticks. 

Arc Colors 

These parameters are used to define different colored zones on the gauge. To define a color 
range on the gauge, enter the Begin and End label values in the boxes provided. Select a color 
for that zone. Boxes for an additional zone are created whenever a value is entered in existing 
boxes. To delete a color zone, remove the label values from the Begin and End boxes. 
  

Needle 

Needle 

 
  
On the Needle tab you can format the needle Style, Length, Tail size, tail Thickness, Center 
size, Needle color and Center color. 
  

Style 

The style of needle to be used. Choices include Thick, Triangle, and Filled Triangle. 
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Length 

Needle length expressed as a percentage of the gauge radius.  
  

Tail 

Needle tail length expressed as a percentage of the gauge radius. 
  

Thickness 

Needle thickness expressed as a percentage of the gauge radius. 
  

Center 

The circle that highlights the needle rotation point. The size of this circle is defined as a 
percentage of the gauge diameter. 
  

Needle Color 

Color of the needle body. 
  

Center Color 

Color of the needle center. 
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Background 

 
  
Check the Custom Background checkbox to enable the custom background commands. This 
lets you enter a custom bitmap as the background for the gauge. 
  
The bitmap can come from an external file or from the Graphics Library Manager  that is 
supplied with EH-View. 
  
Select the image source to be used, select the bitmap and click the Load image button. Use the 
Edit button to edit the bitmap size and colors. 

Meter Instrument Example 

o From the Insert menu select Meter Instrument. 
   

o Use the cursor to define an area for the mete r instrument. 
  

o From the Meter Instrument Properties dialog box select Full Circle as the meter Style. 
  

o Under Range, insert 10 in the Count box to have labels at 10, 20, 30, etc. 
  

o Select the Layout tab and enter a Title for the meter. 
  

o By default the title is in the center of the meter. Slide the Title Y selector to a value of 
85% or 90% to place the title towards the bottom of the meter window. 
  

o Adjust the Size of the gauge as necessary to fit the area defined in step 2. 
  

o Select the Gauge tab. 
  

o Under Ticks, enter a value of 10 for Major and 10 for Minor. This puts a major tick at 
each of the 10 labels, and a minor tick at each whole value. 
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o Select the Needle tab. 
  

o Set the Needle and Center colors to red. 
  

o Set the Center value to 15%. 
  

o Click OK to accept the meter settings and close the Meter Instrument Properties dialog 
box. 
  

o The meter instrument appears on the project page. 

4.5.5 Trend Time Field 

Trend Time Field 

Trend Time Field is a panel internal control variable related to trend components. It shows the 
trend sampling time used on the x-axis. 
  
To insert a trend time field in EH-View, click on the Trend Time Field icon and use the cursor 
to define an area where the field is to appear, or select Trend Time Field from the Insert 
menu. The Trend Time Field Properties dialog box will appear where the contents and layout 
of a trend time field may be configured. 
  

 
  
There are two tabs in the Trend Time Field Properties dialog box. They are General and 
Layout. 
  
The General tab allows you to select the style and contents of the trend time field,  and the 
memory location that is to be represented. 
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The Layout tab lets you select the colors, font, etc., to be used. 
  
An external small window allows to Preview the Trend Time Field. 
  

Preview 

 
  
The Preview window shows how the field will look on the panel screen. 
  

General 

General 

 
  
The General tab includes commands (Style, Contents and Assign) that let you customize the 
appearance of the trend time field. 
  

Style 

The Style section lists several options for the appearance of the trend time field. These 
include Date - Time, in which the date is followed by the time in a horizontal format, Time - 
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Date, in which the time is followed by the date in a horizontal format, Date / Time, in which 
the date is listed above the time, and Time / Date, in which the time is listed above the date. 
  

Contents 

Checkboxes allow you to include seconds, minutes or hours in the time, and days, months or 
years in the date. You also have the option of specifying an AM/PM format for the time. 
  

Assign 

Choose the appropriate control variable from the list. 
  

Text 

 
  
The Text tab allows you to set the Panel Font, the text, text background, and background 
colors, or to make the background transparent. 
  

Trend Time Field Example  

o Select Trend Time Field from the Insert menu. 
  

o Select Time - Date as the Style. 
   

o Remove the checkbox from the Years box to display only the days and months. The date 
display format is now DD-MM. Assume that we wish to have the date displayed as MM-
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DD. This will be set in step 6. 
  

o Under Assign, select a Control Variable. 
   

o Click OK to accept the settings and return to the project page where the new trend time 
field is now displayed. 
  

o To change the date display format, select Panel Setup from the Project menu. 
  

o Select the Settings tab. 
  

o Under Date Format choose the setting MM/DD/YY. 
  

o Click OK. 
   

o The trend time field date is now displayed as MM-DD. 

4.5.6 Recipe Menu 

Recipe Menu 

A recipe menu is a feature that simplifies recipe parameter set selection on EH-HMI panels 
through a user-friendly interface. It provides a menu-like field that can contain names to 
describe the parameter set instead of using numbers. Each name represents one recipe 
parameter set. To add a recipe menu select Recipe Menu from the Insert menu, or press 
Ctrl+R. 
  

 
  
The Recipe Menu Properties dialog box appears containing two tabs; General and Text. The 
General tab controls the size and appearance of the recipe menu while the Text tab controls 
the appearance of the text. 
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Note:  In order to use the Recipe Menu, each Recipe Parameter Set must be given a name. 
This is done by adding a recipe data field with an ASCII display format on the page where the 
recipe is located and filling the Recipe Item values in the Recipe Configuration box with an 
ASCII name for each parameter set. This ASCII field is called a Recipe Name field. This field 
is not a field type name; it only describes the field's purpose. 
  
A set of keyboard macro commands support recipe menus: 
  
o The Go To Recipe Menu macro jumps to a specified page and sets the value of the 

Recipe Page For Selection. 
  

o The Scroll Recipe Menu macro is used to move the selection in the recipe menu field. 
This is the way that a new recipe parameter set name is chosen from the list. 
  

o The Confirm Recipe Menu Selection macro changes the current recipe parameter set to 
the one selected in the recipe menu field. 

  
Note:  If a control variable data item set as Recipe Page For Selection contains the page 
number of a page without a Recipe Name field defined, the recipe menu field will display 
asterisks ("*"). 
  
An example of adding a recipe menu field is provided. 
  

General 

General 

 
  
The General tab allows you to set the recipe menu style, attributes, size, and includes the 
option to show the record numbers. 
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Style 

Recipe Menu is the only choice available. 
  

Attributes 

The currently selected Recipe Parameter Set may be indicated using user defined attribute 
combinations (blink, highlight, reverse). 
  

Size 

The size (in pixels) of the Recipe Menu display. 
  

Display 

Click the Show Record Numbers checkbox to show record numbers (which are just the 
parameter set numbers) together with the recipe name. 
  

Text 

 
  
The Text tab allows you to set the font size and color, and the background color and 
transparency.  
  
EH-View will not let you select a size that is too large to be displayed in the designated area. 
  
If Transparent is selected then text background colors are not available. 
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4.5.7 Special Characters 

 
  
Special characters may be added to text by clicking on the Special Characters button. This 
will bring up the Special Characters dialog box in which you can select the character(s) to be 
used by double clicking on them or by single clicking on them and pressing Insert. The 
characters will appear in the last position the cursor was in before entering the special 
characters dialog box. 
  
  

4.5.8 Import Bitmap Graphics 

Import Bitmap Graphics 

When using a EH-HMI graphics-capable panel you may import, display, and manipulate 
graphics in a project file. Once the graphic is imported into the project file, it may be easily 
moved or resized. 
  
Click on the Import Graphics icon on the toolbar, or select Import Bitmap Graphics from the 
Insert menu. The Open dialog box appears with a list of files or folders. 
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Select a graphic image to import and click on the Open button. 
  

 
  
The Bitmap Settings dialog box appears showing a preview of the image, with two tabs 
labeled Image and Panel. 
  
Options are available for changing the appearance of the image on the panel. Image shows the 
original image, while Panel shows how the image will appear on the panel.  
  
Note:  Only files in supported image formats may be imported using the Import Bitmap 
Graphics box i.e.   
  
Windows and OS/2 Bitmaps(*.bmp, *.dib,*.rle) 
JPEG *.jpeg 
AutoCAD files (*.dwg, *.dxf, *.dwf) 
Scalable Vector graphics  *.svg 
Windows Metafile  *.wmf 
Enhanced Metafile *.emf 
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Windows Icons and Cursors (*.ico;*.cur) 
TIFF (*.tif;*.tiff) 
Adobe Photoshop *.psd 
WordPerfect *.wpg 
Portable Network Graphics *.png 
Kodak PhotoCD *.pcd 
Kodak FlashPix *.fpx 
ZSoft PCX and DCX (*.pcx;*.dcx) 
TARGA *.tga 
Encapsulated Postscript *.eps 
Macintosh PICT *.pct 
Sun Raster *.ras 
MacPaint *.mac 
GEM Image *.img 
Gerber *.gbr 
Computer graphics metafile *.cgm 
DRW *.drw 
Intergraph Microstation Format *.dgn 
ESRI shape format *.shp 
  
  
A graphic can be moved or resized once it is imported.  To move a graphic, simply single 
click the left mouse button over the graphic and move it to the desired location. To resize a 
graphic, single click the left mouse button once on the graphic and use one of the selection 
handles that will appear around the edge of the graphic. 
  
Note:  Resizing a graphic image by using the selection handles may distort the image. 
  
To duplicate or copy a graphic within the same page, left-click on the image then click on the 
Copy icon, select Copy from the Edit menu, or right-click on the image and select Copy. 
Click where the copy of the image is to be placed, then click the Paste icon or select Paste 
from the Edit menu, or right-click and select Paste. 
  
To delete a bitmap graphic, left-click on the graphic to select it and press the Delete key or 
click on the Cut tool, or right-click on the image and select Cut. 
  
Right-click on a bitmap image and select Edit to open the Bitmap Editor dialog box. 
  
Right-click on a bitmap image and select Properties to view the image properties, such as the 
image file name, the image height and width in pixels, and the image resolution. 
  
Dynamic graphics and transparent and three-dimensional touch cells may be placed over 
static bitmaps. 
  
A bitmap graphics example is provided. 
  
  

Import Bitmap Graphics Example 

The following steps are used to import a bitmap file: 
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o Select Import Bitmap Graphics from the Insert menu. This will open a dialog box from 
which you can select a file. 
 

 
 
 Check the Preview box to view files before selection. Select the filename that is to be 
used and click on Open. 
  

o The Bitmap Settings dialog box, shown below, appears. From this dialog box you can 
change the name of the file and change its appearance. 
  

o Click OK. 
 

 
   

  
o The graphic appears in the upper left corner of the project page. You can then move it to 

the desired position on the project page, or resize it. To move a graphic, simply single 
click the left mouse button over the graphic and move it to the desired location. To resize 
a graphic, single click the left mouse button once on the graphic and use one of the 
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selection handles that will appear. To duplicate or copy a graphic within the same page, 
hold the Ctrl key down and click on the graphic. Drag the duplicated graphic to a new 
location and release the mouse button. To delete a bitmap graphic, click on the graphic to 
select it and either press the Delete key or click on the Cut tool. 

Preview 

 
  
The bitmap graphics preview image has two tabs, labeled Panel and Original. The Panel tab 
displays the way the image will appear on the panel, while the Original tab displays the 
original image appearance for reference. The image file name appears under the preview 
window. 
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Panel 

 
  
Sets the number of colors for the image display on the panel, for example black/white or 16 
colors. 
  

Properties 

Right-click on a bitmap image and select Properties to view the image properties, such as the 
image file name, the image height and width in pixels, and the image resolution. 
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Image 

Image 

 
  
There are a number of controls available to change the appearance of the image. They 
include: 
  
o Dither 

   
o Contrast 

   
o Brightness 

   
o Smooth 

   
o Sharpen 

   
o Blur 

   
o Size to Fit 

   
o Invert 

   
o Flip 

   
o Mirror 

   
o Reset 
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Dither 

Various methods to dither the image are available, including Floyd-Steinberg, Bayer, etc. 

Contrast 

A sliding bar lets you adjust the image contrast. 

Brightness 

A sliding bar allows you to adjust the image brightness from darker to lighter. 

Smooth 

Smooths jagged pixel edges in the image. 

Sharpen 

Sharpens the image. 

Blur 

Blurs the sharp lines in the image. 

Size to Fit 

Sizes the image to fit the available space. 

Invert 

Produces a negative image. 

Flip 

Turns the image upside down. 

Mirror 

Turns the image backwards. 

Reset 

Resets the image appearance to the default settings. 
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4.6 Page Menu 

4.6.1 Page Menu 

This section provides information about the Page menu. The Page menu contains commands 
that let you easily move from one project page to another, and to configure the various pages 
within a project. 
  
o Insert Page 

   
o Add Page 

   
o Delete Page  

   
o Go to Page 

   
o Previous Page 

   
o Next Page 

   
o Page Options 

   
o Recipe Configuration 

   
o Special Pages and Page Modes 

4.6.2 Insert Page 

This option lets you insert a blank page in front of the page that you are currently viewing. 
For example, if you are on page 3 of a project file and select Insert Page, the present page 3 
would become page 4, and a blank page would be inserted as page 3. You can also access the 
Insert Page command by pressing the Alt+Ins keys. 
  

4.6.3 Add Page 

Selecting this command adds a new page to the end of the project file. You can also access 
the Add Page command by pressing the F7 function key. 
  

4.6.4 Delete Page 

Selecting this command deletes the currently selected page within the project file. You will be 
prompted to confirm the operation. The pages of the project file will automatically be 
renumbered. You can also access the Delete Page command by pressing the Shift+F7 keys. 
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4.6.5 Go to Page 

This dialog box is one method available for selecting a page in a project. Select a page from 
the pull-down list in the Go to page dialog box, or type the page number in the entry field 
provided. 
Other methods for selecting a particular page in a project include selecting a page from the 
pull-down Current page list on the toolbar, double -clicking on a page from the Project tab in 
the workspace, or by pressing the Ctrl+G keys. 
  

4.6.6 Previous Page 

Selecting this option displays the previous page in the project. Pressing the Page Up key also 
displays the previous page. 
  

4.6.7 Next Page 

Selecting this option displays the next page in the project. Pressing the Page Down key also 
displays the next page. 
  

4.6.8 Page Options 

Page Options 

 
  
The Page Options dialog box lets you: 
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o Select a page from a page list, 
  

o Access tools from a convenient toolbar, 
  

o Link to other pages, and 
  

o Enable page scroll. 

Page List 

This section lists all the pages in the current project. You can rename a page by single -
clicking on the page name, then typing a new page name. 
  

Toolbar 

The toolbar includes icons that allow you to cut, copy, paste, insert special characters, and 
select a language. 
  

Link 

Link the current page to the previous page or to the next page. 
  

Scroll 

This command enables a page scroll frequency and the number of lines to scroll. This allows 
you to see lines that may be off the screen without having to use the arrow keys to scroll 
through the information. 
When pages are linked, the left and right arrow keys on the display panel may be used to 
scroll between pages. By default, the current page is linked to both the previous page and the 
next page. 
  
Note:  If you are having problems using this feature, check the RDA setup under Panel 
Controller Interface in the Project menu. Make sure that the PR box within the section entitled 
PLC is unchecked. 
  

4.6.9 Recipe Configuration 

Recipe Configuration 

A recipe is associated with a particular page and is composed of all the recipe data fields on 
that page.  
  
However, there can be a number of different parameter sets for a recipe. 
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The Recipe Configuration dialog box is accessed by selecting Recipe Configuration from the 
Page menu.  
  

 
  
The Recipe Configuration dialog box lets you: 
  
o Specify the number of parameter sets for the recipe on the current page. 

  
o Specify default values for all recipe data items on the current page. 

  
Note:  Recipe data items must be defined on the current page before the Recipe Configuration 
dialog box can be activated. To do so, insert a Numeric/ASCII, Bargraph, or Message data 
field and select Recipe as the Reference. 
  

Number of Parameter Sets 

Indicate the number of parameter sets. That number of columns is activated in the Recipe 
Parameter Set section. 
  

Multipage Recipe 

Data which are logically part of a single recipe can be scattered over several project pages and 
still be selected, downloaded or uploaded with a single command. A recipe spanning several 
pages is called "Multipage Recipe". 
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Note:  Multipage recipes are supported by EH-HMI firmware versions 4.20 and later. 
  

Set As Recipe Name 

A Recipe Name should be defined for all of the pages containing recipes that are going to be 
handled using the Recipe Menu.  It is also necessary for the pages that are referred to by 
Recipe Key field(s). 
  
The Recipe Name is defined by adding a Numeric/ASCII data field of ASCII style on the 
page with recipes and filling the recipe data field values with a name for each parameter set. 
  
After the recipe data field values have been inserted, click the row number button to select 
that row, then click the Set As Recipe Name button. An asterisk will appear next to the 
Recipe Item to indicate it has been selected as a Recipe Name. 
  
Note:  This ASCII field is not an internal variable in the panel memory. It needs to be 
addressed to a physical location in the PLC memory. The amount of memory required 
depends on the length of the ASCII string: one byte per character. 
  
A Recipe Name definition example is provided. 
  

Cut 

Cut deletes all Recipe Parameter Set entries beyond the position of the cursor. 
  

Copy 

To copy, highlight a Recipe Parameter Set entry and click the Copy button. Clicking the Paste 
button pastes the copied entry into the box currently occupied by the cursor. 
  

Paste 

Clicking the Paste button pastes the copied entry into the box currently occupied by the 
cursor. 
  

Recipe Values 

Recipe Values 

The recipe values section is in the form of a spreadsheet. Each row is associated with a 
particular recipe data field. The controller address of the recipe data item is displayed at the 
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far left hand side of the row, enabling you to tell which row is associated with which recipe 
data item. 
  
Each column is associated with a particular parameter set of the recipe. Each parameter set is 
identified by a number. The first column corresponds to parameter set 1, the second column to 
parameter set 2, and so on. 
The initial values for a particular parameter set can be fully specified by entering a value for 
each row in the column. The first column corresponds to parameter set 1, the second column 
to parameter set 2, and so on.  
  
The number of columns activated in the spreadsheet corresponds to the number entered for 
Number of Parameter Sets. 
  

Recipe Item 

The number of rows activated on the spreadsheet corresponds to the number of recipe data 
fields defined on the page. 
An asterisk next to a Recipe Item indicates that the item has been set as a recipe name. 
  

Recipe Parameter Set 

A parameter set is a specific block of data within a recipe. A recipe parameter set is created 
by assigning particular values to the recipe data fields on a page. With EH-View, it is possible 
to create many different parameter sets within a single recipe. Depending upon the panel 
model, there can be up to 1024 parameter sets of a single recipe. Not only is a block of 
memory in the panel reserved for every recipe; separate blocks of memory are also reserved 
for each of the parameter sets contained within a particular recipe. All the parameter sets of a 
particular recipe always contain the same recipe data items but the values of these recipe data 
items vary between the different parameter sets. 
These different recipe parameter sets can control different processes. One set may be used to 
configure the controller to control the production of 2 mm screws, another set may be used to 
configure the controller to control the production of 5 mm screws, and yet another to control 
the production of 7 mm screws. Each set of parameters is stored in a different parameter set 
within the same recipe. 
  
Note:  The default values entered for a particular recipe parameter set item are in the format 
that was specified in the Field Properties dialog box for that data item.  For example, if a 
numerical format of hexadecimal was entered in the data Field Properties dialog box for a 
recipe data field, then all the values entered in the Recipe Configuration dialog box for that 
recipe data field would also be in hexadecimal. If you specify a numeric data format of 
hexadecimal (base 16) for a recipe data item, and then enter a value of 10 in the Recipe 
Configuration dialog box, the 10 will be interpreted as 10 hexadecimal. Likewise, if ASCII is 
the specified style, then the entry must be in ASCII text. 
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4.6.10 Special Pages and Page Modes 

Special Pages and Page Modes 

The items located within the Special Pages and Page Modes portion of the Page menu include  
  
o Data Entry Screen 

  
o Command Menu 

  
o System 

  
o Password 

  
o Direct Access 

  
o Direct Page Selection 

  
o Time & Date  

  
o Alarm Page 

  
o Event Page  

  
o Current Page Mode. 

  
  
This allows you to place any combination of static text and touch cells on these pages. These 
items should be placed on the lower portions of the page, since these modes reserve some of 
the area contained in the upper portions of the page for display information. 
  
Whenever the panel enters Password mode or Data Entry Mode, a default numeric keypad 
will appear on the screen. In all of the other modes, a row of default keys will appear that 
contains the arrow keys, an Enter key, and a Clear key. 
  
Note:  If you create a screen in any of the special page modes, the default keys for that mode 
will not be displayed. 
  

Data Entry Screen 

This screen will appear whenever you begin Data Entry Mode. When using a EH-HMI 
touchscreen panel, a numeric keypad will appear by default. If anything is placed on this 
screen, the default numeric keypad will not appear. 
  
If this screen is modified, make sure that an Enter key is defined somewhere in this screen so 
that the panel user can always get out of Data Entry Mode. 
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Command Menu 

This is the menu that appears when the panel user presses the Enter key on a touchscreen 
panel and holds it for a period of three to four seconds. 
  
In the case of the keyless touch panel, this menu will appear whenever the user presses any 
area of the screen where there is no touch cell configured. You will not be able to write in the 
two topmost lines. The reason for this is that the panel reserves this area for the Command 
Menu itself. 

System 

This page will appear when the System option is selected in the Panel Command Menu. 
  
This page allows the panel user to adjust the contrast or brightness (on some panels) and to 
see if there are good communications between the panel and the controller. 

Password 

This page is displayed when the panel user selects Passwords from the Panel Command 
Menu. 

Direct Access 

This page is in essence a snapshot of the controller's memory. This page will show all of the 
memory locations contained within the controller. 
  
This menu can only be accessed when using a panel that contains a 16-line display or a 25-
line display. 

Direct Page Selection 

In this menu, you can scroll through a list of page names and select the page to be displayed. 
  
With this option, it is possible to see every page of a project file, even if the links to a 
particular page are broken. 

Time and Date 

This area lets you set the time and date on the panel. This information is used in the Alarm 
List, the Event List, and whenever you insert time fields or date fields into the project file. 

Alarm Page 

This page will appear on the panel whenever there is an active alarm present, providing the 
C2 bit in the RDA is not set. 
  
If the C2 bit is set, the default alarm page will not appear. 
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Event Page 

This page lists the previous 256 (some models up to 1024) events in sequential order on the 
panel. When more than 256 (1024) events have occurred, the older events will be removed in 
order to make room for the newer events. 

Current Page Mode 

This mode displays the page that you are currently on in the project file. This mode is the 
most often used when editing the project file. 

4.7 Project Menu 

4.7.1 Project Menu 

This section provides information about the Project menu. The Project menu allows you to 
configure the panel, the controller, the network, and your project to work together seamlessly. 
Commands on the Project menu include: 
  
o Configure Controller 

   
o Panel Setup 

   
o Network Setup 

   
o Panel Controller Interface 

   
o Report on Panel Printer 

   
o Keyboard Macro Editor 

   
o Passwords 

   
o Alarms 

   
o Languages 

   
o Next Language 

   
o Configure Tag Dictionaries 

   
o Tag Validation 

   
o Trend Buffers 

   
o Memory Use 
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4.7.2 Configure Controller 

Configure Controller 

 
  
By selecting Configure Controller from the Project menu (or by clicking on the Configure 
Controller icon on the toolbar, or by pressing the Ctrl+Alt+P keys), you can access the 
Configure Controllers dialog box and select the brand of controller with which you will be 
working. You can also enable double protocol if desired. 
  
Note:  EH-View uses the current controller setup and applies this setting to all subsequent 
projects until changed. 

Enable Double Protocol 

A single EH-HMI panel can communicate with Controllers simultaneously using different 
communication protocols. When configuring the EH-HMI to communicate with controllers 
simultaneously using two different communication protocols (double protocol configuration), 
distinction must be made between the first communication driver (used to communicate using 
the first protocol) and the second communication driver (used to communicate using the 
second protocol).  
  
The Configure Controllers dialog box contains a checkbox for Enable Double protocol. 
Checking this box lets you specify a second controller. Under the Controller 1 box another 
box will appear where you can specify Controller 2. 
  
EH-View will issue a warning if an illegal combination is chosen and will not close the dialog 
box until an allowable configuration is selected. If a configuration is specified in which a 
switch to new driver(s) was made, EH-View will prompt the user to accept the change. If both 
drivers are changed, EH-View will prompt twice. 
  
If at least one of the drivers is a serial driver, the decision which driver will be set as the 
Controller 1, and which one as Controller 2 is important. Controller 1 will use the PLC port, 
and the Controller 2 will use the PC/Printer port. If one of drivers is using the current loop, it 
must become Controller 1 to ensure that it uses the PLC port because the current loop 
capability is only implemented on this serial port. Also, as the PC/Printer and the PLC port 
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connectors are of different genders, careful selection of Controller 1 and Controller 2 can 
make cabling easier and less expensive.  
  
There is no major difference in configuring UniNET networks for single protocol applications 
and for double protocol applications. However, if one of either network type "Single Server, 
Multiple Clients" or "Multiple Server, Multiple Clients" is selected, all the EH-HMI network 
server nodes will inherit the current configuration of the project. In other words, if the project 
in which the network is being set up is currently configured for single protocol, all the EH-
HMI node servers in the UniNET network will be configured to use only this protocol. If the 
project is configured for double protocol, all the EH-HMI node servers will be configured to 
use both protocols. 
  
It is important to remember the following rules for serial drivers: 
  
o The first driver always communicates with the controllers over the PLC port 

 . 
o The second driver always communicates with the controllers over the PC/Printer port. 

  
Of course, if any of the protocols is a non-serial protocol, its driver will use the AUX port 
instead.  
  
There are a few hardware restrictions when two communication protocols are used: 
  
o If the communication driver is using both serial communication ports - the PLC and the 

PC/Printer port - it cannot be used in multi-protocol configurations. 
  

o If two communication drivers are both serial, there will be no ports left to connect the 
serial UniNET network. (You can still use the Ethernet-based UniNET, of course.) 
  

o Since only one communication module can be plugged into the panel, a combination of 
two communication drivers, each requiring such a module, cannot be supported. 
  

o As the Ethernet protocol is supported by a communication module, a combination of one 
Ethernet-based communication driver and a driver requiring any other communication 
module cannot be supported. 
  

o The internal controller module plugs into the same socket as the communication 
modules. Thus, if an internal controller is plugged into the panel, it not possible to plug 
in a communication module. Therefore, a communication driver requiring a custom 
communication module (including Ethernet-based) cannot be supported. 
  

Note:  Two Ethernet-based communication drivers can normally be used simultaneously 
because they will both communicate through the same Ethernet communication module. 
Ethernet-based UniNET can also be used in addition to one or two Ethernet-based 
communication drivers. 
  

Controller 

The currently selected controller(s) is listed. If this is not correct, click on the "..." button to 
activate the Select Controller dialog box. 
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Select Controller 

Select Controller 

 
  
Pick the brand of controller to be used from the list provided. Buttons within this box allow 
you to remove controllers from the list, refresh the list, or activate the Controller Setup dialog 
box. 
  

Remove 

Clicking the Remove button removes the highlighted controller driver from the list. 
  

Refresh 

Clicking the Refresh button refreshes the list of available controllers DLLs. 
  

Controller Setup 

Controller Setup 

The entries and selections in the Controller Setup dialog box are customized for the particular 
type of controller selected. Indicate the particular controller mode l number, if necessary, and 
any other information necessary to customize the setup for your selected controller. This may 
include Slave ID, Access Multiple PLCs , PLC ID, etc. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 185 

The Access Multiple PLCs checkbox will allow the panel to exchange data with more than 
one controller. You must also enter the slave IDs of the different controllers from which the 
panel will be accessing data. This option is not available with all controllers. 
  
Click the PLC/Driver Comm button to configure communication parameters for this 
particular controller. 
  

Communications Parameters Setup 

Communications Parameters Setup 

The communication parameters for any particular controller are set automatically when the 
selection is made.  
  
However, if there is a need to change the default settings, press the PLC/Driver Comm button 
in the Controller Setup dialog box. This will bring up the Communications Parameters Setup 
dialog box where you can configure the baud rate, parity, data bits, and stop bits for 
communication. 
  

Baud Rate 

This option specifies the baud rate to be used in communication between the panel and the 
controller. 
  

Parity 

Specifies the parity to be used in communication between the panel and the controller. 
  

Data Bits 

Specifies the number of data bits to be used in communication. 
  

Stop Bits 

Specifies the number of stop bits to be used in communication between the panel and the 
controller. 
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4.7.3 Panel Setup 

Panel Setup 

Panels come in many different types with different capabilities. The Panel Setup dialog box 
lets you specify the appropriate panel type and the amount of target memory in the target 
panel. 
  

  
  
Panel selection can be made manually or it can be obtained directly from the EH-HMI panel 
itself by using the Get Panel Resources command. This command retrieves the information 
directly from the EH-HMI panel that is connected to the PC. 
  
To access the Panel Setup dialog box, select Panel Setup from the Project menu or click the 
Panel Setup icon on the toolbar. The tabs in the Panel Setup dialog box include: 
  
o Panel Model, 

   
o Settings, 

   
o External Devices, 

   
o Passthrough, and 

  
o Miscellaneous. 

Recognition of Old Panel Models 

EH-View recognizes a model code that is inside the panel or inside the project file. 
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When using an older panel or an older project file, the model code may not be found. In this 
case, EH-View tries to "guess" the panel model that was initially used by comparing the panel 
capability information stored inside the panel device or inside the project file with the panel 
capabilities that are defined inside the panel database within EH-View. 
  
It is possible that EH-View will find more than one panel that fits the available capability 
description. In this case, EH-View will show a warning message to advise you to manually 
enter the model in the Panel Setup dialog box. 
  
When EH-View cannot determine the EH-HMI model associated with a project file, the 
GENERIC panel model will be selected. In this mode, all of the available panel capabilities 
will be enabled. 
It is also possible to manually select the GENERIC panel model. This is useful if you have a 
new EH-HMI panel that has not been defined within the EH-View panel database.   
  

Panel Model 

Panel Model 

 
  
Use the Panel Model tab to directly select the EH-HMI model being used. On the right side of 
the dialog box a preview picture of the currently selected EH-HMI panel is displayed. You 
can select the panel model, the panel memory, and the firmware version. 
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Panel Model 

To choose a new panel model, choose a panel from the drop-down list under Panel Model. 
The page editor workspace will change in order to reflect the available screen area on the 
selected model. 
  
Note:  The panel model may be changed at any time during development. However, be aware 
that some restrictions apply regarding the screen area. You can change the display from a 
small screen size to a larger screen size without affecting the contents of the project. 
However, changing from a large screen size to a smaller screen size may delete some data 
fields if they are beyond the new screen boundary. If this occurs, you will be given the chance 
to cancel the operation before any fields are deleted. 
  
If you are unsure of the EH-HMI model being used, or if you have a new EH-HMI panel that 
has not been defined within the EH-View panel database, select the GENERIC panel model. 
In this mode, all of the available panel capabilities will be enabled. 
  
Note:  When using the GENERIC selection, you must specify all the panel definitions. 
  

Panel Memory 

Appropriate memory choices for the specified Panel Model are listed. Select the amount of 
memory available in the panel. 
  

Firmware Version 

Choose the appropriate version of the panel firmware. If you have a panel with a newer 
firmware version that is not yet defined inside the EH-View package, please select the highest 
EH-View firmware version. Selecting the All firmware version will enable only the basic 
panel capabilities that are supported with all panel firmware versions. 
  

Preview 

The Preview area shows a typical panel screen for the selected Panel Model. 
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Settings 

Settings 

 
  
The Settings tab shows the capabilities of the selected model. Some capabilities are fixed and 
cannot be changed by the user. Others have a checkbox or a list box and can be modified. 
These settings will vary depending upon the panel model specified. 
  
The Settings tab lists various information about the project, such as the memory type, the 
amount of project memory, the trend buffer memory setting, the recipe size, the available 
alarms, the event size list, and the number of colors. 
This tab also allows you to specify the time and date format for Time and Date data items. 
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Settings List 

Settings List 

The left side of the Settings index tab lists the capabilities supported by the selected panel. 
You can modify these selections when they are supported by the currently selected EH-HMI 
model. 
  
Commonly selectable items include: 
  
Buzzer, 
   
Disable Battery LED, 
   
Events Backup, 
   
Firmware Download, 
   
Recipe Backup, 
   
Touch Screen, and 
  
Update PLC References. 
  

Buzzer 

Enables/Disables the panel buzzer (when available) 

Disable Battery LED 

Enables/Disables the battery LED indicator. 

Events Backup 

Enables/Disables the events log backup inside the internal FLASH memory. This is used by 
the Recipes and Events Backup macro. 

Firmware Download 

New panels that contain the T2000 board (units of the group 58) have the ability to manage 
firmware downloads from within EH-View (without using the UniDataExchanger utility). 
This flag will be checked for panels that support this firmware download feature. 
Firmware Download may be enabled manually from the Settings index tab within the Panel 
Setup dialog box for certain situations. Manual settings are necessary when a real panel is not 
physically connected to the PC and a Get Panel Resources command cannot be executed. 
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Recipe Backup 

Enables/Disables the recipe backup inside the internal FLASH memory. This is used by the 
Recipes and Events Backup macro. 

Touch Screen 

When touch screen is not enabled, the display window can be scrolled down to line 32. When 
touch screen is enabled, the display window has the same size as the panel display and cannot 
be scrolled. 

Update PLC References 

When the EH-HMI panel supports referencing the data field min/max range settings to a 
memory location in the controller (PLC Reference), this field determines the field update 
rules. If this field is checked the PLC Reference will be updated continuously, otherwise they 
will be updated only when the page is activated. 

Memory Type 

Can be FLASH for EH-HMI models with internal memory only or SSFDC for EH-HMI 
models with a removable SSFDC memory card. 
  

Project Memory 

Internal memory reserved for project file. 
  

Trend Buffers. 

Memory assigned to trend buffer can be set here. The trend buffer size parameter can be 
increased /decreased with step of 32k. 

Recipe Size 

Internal memory reserved for recipe data. 
  

Available Alarms 

Number of available alarms. 
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Event List Size 

Number of available events. 
  

Colors 

Number of supported colors. This list box is enabled only for panels that support 256 colors. 
For those models that do not support 256 colors, a fixed value is shown. 
  

Time Format 

Specify whether the panel will display time data fields in a 24-hour format (for example 
20:10) or a 12-hour format (for example 10:10pm). 
  

Date Format 

Specify whether the panel will display date data fields in a month/day/year format or a 
day/month/year format. 
  

External Devices 

External Devices tab 
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Under Panel Setup, the options available under the External Devices index tab can be used to 
specify the presence of the TCM10 communication module (Ethernet Board) and assign an IP 
address to it. 
  
For firmware 5.00 and above the External Devices tab will have an additional property button 
as shown in the below dialog 
  

 
  
  
On clicking the property button Ethernet Settings dialog will be displayed as shown below 
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The above dialog box allows to specify network parameters such as Network Mask and 
Gateway Mask. 
  
  
  

Ethernet Board 

Using the (optional) external TCM10, the EH-HMI can be connected to an Ethernet UDP/IP 
network. Check the Ethernet Board box if there is such an Ethernet board associated with the 
panel to enable network support. 
  

IP Address 

Enter the board's IP address in the entry box. The IP address used has to be chosen according 
to the overall Ethernet configuration. 
  
This address will be disabled when the Network Setup configuration is used. In that case the 
panel node IP Address and the protocol must be selected from the Network Configuration 
dialog box. 
  

Passthrough 

Passthrough 
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The Passthrough tab lets you configure the panel passthrough feature parameters. This  lets 
you remotely put a EH-HMI panel into either Configuration Mode or Operation Mode. In this 
manner, you can remotely upload or download a project file, start the panel, or use 
passthrough mode to access the programming port on the PLC and issue commands. 
  
The communication parameters for any particular controller are set automatically when the 
selection is made.  However, if there is a need to change the default settings, you can do so by 
changing the port settings under the Passthrough tab in the Panel Setup dialog box. 
  
Note:  The EH-HMI panel must contain firmware version 4.10 or later to use this feature. 
  
Note:  The PC/Printer port cannot be used for printing when passthrough is configured. 
  

Port Settings 

Port Settings 

Different models of controllers require different parameters in order to communicate properly 
with the operator interface panel.  
  
Configure the passthrough serial line parameters. If the optimum settings for baud rate, parity, 
data bits and stop bits to be used for communication between the target panel and the 
controller differ from those shown under the Port Settings, you can change the settings. 
  
Note:  All EH-HMI panels are capable of communicating with a PC at a speed of at least 
9600 baud. Some panels will communicate at speeds of 19,200 baud and 38,400 baud. With 
some Pentium-based computers, a speed of 19200 baud may prove to work more efficiently 
than 38,400 baud. 
  

Baud Rate 

This option specifies the baud rate to be used in communication between the target panel and 
EH-View. 
  

Parity 

Specifies the parity to be used in communication between the target panel and EH-View. 
  
  

Stop Bits 

Specifies the number of stop bits to be used in communication between the target panel and 
EH-View. 
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Mode 

Mode 

Define the passthrough activation mode. The available choices are Hardware or Remote 
Hardware. 
  

Hardware 

Panel passthrough mode can be activated locally by the panel by using a macro or a mailbox 
command. 
  

Remote Hardware 

Panel passthrough mode can be activated remotely by sending a string command through the 
serial line. To configure EH-View for remote passthrough via a modem, select Remote 
Hardware passthrough from the Passthrough tab under Panel Setup. 
  
Note:  Remote Hardware passthrough should be selected only if passthrough mode is to be 
used locally and not via a modem. 
  
When Remote Hardware passthrough is selected in Panel Setup, the Remote passthrough 
entry becomes available in the Transfers menu. This entry lets you select one of three remote 
passthrough commands: Configuration Mode, Start and Stop. 
  

Commands 

Commands 

In this section, you can define command strings to manage the passthrough feature.  
Enter the commands to put the panel into Configuration Mode, to send the start command and 
to send the stop command in the Request boxes. Likewise, enter the responses to be received 
back from the panel in the Response boxes. 
  
Note:  The Commands section is only activated if Remote Hardware is selected as the Mode. 
  

Start 

Command and response string to be used to send the start command. 
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Stop 

Command and response string to be used to send the stop command. 
  

Cfg Mode 

Command and response string to put panel in configuration mode. 
  

Miscellaneous 

Miscellaneous 

 
  
The Miscellaneous tab lets you configure several different panel parameters. Selecting any of 
the checkboxes enables the entry boxes associated with those selections. These selections 
include: 
  
o Display Page on Comm Error 
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o Time Out for Panel Menu 
   

o Time Out for Data Entry 
   

o Time Out for Field Selection 
   

o LCD Screen Saver 
   

o Panel Upload Protection 
o   
o Command Menu Access 

Display Page on Communication Error 

This lets you specify a page for the panel to go to whenever a communication error is reported 
or communications between the panel and PLC are lost. 
  

Time Out for Panel Menu 

The period of time the panel will wait for a keystroke before returning to normal operation. 
This lets you return to Operation Mode from the Panel Command Menu if there are no keys 
pressed for the specified amount of time. 
  

Time Out for Data Entry 

The period of time the panel will wait for a keystroke before returning to normal operation. 
This lets you return to Operation Mode from the Data Entry screen if there are no keys 
pressed for the specified amount of time. 
  

Time Out for Field Selection 

The time period the panel will wait for a field selection to be made before returning to normal 
operation. This lets you return to Operation Mode from Data Entry if there are no fields 
selected within the specified amount of time. 
  

LCD Screen Saver 

This option lets you turn off the back-lighting on an LCD panel when no keys or touch cells 
have been pressed for a certain amount of time. 
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Panel Upload Protection 

This feature lets you password protect the project file so that unauthorized uploads cannot 
occur. You can enter a case-sensitive password of up to eight characters. When this field 
contains a value, the defined password will be requested in order to upload the project file 
from the panel. 
  
Once this password is specified, every time you attempt to upload the project from the panel 
onto your computer, EH-View will ask you to enter the password. If the password that you 
enter matches the one that was defined in the project file, the upload operation will be 
performed properly. 
  
However, if you enter a password that doesn't match the one that was specified in the project 
file, the panel will not start the upload process. 
  
Note:  Your panel must contain firmware version 4.10 or later to use this feature. 
  

Command Menu Access 

The time out for access to Command Menu is programmable.  
This feature requires firmware 5.02 and above. Access to Command Menu can be disabled 
and manually handled by means of a macro command. 

4.7.4 Network Setup 

Network Setup 

 
  
The UniNET Network is a feature of the operator panels that enables them to be connected 
together and to communicate with each other. It is possible to connect two or more panels (the 
maximum number is 32) with either a Serial (RS485) connection or an Ethernet connection. 
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This offers the ability to display on one panel either the data from the controller attached to 
the panel itself, or data from other controllers attached to other panels on the network. 
  
Information about UniNET networks, clients and servers, connecting operator panels to the 
network, advanced network programming, and network setup is available. 
  
An example is provided that describes the steps required to set up a UniNET network 
composed of a single server operator panel connected to a controller and two client operator 
panels which will access the controller data via the server through the network services. 
  
If a network is not defined for a project, selecting Network Setup from the Project menu (or 
by clicking the Network Setup icon on the toolbar) brings up the Network media & protocol 
selection dialog box. If a network type is already defined for a project, selecting Network 
Setup takes you directly to the Network Configuration dialog box. 
  

Network Media and Protocol 

Network Protocol 

The first step in configuring the network is selecting the network type. The EH-View software 
supports two types of UniNET network: an RS485 network, or an Ethernet-based network. 
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Select the type of network, click the Next> button, and the Network Selection dialog box 
appears. 
  

Ethernet 

The networking capabilities of the EH-HMI operator panels include connections to Ethernet-
based networks. Ethernet is becoming a popular communication support for cell-level 
industrial controllers. There is no standard set in the industry for the application level 
protocol, but there are several non-compatible protocols. As the only common point, they are 
all based on the TCP/IP or UDP/IP protocols. 
  
There are two main classes of applications where Ethernet networking capabilities can be 
successfully used: 
  
o Direct connection to Ethernet-based PLC networks 

  
o Extending the UniNET network 

  
Note:  EH-HMI panels can be successfully connected to an Ethernet-based PLC network only 
if the specific application layer protocol has been implemented. 
  
The EH-HMI UniNET network is able to use Ethernet, when available, as the communication 
media.  
  
The advantages of this type of network, as compared to conventional UniNET technology, are 
the ability to use existing network cables and a more effective solution for connecting a 
computer to the UniNET network. 
  
Information is available on the TCM10 board (required to connect a EH-HMI panel to an 
Ethernet network), the UniNet OPC Server, and configuring Ethernet networks. 
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RS485 

This network type must be used if the optional TCM10 board is not built into the panel. In 
this type of network, panels are interconnected using simple RS-485 cables. 
  
Please refer to the Connecting Panels to a RS485 Network section to see how to build your 
RS485 UniNET Network. 
  

Network Selection 

 
  
You may choose between the three network types: 
  
o Single Server, Multiple Clients 

   
o Multiple Servers, Multiple Clients (same controller types) 

  
o Mixed Multiple Servers, Multiple Clients (different controller types) 

  
The parameters for the network are automatically configured if it is selected to be of either the 
Single Server, Multiple Client type or of the Multiple Server, Multiple Client type. However, 
EH-View lets you make modifications to the network parameters by clicking on the 
Configure button. 
  
If you chose Mixed Multiple Servers, Multiple Clients, you must specify all of the 
configuration parameters for the network by clicking on the Configure button. 
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Network Configuration 

Network Configuration 

The parameters for the network are automatically configured if it is selected to be of either the 
Single Server, Multiple Client type or of the Multiple Server, Multiple Client type. However, 
EH-View lets you make modifications to the network parameters by using the Network 
Configuration dialog box.  
  
If you chose Mixed Multiple Servers, Multiple Clients, you must specify all of the 
configuration parameters for the network. 
  
The Network Configuration dialog box may be accessed by clicking on the Configure button 
in the Network Selection process, or by selecting Network Setup from the Project menu (or 
clicking on the Network Setup icon on the toolbar) after a network has been configured for a 
project. 
  

 
  
When the Mixed Multiple Servers, Multiple Clients option is selected, you must click on the 
Configure button to access the Network Configuration dialog box and explicitly enter all of 
the parameters for the required network. 
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The Network Configuration dialog box contains a number of commands, including:  
Maximum Node Number, Enable UniNET Network, Broadcast Periodic Clock 
Synchronization Messages, a list of the Configured Nodes, an Add button, a Delete button, a 
Properties button, a Net Comm button, an Export button, and an Import button. 
  

Maximum Node Number 

The Maximum Node Number is the node number of the highest node that will be allowed to 
receive the network token. Nodes that have a node number higher than this value will not be 
able to communicate over the network. The Maximum Node Number should be set as low as 
possible to minimize the amount of time that will be required for token rotation. 
  

Disable Undeclared Client Access 

When checked, this box specifies that partners of the UniNET network cannot be accessed by 
a client not expressly declared to be a member of the network. 
  
Note: this field is only available when the UNiNET Network employs Ethernet Connectivity. 
  
Note:  A general configuration where the EH-HMI UniNET node is set to 1 and several 
servers are configured with a different IP address is allowed if it corresponds to several 
UniNET networks, each one composed of only one panel working as a server. These UniNET 
networks are part of the same Ethernet network; the EH-HMI servers are independent from 
each other and the use of a similar layout is useful when a UniNET client running on a PC 
may be required to collect data coming from several different controllers. 
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UniNET TCPIP 

Represents the port number from which the UniNET protocol services respond. The default 
value is normally correct. However, it may be changed in case the default port is already 
assigned to another service. 
  
Note: this field is only available when the UNiNET Network employs Ethernet Connectivity. 
  

Enable UniNET Network 

Click the Enable UniNET Network checkbox to activate (enable) the configured network 
configuration. If the UniNET network is enabled then the panel to which the project file will 
be downloaded will act as part of the network. If it is disabled the panel will function as a 
normal, non-networked panel. If the UniNET network is enabled then one of the already 
configured nodes can be selected, thus assigning the node number for the current project file 
and for the panel to which the project file will be downloaded. 
  
A checkmark appears next to a node number when the UniNET Network is enabled. This is 
used to determine which UniNET node is assigned to the current project. Right mouse click 
on the name and then Set as Current Panel node. 
  

Broadcast Periodic Clock 

If the UniNET network is enabled then you can specify whether the panel is to broadcast 
periodic real time clock synchronization messages across the network. The purpose of these 
messages is to synchronize the clocks in the different panels attached to the UniNET network. 
If the check box Broadcast Periodic Clock Synchronization Messages is checked then the 
panel will broadcast a clock synchronization message across the network every 60 minutes. If 
the check box is not checked then the periodic clock synchronization messages will not be 
broadcast by the panel. 
The best way to ensure clock synchronization across the UniNET network is to configure 
only one panel as the broadcaster of the periodic clock synchronization messages. 
  
Note:  The check box Broadcast Periodic Clock Synchronization Messages only controls the 
periodic clock synchronization broadcasts. However, every panel in the UniNET network, 
regardless of the setting of this check box, will always broadcast a one-off clock 
synchronization message to the network whenever the time and date menu is exited on the 
panel and whenever the panel receives a mailbox command instructing it to perform a clock 
synchronization. 
  

Net Comm 

Pressing the Net Comm button displays the Communication Parameters Setup dialog box 
where you can configure the communication parameters for the network. To obtain the best 
results the highest baud rate possib le should be used. 
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Note:  Network communications parameters need to be set for an RS-485 network only. The 
Net Comm button is not activated for Ethernet networks. 
  

Export 

Click on the Export button to save the existing network configuration to a file. Network 
configuration files have the extension .NET. 
  

Import 

Any network configuration may be saved for later use or for sharing between multiple project 
files designed for the same network. Click on the Import button to load an existing 
configuration. Network configuration files have the extension .NET. 
  

Configured Nodes 

Configured Nodes 

This is list of the already configured network nodes. Each node in the list is described by its 
node number, controller driver and model. 
  

Node Number 

The node number of the node being selected for configuration. It must be a number greater 
than 0 and smaller or equal to the Maximum Node Number. 
  

Controller Driver 

During the configuration process all the client panels must be assigned the Network Client 
protocol, and all the server panels must be assigned the protocol of the controller they are 
directly attached to. 
  

Controller Model 

The controller panel model. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 207 

Add 

Click this button to add a new node to the list of configured nodes, using the Add/Edit Panel 
Node dialog box. To activate the Add button, change the Maximum Node Number. 
  

Properties 

Properties 

To modify an existing node you must first select the required node from the list of already 
configured nodes.  
  
Click Properties from the Network Configuration dialog box to view the network properties 
associated with that node as listed in the Add/Edit Panel Node dialog box, or click Add to add 
another node to the list. 
  

 
  
A number of items can be specified in the Add/Edit Panel Node dialog box. These include the 
Panel Node, the IP Address, the Printout Node, the Number of Communication Retries, the 
Communication Time Out setting, whether to Enable Double protocol, and the controller 
setting. 
  

Panel Node 

Represents the UniNET node of the panel. Ethernet networks are still based on the UniNET 
application layer protocol. 
  
More than one panel can have the same panel node. The configuration corresponds in this 
case to several different UniNET networks that cohabit on the same Ethernet line. Each time 
two partners are configured with the same UniNET node and they reside together on the same 
Ethernet network, they are conceptually part of distinct UniNET networks. This concept 
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allows users to put more than 32 UniNET nodes on the same UniNET Ethernet based 
network. 
  
Note:  A general configuration where the EH-HMI UniNET node is set to 1 and several 
servers are configured with different IP address is allowed if it corresponds to several 
UniNET networks, each one composed of only one panel working as server. These UniNET 
networks are part of the same Ethernet network; the EH-HMI servers are independent from 
each other and the use of a similar layout is useful when a UniNET client running on a PC 
may be required to collect data coming from several different controllers. 
  

IP Address (Ethernet network only) 

Represents the IP address assigned to the UniNET node. This must be unique in the Ethernet 
network. 
  

Comm Port (for Network RS-485 network only) 

Specify the port that the network will use for communication. 
  

Printout Node 

Node number of the node to be used for the network printout function. 
  

Num Comm Retries 

Number of times a network message is retried in case of communication errors. 
  

Comm Time Out 

Value of the time out interval used in the network communication. 
  

Delete 

Click the Delete button to remove the currently selected node from the list of configured 
nodes. 
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4.7.5 Panel Controller Interface 

Panel Controller Interface 

 
  
The Panel Controller Interface allows you to set parameters for RDA Setup, the Interlock 
Mailbox, Panel I/O. 
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RDA Setup 

RDA Setup 

 
  
The RDA Setup tab lets you specify the Programmable Logic Controller (PLC) address for 
the RDA (Reserved Data Areas).  
  
The RDA can be left as a continuous block of memory, in which case the PLC address for the 
start of the RDA can be specified. Alternatively, the elements of the RDA can be placed in 
different memory locations. In this case, the PLC starting address for each of the different 
elements can be specified. It also lets you enable or disable the individual elements of the 
RDA. 
  
A more detailed description of the RDA is available. 
  

Keep RDA Continuous 

Check the Keep RDA continuous box to leave the RDA as a continuous block of memory. 
Specify the PLC address for the start of the RDA by indicating the Reference type and 
location. 
  
Note:  The Keep RDA continuous option is not supported for internal controllers. The 
checkbox should always be always left unchecked when an internal controller is specified. 
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Enable RDA 

It is not necessary to have a full working knowledge of the reserved data areas to complete a 
project. It is entirely possible to toggle bits in the controller, display messages and controller 
data, edit read/write fields, etc. without having any areas of the RDA enabled. For this reason, 
the RDA is disabled by default. This also helps to optimize communication between the panel 
and the controller. There are, however, several functions that are only available through the 
RDA.     
  
Note:  If you are having trouble establishing initial communication with your panel, disabling 
the RDA is recommended. Make sure the check box entitled Enable RDA is not checked. If it 
is, uncheck it and re-download your project. 
  

RDA References 

RDA References 

Each EH-HMI panel may use up to three small reserved areas of controller memory to 
establish an interface with the controller. These three reference areas are:  Keys, Panel, and 
PLC. You can select the starting address of each of these areas. 
  
Each of the three reference areas lists References, Update Cycles, and RDA Elements. 
Clicking on the "…" button under References brings up the Data Field Properties dialog box 
where reference information can be specified. The cycle time may be set as necessary under 
Update Cycles. The various RDA Elements that pertain to the Keys, Panel, and PLC reference 
areas are discussed under those headings. 
  

Keys 

This reserved area is formatted to contain flags for each key on the panel and extended 
keyboard, up to a maximum of 64. (The maximum number must be a multiple of 16, as in 
essence the maximum number of keys tells the EH-HMI panel how many words of the 
Keyboard Update Area in the RDA are to be used.) 
  
These flags are set HIGH when a key is pressed and set LOW when released. Each key status 
flag occupies one bit in the controller memory. These bits can be used by the controller to 
detect when a particular key has been pressed and then in turn perform a specific operation. 
  
Note:  Use the Keyboard Macro Editor to program keys. 
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Panel 

Panel 

This reserved area is formatted to contain time and date information from the panel's real time 
clock, a current page register, and a two-byte panel status word. 
  

Time 

The real time clock contains the time and date information. Depending upon the type of 
controller that is being used, this information will be stored in either binary or BCD. A listing 
of various PLC's and how the RTC (Real Time Clock) is stored can be found in the back of 
the Installation & Operation Guide that came with the panel. 
  

Current Page (CP) Register 

The panel writes the number of the currently displayed page into the Current Page (CP) 
register whenever the panel is in Page Mode or Data Entry Mode. In all other modes, a zero is 
written into this register, indicating that page data is not currently being displayed. 
  
Note:  Page numbers are stored in either binary or BCD format, depending on the controller 
being used. 
  

Panel Status Word 

The panel sets and resets bits S0-S8 and S13-S15 in the Panel Status Word to indicate its 
current status. Your application logic can monitor these bits to determine how and when it 
should interact with the panel.  A brief description of each status bit is provided. 
  

PLC 

PLC 

The PLC (programmable logic controller) update area allows the controller to access and 
control certain aspects of the panel. 
  
All front panel LED's can be controlled from this area to provide feedback to the operator. 
The controller may also request a specific page to be displayed by writing the appropriate 
value into the Page Request register. The controller control word allows the controller to 
request the printing of a page, disable data entry, select an alarm mode, or enable the mailbox 
function. 
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All panels include a standard set of dedicated indicators that allow the user to monitor the 
status of the panel. Along with these dedicated indicators, certain models include a subset of 
user defined LED's that can be monitored and controlled by application logic. The control of 
these LED's is carried out through the Controller Update Area. Each of the registers found 
there can be copied to bit address contacts so that the status bits can be referenced as control 
relays. 
  

Page Request Register 

The page to be displayed can be selected either by the operator from the front panel keypad or 
by the controller itself. The controller selects the page to be displayed by writing the 
corresponding page number into the PR register in the Controller Update Area. When the 
panel detects a page request from the controller, it checks the front panel keyboard and the 
Expanded Keyboard (if present). If no key has been pressed for the last three seconds, the 
page selected by the controller is displayed. 
  
Note:  Once the panel has changed to the corresponding page, you need to write a 0 back into 
the PR register in order to return control back to the keys on the panel. If this is not done, you 
will be "stuck" on that page.   
  
Note:  While a controller page request is active (PR not 0), the operator will not be able to 
change pages using the arrow keys. 
  
Note:  Page numbers are stored in either binary or BCD format, depending on the controller 
being used. 
  

LED Control Bits 

Bits L1 through L32 control the LED indicators that can be found on various panel models. 
The mappings of these bits are provided. 
  
Note:  The LED's can be controlled via the Keyboard Macro Editor. 
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Interlock Mailbox 

Interlock Mailbox 

 
  
The Interlock Mailbox tab lets you enable the Interlock Mailbox, determine the read modes 
and the read cycle, and specify the controller address for the Interlock Mailbox. 
  
The EH-HMI Interlock Mailbox is designed to allow the operator interface panel to interact 
with the controller's ladder logic program. The Interlock Mailbox is simply a group of 
registers in the controller memory (from a minimum of 2 registers to a maximum of 20). 
  
The Mailbox can be placed anywhere in the controller memory at an address you select. 
When the mailbox is enabled, the operator panel cyclically reads the contents of the mailbox 
from the controller. The controller can command the EH-HMI panel to perform certain tasks 
by placing data in the memory area used by the mailbox. When the panel detects that the 
controller has written data in the mailbox, it interprets the data as a numeric code for a 
required command.  If the panel recognizes the command, it immediately executes it. If the 
command requires a response from the panel, then the panel places the response back into the 
mailbox itself.  
  
Further information on the Interlock Mailbox is provided. 
  
Note:  The Interlock Mailbox offers a powerful way to control the operation of recipes from 
the controller. 
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Enable 

To enable the Interlock Mailbox, select the Interlock Mailbox tab from the Panel Controller 
Interface dialog box under the Project menu. The Mailbox is disabled by default. To enable it, 
simply mark the checkbox entitled Enable. 
  

Read Modes 

The Mailbox can be enabled in one of two ways. 
  
o Read in cycles 

  
o Read in cycles if PCW (PLC Control Word) flag is set 

  
If the Mailbox is read in cycles, you may specify a read cycle time. The faster the read cycle 
time, the more often the Mailbox gets checked; however, the slower the rest of the system 
will become. 
  
Or, you may set the Mailbox up such that it is only read when bit C15 in the PLC 
(programmable logic controller) Control Word is set. 
  
The purpose of this mode is to reduce the overhead of the communication time when there is 
no need for the controller to send commands to the panel.  
  

Read Cycle 

The Read Cycle time under Project - Panel Controller Interface - Interlock Mailbox specifies 
how frequently the operator panel will read the data in the mailbox to check to see if it 
contains a new command.  
  
The faster the mailbox Read Cycle, the faster the panel will respond to commands from the 
controller.  
  
However, the update of the variables shown on the display will be slower. 
  

Interlock Reference 

The Interlock Reference is the address of the first Mailbox register in the controller memory. 
The address can be entered directly as a string or via the Data Field Properties dialog box 
displayed by clicking on the "…" button. 
  
A memory map of the Mailbox in the controller memory is shown below. The Status Word 
and the Command/Response Word are always required for the Mailbox. Parameter 0 - 
Parameter 17 Words are only used if required by the particular mailbox command. 
  
Offset  Item 
0 Status Word 
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1 Command/Response Word 
2 Parameter 0 
3 Parameter 1 
... ... 
19 Parameter 17 
  
Note:  When entering the starting address, care must be taken to ensure that the controller 
memory used by the Mailbox does not overlap with the memory areas reserved for other 
panel functions such as alarms, I/O update, keyboard update, etc. 
  

Panel IO 

Panel I/O 

EH-HMI panels with hardware type -0050 are ready to house the local I/O (Input/Output) 
module UIM-03. It can be used in conjunction with the internal controller to be part of its I/O, 
it can be used as an extension of the external controller that is connected to the EH-HMI 
panel, or it can be used as a stand-alone module. 
  
Note:  The UIM05 I/O board cannot be used with Panel I/O. 
  
To configure the Panel I/O, select Panel Controller Interface from the Project menu and click 
on the Panel I/O tab. 
  

 
  
The digital I/O points of the UIM03 board can be mapped to a free memory area within the 
connected controller (either the internal controller or an externally connected controller). The 
resident PLC program will read the physical status of the UIM03 inputs from the memory 



EH-VIEW (en) - July 2005 - 05/005 

Page 217 

area dedicated to the input points; the UIM03 outputs are controlled by the PLC user program 
by writing to the memory area assigned to the UIM03 output points. 
  
You can enable and set the input and output, and specify which modules are to be connected. 
  

Input 

Input 

The Input area allows you to specify the configuration parameters for the digital input points 
of the UIM03 board. Check to box enable panel input. The frequency of updates and the 
Reference location may be specified. 
  

Update Cycle 

Specifies the average update cycle time used by the EH-HMI firmware to update the external 
controller memory area assigned to the input points. This memory area can be specified in the 
Reference address. 
  
Note:  The Update cycle time needs to be selected with care, as the EH-HMI panel uses the 
same communication channel to update the local I/O as it does for communication with the 
external controller. If the Update cycle time is set to a value that is too small, communication 
performance between the EH-HMI panel and the external controller could be sacrificed. 
  

Reference 

Specifies the starting address for copying the image of the input data. Clicking on the "…" 
button brings up the Data Field Properties dialog box, where more detailed PLC 
(programmable logic controller) information may be entered. 
  
Note:  The panel I/O feature requires a minimum offset between the starting addresses of the 
input and output area. The difference between the starting addresses must be at least of 16 
bytes. The data format used to specify the initial address can be byte, word or double word 
depending on the protocol. 
  

Output 

Output 

The Output area allows you to specify the configuration parameters for the digital output 
points of the UIM03 board. Check the box to enable panel output. The frequency of updates 
and the Reference location may be specified. 
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Update Cycle 

Specifies the average update cycle time used by the EH-HMI firmware to update the status of 
the physical output points. The output points are updated by reading them from the external 
controller memory area assigned to the output points as specified in the Reference address. 
  

Output Reference 

Specifies the starting address for copying the image of the output data. Clicking on the "…" 
button brings up the Data Field Properties dialog box, where more detailed PLC 
(programmable logic controller) information may be entered. 
  
Note:  The panel I/O feature requires a minimum offset between the starting addresses of the 
input and output area. The difference between the starting addresses must be at least of 16 
bytes. The data format used to specify the initial address can be byte, word or double word 
depending on the protocol. 
  

Modules 

A list of all the local I/O boards available for use with the Panel I/O feature is provided. Use 
the arrow buttons to move modules from the Available list to the Connected list, and vice 
versa, and to specify the order of modules in the Connected list. 
  
Note:  Current EH-HMI hardware supports only one local I/O module. 
  

4.7.6 Report on Panel Printer 

Report on Panel Printer 

It is possible to define the printer device driver and the communication parameters, the report 
format and the timetable on which a report is printed, to configure a key or touch cell to print 
a report, or to request a printout by using the Interlock MailBox. 
  
Note:  In order to use these features, the panel must contain firmware version 4.10 or higher. 
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Printer Setup 

Printer Setup 

To log alarms and messages, a serial printer may be connected to the panel. 
  
Note:  The same port is used for both programming the panel while in Configuration Mode 
and for logging information to a printer during Operation Mode. 
  
To configure a serial printer, select Project - Report on Panel Printer - Printer Setup. 
  

 
  
From the Printer Setup dialog box choose a printer and set the communication parameters 
such as baud rate, parity, stop bits, data bits, and protocol. It is also possible to define the page 
size. 
See the Printing section for additional information on printing. 
  

Printer 

Printer 

Select a printer type from the pull-down list. If the printer to be used is not listed, use the Add 
button to add a new printer to the list of available printers. Doing so will bring up the Printer 
Properties dialog box in which the parameters for the newly added printer can be defined. 
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Similarly, the Edit button can be used to redefine the parameters for an existing printer. The 
Delete button removes the currently selected printer from the list of available printers. 
  
Note:  Any new printer must also be supported by the panel firmware. Simply defining a new 
printer in the EH-View software may not be enough to get the new printer running. 
  

Printer Properties 

The Printer Properties dialog box, invoked by clicking on the Add or Edit buttons from the 
Printer Setup dialog box, lets you configure a printer. You can enter the printer name, escape 
sequences, enable reversing font bitmap after rotation, make automatic linefeed selections, 
specify eject parameters, and make selections for graphical printouts. 
  

Printer Name 

Enter a name for this printer. 
  

Escape Sequences 

The list of escape sequences for text and graphic control. The escape sequences can be freely 
assigned. 
  

Reversing Font Bitmap After Rotation 

This property allows to specify if the Font Bitmap requires to be reverted after rotation. 
  

Auto Linefeed 

Radio buttons allow for a simple carriage return (CR), or a line feed (LF) after carriage return 
(CR/LF). 
  

Eject 

Checking the Form feed box instructs the printer to eject a blank sheet of paper following 
every report printed. The delay after form feed is indicated in seconds. 
  

Graphics 

Checking the Enable box indicates that the current page must be printed in graphic mode. 
The printer control code comes from the printer documentation. 
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The ratio of the character width in text and graphic mode depends on the resolution of the 
graphical printout. 
  

Baud Rate 

This option specifies the baud rate to be used in communication between the panel and the 
printer. 
  

Parity 

Specifies the parity to be used in communication between the panel and the printer. 
  

Data Bits 

Specifies the number of data bits to be used in communication between the panel and the 
printer. 
  

Stop Bits 

Specifies the number of stop bits to be used in communication between the target panel and 
the controller. 
  

Protocol 

The protocol used for the panel and printer to communicate. Xon/Xoff is also known as 
software flow control. RTS/CTS is also known as hardware flow control. 
  

Page Size 

Specifies the width and height of the print area, in characters. 
  
Note:  If reports are to be printed, the paper height must be defined here before the report is 
defined. If the paper height is changed after some reports have already been defined, the 
previously defined report layouts will not automatically be rearranged. 
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Reports 

Reports 

A report is a collection of project file pages (or parts of project file pages). 
  
The Reports dialog box under Report on Panel Printer on the Project menu lets you define the 
parameters of each specific report. 
  

 
  
There are four tabs in the Reports dialog box: General, Header, Footer, and Advanced. Each 
deals with a different section of the report. A list of reports is shown on the left side of the 
dialog box. In addition, there are buttons to add a new report, delete an existing report, and 
change languages. 
  
Note:  More than one report can be created for each project file. 
  
Note:  If reports are to be printed, the paper height must be defined in Printer Setup before the 
report is defined. 
  

Report List 

A list of existing reports, if any, is shown and is available for selection. 
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New 

A report may be added by clicking the New button and giving the report a name. 
  

Delete 

Clicking on the Delete button removes the currently selected report from the list. 
  

Languages 

Click on the Languages icon to select a language.  
  

General 

General tab 

 
  
All of the pages of a project file are shown within the left-hand box. Pages in the current 
report are shown in the right-hand box. Use the buttons between the boxes (Add, Remove, 
Add all, Remove all, and Properties) to set up the reports. You can also specify margin 
measurements. 
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Add 

To add a page to the current report, select a page from within the left-hand box and click on 
the Add-> button. Doing so will place the page name into the right-hand box. 
  

Remove 

To remove a page from the current report, select the page name from within the right-hand 
box and click on the <-Remove button. 
  

Add All 

To add all of the pages of your project file to a report, select the Add All>> button. 
  

Remove All 

To remove all of the pages from the report, click on the <<Remove All button. 
  

Properties 

By selecting a page of interest and pressing the Properties button, you can specify what part 
of the project file page to print and the font for printing in the EH-HMI page Property dialog 
box. 
  

Panel Page Property 

The Panel Page Property dialog box is accessed by clicking on the Properties button under the 
General tab from Project - Report on Panel Printer - Reports. 
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This dialog box lets you set the number of line spaces before and after the report, the starting 
row, the total number of lines to print, whether to put a page break after printing the report, 
whether to enable graphics printing, and which font to use for printing. 
  

Margins 

Set the amount of space, in characters, to be allotted as left, right, top and bottom margins on 
the printed reports. 
  

Header 

Header 

 
  
The structure of the header and the footer are the same. The header and footer both remain 
consistent throughout the report (i.e., the header on page 1 of a report will be the same header 
that appears on page 9 of a report). 
  
You can define the height of the header. A number of predefined fields can be inserted into a 
header, such as the time and date, the page number, the report name and a label (which allows 
the user to enter static text). It is also possible to specify where the fields are inserted and how 
they are positioned. 
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Height 

The height, in inches, of the header or footer. 
  
  

Fields 

Fields 

The list of fields to be included in the header or footer, such as the time and date, the page 
number, the report name or a label (which lets you enter static text). To add a field to the list, 
select an entry from the Field Type list. Add and Delete buttons are available. You can also 
specify row, column, alignment, and argument parameters for headers and/or footers. 
  
  

Field Type 

A list of predefined fields available for insertion into a header or footer. Selecting the field 
type Label activates the Argument entry box where the label text may be inserted. 
  
  

Add 

Clicking on the Add button inserts the item currently displayed in the Field Type list into the 
list of Fields to be included in a header or footer. 
  
  

Delete 

Clicking on the Delete button removes the currently selected item from the list of Fields to be 
included in a header or footer. 
  

Row 

The number of the row where the currently selected items in the Fields list will be inserted 
into the header or footer. 
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Column 

The number of the column where the currently selected items in the Fields list will be inserted 
into the header or footer. This option is only available when the alignment is set as Custom. 
  

Align 

The alignment for the header or footer. Choices include Left, Center, Right, and Custom. If 
Custom is selected then a Column value may be entered. 
  

Argument 

Selecting the field type Label activates the Argument entry box where the label text may be 
inserted. 
  

Footer 

Footer 

 
  
The structure of the header and the footer are the same. 
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The header and footer both remain consistent throughout the report (i.e., the header on page 1 
of a report will be the same header that appears on page 9 of a report). 
  
It is possible to define the height of the header and the footer. Several predefined fields can be 
inserted into a header or footer, such as the time and date, the page number, the report name 
and a label (which allows the user to enter static text). It is also possible to specify where the 
fields are inserted and how they are positioned. 
  

Fields 

Advanced 

Advanced tab 

 
  
The Advanced tab allows you to select the following parameters, which are common for 
every page in the report. 
  
o Wrap Lines 

   
o Page Separator 
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o Packing 
   

o Default Font 
   

o Attribute Transformations 
   

o Non-printable characters 
   

o Special Formats 

Wrap Lines 

If wrapping is selected, lines longer than the width of the page will be printed on the next line. 
If wrapping is not selected, lines longer than the width of the page will be truncated. 
  

Page Separator 

The page separator is a character that can be optionally defined as a placeholder for empty 
lines in the printed page. 
  

Packing 

If the page width is longer than the display width, it is possib le to print two or more rows on a 
single line. 
  

Default Font 

Specifies the default font to use when a particular font has not been selected in the page 
definition dialog box. The list of available fonts depends on the printer driver. 
  

Attribute Transformations 

Display attributes such as reverse, underline, or blink, or can be transformed into another 
printer attribute, such as normal, underlined, bold or italicized. 
  

Non-printable Characters 

Non-printable characters can be printed as blanks or asterisks. If Print Anyway is checked, 
corresponding codes are sent to the printer even if the printer cannot correctly interpret them. 
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Special Formats 

The options of printing in condensed or enlarged text are available. 
  

Triggers 

Triggers 

 
  
  
Triggers let you specify when a report is to be printed. A list of triggers is shown at the left of 
the box, with buttons to add and delete triggers. Trigger properties may be set on the right 
side of the box. 
  
Note:  It is also possible to print a report by using a function key or touch cell programmed 
via the Keyboard Macro Editor, or by having the PLC issue a print request by using the 
Interlock Mailbox command Start Report Printout. 
  
Note:  It is possible to start printing more than one report. Up to ten (10) printer requests can 
be stored in a FIFO (first in first out) buffer. 
  

List of Triggers 

The report to be printed can be selected from the list of available reports as defined under 
Project - Report on Panel Printer - Reports. 
  

Add 

Click on the Add button to add a new trigger. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 231 

Delete 

Click on the Delete button to the selected trigger from the list. 
  

Trigger Properties 

Trigger Properties 

The trigger Type can be set as cyclic, which will print the Report at certain specified intervals 
(up to 99 hours apart), or every day at a specified time. The specified interval or specified 
time is set under Time. 
  

Report 

The name of the report to which the trigger will apply. 
  

Trigger Time 

Any report can be printed cyclically in two different modes: 
  
o cyclically after an interval of time 

  
o every day at a specific time 

Time 

For cyclic triggers, this is the number of hours (up to 99) between triggers. For daily triggers, 
this is the time of day when the report will be triggered. 
  

4.7.7 Keyboard Macro Editor 

Keyboard Macro Editor 

The Keyboard Macro Editor lets you configure panel keys to perform application specific 
functions. It may be invoked by selecting Keyboard Macro Editor from the Project menu, by 
clicking on the Keyboard Macro Editor icon in the toolbar, or by pressing the Shift+Ctrl+M 
keys. 
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Each of the available functions is called an elementary macro command. They can be 
accessed by clicking on the proper icon in the Commands toolbar from within the Keyboard 
Macro Editor. Advanced commands, called complex macro commands, are composed of two 
or more elementary macro commands. For example, "Go to page 2" is an elementary macro 
command. "Select field 5, Begin data entry" is a complex macro command composed of two 
elementary commands. Complex macro commands function by executing each of the 
elementary macro commands in the sequence in which they were entered. 
  
The Keyboard Macro Editor consists of a list of panel keys, buttons for key states, a row of 
command icons, a command list window, Append and Insert buttons, and a Delete button. 
  
The above (with varying Commands) are available on tabs for All Pages, Page n (where n is a 
number), Data Entry, Alarms, System, Command Menu, Event List, and Time/Date. 
  
Three examples of using the Keyboard Macro Editor are given. 
  

Operating Modes 

Operating Modes 

The Keyboard Macro Editor has eight different modes of operation, represented by index tabs 
across the top of the dialog box. These eight modes are:  All Pages, Page n (where n is a 
number), Data Entry, Alarms, System, Command Menu, Event List, and Time/Date. The 
index tab displayed in the foreground with respect to the other tabs indicates the selected 
operating mode. 
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Note:  Not all elementary macro commands are available in each operating mode. The 
Keyboard Macro Editor will only display those macros that are available for a particular 
mode. 
  
Note: Even if a command is present in more than one operating mode, this on-line help shows 
its icon only once. 
  
  

All Pages 

 
  
Keys that are programmed in this operation mode will be active in all pages of the project. 
This means that you need to define (i.e., program) the key only once on one page of the 
project. The key will perform its specified function on each and every page of the project, 
regardless of what page you are on when the key is programmed. 
  
Note:  The relationship between the All Pages mode and Page n mode is particularly 
important to understand. A single key can be programmed in different operating modes to 
perform different functions. A macro programmed in All Pages mode will be active in all 
pages of the project. A macro programmed in Page n mode will be active only when the panel 
is on page n (where n is the page number). A macro that is programmed in Page n mode will 
override a macro that is programmed in All Pages mode only when the panel is on page n. For 
example, suppose you have key F1 programmed to "go to page 2" in All Pages mode, while 
also having it programmed for "Begin data entry" in Page n mode (say, page 5). In this case, 
the only time that the panel will go into Data Entry Mode when the F1 key is pressed is when 
the panel is on page 5. On all other pages of the project, pressing F1 will take the user to page 
2. 
  
The following elementary macro commands are normally available on the All Pages tab. 
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o Attribute 

   
o Begin Data Entry 

   
o Brighter Display 

   
o Clear Event List 

   
o Confirm Recipe Menu Selection 

   
o Data Editing 
o   
o Display Object 

  
o Enter Command Menu 

   
o Go to Page 

   
o Go to Recipe Menu 

  
o High Contrast 

  
o Hide Object 

   
o LED State 

  
o Low Contrast 

   
o Next Page 

   
o Passthrough Mode 

   
o Password Logout 

   
o Password Protect 

   
o Passwords 

  
o Port Assignment 

   
o Previous Page 

   
o Print Report 

   
o Recipe and Events Backup 

   
o Recipe Control 

   
o Return to Initial Page 

   
o Scroll Down 
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o Scroll Recipe Menu 
   

o Scroll to Line 
   

o Scroll Up 
   

o Select Data Entry Field 
  
o Send Command 

   
o Show Alarm List 

   
o Show Event List 

   
o Step 

   
o Step Control Variables 

   
o Toggle Relay 

   
o Trend Window 

   
o Wait 

   
o Write to Controller 

Page n 

 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 236 

Macros defined in this mode will be active only when the panel is on page n (where n is an 
integer). 
  
Note:  The relationship between the All Pages mode and Page n mode is particularly 
important to understand. A single key can be programmed in different operating modes to 
perform different functions. A macro programmed in All Pages mode will be active in all 
pages of the project. A macro programmed in Page n mode will be active only when the panel 
is on page n (where n is the page number). A macro that is programmed in Page n mode will 
override a macro that is programmed in All Pages mode only when the panel is on page n. For 
example, suppose you have key F1 programmed to "go to page 2" in All Pages mode, while 
also having it programmed for "Begin data entry" in Page n mode (say, page 5). In this case, 
the only time that the panel will go into Data Entry Mode when the F1 key is pressed is when 
the panel is on page 5. On all other pages of the project, pressing F1 will take the user to page 
2. 
  
The following elementary macro commands are normally available on the Page n tab. 
  
o Attribute 

   
o Begin Data Entry 

   
o Brighter Display 

   
o Clear Event List 

   
o Confirm Recipe Menu Selection 

   
o Data Editing 

  
o Display Object 

   
o Dimmer Display 

  
o Enter Command Menu 

   
o Go to Page 

   
o Go to Recipe Menu 

  
o High Contrast 

  
o Hide Object 

   
o LED State 

  
o Low Contrast 

   
o Next Page 

   
o Passthrough Mode 

   
o Password Logout 
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o Password Protect 
   

o Passwords 
  
o Port Assignment 

   
o Previous Page 

   
o Print Report 

   
o Recipe and Events Backup 

   
o Recipe Control 

   
o Return to Initial Page 

   
o Scroll Down 

   
o Scroll Recipe Menu 

   
o Scroll to Line 

   
o Scroll Up 

   
o Select Data Entry Field 

  
o Send Command 

   
o Show Alarm List 

   
o Show Event List 

   
o Step 

   
o Step Control Variables 

   
o Toggle Relay 

   
o Trend Window 

   
o Wait 

   
o Write to Controller 
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Data Entry 

 
  
Keys that are programmed in this mode of operation will be active only when the panel is in 
the process of data entry. 
  
Panels that contain firmware version 4.07G and greater offer the capability of multiple field 
data entry. This feature lets you edit more than one field without exiting Data Entry Mode. 
  
In order to use this feature, you need to create a macro key that is programmed in the 
following manner: 
  
o In the Pressed state, the key needs to be programmed with the macro Begin Data Entry. 

   
o In the Released state, the key needs to perform the following elementary macro 

commands in sequence: 
  

Confirm Data Entry 
   
Begin Data Entry 
   
Go to Next Field 
   
Begin Editing Value 
  
Commands normally available in this mode include: 
  
o Begin Data Entry 

   
o Cancel 
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o Confirm Data Entry 
   

o Data Editing 
   

o Erase 
   

o Field Down 
   

o Field Up 
   

o Next Field 
   

o Previous Field 
   

o Step 
   

o Step Control Variables 
   

o Toggle Relay 
   

o Wait 
   

o Write to Controller 

Alarms 

 
  
Macros defined on the Alarms tab are active only when the panel is in Alarm Mode. 
  
Commands normally available in this mode include: 
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o Acknowledge Alarm 

   
o Acknowledge All Alarms 

   
o Go to Alarm Page 

   
o Go to Page 

   
o Page Mode 

   
o Print Alarms 

   
o Scroll Down 

   
o Scroll Up 

   
o Step Control Variables 

   
o Toggle Relay 

   
o Wait 

   
o Write to Controller 

System 

 
  
This operation mode is used for the global setup of toggle keys. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 241 

Commands normally available in this mode include: 
  
o Set Toggle Key 

  
  
Allows the key to behave as a toggle push-button. The Data Field Properties dialog box lets 
you enter the specific memory location to be toggled. 
  
Note: A key programmed in System mode will function as a toggle push-button in all other 
modes as well. 
  

PowerUp 

 
  
The PowerUp macro commands are execute once at panel start up. This feature does not 
require any update in the firmware 
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Command Menu 

 
  
Keys that are programmed in this mode are only active when the panel is in the Command 
Menu. 
  
Commands normally available in this mode include: 
  
o Confirm 

   
o Down 

   
o Left 

   
o Page Mode 

   
o Right 

   
o Step Control Variable  

   
o Up 
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Event List 

 
  
Keys programmed in Event List mode are active only when the panel is in the Event List 
Mode. 
  
Commands normally available in this mode include: 
  
o Clear Event List 

   
o Page Mode 

   
o Password Protect 

   
o Scroll Down 

   
o Scroll Up 

   
o Step Control Variables 
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Time/Date 

 
  
Macros defined in the Time/Date mode are active only when the panel is in the Time/Date 
Mode 
  
Commands normally available in this mode include: 
  
  
o Next Field 

   
o Page Mode 

   
o Step Control Variable  

  
o Time/Date Decrement 

  
o Time/Date Increment 

Panel Keys 

At the top of each tab within the Keyboard Macro Editor dialog box is a scrollable toolbar of 
panel keys that are available for programming. A sliding bar located beneath the toolbar 
makes it easy to maneuver through the panel keys. A key is selected by single clicking on it 
with the left mouse button. The selected key will be displayed in a lighter color than the other 
keys. 
  
Note:  Not all keys are available on every panel. 
  
The small circle located in the upper left-hand corner of each panel key is a program 
indicator. If the circle is red, this indicates that a key is programmed in that particular 
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operating mode. Similarly, if the circle is yellow, there are no keys programmed in that 
particular operating mode. 
  

Key States 

Below the toolbar of panel keys are the Key states radio buttons. The state can be selected by 
simply clicking on the proper radio button. You can program a key to be active whenever it is 
Pressed, Released, or held down (Fast Autorepeat). 
  
Fast Autorepeat is useful when dramatically changing the value of a register. For example, 
suppose you have programmed the F1 key to step a register up by a value of 1. If you want to 
change the value in the register from 20 to 200, you would have to press the F1 key 180 times 
if it were programmed in the pressed state. However, by programming the key in the Fast 
Autorepeat key state, you can press and hold the key until it reaches the value of 200. 
  

Commands 

Commands 

Located beneath the Key states is the Commands toolbar. Each elementary macro command 
is represented by an icon in this toolbar. If there is not enough room to display all of the icons, 
left and right arrow keys will be present at the ends of the toolbar, letting you access all of the 
elementary macro commands available for a particular mode of operation.  
  
Note:  Not all commands are available on all tabs. 
  
Note: Even if a command is present in more than one operating mode, this on-line help shows 
its icon only once. 
  
Commands that may be available on various tabs include: 
  
o Acknowledge Alarm 

   
o Acknowledge All Alarms 

   
o Attribute 

   
o Begin Data Entry 

   
o Brighter Display 

   
o Cancel 

   
o Clear Event List 

   
o Confirm 
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o Confirm Recipe Menu Selection 
   

o Data Editing 
   

o Dimmer Display 
  
o Display Object 

  
o Down 

   
o Erase 

  
o Enter Command Menu 

  
o Enter Password if needed 

  
o Field Down 

   
o Field Up 

   
o Go to Alarm Page 

   
o Go to Page 

   
o Go to Recipe Menu 

  
o High Contrast 

  
o Hide Object 

  
o LED State 

   
o Left 

  
o Low Contrast 

  
o Next Field 

   
o Next Page 

   
o Page Mode 

   
o Passthrough Mode 

   
o Password Logout 

   
o Password Protect 

   
o Passwords 

  
o Port Assignment 
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o Previous Field 
   

o Previous Page 
   

o Print Alarms 
   

o Print Report 
   

o Recipe and Events Backup 
   

o Recipe Control 
   

o Return to Initial Page 
   

o Right 
   

o Scroll Down 
   

o Scroll Recipe Menu 
   

o Scroll to Line 
   

o Scroll Up 
   

o Select Data Entry Field 
  
o Send Command 

  
o Show Alarm List 

   
o Show Event List 

   
o Step 

   
o Step Control Variables 

   
o Toggle Relay 

   
o Trend Buffer Print 

   
o Trend Window 

   
o Up 

   
o Wait 

   
o Write to Controller 
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Acknowledge Alarm 

 
  
This command acknowledges an active alarm. 
  

Acknowledge All Alarms 

 
  
This command acknowledges all active alarms 
  

Attribute 

This lets you specify the display attribute of an area on the page. Available attributes are 
reverse, highlight, and blink. You must enter the row, column, width, and height of the area 
that the attribute is to affect. 
  

Begin Data Entry 

 
  
This command switches the panel into Data Entry Mode so that you may select a field and 
press Enter to begin editing the value. 
  

Brighter Display 

 
  
This command increases the brightness of a vacuum fluorescent display panel.  
  

Cancel 

 
  
This command cancels the entered value. 
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Choose Report 

In the Choose Report dialog box you can select which report is to be printed when a key (or 
touch cell) is pressed. 
  

Clear Event List 

 
  
This command clears all of the entries from the queue of events. 
  

Confirm 

 
  
This command confirms the entered value or menu selection.. 
  

Confirm Recipe Menu Selection 

 
  
The Confirm Recipe Menu Selection macro accepts the selected parameter set name and sets 
the current recipe parameter set to the new value. It can be assigned to a key together with 
Return To Initial Page macro to "close" the Recipe Menu page and return to the page jumped 
from with the Go To Recipe Menu macro. 
  

Data Editing 

 
  
This command allows the panel user to select a digit of the field and begin editing the value, 
providing the field is set up as read/write. This functions mainly as an Enter key and should 
be used in a complex macro command following Begin data entry. 
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Dimmer Display 

 
  
This command decreases the brightness of a vacuum fluorescent display panel. 
  

Display Object 

 
  
  

 
  
This command is used to display an object. User can select the objects to be displayed from 
the Display Object dialog. 

Down 

 
  
This command positions the cursor directly beneath the current position. 
  

Enter Command Menu 

 
  
This command is used to force the panel to go to command menu page from operation mode.  

Enter Password if needed 

The ENTER PASSWORD IF NEEDED macro command can be used to block/allow the 
execution of the following macro commands depending of the inserted password; the macro 
requires one argument, which specifies the accepted passwords. If one of the specified 
passwords is already active, the password page is not displayed and the following macro are 
immediately executed; otherwise, the password page is displayed asking to enter a password. 
When the correct password is entered, the following macro comands are immediately 
executed. 
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The below example shows how to use the macro to block or allow the execution of the toggle 
bit; when the password is already active, the toggle macro is executed without entering the 
password. 
  
  

 
  
  
Note: 
Firmware 5.30 or greater is need. 

Erase 

 
  
This command erases the entry text. 
  

Field Down 

 
  
This command positions the cursor on the next available read/write field directly below the 
currently selected field. If the data fields are not aligned vertically, this command has no 
functionality. 
  

Field Up 

 



EH-VIEW (en) - July 2005 - 05/005 

Page 252 

  
This command positions the cursor on the next available read/write field directly above the 
currently selected field. If the data fields are not aligned vertically, this command has no 
functionality. 
  

Go to Alarm Page 

 
  
If an alarm page has been specified for the currently active alarm, this macro command takes 
you to that specified page. 
  

Go to Page 

 
  
This command causes the panel to display a specific page. You are asked to input the page 
number. 
  

Go to Recipe Menu 

 
  
This macro lets you indicate the page with the Recipe Menu to which the macro should jump. 
The Go To Recipe Menu macro sets the Recipe Page For Selection control variable and jumps 
to the specified page.  
  
This is the preferred way of going to a Recipe Menu page (page with Recipe Menu field).  
The other way is to set the page number in the Recipe Page For Selection field and then go to 
the Recipe Menu page using any other page-changing macros (Go To Page, Next Page, etc.). 
  

Hide Object 
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This command is used to hide an object. User can select the objects to be hidden from the 
Hide Object dialog. 

High Contrast 

 
  
This commands increases the contrast of a LCD display panel. 

LED State 

 
  
This lets you set the state of any LED that is attached to the keys on the panel. The LED's 
may take the value of On, Off, Blink, or Default. The Default state is determined by the value 
of the corresponding LED bit in the reserved data area (RDA). 
  

Left 

 
  
This command positions the cursor directly to the left of the current position. 
  

Low Contrast 

 
  
 This commands decreases the contrast of a LCD display panel. 
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Next Field 

 
  
This command will position the cursor on the next read/write field. Fields are sorted left to 
right, top to bottom. This directionality defines what is considered to be the next field. If a 
field is read only, it will be skipped and the cursor will fall on the next available read/write 
field. This is because a field that is read only cannot be edited. 
  

Next Page 

 
  
This will cause the panel to display the next page of the project, providing you are not on the 
last page. 
  

Page Mode 

 
  
This macro is used to return the panel back to Page Mode. 
  

Passthrough Mode 

 
  
This lets you enable or disable passthrough mode. This is designed so you can go on-line with 
the controller without disconnecting any cables. 
  
Note:  Passthrough mode does not work with all protocols and controllers. 
  

Password Logout 
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When the Password logout macro is executed, the currently active password is logged out. If a 
password defined with the ALOGI (Automatic Login) option is present, it will be activated; if 
no automatic login password is configured then no password is activated in the system. 
  

Password Protect 

 
  
This command allows you to require that a password be entered from the panel before 
executing any macros that follow. If the password is not active, the panel will simply not 
execute any macro commands that follow. A dialog box will appear, letting you specify 
which password(s) must be active. 
  
Note:  The panel will not prompt the user to enter the password, rather the user must enter the 
password by using the Password selection in the panel command menu. 
  

Passwords 

 
  
This will request that the panel user enter a password. 
  
Note:  If passwords are not defined in the project, this command has no effect. 
  

Port Assignment 

 
  
EH-HMI serial ports (PC/Printer and PLC ports) can be assigned for communication with the 
iPLC using Port Assignment commands while EH-HMI is in Operation Mode. 

Previous Field 

 
  
This command positions the cursor on the previous read/write field. Fields are sorted left to 
right, top to bottom. This directionality defines what is considered to be the previous field. If 
a field is read only, it will be skipped and the cursor will fall on the next available read/write 
field. This is because a field that is read only cannot be edited. 
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Previous Page 

 
  
This will cause the panel to display the previous page of the project, providing you are not on 
the first page. 
  

Print Alarms 

 
  
This command prints all of the active alarms. 
  

Print Report 

 
  
This command lets you print any of the reports that have been configured. The Choose Report 
dialog box appears. 
  

Recipe Control 

 
  
Lets you perform different recipe functions, including downloading a particular parameter set, 
uploading a particular parameter set, and selecting a particular parameter set. You must enter 
the page number and the parameter set that is to be affected. Entering a 0 for either causes the 
current page/parameter set to be chosen. 
  

Recipes and Events Backup 

 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 257 

On some EH-HMI panels it is possible to back up recipe data, as well as the event list, into 
flash memory inside the panel. This means that even if the panel loses power and the backup 
battery is discharged or missing, the recipe data and event list will be preserved. 
  
Note:  Selecting these features uses memory within the EH-HMI panel that is normally 
reserved for the project file. Therefore, the amount of memory available for the project file is 
reduced by the amount of memory reserved for the entire backup of both recipe data and the 
event list, which is 128 KB. 
  
When this feature is enabled, recipes are copied to flash memory automatically from the EH-
HMI panel after any recipe backup or recipe upload operation. The event list is copied to flash 
memory any time an event happens. 
  
More information on this topic is provided in the Advanced Section: Recipes and Events 
Backup in Flash. 
  

Return to Initial Page 

 
  
This causes the panel to display the page that was displayed before the Go to page macro 
command was executed. 
  

Right 

 
  
This command positions the cursor directly to the right of the current position. 
  

Scroll Down 

 
  
This command will scroll the display down one line. 
  

Scroll to Line 

 
  
This command lets you specify the page row that is to be considered the topmost row of the 
display. Activating this command scrolls the panel to the "new" topmost row. This is useful 
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when there are more lines on a page than there are viewable lines on the panel. This macro 
functions only when there are enough defined lines to make the selected line the topmost line. 
  

Scroll Recipe Menu 

 
  
The Scroll Recipe Menu macro is used to move the selection in the Recipe Menu field. This is 
the way that a new recipe parameter set name is chosen from the list. Positive values for the 
scroll step move the selection down, while negative values move the selection up. 
  
If there are many recipe parameter sets, more than one key can be assigned to Scroll Recipe 
Menu macros: two keys with step of 1 (-1) for "fine" scrolling and two other keys with step 
greater than 1 for "fast" scrolling. 
  

Scroll Up 

 
  
This command will scroll the display up one line. 
  

Select Data Entry Field 

 
  
This command lets you select the field that you wish to edit. This only selects the field; to edit 
it you must begin data entry. 
  
Note:  Fields are counted from left to right, top to bottom on the panel. 
  
Note:  Attributes, time data fields, date data fields and touch cells attached to the controller 
are counted as fields. 
  
Note:  All references used in this macro are re-indexed as fields are inserted or deleted. 
  

Send Command 

 
  
This command can be used to send ASCII string commands from the panel to the controller 
asking the controller to do a specific action. 
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Show Alarm List 

 
  
This command switches the panel to Alarm Mode and displays the currently active alarms. 
This is designed for use when you don't want the alarm list to appear every time there is an 
active alarm; rather, it enables you to bring up the alarm list on demand. This macro works 
only if there are active alarms. 
  

Show Event List 

 
  
This command displays all of the events that are currently stored in the event list. This macro 
works only if there are events in the list. 
  

Step 

 
  
The Data Field Properties dialog box appears where you can indicate the reference area, then 
the Step dialog box appears to let you specify a step up or down, set the step size, set a 
minimum or maximum step size, or allow for variable step sizes. 
  

Step Control Variables 

 
  
The Data Field Properties dialog box appears to let you indicate the reference area, then the 
Step dialog box appears to let you specify a step up or down, set the step size, set a minimum 
or maximum step size, or allow for variable step sizes. 
  

Time/Date Decrement 

 
  
This command decrements the time/date field. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 260 

Time/Date Increment 

 
  
This command increments the time/date field. 
  
  

Toggle Relay 

 
  
Allows the key to behave as a toggle push-button. The Data Field Properties dialog box lets 
you enter the specific memory location to be toggled. 
  
Note:  A key programmed in System mode will function as a toggle push-button in all other 
modes as well. 
  

Trend Buffer Print 

 
  

 
  
This macro gives the user the ability to print the trend buffer in alphanumeric format.  The 
“buffer to print” parameter shows all of the active trend buffers that can be printed. 
  

 
   

Trend Window 

Trend Window 
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This macro allows for manipulation for the trend currently being viewed. It offers the 
possibility of setting several actions, divided into the following categories: 
  
o trend cursor, 

  
o trend viewer scrolling, and 

  
o trend viewer zooming. 

Trend Cursor 

On/Off Cursor  
This command will enable/disable the graphic cursor. When a graphic cursor is enabled, the 
scrolling of the trend is stopped. You can implement the scroll cursor macros to move the 
graphical cursor over the curves or to move the entire trend window. 
  
Note:  To display values from the Y-axis on the EH-HMI panel, use the internal panel control 
variables. The names of the available Y-cursor variables can be found by looking under Insert 
- Trend Window. 
  
Note:  To display values from the X-axis, use the Time/Date function. 
  
Action: Scroll Cursor Forward, Scroll Cursor Backward 
Use these commands to create buttons that move the cursor forward or backward.  The scroll 
step parameter defines the scrolling size. 
  
Note:  In order to have a smooth cursor movement over the curve, it is helpful to program 
these commands in the autorepeat mode. 
  

Trend Viewer Scrolling 

Action: Scroll Forward, Scroll Backward 
  
Scroll the entire trend viewer left or right.  The scroll step parameter defines the scrolling 
size. 
  
  



EH-VIEW (en) - July 2005 - 05/005 

Page 262 

Action: Automatic Scroll On/Off 
  
Trend viewers are configured to scroll the trend to the left by default. This macro will disable 
the automatic scrolling feature. 
  

Trend Viewer Zooming 

Action: Zoom X, Zoom Y 
  
The zoom percentage parameter defines the new displayed range of the trend. For example, a 
zoom percentage of 200% will show half of the originally displayed trend, while a 50% value 
will show an area twice the size of the originally displayed trend. 
  
  
Reset Trend Wnd. Time 
  
This command resets the axes ranges to their original values. 
  

Up 

 
  
This command positions the cursor directly above the current position. 
  
  

Wait 

 
  
Allows the panel to pause for a specified amount of time (up to ten seconds) before executing 
the next macro command. The time entered for this command is in tenths of a second. 

Write to Controller 

 
  
This command lets you write constant values to the controller memory. The Data Field 
Properties dialog box appears where you enter the specific memory location. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 263 

Command List 

Once commands are selected, they are displayed in the list box at the bottom left side of the 
Macro Editor dialog box in the sequence in which they are to be executed. 
  
Advanced commands, called complex macro commands, are composed of two or more 
elementary macro commands. For example, "Go to page 2" is an elementary macro 
command. "Select field 5, Begin data entry" is a complex macro command composed of two 
elementary commands. Complex macro commands function by executing each of the 
elementary macro commands in the sequence in which they were entered. 
  

Delete 

The Delete button removes the selected command from the command list. 
  

Append 

If Append is selected, commands are appended to the end of the Keyboard Macro Editor 
command list. 
  

Insert 

If Insert is selected, commands are inserted in the command list in front of the currently 
selected command. 
  

Keyboard Macro Editor Examples 

Keyboard Macro Editor Examples 

Three examples of using the Keyboard Macro Editor are provided. The first example 
describes the steps necessary to create a simple macro. The second example illustrates how to 
program panel key F1 to perform a data entry function. The third example explains 
programming a touch cell with the Keyboard Macro Editor. 
  

Keyboard Macro Editor Example 1 

This example describes the steps necessary to create a simple macro. 
  
o Make sure that the panel is connected to the PC, and is in Configuration Mode. 
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o Make sure that the project file is set up to work with the panel you are using. To do this, 
select Get Panel Resources from the Transfers menu. 
  

o Select the Keyboard Macro Editor from the Project menu or click on the Keyboard 
Macro Editor icon in the toolbar. 
  

o The Macro Editor dialog box will be displayed. Click on the F12 key to assign this 
macro to that key. 
  

o Click on Pressed beside Key states. 
   

o Click on the All Pages index tab. The macro is now set up to function whenever the F12 
key is pressed on any page of the project. 
  

o Click on the leftmost icon in the Commands toolbar. This icon represents the elementary 
macro command Go To Page. 
   

o The Macro Parameter Value dialog box will pop up. In this case, we want to have the 
panel go to page 2 whenever the key is pressed. Therefore, enter a 2 in this box and click 
on OK. 
   

o The list box located at the bottom left hand side of the Macro Editor dialog box will list 
the defined macro as shown below. Press OK to confirm the action and return to the page 
editor workspace. 
  

 
  
o Type the text Page 1 in the topmost row of the current page. 

  
o Select Insert Page from the Page menu, or press the F7 key to create another page. Press 

the Page Down button on the keyboard to move to this page. Type the text Page 2 in the 
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topmost row of this page. 
  

o Select File - Save to save the file. 
  

o Select Download from the Transfers menu. The project file will be downloaded to the 
panel. 
  

o When the download is completed, the panel will go into Operation Mode and display the 
text Page 1 that was entered in step 10. 
  

o Press the F12 key. The panel will go to the second page of the project and the text Page 2 
will appear on the display. 

Keyboard Macro Editor Example 2 

If you want to program panel key F1 to perform a data entry function, you would perform the 
following steps: 
  
o Select the Keyboard Macro Editor from the Project menu or click on the Keyboard 

Macro Editor icon in the toolbar. 
  

o The Macro Editor dialog box will be displayed. Click on the F1 key to assign the macro 
to this key. 
  

o Select Pressed for the Key states. 
   

o Click on the All Pages index tab. The macro is now set up to function whenever the F1 
key is pressed on any page of the project. 
  

o Click on the Begin data entry icon in the Commands toolbar (this icon shows a hand 
pressing a key). 
  

The figure below shows the Macro Editor dialog box after these steps have been completed. 
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Now we need to program the key for the Released state: 
  
o Click on the Released radio button beside Key states. 

   
o Click on the Data Entry index tab. 

  
o Click on the Confirm Data Entry icon in the Commands toolbar (this icon is a green 

check mark). 
  

o Click on the Begin data entry icon in the Commands toolbar (this icon shows a hand 
pressing a key). 
  

o Click on the Next Field icon in the Commands toolbar (this icon has of a yellow box 
with a crooked arrow pointing down to a white box). 
  

o The Field selection macro properties dialog box appears. Click OK without checking the 
Enable automatic scrolling box. 
  

o Click on the Data Editing icon in the Commands toolbar (this icon is a small box with 
the numbers 1, 2, and 3 below it). 
  

The following figure depicts the Macro Editor dialog box following the completion of these 
steps. 
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o Click the OK button to save this macro for this project. 

4.7.8 Passwords 

Passwords 

 
  
This feature le ts you password protect the project file so that unauthorized uploads cannot 
occur. Four-digit passwords are used. 
Once a password is specified, every time a user attempts to upload the project from the panel 
onto a computer, the password is requested. If the password entered matches the one that was 
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defined in the project file, the upload operation will be performed properly. However, if a 
password is entered that doesn't match the one that was specified in the project file, the panel 
will not start the upload process. 
  
Note:  Panels must contain firmware version 4.10 or later to use this feature. 
  
EH-HMI panels have eight different levels of passwords, enabling supervisors to restrict the 
amount of control an operator has over the functionality of the panel. 
The person having the highest level password has access to all of the panel functions. This is 
done by default so as to allow at least one person the ability to change the project file 
contained within the panel. 
If a checkbox is selected, the panel user will have access to the respective area providing the 
correct password is entered. If an incorrect password is entered, asterisks will be displayed on 
the panel and the previous valid password is lost. 
  
An example is provided. 
  
Available password options include: 
  
o CONF, 

   
o TIME, 

   
o ACK, 

   
o PRINT, 

   
o PAGE, 

   
o ALOGI, 

   
o ALOGO, and 

  
o Data entry enable. 

CONF 

Access to Configuration Mode. In this mode, you may choose to alter the project file and re-
download it from the PC. 
  

TIME 

Access to the Time & Date Mode. In this mode, you may change the time and date 
information that is stored within the panel. 
  

ACK 

The ability to acknowledge alarms. 
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PRINT 

The ability to request printouts. 
  

PAGE 

Access to Direct Page Selection Mode. In this mode, you can access specific pages of the 
project. 
  

ALOGO 

Automatic logoff. This is used to automatically disable a specified password in the following 
cases: 
  
inserting another valid password, 
  
inserting a wrong password 
  
using the macro command Password logout 
   
after a specified period of time with no panel activity 
  
It is possible to specify a custom timeout for passwords configured with automatic logout 
using Logout timeout. 
  

Data Entry Enable 

Access to Data Entry Mode for specific pages. In this mode, you can edit any read/write fields 
contained within the specified pages. 
  

ALOGI 

ALOGI 

Automatic login. This is used to automatically load a specified password whenever there is no 
valid password in the system (e.g., when the panel goes from Configuration Mode to 
Operation Mode, or when an incorrect password is entered. This option can only be assigned 
to one password and will work only if there are no other valid passwords in the system. 
  
The automatic login feature allows users to change any of the user passwords defined in the 
project file directly from the panel. In order to do this, there must be at least two passwords 



EH-VIEW (en) - July 2005 - 05/005 

Page 270 

defined, with one of them setup to be automatically logged in. This means that whenever the 
panel goes from Configuration Mode to Operation Mode, the specified password is logged in. 
  
Once the passwords are defined in the project file, an ASCII control variable field is needed 
for each password that the panel user will be able to change. 
  
An example of the automatic login feature is provided. 
  
Note:  In order to use this feature, the panel must be equipped with firmware version 4.10 or 
later. 
  
Note:  Only one password per project can have the automatic login feature enabled. 
  

Password Automatic Login Example 

To program a control variable field to perform the password automatic login function, you 
need to perform two basic steps: create the password file, and create control variables to 
manipulate the passwords. The individual steps are as follows: 
  
o Select Passwords from the Project menu. 

  
o Set up three passwords: 1234, 4321, 6574, and 9809. 

  
o Check the ALOGI box for password 6574. The Passwords dialog box will resemble that 

shown below. Note that there are eight possible passwords, and that ALOGI is checked 
for password number three in the list. 
 

 
   

o Click OK. 
   

o Create an ASCII control variable field by selecting Insert - Data Fields - Numeric/ASCII, 
or by clicking on the Numeric Field icon in the toolbar. 
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o Set the Style as ASCII. 
   

o Set the Reference as Variable. 
   

o Click the "…" button under Reference. 
   

o Set the Data Type as Password. (If Password is not available as a data type, go back to 
step 6 and set the Style as ASCII.) 
  

o In the Password box, enter 3. The arrows can be used to scroll from 2 through 8. That is 
because there are eight possible passwords, as noted in step 3 above. Automatic login is 
only available for passwords 2 through 8. Our example has automatic login set for 
password 3 (9809). The Data Field Properties dialog box will resemble that shown in the 
figure below. 
 

 
   

o Click OK to close the Data Field Properties dialog box. 
  

o Select the Range tab in the Numeric Field Properties dialog box. Select Read/Write so 
that you can change the value of this field (the actual password). 
  

o Click OK to close the Numeric Field Properties dialog box. 
  

o The automatic login control variable field is indicated on the project page by "CCCC". 
  

Logout Timeout 

The period of inactivity that will trigger an automatic logoff. The valid range is 10-700 
seconds. 
  

Password Example 

Assume there are three users who will have access to the operator panel. User 1 is to have 
access to all areas of the project (at least one user must have this type of access in every 
project). User 2 is only allowed to acknowledge alarms and enter data on pages 2, 3, and 4. 
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User 3 is capable of entering data throughout the project and is allowed into Configuration 
Mode. It is also desired to have User 3 automatically logged out of the system after 10 
minutes. 
  
o Select Passwords from the Project menu. This will bring up a dialog box similar to the 

one shown in the figure below in which we will configure our passwords for the project. 
 

 
   

o Since User 1 is to be allowed full access to all areas of the panel, we can assign the 
highest-level password to him. Simply click in the top password box and enter a four-
digit password for User 1. By default, User 1 has access to all areas of the project. 
  

o User 2 is allowed to acknowledge alarms and enter data on pages 2, 3, and 4. Click on 
the second password box and enter a four-digit password for User 2. To allow access to 
acknowledge alarms, click on the ACK box. Doing so places a check mark in the box. To 
allow data entry from page 2 to page 4, enter a 2 in the Data entry enable From page box 
and a 4 in the Data entry enable To page box. 
  

o User 3 can enter data on all pages of the project, will be automatically logged out after 
ten minutes, and can access Configuration Mode. Click on the third password box and 
enter a four-digit password for User 3. Click in the CONF box to give User 3 access to 
Configuration Mode. Check the ALOGO box to enable automatic logout. The default 
time in the Logout timeout box at the bottom of the dialog box is 600 seconds, or ten 
minutes, so no changes are necessary. Because User 3 will be allowed data entry 
throughout the entire project, set the entries for the Data entry enable From page box and 
the Data entry enable To page to span all the pages in the project. For example, if the 
project consists of 10 pages leave the default setting of 1 in the Data entry enable From 
page box and set the Data entry enable To page to 10. 
  

o The passwords should now be configured correctly for this situation. The dialog box 
representing this situation is shown below. 
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4.7.9 Alarms 

Overview 

Alarms offer a maximum of 1024 alarms, which are broken into 4 blocks (there are some 
models which offer 256 total alarms in 4 blocks). The lower the numerical value assigned to 
the alarm, the higher its priority. Each block can be addressed to any register within the 
controller's memory. Each alarm is referenced to a bit in the controller. Whenever a bit goes 
high, the respective alarm message will be displayed. 
  
To use alarms, select Alarms from the Project menu. Instructions on configuring alarms, 
alarms and the Keyboard Macro Editor, alarms safety issues, and alarms examples are given. 
  
Note: Old compatibility mode alarms are not supported in EH-View. 
  
Note:  Beginning with firmware version 4.22, you can define an alarm message up to 40 
characters in length for all EH-HMI operator interfaces that have a 20-character display. In 
these cases, the complete message associated with an alarm will take up three (3) lines on the 
display. The first line will be for time and date indication, the second and third lines will be 
for the alarm message itself. 
  
The following is the existing Alarm page for setting various alarm options.  
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The following is the Enhanced Alarm Page for setting the alarm options. This feature works 
when the right panel and the firmware version is selected.  
  
Note:  This feature requires firmware version 5.12 or greater. 
  

 
  
For detailed explanations of the Alarm Options please refer the Alarms Main Options page.  
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Alarms Main Options 

 

Current Alarm Block Options 

The Current alarm block options section at the top of the Alarms tab contains settings for the 
alarm block, such as the block number, the number of alarms, the update cycle, and the 
reference block starting location. 

Block No. 

The Block No. field lets you choose block 1, 2, 3, or 4. 

No. of Alarms 

The No. of Alarms field is used to specify how many alarms will be used in a particular 
block. The software will automatically round off the specified number to a multiple of 16 
because the alarms are addressed as words of information. 

Update Cycle 

The Update cycle field lets you specify how often the alarms are updated, from 500 msec up 
to 127 sec.  
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Block 

The Block start address field lets you specify the starting address of the current block. 
Clicking on the "…" button will bring up the Data Field Properties dialog box. 

Data Field Properties 

This feature can be accessed by selecting the "…" button whenever a PLC, Variable, or 
Recipe reference is set. (If Index is selected, a similar box named Indirect Addressing Fields 
appears.) 
  
The contents of the Data Field Properties dialog box will vary depending upon the type of 
controller being used and the type of reference specified. Elements to be configured may 
include the File or Data Type, the Data Format, File or Page Number, Element, Offset, and 
Left/Right Byte. These options let you configure responses to the controller memory location. 

Toolbar 

The Alarms tab toolbar contains icons for commands that can be useful when working with 
alarms.  
  

 
  
These include:   

Cut 

The familiar Windows Cut feature is available for use in editing messages. 

Copy 

The familiar Windows Copy feature is available for use in editing messages. 
  
If several alarm messages are similar, the Copy and Paste features may be used to copy 
messages. Simply select which messages to copy by highlighting them. If several messages 
that are in successive order are to be copied, click on the first one and drag the mouse down 
until the last one is highlighted and release the mouse button. If several messages are to be 
copied that are not in successive order, hold down the Ctrl key, click on each of the messages 
to be copied, and release the Ctrl key. All of these methods will select the text to be copied. 
Then click on the Copy icon to copy the messages into the Windows Clipboard. 

Paste 

The familiar Windows Paste feature is available for use in editing messages. 
  
If several alarm messages are similar, the Copy and Paste features may be used to copy 
messages. Highlight the alarm message number where the first message is to be pasted and 
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click on Paste to copy the messages into their new locations. A Windows-based text editor, 
such as Notepad, may also be used to create a list of messages. To do this, place each message 
on a separate line. Use the Copy function of the editor to copy the text to the Clipboard and 
then use the Paste feature to copy the messages into their new locations. 

Delete 

The familiar Windows Delete feature is available for use in editing or deleting messages. 

Special Characters 

 
  
Special characters may be added to text by clicking on the Special Characters button. This 
will bring up the Special Characters dialog box in which you can select the character(s) to be 
used by double clicking on them or by single clicking on them and pressing Insert. The 
characters will appear in the last position the cursor was in before entering the special 
characters dialog box. 
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Languages 

 
  
This feature lets you create a single project file that contains multiple languages. The 
language that the project file uses can be selected at run time. 
  
Note:  You must type in the text in each language. EH-View does not have the ability to 
translate from one language to another. In other words, if you enter text in English and then 
select Spanish as the language, the text must then be entered in Spanish. By storing the 
appropriate text translated into various languages, you can easily change the language as 
needed at run time. 
  
Note:  The standard ASCII character set is used for all languages. Other symbols may be 
inserted using Special Characters. 
  
To set up languages, select Languages from the Project menu. Doing so will bring up the 
Configure Languages dialog box where you can define the languages to be used. Insert, 
Delete, Move Up, Move Down, and Set As Default icons help you manage the list of 
languages. A counter displays the number of languages defined for the project. 
  
A Languages icon is available on many toolbars in EH-View to make it easy to switch to 
another language. 
  
To change the language that a project file uses once it has been downloaded to the EH-HMI 
panel, you can create a control variable with a data type of Language. 
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Alarm Messages 

You can scroll through the alarm messages using the scroll arrows located to the right of the 
alarm message list box. To create or edit a message, click on the desired line and then enter 
the message. Special characters may be added to the message by clicking on the Special 
Characters button. Alarm messages may be in various Languages. 

Current Alarm Options 

The Current alarm options section at the bottom of the Alarms tab allow you to set the panel 
to go to a certain page upon an alarm, to print the time of acknowledgement, to log the event 
to the event list, to require that alarms be acknowledged, the set the alarm print capability to 
ON or OFF, and to give an alarm message only status. 

On Alarm Go to Page 

The On alarm go to page field can be used to make the panel jump to a specified page 
whenever the alarm is activated. You will need to program a key in Alarms Mode in the 
Keyboard Macro Editor using the following elementary macro commands in sequence: 
  
o Acknowledge Alarm (if required) 
o Go to Alarm Page 
o Page Mode 

  
Whenever the alarm occurs, the panel will switch to the alarm screen. The user can use the 
arrow keys to select the proper alarm and press the key that was programmed in the Keyboard 
Macro Editor to take them to the correct page. 

Print Time of Acknowledgement 

By selecting Print time of acknowledgment, you can have the specific alarm data printed via a 
printer. 

Enable Log to Event List 

The checkbox Enable log to event list lets you send the selected alarm to the historical event 
list if desired. 

Alarm Requires Acknowledgement 

The Alarm requires acknowledgment field can be selected if you wish to have the operator 
press a key to acknowledge that the alarm is active. Once the alarm is activated, the panel will 
enter Alarm Mode and display the currently active alarms. The operator must acknowledge 
the alarm by pressing the Enter key for a few seconds. Pressing the Clear key will return the 
panel to Operation Mode. 
  
Note:  It is still necessary to reset the proper alarm bit. 
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Print Alarm On 

By selecting Print alarm ON, you can have the specific alarm data printed via a printer. 

Print Alarm Off 

By selecting Print alarm OFF, you can choose not to have the specific alarm data printed via a 
printer. 

Message Only 

The checkbox Message Only allows the alarm message to be treated strictly as a message and 
not a true alarm. If this checkbox is marked for a specific message, the Alarm LED on the 
panel will remain off for the specific event and the first row of the message will not contain 
the familiar "A", as is the standard for an alarm message. It is possible to require that these 
messages be acknowledged, just as for a standard alarm message. These messages can also be 
logged to the Event List if the Enable log to event list checkbox is marked.  
  
Note:  This feature requires firmware version 4.22 or greater. 
  

Enhanced Mode Alarms Options 

 
  
Note:  This feature requires firmware version 5.11 or greater. This Enhanced mode alarm 
options is visible only after selecting the right panel and firmware version.  
  
The Current alarm block options, Toolbar and the Alarm Messages section at the top of the 
Alarms tab is same as the earlier Current Alarm Block Options of the Alarms Tab.  

Current Alarm Options 

The Current alarm options section at the bottom of the Alarms tab allow you to require the 
alarms be acknowledged, the text and the background colour of the acknowledged alarm, to 
set the Alarm Text and Background colours, to give a alarm message only status, to give an 
alarm an event only status, to log the event to the event list, set the panel to go to a certain 
page upon an alarm, to log the alarm off, alarm on and acknowledged alarms and to print the 
alarm off, alarm on and acknowledged alarms  
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Alarm Requires Acknowledgement 

The Alarm requires acknowledgment field can be selected if you wish to have the operator 
press a key to acknowledge that the alarm is active. Once the alarm is activated, the panel will 
enter Alarm Mode and display the currently active alarms. The operator must acknowledge 
the alarm by pressing the Enter key for a few seconds. Pressing the Clear key will return the 
panel to Operation Mode. 
  
When the Alarm Requires Acknowledgement check box is enabled, the pull down menu's 
below is activated and it can be used to set the acknowledged alarms Text and the background 
colour.  
  
Note:  It is still necessary to reset the proper alarm bit. 

Alarm Text and Background 

You can set the Alarm Text and the Text background colour using this option. 

Message Only 

The checkbox Message Only allows the alarm message to be treated strictly as a message and 
not a true alarm. If this checkbox is marked for a specific message, the Alarm LED on the 
panel will remain off for the specific event and the first row of the message will not contain 
the familiar "A", as is the standard for an alarm message. It is possible to require that these 
messages be acknowledged, just as for a standard alarm message. These messages can also be 
logged to the Event List if the Enable log to event list checkbox is marked.  
  
Note:  This feature requires firmware version 4.22 or greater. 

Event Only 

The checkbox Event Only allows the alarm message to be treated as a Event and not a true 
alarm. If this checkbox is marked, the Alarm LED on the panel will remain off for the specific 
event and the first row of the message will not contain the familiar }A}, as is the standard for 
an alarm message. It is possible to require that these messages be acknowledged, just as for a 
standard alarm message. These messages can also be logged to the Event List if the Enable 
log to event list checkbox is marked.  
  
Note:  This feature requires firmware version 4.22 or greater. 

Enable Log to Event List 

The checkbox Enable log to event list lets you send the selected alarm to the historical event 
list if desired. 
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On Alarm Go to Page 

The On alarm go to page field can be used to make the panel jump to a specified page 
whenever the alarm is activated. You will need to program a key in Alarms Mode in the 
Keyboard Macro Editor using the following elementary macro commands in sequence: 
  
o Acknowledge Alarm (if required) 
o  Go to Alarm Page 
o  Page Mode 

  
Whenever the alarm occurs, the panel will switch to the alarm screen. The user can use the 
arrow keys to select the proper alarm and press the key that was programmed in the Keyboard 
Macro Editor to take them to the correct page. 

Log Alarm Off 

By selecting Log Alarm Off, you can disable the specific alarm logging onto the Event list. 

Log Alarm On 

By selecting Log Alarm On, you can enable the specific alarm logging onto the Event list. 

Log Alarm Ack 

By selecting Log Alarm Ack, you can enable the specific alarm acknowledgment logging 
onto the Event list. 

Print Alarm Off 

By selecting Print alarm OFF, you can choose not to have the specific alarm data printed via a 
printer. 

Print Alarm On 

By selecting Print alarm ON, you can have the specific alarm data printed via a printer. 

Print Alarm Ack 

By selecting Print alarm Ack, you can have the specific alarm acknowledgement data printed 
via a printer. 
  

Alarms Popup Options tab 

Clicking on the Popup Options tab presents options for choosing how an alarm popup 
window will appear once an alarm occurs. Options include: 
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Default 

Alarms are displayed immediately if no keys are pressed and no keys have been pressed 
within the last three seconds. 

Disable alarm popup 

The alarm popup window will not be displayed.  

Show immediately on any alarm 

The alarm popup window will be displayed as soon as an alarm occurs. 

Set delay after last keystroke 

You can have the alarm popup window appear at a specified amount of time after the last 
keystroke or touch cell press, as set in the Delay time box. 
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Delay Time 

Set the amount of time between the last keystroke or touch cell press and the appearance of an 
alarm popup window. The time may be between 1 second and 127 seconds. 

Disable time and date display 

This option lets you disable the time and date display in the EH-HMI alarm page. This feature 
is for use in cases where the time and date information is not of interest. 
  
Note:  The Disable time and date display feature requires firmware version 4.20 or greater. 

Alarms Examples 

Two alarms examples are given. 
  
The first example assumes a user is using an Allen-Bradley SLC 500 series controller. They 
want to use alarms that begin at N7:0 for their particular controller. The steps required to set 
up the alarm messages and their respective locations in the controller are as given. 

Alarms Example 1 

Assume a user is using an Allen-Bradley SLC 500 series controller. They want to use alarms 
that begin at N7:0 (a word) for their particular controller. Their alarm messages and their 
respective locations in the controller are as follows: 
  
N7:0  - Bit 0 = Pressure too high 
N7:0  - Bit 1 = Temperature too high 
N7:0  - Bit 2 = Pressure too low 
N7:0  - Bit 3 = Temperature too low 
  
  
Keep in mind that each alarm message is referenced to a BIT in the controller. 
  
o Select Configure Controller from the Project menu. 

  
o Click on the "..." button under controller. The Select Controller dialog box appears. 

  
o Select A-B DF1 as the controller. 

  
o Click the Controller Setup button. 

  
o Select SLC500 Modular I/O as the PLC model. (A warning message may appear. If so, 

click Yes.) 
  

o Click OK. 
  

o Click OK to close the Select Controller dialog box. 
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o Click OK to close the Configure Controllers dialog box. (The Select Tag Dictionary 
dialog box may appear. If so, click Cancel as it is irrelevant to this example.) 
  

o Select Alarms from the Project menu. The Alarms dialog box, as shown in the figure 
below, appears. 
 

 
 
 Under Current alarm block options, click on the "…" button next to Block. The Data 
Field Properties dialog box appears. 
  

o Set the Logical Address to N7:0. 
  

o Click OK to close the Data Field Properties dialog box. 
  

o For alarm #1, enter Pressure too high. 
  

o For alarm #2, enter Temperature too high. 
  

o For alarm #3, enter Pressure too low. 
  

o For alarm #4, enter Temperature too low. The completed Alarms dialog box should 
resemble that shown below. 
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o Click on OK to close the Alarms dialog box and return to the project page. 
  
The second example assumes use of a Profibus DP S7 controller, configures a high 
temperature alarm and program the panel to go to a certain page whenever the alarm is active. 

Alarms Example 2 

Assume that we are using a Profibus DP S7 controller. We want to configure a high 
temperature alarm, and program the panel to go to page 3 whenever the alarm is active. 
Assume that the alarm requires acknowledgment, and that the F1 key is to perform the 
function of acknowledging the alarm and going to page 3.   
  
o Select Configure Controller from the Project menu and make sure that Profibus DP S7 is 

the selected controller. 
  

o Select Alarms from the Project menu 
 . 

o Make sure that all of the alarm data is entered correctly under the Current alarm block 
options. 

o For alarm #1, enter High Temperature. 
  

o Under Current alarm options, in the box beside On alarm go to Page enter 3. 
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o Click in the box beside Alarm requires acknowledgement to select that option. The 
completed Alarms dialog box should resemble that shown below. 
 

 
   

o Click OK to return to the project page. 
  

o From the Project menu select Keyboard Macro Editor. 
   

o Select the F1 key, and indicate Pressed for the Key states. 
   

o From the Alarms tab, select the command Acknowledge Alarm. 
   

o Select the command Go to alarm page. 
   

o Select the command Page Mode. 
   

o The alarm bit must still be reset. To do this, select the command Write to Controller and 
to reset the value in the Data Field Properties dialog box to clear the proper alarm bit. 
  

o The figure below shows the completed Macro Editor dialog box. 
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o Click OK to close the Macro Editor box and return to the project page. 

4.7.10 Languages 

Languages 
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This feature lets you create a single project file that contains multiple languages. The 
language that the project file uses can be selected at run time. 
  
Note:  You must type in the text in each language. EH-View does not have the ability to 
translate from one language to another. In other words, if you enter text in English and then 
select Spanish as the language, the text must then be entered in Spanish. By storing the 
appropriate text translated into various languages, you can easily change the language as 
needed at run time. 
  
Note:  The standard ASCII character set is used for all languages. Other symbols may be 
inserted using Special Characters. 
  
To set up languages, select Languages from the Project menu. Doing so will bring up the 
Configure Languages dialog box where you can define the languages to be used. Insert, 
Delete, Move Up, Move Down, and Set As Default icons help you manage the list of 
languages. A counter displays the number of languages defined for the project. 
  
A Languages icon is available on many toolbars in EH-View to make it easy to switch to 
another language. 
  
To change the language that a project file uses once it has been downloaded to the EH-HMI 
panel, you can create a control variable with a data type of Language. 
  
  

Insert 

Use the Insert icon to add a new language. Enter the name of the language to be added. The 
language is added to the list of languages, placed at the end of the list. 
  

Delete 

The Delete icon is used to remove a language from the list. 
  

Move Up 

Click the Move Up icon to move a selected language up one position in the list of languages. 
  

Move Down 

Click the Move Down icon to move a selected language down one position in the list of 
languages. 
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Set As Default 

Click the Set As Default icon to set the selected language as the default language for the 
project. The default language is labeled as such in the list of languages. 
  

List of Languages 

Lists the languages that are currently available for the project. 
  

Number of Languages 

Indicates the number of languages that have been defined for the project. 
  

4.7.11 Next Language 

This option selects the next language from the list of available languages within the project 
file. For example, assume that there are three languages defined: Italian, English and German. 
If you are currently working with Italian, selecting Next Language will change the working 
language to English. Next Language may be selected from the Project menu or by pressing 
the Shift+Ctrl+L keys. 
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4.7.12 Configure Tag Dictionaries 

Configure Tag Dictionaries 

 
  
Tags allow mnemonic reference to PLC variables. Tags in a project can be imported from a 
description file outside EH-View. A discussion of the use of tags in EH-View projects is 
provided, along with an example of using tags. 
  
Tag dictionaries are tools integrated with EH-View accessible from Project - Configure Tag 
Dictionaries once support for an internal controlle r has been enabled under Configure 
Controller. This lets you to switch from one tag dictionary to another tag dictionary without 
having to change each field in the project. 
Items in the Select Tag Dictionary dialog box include the Enable Tags checkbox, the 
Database box, the Refresh Database button, and the Controller List. 
  
Note:  When a tag name is selected, the PLC Reference information will be filled in with the 
reference information from the tag and the PLC Reference dialog controls will be disabled. 
You will only be able to change tag information from the Tag Editor in the Tools menu. 
  
Note:  Tag definition for an External Controller is allowed only if the External PLC supports 
tag definitions. Please refer to Hitachi Technical Documentation for further information about 
drivers that support tag definition. 
  
A tag dictionary is associated with each project and defines the model and attributes of the 
PLC. You can select a dictionary for your project when you enable the tag feature in the 
project for the first time. 
  
You can create multiple tag dictionaries inside a tag database and add tags to each dictionary. 
Each dictionary is configured for a specific PLC controller and model name. Each project is 
assigned to a dictionary. 
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You can create multiple dictionaries in a database in order to support a project that has a PLC 
Network and/or UniNET Network. To be able to use tags for a project that supports the 
UniNET/PLC Network, at least one dictionary must exist in the database for each of the 
nodes in the network. 
  
Note:  If a project supports a UniNET/PLC network, each UniNET node/ PLC Node must be 
tied to a tag dictionary in the database. You will be required to assign a tag dictionary for all 
the nodes during the configuration of UniNET/PLC network. Each node must have at least 
one dictionary in the database. If PLC network is enabled and you change the PLC Node, the 
Tag Name controls will be initialized with the tags from the dictionary tied to the current PLC 
Node. 
  

Enable Tags 

Checking this box enables the use of tags. 
  

Database 

The location of the tag database to be used is listed. Click on the "…" button to select the 
location of a tag database file (file format *.mdb). Tag dictionaries are tied to controller 
brands and models. 
  

Refresh Database 

Click on the Refresh Database button to reset the tag database to the default settings for the 
specified controller. 
  

Controller List 

Lists the selected brand and model of controller and the matching tag dictionary. 
  

4.7.13 Tag Validation 

By using this feature you can switch from one tag dictionary, referring to one set of PLC 
addresses, to a different dictionary, referring to different set of PLC addresses in the same 
controller, and update all the fields in the project without needing to update the individual 
PLC addresses used in the whole project. 
  
Also, you can switch from one tag dictionary, referring to Controller A to a different 
dictionary, referring to controller B and update all the fields in the project without updating 
the individual PLC addresses used in the whole project. 
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This feature can also validate the PLC addresses used in a project with respect to the PLC 
addresses used in the tag dictionary, and finds and lists any discrepancy items with all details 
such as location, etc. 
  
This feature supports updating the tag database (with regard to PLC Address used in the 
project) and updating the project field (with regard to PLC Address used in the tag 
dictionary). 
  
When a dictionary is changed, EH-View will scan each field in the project, retrieve the tag 
name for the field and then check if the tag name exists in the new dictionary. If the tag name 
exists in the new dictionary, the PLC address for the tag will be updated in the project. If the 
tag name does not exist, the address information will be set to default address of the PLC. 
After all fields have been checked, a dialog box will be displayed listing the tag names that 
were not found in the new dictionary and set to default address. 
  
The idea behind changing the tag dictionary is to let you switch tag dictionaries for similar 
PLCs or PLCs that use the same tag names. For example, if you have two different PLCs that 
use the same PLC program, you can change the tag dictionary in the project and EH-View 
will automatically update the addresses for the tags in the project. 
  
An example of using the tag validation feature is provided. 
  

4.7.14 Trend Buffers 

Trend Buffers 

Trending is divided into two main parts: trend acquisition and trend viewer. The acquisition 
module is responsible for collecting the data into a database. This is configured using the 
Configure Trend Buffers dialog box, accessed by selecting Trend Buffers from the Project 
menu. The trend viewer is responsible for displaying the data from this database in a 
graphical format. This is configured using the Trend Window command from the Insert menu. 
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The Configure Trend Buffers dialog box is composed of a list of buffers, a General tab and a 
Sampling tab. 
  
The first step in creating a trend is to create a trend buffer. You will need to define two items: 
  
o the PLC variable that is to be sampled and 

  
o the method in which the variable is to be sampled. 

  
The variable can be sampled from the EH-HMI panel or the variable can be sampled directly 
from the PLC. 
  
If the variable is sampled from the EH-HMI panel, all of the data from the trend buffer will be 
stored within the memory of the EH-HMI panel. If the variable is sampled directly from the 
PLC, the data from the trend buffer will be stored in the memory of the PLC. In the latter 
case, the only duty of the EH-HMI will be to graphically display the trend buffer data from 
the PLC. 
  
There are two Keyboard Macro Editor commands associated with trending. These are: Trend 
buffer print and Trend Window. 
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Buffers 

Buffers 

Provides a list of the currently defined trend buffers and statistics on global buffer usage. 
  
This list has two buttons. The first one is used to Insert a new buffer. The second one to 
Delete the currently selected one. 
  

Delete 

To remove a previously defined trend buffer, select the name of the buffer from the trend 
buffer list and click the Delete button. 
  

New (Insert) 

Click the New (Insert) button to add a new trend buffer name at the end of the list of trend 
buffers. Or, simply type the name of a new trend buffer into the box in the Buffers list. 
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General 

General tab 

 
  
To activate the General tab, you must first select a buffer from the Buffers list. Then specify  
the Size and Type of buffer to be defined and the Reference Variable to be sampled. 
  

Type 

Type 

Trends can be sampled in three different ways. The first option (All Pages) is to continuously 
sample the trend buffer, regardless of whether or not the trend associated with the trend buffer 
is being displayed. The second option (Current Page) is to sample the trend buffer only when 
the page where the trend associated with the trend buffer is being displayed. The third option 
(On Page) is to sample the trend buffer only when a particular page is being displayed. 
  
Note:  The number of trends that can be sampled in the background is limited. 
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All Pages 

The trend buffer will be sampled regardless of what page is being displayed. 
  

Current Page 

The trend buffer will be sampled only when the page containing the trend associated with the 
trend buffer is displayed. 
  

On Page 

The trend buffer will be sampled only when the identified page is displayed. 
  

Size 

Indicate the buffer size, i.e., the number of samples that will be kept during the background 
sampling. 
  
Note:  When a trend is sampled in the background (All Pages), the sample size reflects the 
number of old samples that will be shown when the page that contains the trend associated 
with the trend buffer is displayed. When a trend is sampled in real time (Current Page), you 
will never see any old samples because sampling begins when the page that contains the trend 
is displayed. In this configuration the sample size is useful only when using the macros to 
scroll the trend along the X-axis. If these macros will not be used, you can save EH-HMI 
memory by setting the sample size to 1. 
  

Reference 

Reference 

The variable to be sampled. This can be a PLC variable or an internal EH-HMI control 
variable. You can scale this variable, if desired. 
  

PLC 

If the variable to be sampled is a PLC variable, click on the "…" button to define the Data 
Field Properties. 
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Internal Variable 

If the variable to be sampled is an internal variable, pick the type of variable from the list 
provided.  
  

Scaling 

Allows for a linear transformation of the data being sampled. This lets you scale the data 
before storing it inside the trend buffer.  
  

Sampling 

Sampling tab 

 
  
This area lets you define when and how trend samples will be taken. You can set the sampling 
circumstances, select to stop sampling when the buffer is full, and determine when to clear the 
buffer. 
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Sampling 

Sampling 

Sampling selections include sampling on PLC, cyclic sampling, sampling on a control 
variable event, or sampling only when the variable is not zero. 
  

On PLC 

Samples are collected from the trend buffer and stored inside the memory of the PLC. 
  

Cyclic 

Samples are taken from the memory of the EH-HMI on a cyclical basis. The cycle time, in 
seconds, must be defined. 
  

On Control Variable Event 

Samples are taken, one a time, when a variable (PLC or internal variable) changes value. 
Tip:  Use a counter to trigger the sampling: 000->001->002->003.... 
  

Only When Variable Not 0 

When this checkbox is set, data will be sampled only when the defined variable does not 
contain a value of zero. Sampling is suspended when the variable contains a value of zero. 
This checkbox can be set with any of the other sampling types. 
  

Stop Sampling 

Use the Stop when buffer is full checkbox to stop the sampling when the trend buffer is full. 
This is a first-in first-out (FIFO) buffer. Once the buffer is full, older sample values will be 
erased to allow the new sample values to be stored. 
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Clear Buffer 

Clear Buffer 

This option lets you define when to clear the trend buffer. Choices include no automatic clear, 
clear on panel startup, clear on control variable change, and clear when buffer is full. 
  

No Automatic Clear 

The trend buffer is never cleared. However, if the Stop when buffer is full checkbox is not 
selected, the oldest sample is removed and the newest sample is stored when the buffer is 
filled. 
  

On Control Variable Change 

The trend buffer is cleared when the selected variable changes value. 
  

On Panel Startup 

The trend buffer is cleared upon power-up of the EH-HMI panel. 
  

When Full 

The entire trend buffer is cleared when it becomes full. 
  

4.7.15 Memory Use 

You can determine how much memory is used by the current project file by selecting 
Memory Use from the Project menu (or by pressing the Ctrl+M keys). 
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The Memory used dialog box appears containing information on the amount of memory that 
is used by the project file, how many bytes of recipe data are contained within the project file 
and the amount of memory used by an SSFDC memory card. 
  

4.7.16 Time Scheduled Triggers 

The Time Scheduled Triggers give you the possibility to program the Panel Operator to 
execute specific  macro sequences cyclically or at specific time.  It may be invoked by 
selecting Time Scheduled Triggers from the Project menu. 
  

 
  
  
New Triggers can be added as shown in the above figure. Using the Edit Macro button, each 
trigger can be assigned macros from the list schedule at specific time as shown below. 
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Time Tab 
  
From the Time tab it is possible to specify any of the following trigger type.  
  
o Yearly 
o Weekly 
o Daily 
o Hourly 
o Single Shoot 
o Every (Interval time) 
o   
o   
o Enable Tab 
o   

From the Enabled tab it is possible to define the time window when the trigger is enabled. By 
default, the Enable checkbox is not checked, the trigger is always enabled.  
  
When the Enabled check box is checked, the trigger is enabled only inside the time windows 
specified inside this dialog box. 
  

o  
o   
o   
o After Date - Before Date 

When only the “after date” and the “before date” are checked the trigger is active only inside 
the two defined days. 
o   
o After Time - Before Time 

hen only the “after time” and the “before time” are checked the trigger is active all days but 
only when time is between the two defined time values. 
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o   
o After Date - Before Date - After Time - Before Time 

When all four parameters are defined the trigger is active only after the defined After Date 
and After Time until the defined Before Date and Before Time. 
o   
o After Date  
o When only the single “After date” parameter is defined, the trigger is active all days after 

the specified day. 
o   
o After Time 

When only the single “After time” parameter is defined, the trigger is active all days after the 
specified time. 
o   
o Before Date  

When only the single “Before date” parameter is defined, the trigger is active all days until 
the specified day. 
  
o Before Time 

hen only the single “Before time” parameter is defined, the trigger is active all days until the 
specified time. 
o   
o After Date - After Time  

When “After date” and “After time” parameters are defined the trigger is active all days 
starting from the specific time and date. 
  
o Before Date - Before Time  

When “Before date” and “Before time” parameters are defined the trigger is active all days 
until the specific time and date. 
o   
o   
o Time Scheduler Control Variables. 
o   

To be able to edit the trigger parameter values from the panel operator, it is necessary to put 
the desired trigger parameters on a panel page using the new Time Scheduler Control 
variables as shown in the below figure. 
o   

o  
o   
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4.8 Transfers Menu 

4.8.1 Transfers Menu 

This section provides information about the Transfers menu. Options in the Transfers menu 
let you set the parameters to communicate with a target system (panel). Control functions that 
can be performed from the Transfers menu include: 
  
o Download, 

   
o Upload, 

  
o Download to SSFDC, 

   
o Get Panel Resources, 

   
o Check Firmware Versions, 

  
o Switch to Operation mode, 

  
o Remote Passthrough, 

  
o Dial, and 

  
o Hang Up; 

  
plus various transfer Options may be set. 
   
  
To communicate with a panel, you must have: 
  
o The EH-View software installed correctly 

  
o The EH-View communication cable connected between the PC and the panel 

  
o The correct communications parameters set 

  
o The panel placed in configuration mode 
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4.8.2 Download 

 
  
This lets you transfer the project file from the computer to the operator interface panel. You 
can choose this option by selecting Download from the Transfers menu, by clicking on the 
Download icon in the toolbar, or by pressing the F2 key. 
  
Note:  The panel must be in Configuration Mode in order for the download procedure to 
work. 
  

4.8.3 Upload 

 
  
Selecting this option lets you upload an existing application from the target system memory 
into PC workstation memory. As this will erase the application that is currently loaded in the 
EH-View software, you will be prompted to confirm the operation. 
  
You can choose this option by either selecting Upload from the Transfers menu, by clicking 
on the Upload icon in the toolbar, or by pressing the F3 key. 
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4.8.4 Download to SSFDC 

Download to SSFDC 

 
  
This command allows you to download a file to an SSFDC memory card, if one is installed. 
To download a file to an SSFDC card, select Download to SSFDC from the Transfers menu, 
or press the F6 key. 
An explanation of SSFDC error codes is provided. 
  

UniOP SSFDC Error Codes 

EH-HMI SSFDC Error Codes 

This section contains a description of the error codes displayed by the EH-HMI MMI 
products when the panel cannot go into Operation Mode for any reason. The Bootstrap 
module of EH-HMI firmware includes a diagnostic system very useful for determining why a 
EH-HMI panel stays in Operation Mode without apparent reason. 
  
Note:  This diagnostic service is available only in products with firmware type 38 and 58 with 
SSFDC memory card.  
  

Displaying SSFDC Error Codes 

During the system start-up phase, the EH-HMI firmware checks the contents of the flash 
memory to verify its integrity. When something goes wrong in this phase and a valid 
application has not been recognized, EH-HMI cannot start Operation Mode and remains in 
Configuration Mode. 
  
Once the panel is unexpectedly in Configuration Mode, the corresponding error code can be 
recalled. The error code will be displayed in the 3rd row of the display, below the text 
"Configuration Mode". To display the error code press the Enter key for more than 2 seconds. 
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List of Error Codes 

There are a number of reasons why a panel does not enter normal Operation Mode as 
expected. The following table lists the possible the error codes. 
  
All the error codes in the table are in hexadecimal format. If more that one condition is 
verified the corresponding code is the sum of the single codes. 
  
Error Code Description Causes 
0001 The SSFDC header is missing The format process of the SSFDC card was 

not completed successfully. The card should 
be reformatted by downloading the project 
again or by using the Format Utility with the 
SSFDC Programmer software. 

0002 Graphic file in the project is missing Graphic information in the downloaded file 
is missing. The option Download Graphics 
should not be inactivated the first time a 
project is downloaded. 

0004 Project file is missing Project information in the downloaded file is 
missing. The option Download Protocol 
Only should not normally be used when 
downloading EH-View projects. 

0008 Application file is missing Communication protocol in the downloaded 
file is missing. The project should be 
completely downloaded again or the option 
Download Protocol Only should be used. 

0010 Project and graphic file do not match; 
they have different time reference 

The last download was probably done with 
the option Download Graphics inactivated, 
but the graphic information has changed in 
the EH-View project. The file should be 
completely downloaded again. The 
hardware /software consistency should also 
be checked. 

0020 SSFDC card is not present The memory card is not present or it is not 
correctly inserted. 

0040 The downloaded project file supports 
different hardware type 

The project is the memory requires different 
hardware. 

0100 The firmware is missing in the panel Only the Bootstrap software module is 
loaded in EH-HMI. The firmware is either 
missing or it is damaged. 

0200 Communication session is in progress Attempting to go into Operation Mode 
during a project file download. This happens 
if the Enter key is pressed during the 
download process. 

0400 Bad checksum in the project The global consistency checks of the 
downloaded project failed. The project 
should be downloaded again. 

0800 Wrong application type or it does not 
match the project file  

The protocol present in the memory card is 
not consistent with the downloaded project. 
This could happen if a project is 
downloaded with the option Download 
Project Only activated without erasing the 
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previous protocol still present in the 
memory. 

1000 MIPS FW code (Graphic Engine) is 
missing 

The MIPS part of the FW code on the card 
is missing, corrupted, or not compatible with 
8051 FW. This error is possible only on 
boards using MIPS (T2000 or later). 

  
  

4.8.5 Options 

Options 

 
  
Selecting Options from the Transfers menu lets you choose the panel memory location for 
both the project and the protocol, and set communication parameters display preferences. 
Tabs in the Options Properties dialog box include: 
  
o Ports, 

  
o Transfer, 

   
o Transfer advanced, 
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o Compatibilty with Version 1, 
   

o Modem commands, and 
  

o Modem messages. 

Serial Ports 

Ports 

 
  
The communications parameters between EH-View and the EH-HMI panel are set during 
installation. However, they should be checked by selecting the Ports tab under Transfers - 
Options. From this tab you can configure the ports to be used, the parity and stop bits, 
whether a modem is used to communicate with the panel, and the baud rate. 
  
Unless otherwise noted, communication is possible with all panel models by setting the 
following parameters: 
  
Baud  38400* 
Data Bits 8 
Parity  None 
Stop Bits 1 
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 * Not all panels are capable of communicating at this speed. 
  

Ports Available 

Indicate the PC port to be used for communication with the panel. 
When EH-View is started, it first checks to see if the requested COM port is available. If the 
requested COM port is currently occupied by some other program, EH-View will 
automatically switch to the next available port. When this occurs, a message box will appear 
explaining the conflict and the action taken. 
  

Use Modem 

Check the box if communication with the panel is to be via modem. 
  

Transfer 

Transfer 
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The Transfer tab contains commands pertaining to communications between your PC and the 
EH-HMI panel. These include: 
  
o Start Program After Download, 

   
o Compress Graphics, 

   
o Communications Number of Retries, 

   
o External Memory Types, 

   
o Update Firmware, 

   
o Memory Location for Project, and 

  
o Recipe Upload. 

  

Start Program After Download 

Automatically starts a program on a panel after download. 

Compress Graphics 

Compresses graphics during transfer. This makes for faster communications but can have a 
detrimental effect on certain types of graphics. 

Communications Number of Retries 

The number of times EH-View will try to establish a connection with a panel. 

External Memory Types 

Select the type of external memory being used. 
  
Note:  This option is only available when external memory is specified under Configure 
Controllers in the Project menu. 

Update Firmware 

It is possible to update the firmware on some panels by checking this box. Some EH-HMI 
panels are able to accept new firmware files through the serial line or through the SSFDC 
memory card. For these panel models, the firmware files can be stored in the SSFDC memory 
card. 
The setup procedure installs a firmware subdirectory inside the EH-View working directory.  
This directory contains all the necessary firmware files used by EH-View to check and update 
the panel SSFDC memory card. New firmware files have to be copied inside this directory to 
be accessible from EH-View. 
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Note:  A special key sequence is necessary to complete the firmware update. This special key 
sequence ensures that inexpert users cannot update the panel firmware unintentionally. 
  
Note:  EH-View checks the firmware version before beginning any download operation. 
When an old firmware file version is detected inside the panel, a dialog box is displayed to 
give you a chance to upgrade the firmware file. 

Memory Location for Project 

Indicate whether the project will be stored on internal panel memory, such as an SSFDC card, 
or on a memory device external to the panel. 

Recipe Upload 

Indicate whether original or modified data is to be used during recipe upload. 

Transfer Advanced 

Transfer Advanced 
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The Transfer Advanced tab lets you select the memory location for the protocol, 
download/compress options, and whether to download the project, the protocol, or both. 
  

Memory Location for Protocol 

Specify whether the memory location for the protocol is internal or external to the panel, or in 
the firmware. 
  

Download 

You can choose to download the project, the protocol, or both. If Both is selected, you have 
the option to not download the protocol if it already exists in the tar file, as a precaution. 
  

Download Compress Options 

Select whether graphics, fonts, tags, and/or object information are to be downloaded, and 
whether fonts are to be compressed during downloading. 
  

Modem Commands 

The Modem commands tab is only visible if Use modem is selected on the Ports tab under 
Transfers - Options. 
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Selecting this feature lets you specify modem settings, such as initialization strings, dial or 
hangup strings, etc. Indicate if the DTR signal should be dropped for hangup. 
  

Modem Messages 

Modem Messages 

The Modem messages tab is only visible if Use modem is selected on the Ports tab under 
Transfers - Options.  
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This tab contains entry boxes for a connection message and no connection messages, plus 
other modem options. 
  

Connection Message 

Enter any necessary connection messages in the box provided. 
  

No Connection Messages 

Enter any necessary messages in the case that no connection is established in the boxes 
provided. 
  

Options 

Options 

Various modem options are available, including the dial timeout, the number of redials, and 
whether or hang up upon exiting EH-View. 
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Hangup 

Check this box to have the modem hang up when the program is exited. This prevents 
unnecessary use of the modem. 
  

Dial Timeout 

Set the timeout, in seconds, if a successful dial is not achieved. 
  

Number Redials 

Set the number of automatic redials. 
  

4.8.6 Get Panel Resources 

Before beginning work on a particular project, you need to specify the type of display that the 
target panel contains. The physical size of the screen, as well as its type (backlight LCD, 
passive color) must be specified. Failure to do this accurately may result in the loss of text 
and data whenever an attempt is made to download a project file to the panel. 
  
The Get Panel Resources feature is provided to help set the parameters for the target panel 
quickly or to determine unknown information about the connected panel. This option may be 
selected from the Transfers menu, by clicking on the Get Panel Resources icon in the toolbar, 
or by pressing the F4 button. In order to use this feature, the target panel must be connected to 
the PC and the panel must be in Configuration Mode. Upon selecting this item, EH-View will 
attempt to retrieve the connected panel's configuration. 
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When successful the following information is displayed. 
  
Panel Model: The panel model. 
Panel FW version: The panel firmware version. 
Controller Type: Internal code to identify the type of controller. 
FW driver version: Version of the controller driver being used. 
Project in panel: Reports if there is a project file in the panel. 
Display type: Type of display. 
Max num of rows: Number of rows per project page. 
External keyboard: Whether or not a keyboard is present. 
Internal memory: Amount of memory available for project file. 
Recipe memory: Amount of memory available for recipes. 
Event list length: Number of events that can be stored in Event list. 
Support for graphics: If the panel is capable of supporting graphics. 
Color display: If the panel contains a color display. 
Touchscreen present (code): If the panel has a touchscreen (and the internal code, if 

present). 
Pixel/Vector Graphics Support: If the panel is capable of supporting Pixel/Vector Graphics. 
Double Protocol Support: If the panel is capable of Double Protocol Support. 
  
You may copy the displayed resource configuration to the current project by pressing the Yes 
button. If you do not wish to use the reported parameters, press No. 
  
If for any reason EH-View is unable to communicate with the panel, a message box will 
appear explaining the problem. 
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It is also possible to manually configure the software by using Panel Setup from the Project 
menu. 
  

4.8.7 Check Firmware Versions 

Correctly setting the Firmware Download flag is necessary to give EH-View the necessary 
information required to correctly calculate the SSFDC memory used, taking into account the 
size of the firmware files. 
  
After exchanging information with the panel to detect the version of the firmware files that 
are inside the SSFDC memory card, a dialog box is displayed. 
  

 
  
The left column displays the versions of the firmware files that are located in the SSFDC 
memory card. The right column displays versions of firmware files only if your computer 
contains a newer version. If a newer version is not detected, <Do not update> is displayed. 
  

4.8.8 Switch to Operation mode 

Selecting this option causes the application in the panel's memory to begin running. 
  
Note:  Communication with the panel is interrupted until the panel returns to Configuration 
Mode. 
  

4.8.9 Switch to Configuration mode 

Selecting this option causes the panel to switch to Configuration mode. 
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4.8.10 Remote Passthrough 

Remote passthrough 

This entry lets you select one of three remote passthrough commands: Configuration Mode, 
Start or Stop. 
This feature lets you remotely put a EH-HMI panel into either Configuration Mode or 
Operation Mode via a modem. In this manner, you can remotely upload or download a project 
file, start the panel, or use passthrough mode to access the programming port on the PLC. 
  
Note:  The EH-HMI panel must contain firmware version 4.20 or later to use this feature. 
  
Note:  The Remote passthrough commands are active only when Remote Hardware mode has 
been selected under the Passthrough tab of Project - Panel Setup. 
  

Configuration Mode 

If no project file has been downloaded to the panel, the panel will default to Configuration 
Mode when power is applied. 
  
To re-enter Configuration Mode after the panel is in operation, press and hold the Enter key 
for a few seconds. The System Menu will appear. Use the arrow keys on the display panel to 
highlight the CONFIG selection in the top right-hand corner of the menu and press Enter. 
  
Note:  If the Enter key is not available, touch and hold any open space on the touchscreen 
panel for several seconds. The System Menu should appear, listing the Configuration Menu as 
a selection. Use the arrow keys on the panel to select the Configuration Menu. 
  
Note:  If Configuration Mode is locked out, hold down three (3) arrow keys, power the unit 
down (continue holding down the three arrow keys), and power the unit back up. Make sure 
that the project file is saved before attempting this! 
  
Note:  Another method for accessing Configuration Mode from a touchscreen panel is listed 
below. Please note that not all touchscreen panels are capable of this "quick fix". Make sure 
that the project file is saved before attempting this! 
  
o Begin tapping the center of the screen. 

  
o Power the unit down and back up (when you power it up continue tapping the center of 

the screen). 
   

o You should be prompted by the panel to touch a circle on a portion of the screen. Follow 
the panel directions. After completing the panel's instructions, press the Enter key 
displayed on the panel. (This process is sometimes difficult to complete, as the 
touchscreen is particular about the area pressed. You may have to do this procedure more 
than once to get it to work.) This should activate Configuration Mode. 

  
Note:  If a project that uses passwords is locked out of Configuration Mode, enter 0007 as the 
password. This should allow access to Configuration Mode. 
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Start 

This transfers a start command to the panel. 
  

Stop 

This transfers a stop command to the panel. 
  

4.8.11 Dial 

This feature lets you enter a phone number and send a dial command to your modem. By 
using the Add Entry and Delete Entry buttons, you may add commonly used numbers to a 
phone directory for reference, and delete numbers when they are no longer needed. Click on 
the Start Dialing button to initiate dialing by your modem. 
  

4.8.12 Hang Up 

This feature lets you send a hang-up command to your modem. 
  

4.9 Tools Menu 

4.9.1 Tools Menu 

The Tools menu contains commands to help you to customize the appearance of the toolbars, 
grid, and font that appear on the screen. 
  
o Tag Editor 

   
o Font Editor 

   
o Keypad Designer 

   
o Customize 

   
o Options 

   
o Advanced 
o   
o Replace Image(s) 
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4.9.2 Tag Editor 

Tag Editor 

  

 
  
Tags allow mnemonic reference to PLC variables. A thorough discussion of the use of tags is 
available. 
  
The Tag Editor allows you to easily work with a large number of tags by creating a tag 
database for your project. It provides the capability to add, delete and modify tags as well as 
assign PLC addresses to each tag, plus it includes import and export capabilities to exchange 
tags with external applications. You can create a list of tag names in the Tag Editor and then 
assign the tag names to various fields of the EH-View project by simply selecting a tag name. 
  
The Tag Editor provides a grid-like user interface where you can enter a tag name, assign a 
tag address, a group name for the tag, and enter a comment for the tag.   
  
An example of using tags and the Tag Editor is available. 
  
To open the Tag Editor, select Tag Editor from the Tools menu of EH-View. The Tag Editor 
application opens. The Tag Editor is a typical Windows  application with menus across the 
top, a workspace to on the left side, and the currently open file shown on the right. 
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File Menu 

File Menu 

The Tag Editor File menu includes commands for managing tag dictionaries, such as: 
  
o New 

   
o Open 

   
o Save As 

   
o Import Tags 

   
o Export Tags 

   
o New Dictionary 

   
o New Group 

   
o Delete Dictionary 

   
o Print 

   
o Print Preview 

   
o Print Setup 

   
o Recently Opened Files 

   
o Exit 

  

New 

 
  
Selecting New from the File menu of the Tag Editor opens the New Tag Database dialog box. 
From this box you can name a new database and specify its location. Click the "…" button 
next to Location if you want to store the database file in another folder or drive. 
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Open 

 
  
This familiar Windows  box allows you to choose a file to open in the Tag Editor. Tag 
database files are normally in the format *.mdb. The selected database will appear in the 
workspace on the left of the page. 
  

Save As 

 
  
This familiar Windows  box lets you save a file in the Tag Editor. Enter a file name and 
specify where the file is to be saved. 
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Import Tags 

Import Tags 

It is possible to import tags from external sources such as an ExcelTM database. Select 
Import Tags from the File menu of the Tag Editor and the Tag Import Wizard steps you 
through the process. <Back and Next> buttons help you navigate through the process. A 
Cancel button is available if you want to exit the Tag Import Wizard. 
  
A Help button provides access to help text about the Tag Import Wizard. 
  

Import Tags Step 1 

 
  
Enter a name for the new tag dictionary in the Tag box. Select a controller driver from the list. 
Select a particular driver model, if necessary. 
  
The Refresh Controller List button is available if it is necessary to refresh the list for any 
reason. 
  
When you have completed Step 1, click the Next> button to continue to Step 2. 
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Import Tags Step 2 

 
  
In Step 2 you will select the file that you wish to import. 
  
If you know the file name you can enter it in the box. Otherwise, click on the "…" button to 
browse the system. When you locate the file that you want to import, click on the file name to 
select it, the click the Open button. You are returned to the Tag Import Wizard and the 
selected file name is entered in the box. 
  
The following file formats are supported. 
  
Excel files (*.xls) 
CSV files (Comma delimited) (*.csv) 
CSV files (Semicolon delimited) (*.csv) 
Text (Tab delimited) (*.txt) 
  
When you have completed Step 2, click the Next> button to continue to Step 3. 
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Import Tags Step 3 

 
  
In Step 3 you will configure the columns in your imported files. In the left box are the 
columns available in the database being imported. 
  
Specify the value in the edit box of 'Start import at row' in order to specify the first row of the 
data user want to import.  
  
You may need to scroll to see all of the available column names. In the right box are the 
columns normally available in a tag database. If you want to add columns to this list, you may 
do so. Simply click on a column name in the left box and click the Add-> button. The column 
name appears in the right box. 
  
Column names are appended to the bottom of the list. Select a column name and use the 
Up and Down buttons to rearrange the list order, if necessary. If you change your mind, the 
Delete button will remove a column from the list. 
  
When you have completed Step 3, click the Next> button to continue to Step 4. 
  

Import Tags Step 4 

(For excel import only) 
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If the imported file has more than one worksheet the user is given three choices as shown in 
the above dialog. This is applicable only to .xls file format. For all other format this step is 
skipped. 
  
When you have completed Step 4, click the Next> button to continue to Step 5. 
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Import Tags Step 5 

 
  
The final step of the Tag Import Wizard is to create the dictionary and tag groups, and to 
import the tags.  
  
Verify the location from which the tags are being imported, and click the Finish button to 
complete the operation.  
  
A confirmation message will appear. Click OK. 
  

Export Tags 

Export Tags 

It is possible to export tags for use in another application. Select Export Tags from the File 
menu of the Tag Editor and the Tag Export Wizard steps you through the process. <Back and 
Next> buttons help you navigate through the process. A Cancel button is available if you 
want to exit the Tag Export Wizard. 
  
A Help button provides access to help text about the Tag Import Wizard. 
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Export Tags Step 1 

 
  
In Step 1 you will configure the columns to be exported. In the left box are the columns 
available in the database being exported. You may need to scroll to see all of the available 
column names. 
  
In the right box are the columns normally exported. If you want to add columns to this list, 
you may do so. 
Simply click on a column name in the left box and click the Add-> button. The column name 
appears in the right box. 
  
Column names are appended to the bottom of the list. Select a column name and use the 
Up and Down buttons to rearrange the list order, if necessary. 
  
If you change your mind, the Delete button will remove a column from the list. 
  
When you have completed Step 1, click the Next> button to continue to Step 2. 
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Export Tags Step 2 

 
  
In Step 2, select the dictionary to be exported. 
  
If the selected dictionary has more than one group associated with it then user has the option 
to export tags from all groups or to export tags from selected group.  
  
When you have completed Step 2, click the Next> button to continue to Step 3. 
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Export Tags Step 3 

 
  
In Step 3, select a name for the exported file. A default name is already entered in the box. If 
you wish, enter a different name in the box, or click the "…" button to bring up the Save As 
box. 
  
If the user has selected the option 'Export tags from all groups' in the second step of export 
wizard then the user is given the option to export each group to a work sheet or export all 
groups to a single work sheet. This is applicable only to .xls file format. 
  
When you have completed Step 3, click the Next> button to continue to Step 4. 
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Export Tags Step 4 

 
  
In the final step you are asked to confirm the dictionary to be exported. If the information is 
correct, click the Finish button the export the tags. 
  
The exported file will be saved in the location and with the file name that you specified. 

New Dictionary 

The New Dictionary command is available from the Tag Editor File menu if no tag 
dictionaries are currently opened. If a tag dictionary is open, then the New Dictionary 
command is available under the Dictionary menu. 
  
Selecting New Dictionary from the File or Dictionary menus, clicking on the New icon, or 
right clicking on a dictionary in the workspace and selecting New Dictionary, will open the 
New Tag Dictionary dialog box. In this box you name your new dictionary and associate it 
with a particular controller. 
  
Enter a name for your new dictionary in the Tag Dictionary box. Select the controller driver 
that you plan to use from the list provided. If more than one driver model is available with the 
selected controller, select the model you plan to use from the list under Driver Model. 



EH-VIEW (en) - July 2005 - 05/005 

Page 333 

New Group 

The New Group command is available from the Tag Editor File menu if no tag dictionaries 
are currently opened. If a tag dictionary is open, then the New Group command is available 
under the Dictionary menu. 
  
The New group dialog box allows you to enter tag information. The particular columns 
available may vary, but will normally contain at least the tag name, the logical address for the 
tag, the data format for the tag, and any comments necessary. 
  
Type a tag name in the Tag box and any comments in the Comment box. Clicking on the 
Logical_address box activates an arrow. Click on the arrow to bring up the Data Field 
Properties dialog box. Specify the reference address, data type and format, etc. Click OK to 
return to the New group dialog box with the logical address and data format information 
completed. 
  
Every time you enter information on one line, an additional line appears below it. Fill in as 
many lines as you need. When you have entered all the information in the New group dialog 
box, select Save As from the File menu to save the dictionary. 

Delete Dictionary 

This command deletes the selected dictionary. 

Print 

The Print command in the File menu allows you to print the currently open Tag Database. 
  
Selecting Print from the File menu (or pressing the Ctrl+P keys) brings up the familiar 
Windows  Print dialog box. 

Print Preview 

Selecting Print Preview from the File menu brings up the familiar Windows  Print Preview 
view, from which the Tag Database may be previewed for printing. 

Print Setup 

Selecting Print Setup from the File menu brings up the familiar Windows  Print Setup 
dialog box, from which printer properties may be selected. 
  

Recent Files 

The most recently opened files are listed under the File menu as a shortcut. Click on the name 
of a file to reopen it. 
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Exit 

The Exit command closes the Tag Editor application. 

Edit Menu 

Edit Menu 

The Edit menu of the Tag Editor contains familiar WindowTM commands for working with 
text and objects on the page. These include: 
  
o Undo 

   
o Redo 

   
o Cut 

   
o Copy 

   
o Paste 

   
o Find 

   
o Replace 

Find 

Enter the text for which you are searching into the box. Check the Match case box if you are 
looking for an exact match with regard to capitalization. Indicate whether you wish to search 
up or down from the current point. 

Replace 

Enter the text for which you are searching into the Find what box. Enter the text with which 
you wish to replace it in the Replace with box. Check the Match case box if you are looking 
for an exact match with regard to capitalization. Click the Find Next button to locate the next 
occurrence of the text in the Find what box. When the text is located, you can click the 
Replace button to replace only that instance, or click the Replace All button to replace every 
instance. 
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Dictionary Menu 

Dictionary Menu 

The Dictionary menu allows you to add a New Dictionary, a New Group, or to Delete a 
Dictionary. The commands on the Dictionary menu are available only when a dictionary is 
opened within the Tag Editor. 

Record Menu 

Record Menu 

The commands in the Record menu are used to manage the records located in the New group 
dialog box. These commands include: 
  
o Next Record 

   
o Previous Record 

   
o First Record 

   
o Last Record 

   
o Delete Records 

Next Record 

The Next Record command is used for navigating between cells in the New group dialog box. 
This command moves you to the next cell. 
  

Previous Record 

The Previous Record command is used for navigating between cells in the New group dialog 
box. This command moves you to the previous cell. 
  

First Record 

The First Record command is used for navigating between cells in the New group dialog box. 
This command moves you to the first cell. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 336 

Last Record 

The Last Record command is used for navigating between cells in the New group dialog box. 
This command moves you to the last cell. 
  

Delete Records 

The Delete Records command is used to delete all the records located in the New group 
dialog box. 
  

View Menu 

View Menu 

The View menu allows you to customize the appearance of the Tag Editor. Commands 
include: 
  
o Workspace 

   
o Toolbar 

   
o Status Bar 

  

Workspace 

The workspace bar is located at the left side of the Tag Editor dialog box and displays any 
open tag databases. If Workspace is checked in the View menu, then the workspace is visible. 
If it is unchecked, then the workspace bar is hidden. 
  
The workspace can be docked to a side of the Tag Editor or float in the main Tag Editor 
window. Right-click on any item displayed in the workspace brings to up a command list that 
controls docking. Additional commands provide shortcuts to create a new dictionary or hide 
workspace. (To make the workspace visible again, simply check Workspace in the View 
menu.) 
  

Toolbar 

The toolbar is located under the Tag Editor menu bar and contains icons as shortcuts for 
commonly used commands. If Toolbar is checked in the View menu, then the toolbar is 
visible. If it is unchecked, then the toolbar is hidden. 
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Status Bar 

The status bar is located at the bottom of the Tag Editor dialog box and displays contextual 
information. If Status Bar is checked in the View menu, then the status bar is visible. If it is 
unchecked, then the status bar is hidden. 
  

Tools Menu 

Tools Menu 

The Tools menu contains the commands Customize and Options, which allow you to set the 
toolbars and colors of the Tag Editor to your own preferences. 
  

Customize 

 
  
The commands on the Toolbars tab and the Command tab allow you to customize the 
appearance of the toolbars and the commands contained on the various toolbars within the 
Tag Editor. 
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Options 

 
  
In the Options dialog box you can set text and background colors. To have alternating lines in 
different colors for improved readability, check the Alternate Row Color box and set the 
colors for the alternating row. 
  

Window Menu 

Window Menu 

The Window menu contains familiar Window  commands for managing multiple windows. 
These include: 
  
o New Window - opens a new window 

  
o Cascade - places each new window slightly below and to the right of the current window. 

  
o Tile - places each new window below the current window. 

  
o Arrange Icons - arranges the visible icons in an orderly manner 
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o Close All - Closes all currently open windows. 
  

o File Identification - gives the file names of the files in the currently open windows. 
o   

Help Menu 

Help Menu 

The Help menu contains helpful information about the Tag Editor. You can search the 
contents for information about various commands within the tag editor, or you can view 
information about the Tag Editor application. 
  

Contents 

Lists the contents of the Tag Editor help text. 
  

About TagEdit 

Provides basic version and copyright information about the Tag Editor application. 
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4.9.3 Font Editor 

Font Editor 

 
  
The Font Editor lets you modify the downloadable font of semi-graphical displays. Each font 
consists of 256 characters that can be edited or changed. This lets you create any necessary 
characters for a particular project. In most cases, you would not want to edit any of the 
standard characters such as letters, numbers, large character blocks, or bargraph blocks. 
  
The Font Editor has its own menus and toolbar. The characters of the currently selected font 
are displayed across the bottom of the Font Editor screen. Click on a character to display it in 
the Font Editor window. 
  
The Font Editor includes the File menu, the Edit menu, the Font menu, the Fill menu, the 
Row menu, the Column menu, the Width menu, the Options menu, and the Help menu. 
  

File Menu 

File Menu 

The Font Editor File menu contains familiar Windows -type commands such as Open, Save, 
Save As and Exit. 
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In addition, the command Install/View installed Panel Fonts lets you view Panel Display 
Types and corresponding Installed Fonts with the font width and height. 
  
The Install Font button lets you select the display panels with which this font is to be used. 
The font will then be listed in the Installed Fonts box. The Remove Font button lets you 
delete the currently highlighted font from the Installed Fonts list. 
  
An example of saving and installing a new font is available. 
  

Open 

 
  
This familiar Windows  box allows you to choose a file to open in the Font Editor. Font  
files are normally in the format *.fon. 
  

Save 

To save a project, select Save from the File menu. 
  
The cursor may be momentarily replaced with an hourglass while the file is saved. 
  
If the application has not been named, the Save As dialog box will appear instead. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 342 

Save As 

 
  
This familiar Windows  box lets you save a file in the Font Editor. Enter a file name and 
specify where the file is to be saved. 
  

Edit Menu 

The Font Editor Edit menu contains familiar Windows -type commands such as Undo, 
Copy, Paste and Refresh. 
  

Font Menu 

Font Menu 

The Font Editor Font menu lets you see the font size and see, modify, the  font header 
information. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 343 

Font Size 

 
  
The Font Size dialog box in the Font Editor lets you see the character pixel width and height, 
the first and last character, and the pitch for a font. 
  

Font Header 

 
  
The Font Header dialog box lists the file name used for the selected font, the face name (font 
name) for that font, provides a box for entering any necessary copyright information, sets the 
external and internal leading values, identifies the character set and the version.  
  

Fill Menu 

It is possible to fill the entire character grid with either white or black, or to invert the 
displayed colors. 
By double clicking on a particular pixel, you can toggle the appearance of that pixel. For 
example, if a pixel is initially black, double clicking on it will change its color to white. 
  
An example of editing characters is provided. 
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Row Menu 

The Insert and Delete commands on the Row menu of the Font Editor let you customize a 
character by adding or deleting a row of pixels. 
  
Note:  The row is added or deleted from the present position of the cursor. 
  
Note:  When a row is added all the other rows below it are shifted one pixel down. 
  
  

Column Menu 

The Insert and Delete commands on the Column menu of the Font Editor let you customize a 
character by adding or deleting a column of pixels. 
  
Note:  The column is added or deleted from the present position of the cursor. 
  
Note:  When a column is added all the other columns to its right are shifted one pixel to the 
right. 
  

Width Menu 

The Font Editor Width menu is currently disabled. 
  

Options Menu 

Options Menu 

The Font Editor provides a method of editing characters that are used in basic character 
formation. These commands are available under the Options menu of the Font Editor. 
Commands in the Options menu include: 
  
o Rectangles, 

   
o Large Characters, 

   
o Bargraphs, 

   
o Define Symbol, and 

  
o Symbol Browser. 
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Rectangles 

By selecting Rectangles from the Options menu of the Font Editor, you can edit the characters 
that form each of the two rectangles that are implemented in the EH-View software. 
  
The rectangle is composed of eight characters: 4 corner characters and 4 characters that 
connect the corners. By selecting any of these characters, you can create the rectangle with a 
particular style. EH-View comes with two default rectangle styles: single line and double line. 
  
Once you have defined the characters that make up the rectangle, you can draw a rectangle of 
any size in any page of your project.  
  
Note: You should launch the Font Editor from within EH-View, so that the necessary .INI 
files are updated automatically. If the Font Editor is launched outside of EH-View, you will 
need to enter the character codes that make up the rectangle into the DISPLAYS.INI file 
manually. This file is located in the Windows directory. As you scroll through the file, each 
font will have a line that begins with BoxChars=. You will need to specify the eight character 
codes that make up the rectangle. These codes need to be entered in scanline order - left to 
right, top to bottom of the rectangle. So, you would first start with the top, left corner of the 
rectangle extending across the top. You would then go to the top, left corner and extend 
down. Next, go to the top, right corner and extend down. Finally, you would go to the bottom 
of the rectangle. 
  
  

 
  
The above dialog box is used to define each of the eight characters that make up a rectangle. 
To get an explanation about the function of any part of the dialog box, position the mouse 
over the area and click the left mouse button. 
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Large Characters 

 
  
The large character set must be kept continuous. The Large Character Start Code dialog box 
in the Font Editor identifies the starting character in a large character set. 
  
Note:  This starting character is not the same for every font. 
  
Note: The characters in the sequence must have a predetermined shape. Characters that are 
larger than the standard panel character set are composed algorithmically from the set of 
specially shaped characters shown below. You must maintain this exact sequence of shapes in 
order to introduce large characters into your font. 
  

Bargraphs 

 
  
The Font Editor start code for bargraphs is the first non-blank character within the bargraph 
character set. Keep in mind that the bargraph character set must be kept continuous (i.e., the 
characters must be kept in numerical order. 
  
Note:  The character code will not be the same for each font. 
  

Define Symbol 

The EH-View software offers you the ability to create your own symbols using the Font 
Editor. While still included in the software, this feature has become obsolete with the current 
graphical release. 
  
o To select symbol mode, select Define Symbol from the Options menu. 

  
o Select Symbol Dimensions and enter the height and width of the symbol you would like 

to define. 
  

o Select OK. 
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o Select Define Symbol - Draw New Symbol from the Options menu. 
  

o The display will then change to the symbol dimensions that were selected. The editor 
will put the selected number of characters from the font in this symbol edit box, starting 
with the character that was highlighted. 
  

o Select Define Symbol - Compose Symbol from the Options menu.  Double -click on each 
character that makes up the symbol. Start with the character is in the upper left-hand 
corner and move across. The light gray character box will automatically move to the next 
character location. If you make a mistake, simply single click on the character location to 
move the cursor box and then double -click on the correct character in the font bar. When 
the symbol contains all the correct characters, click in the small upper box. Give the 
symbol a name by typing it in this box and clicking on OK. 

Symbol Browser 

The Symbol Browser allows browsing among the symbols you have created in the Font 
Editor. 
  
To create a  new symbol use Options - Define Symbols - Symbol Dimensions. 
  
Select the size of the new symbol (in number of characters). 
  
When you select the enabled item Draw new Symbol the Font Editor represents a preview of 
the new symbol in a map of 2 by 2 characters. 
  
The preview consists of the current character plus the next 3 characters. Since in our example 
we selected a symbol size of 2 by 2 characters we need in fact 4 characters in total. 
  
When the new symbol is modified using the bitmap editor, the Font Editor automatically 
changes all the involved characters. 
  

Help Menu 

The Help menu is constructed in the typical Windows  manner, with a list of the Contents of 
the help text, and information about the Font Editor. 
  

Font Editor Example 

Font Editor Example 

Creating or modifying a font using the Font Editor consists of two parts; editing the 
character(s), and then saving the new or modified font. 
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Editing Characters 

o Select Font Editor from the Tools menu. 
  

o The font will appear on the display in the Font Editor as shown in the figure below. 
  

          (insert figure here) 
  
o Select a character to edit by clicking on it from the character list across the bottom of the 

window. 
  

o By double clicking on a particular pixel, you can toggle the appearance of that pixel. For 
example, if a pixel is init ially black, double clicking on it will change its color to white. 
  

To save the changes you have made, see the Saving a Font section. 
  

Saving a Font 

o When finished modifying the font (see the Editing Characters section) you can save it by 
selecting Save or Save As from within the File menu within the Font Editor. When 
changing a font, we recommend that you use Save As and give the font a new name so as 
not to change the original font. Fonts need to be saved to the Windows System directory. 
  

o The font must then be installed by selecting Install/View installed Fonts under the File 
menu within the Font Editor. Select the display panels with which this font is to be used 
and click on the Install Font button. 
  

o Select File - Exit from the Font Editor to return to your EH-View project page. 
  

o Now choose Edit - Fonts - Panel Font from within EH-View (or press Ctrl+F or click on 
the Panel Font icon in the toolbar) and the customized font will be available from the 
Font Name pulldown menu in the Select Font dialog box. 

o   
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4.9.4 Keypad Designer 

Keypad Designer 

 
  
The Keypad Designer utility is a Windows -based application that allows you to design, 
manage and download custom keypads to a EH-HMI panel. It is possible to define 
customized floating popup keypads for four different types of fields by using the Keypad 
Designer utility. These fields are: 
  
o numeric fields with a decimal base, 

  
o numeric fields with a hexadecimal base,  

  
o ASCII fields, and 

  
o message fields. 

  
These popup keypads are dynamic objects that are displayed by the EH-HMI firmware over 
the current page whenever Data Entry is started on a field for which a popup keypad is 
defined. 
  
Note:  Touch Data Entry Keypads are only supported by firmware type 58 starting from 
version 4.40. 
  
A Keypad Designer keypad can contain two types of objects: 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 350 

o Buttons 
  

o Value Objects 
  
Buttons can represent any of the keys that are present on a standard keyboard (i.e., F1, Enter). 
A Keypad Designer button is merely a button programmed to execute a certain action 
  
Value objects are rectangular areas inside the keypad where the EH-HMI firmware displays 
different information related to the field that is being edited. A value object is a field that is 
able to display a value. 
To create a new popup keypad, select New from the Keypad Designer File menu. The Keypad 
Designer utility presents a blank programming area where the keypad can be designed. 
  
o File Menu 

   
o Edit Menu 

   
o View Menu 

   
o Window Menu 

   
o Help Menu 

   
o Buttons 

   
o Value Objects 

File Menu 

File Menu 

The File menu contains familiar Windows  commands for managing files and printing. 
  
o New 

   
o Open 

   
o Close 

   
o Save 

   
o Save As 

   
o Print 

   
o Print Preview 

   
o Print Setup 
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o Recent Files 
   

o Exit 
   

plus the less familiar commands 
  
o Export to ROM, and 

  
o Download to ROM 

New 

A new Keypad Designer File  may be created by selecting New from the File menu, by 
clicking the New Keypad icon, or by pressing the Ctrl+N keys.  
  

 
  
The file is created with a default name. You can change this name when saving the file, by 
selecting the Save As from the File menu. 
  

Open 

To open an existing Keypad Designer File, select Open from the File menu, click the Open 
icon on the toolbar, or press the Ctrl+O keys. The Open Keypad dialog box will appear, 
providing a list of the file names in each directory. 
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Enter the name of the file to be loaded or use the list box to select from the existing files. If an 
extension is not specified, .kbd is assumed. 
  

Close 

To close a currently open file, select Close from the File menu. 
  

Save 

To save a Keypad Designer Files, select Save from the File menu, click on the Save file icon 
on the toolbar, or press the Ctrl+S keys. 
  

Save As 

If a Keypad Designer file to be saved has not been named, the Save As dialog box appears. 
Or, you may select Save As from the File menu. This option can also be used to save a 
Keypad Designer File under a different name. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 353 

 
  
The Save As dialog box shows the current directory path and the current file name. A new 
name and path may be entered or the ones presented may be accepted. 
  

Print 

Selecting Print from the File menu (or pressing the Ctrl+P keys) brings up the familiar 
Windows  Print dia log box, from which the currently open may be printed. 
  

Print Preview 

Selecting Print Preview from the File menu brings up the familiar Windows  Print Preview 
view, from which the currently open Keypad may be previewed for printing. 
  

Recent Files 

The most recently opened files are listed under the File menu as a shortcut. Click on the name 
of a file to reopen it. 
  

Exit 

Selecting Exit from the File menu can be used to terminate the EH-View program. You are 
prompted to confirm the operation if the current application has not been saved. 
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Export to ROM File  

 
  
This creates a binary file with extension .ROM that can be used to program the memory card 
directly using a programmer. 
  

Download to Panel 

Floating keypads created with the Keypad Designer software need to be downloaded to the 
panel in addition to the standard project file. Once the keypads have been downloaded, the 
EH-HMI panel will use them for editing when in Data Entry mode.  
  
Note:  If you created a custom Data Entry screen using the Special Pages section in EH-View, 
the keypads created in the Keypad Designer software will not be used. 
  
Keypad Designer keypads can be downloaded to the EH-HMI panel by using the standard 
download cable connected to the PC/Printer port.  
  
Selecting the Download icon will start the communication session between the Keypad 
Designer utility and the EH-HMI panel.  
  

 
  
When the New File checkbox is marked, this indicates that the keypad being downloaded is a 
new object that is not intended to substitute an existing keypad. 
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The left part of the dialog box shows the keypads that have been downloaded to the EH-HMI 
panel. The right part of the dialog box shows the association between each of the keypads and 
the corresponding field types. 
  
When selecting OK, the download procedure will begin and the Transfer dialog box will be 
displayed. 
  

 
  
This dialog box shows information about the current download process, such as the 
completion rate of the process, the estimated time for completion and the average transfer 
speed.   
  
Once the file download is completed, the next keypad can be downloaded to the EH-HMI 
panel. 
  

Edit Menu 

Edit Menu 

The Edit menu contains many familiar Windows  commands for working with text and 
objects on the page. 
  
o Undo 

   
o Redo  

   
o Cut  
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o Copy 
   

o Paste, and 
  

Delete, 
   
plus the less familiar commands 
  
o Components 

   
o Communication Parameters 

   
o Keyboard 

   
o SSFDC 

Components 

 
  
The Components dialog shows in one single list all the object / components present in a given 
page. 
  

Communication Parameters 

 
  
The Communication Parameters dialog allows the user to configure the setting of the 
communication port. 
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The communication parameters need to be set as follows in order to perform a successful 
keypad download: 
  
Baud rate: 38400 (recommended) 
  
Parity: none 
  
Stop bits: 2 
  
Data Bits: 8 
  
  
In addition, specify the Com Port to be used. 
  

Keyboard 

Keyboard 

 
  
When you select Keyboard from the Keypad Designer Edit menu (or clicking the Keyboard 
Properties icon) the Model Properties dialog box is displayed, allowing you to define the 
basic parameters of the keypad. The Model Properties dialog box consists of three tabs: 
  
o General 

   
o Background 

   
o Panel 
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General 

General tab 

 
  
Items on the General tab allow you to specify a name, the number of colors, the type of 
associated fields, and position information. 
  

Name 

The name assigned to the keypad. This is used by Keypad Designer to identify different 
keypads. 
  

Number of  Colors 

Lets you select the number of colors used to represent the keypad. 
  

Associated Fields 

Specifies the types of fields that can be edited using the selected keypad. 
  
Note:  A field type (i.e., numeric field with decimal base) can have only a single keypad 
associated with it. 
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Position 

Position 

The Position area contains the controls used to define where the keypad will appear on the 
display, including: 
  
o Avoid Field 

   
o Absolute Coordinates 

   
o Horizontal Position 

   
o Vertical Position 

Avoid Field 

When checked, this specifies that the keypad will be displayed in a position such that the field 
being edited will not be covered by the keypad. When Avoid field is checked, the Horizontal 
and Vertical controls allow you to define the position of the keypad. 

Absolute Coordinates 

When this checkbox is marked and the Panel Predefined Model has been selected, the keypad 
will be placed by the EH-HMI firmware in the same position as it is displayed in the Keypad 
Designer utility.  If the Avoid field checkbox is also selected, the firmware will place the 
keypad in the specified position only if the field under editing is not covered by the keypad. 

Horizontal Position 

The Horizontal position can be Left, Center, or Right. This refers to relative position, the 
references of which can be specified in the corresponding from list box. 

Vertical Position 

The Vertical position can be Top, Center or Bottom. This refers to relative position, the 
references of which can be specified in the corresponding from list box. 
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Background 

Background 

 
  
Allows you to specify both Background and Border properties. 
  

Background 

You can select a bitmap image to be used as the background of the keypad. The Browse 
button allows you to search for an image and select it to be entered in the Bitmap box. 
  
The Color list box allows for selection of the desired background color. 
  

Border 

Check the box to include a border. Allows you to specify the color of the border of the 
keypad. 
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Panel 

Panel 

 
  
Options on the Panel tab allow you to set the type of panel model or the panel size, and the 
grid size. 
  

Predefined Models 

Lets you specify the display type of the panel to which the keypad will be downloaded. This 
is especially useful when absolute coordinates are used to place the overlapping keypad. 
  

Panel Size 

This can be used to set the dimensions of the EH-HMI panel when the Predefined models 
option is not defined. Specify the panel width and height in pixels. 
  

Grid Size 

Specifies the character grid size (in pixels) of the panel where the keypad will be downloaded. 
Correct values for the grid size can be derived from EH-View by selecting one character and 
reading the pixel size of the selected area in the EH-View Status Bar. 
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SSFDC 

 
  
When the EH-HMI panel is in Configuration Mode, selecting SSFDC from the Edit menu 
within the Keypad Designer software will return a list of all the keyboard files currently 
stored in the EH-HMI memory. 
  
To delete a particular keypad, simply select the name of the keypad from the list and click on 
the Delete button.  
  
To close the communication session, click on the Close button. 
  

View Menu 

This section provides information about the View menu. The View menu lets you set the 
screen to view the project in the most comfortable manner for various tasks. 
  
The items Toolbar, Status Bar, and Grid may be checked in the View menu to make them 
visible. Uncheck them if you do not want them visible in the current workspace. 
  
Zoom commands on the View menu include: 
  
o Zoom Normal - to return to normal viewing 

  
o Zoom Percent - to zoom in by a preset percentage of 50%, 75%, 100%, or 200%. 

  
o Zoom Custom - to magnify by a percentage that you specify 

  
o Zoom to Fit - to zoom to fit the defined viewing space. 
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Window Menu 

The Window menu contains familiar Window  commands for managing multiple windows. 
These include: 
  
o New Window - opens a new window 

  
o Cascade - places each new window slightly below and to the right of the current window. 

  
o Tile - places each new window below the current window. 

  
o Arrange Icons - arranges the visible icons in an orderly manner 

  
o Currently Open File(s) - the filenames of the currently opened files. 

Help Menu 

The Help menu is constructed in the typical Windows  manner, with a list of the Contents of 
the help text, and information about the Keypad Designer. 
  

Buttons 

Creating Buttons 

To create a Button, click the Button icon and click on the screen. 
  
A button appears with its upper left corner at the point where you clicked. Right click on the 
button and select Properties to bring up the Uni Button dialog box, 
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where you can define the functionality of the button, including Colors, Key Code, and Label. 
  

Colors 

The Colors area contains three list boxes that let you select the colors for the button face, the 
button shadow and the button line. 
  
Using a proper combination of the three colors will result in a three-dimensional aspect of the 
button.  
  
The button can also be made to appear as a "flat button" by assigning the same color to the 
Shadow and Line color. 
  

Key Code 

The functionality assigned to the button. Each button can be assigned as a standard EH-HMI 
key or as an ASCII character. 
  
The available selections in the list can be fully personalized by modifying a configuration file 
in the Keypad Designer installation directory called KeyCodes.txt. This file contains the 
ASCII codes and the EH-HMI key definition used by the Keypad Designer software to build 
the Key Code list of available functions and can be modified by any text editor. 
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Label 

Label 

The Label area contains the necessary selections required to customize the button label. 
  

Text 

The text that will appear on the face of the button. 
  

Font 

The font in which the label is displayed. This can be any Windows  font that is installed on 
the computer that is running the Keypad Designer utility. 
  

Picture 

This lets you specify a background bitmap image for the button. Use the Browse button to 
select a bitmap image. 
  

Horizontal Align 

Specifies the horizontal position of the label (right, center, left). 
  

Vertical Align 

Specifies the vertical position of the label (top, center, bottom). 
  

Value Objects 

Creating Value Objects 

Creating Value Objects is done in much the same manner as creating a Button. Simply click 
the Value icon and click on the screen. An object appears with its upper left corner at the 
point where you clicked.  
  
Right click on the object and select Properties to bring up the Value Box dialog box. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 366 

 
  
From the Value Box dialog box you can set the following 
  
o Type 

  
o Alignment 

  
o Font Size 

  
o Colors. 

Type 

The type of value object being created 
  
Edit (current) value  
The field is configured for the editing process. 
  
Old value 
The field is configured to display the old value of the controller variable being edited. 
  
Min (minimum) value 
The field is configured to display the minimum allowable value that has been programmed for 
the controller variable being edited. 
  
Max (maximum) value. 
The field is configured to display the maximum allowable value that has been programmed 
for the controller variable being edited. 

Alignment 

Specifies the alignment of the different value objects. Possible options are: Left, Center, Right 
and Default. 

Font Size 

Select the font size to be used with the value object. 
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Colors 

The Background and Foreground controls within the Colors area let you specify the 
background and foreground colors for the value object. 

4.9.5 Customize 

Customize 

 
  
The Customize dialog box (accessible under Tools - Customize or by clicking the Customize 
button from View - Toolbars) allows you to customize toolbars, commands, and tools within 
EH-View. 
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Toolbars 

Toolbars 

 
  
Lists the various toolbars displayed for the current project. These may include the following: 
  
o Primary toolbar - typically provides shortcuts to commonly used Windows -type 

commands. 
  
o Secondary toolbar - typically provides shortcuts to EH-View project-level commands 

  
o Full Screen toolbar - typically provides shortcuts to viewing preferences 

  
o Tools toolbar - typically provides shortcuts to user-specified tools 

  
o TouchScreen toolbar - typically provides shortcuts to touchscreen-specific commands 

  
Commands available from the Toolbars dialog box include: 
  
o Toolbar Name 

   
Shows the name of the selected toolbar. 
  
  
o Show Tooltips 

   
Provides a short description of a toolbar icon when the cursor pauses above the icon. 
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o Cool Look 

   
Gives the buttons on the toolbars an invisible edge, making for a smoother appearance on the 
toolbars. 
  
  
o Large Buttons 

   
Makes the buttons appear twice as large as normal for easier viewing and use. 
  
  
o New 

   
o Reset/Delete 

   
The Reset button returns the toolbars to their default state. 
  
If you have added any toolbars, the Reset button becomes a Delete button so that user-added 
toolbars can be removed. 
  
  
o Default 

  
Click the Default button to align and dock the toolbars to the installed state. It also reloads all 
buttons on the toolbar. 
  

Toolbar Name 

Shows the name of the selected toolbar. 

Show Tooltips 

Provides a short description of a toolbar icon when the cursor pauses above the icon. 

Cool Look 

Gives the buttons on the toolbars an invisible edge, making for a smoother appearance on the 
toolbars. 

Large Buttons 

Makes the buttons appear twice as large as normal for easier viewing and use. 

Reset Delete  

The Reset button returns the toolbars to their default state. 
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If you have added any toolbars, the Reset button becomes a Delete button so that user-added 
toolbars can be removed. 

Default 

Click the Default button to align and dock the toolbars to the installed state. It also reloads all 
buttons on the toolbar. 

Commands 

Commands 

 
  
This section lets you customize the buttons and descriptions of various categories of items. 
  

Categories 

Lists the various toolbars onto which the various commands are grouped. 
  

Buttons 

The icons for the currently highlighted toolbar category are shown. Drag a button to any 
toolbar. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 371 

Description 

Displays a description of the activity performed by each button on a toolbar. Select a 
category, then click a button to see its description. 
  

Tools 

Tools 

 
  
The tools tab allows you to have the possibility to launch external applications from within 
EH-View. 
  
Commands in this tabinclude: 
  
o Menu Contents, 

   
o Command, 

   
o Arguments, and 

  
o Initial Directory. 

New 

Inserts a new tool into the list of Menu Contents and the Tools menu. 
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Delete 

Deletes a tool from the list of Menu Contents and the Tools menu. 
  

Move Up 

Rearranges the list of Menu Contents and the Tools menu so that the selected tool is moved 
up one position. 
  

Move Down 

Rearranges the list of Menu Contents and the Tools menu so that the selected tool is moved 
down one position. 
  

Menu Contents 

 
  
  
This section of the dialog allows you to define New Tools, to Delete already existing ones, to 
move one tool up (Move Up) or down (Move Down) in the tools list.  
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Command 

 
  
This area of the dialog allows the user to specify the full file name of the application to be 
launched. Press the "..." button to look  in the file system for the application executable file. 
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Arguments 

 
  
Use this line to enter the optional parameters (command line parameters) that have to be 
passed to the application. 
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Initial Directory 

 
  
Use this optional field to specify the initial working directory (folder) in which the application 
is to be launched.  Press the "..." button to look  in the file system for a suitable directory. 
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4.9.6 Options 

Options 

 
  
Selection Options from the Tools menu brings up the Layout Options dialog box. This dialog 
box contains two tabs, General and Layout. 
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General 

 
  
The General tab allows you to specify if the if the page names have to be displayed or not by 
the panel. 
  
The "Show page names in panel font" option allows you to show the page names with the 
panel font inside the Page Options dialog. 
  
  
The "Draw button shading..." option allows you to control if buttons inside bitmaps or custom 
touch cells have to be shaded or not. 
  
The  "Interpolate character shapes..." option controls how the character shapes created with 
previous version of EH-View are to be converted into the new  graphic format. By default the 
option is on, if you get a bad conversion, try to disable it and repeat the operation. 
  
The "Enable all languages..." controls how the multilanguage texts created with previous 
version of EH-View are to be converted into the new  graphic format. By default the option is 
on, i.e. all languages are enabled, otherwise disables the text object for languages with empty 
texts. 
  
When the “On Designer Startup open the last used project” option is checked Designer will 
load at at start up the last used project automatically.  
  
Using the “Select default project directory” you can specify the default project directory 
where the Designer files are stored 
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Layout 

Layout 

 
  
The Layout tab allows you to control the Grid and the Text Entry behaviours. 
  

Grid 

Grid 

The options under the Grid section let you display a grid on the screen, align items with the 
grid, and set the spacing of the grid. 
  

Show Grid 

Check this box to display a grid on the screen for the current project. 
  

Snap to Grid 

Check this box if project items are to align with the grid. 
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Spacing 

The grid spacing may be based on character size, or you may set a custom grid size by setting 
the number of pixels for the grid in both the X and Y directions. 
  

Text Entry 

Check the Word Wrap box under Tools - Options to enable word wrapping, which 
automatically continues a sentence on additional lines if it does not fit on the current line. If 
word wrapping is not selected, then the portion of any lines that are too long for the display 
will not be viewable. 
  

4.9.7 Advanced 

Advanced 

Commands in the Advanced submenu on the Tools menu include: 
  
o Format SSFDC 

   
o Erase Protocols in Panel 

   
o Erase NiceFonts in Panel 

  
o FW Rescue Mode 

  
o Validate Project Data  

  
o Connect to Tags 

  
o Swap Protocols 
o   

Format SSFDC 
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The SSFDC card comes formatted for use inside of a EH-HMI panel. If it becomes necessary 
to format the SSFDC card, the Format SSFDC command can be used. 
  
This refers to a special feature that allows you to format the panel memory card using the 
UniLOD programmer. It is an external device for memory card programming via PC parallel 
port. 
  

Erase Protocols in Panel 

From the point of view of the EH-HMI panel a project consists of: 
  
o project data 

  
o graphics (optional) 

  
o enhanced fonts (optional) 

  
o Keypad Designer keyboards (optional) 

  
o protocol or communication driver 

  
This command allows to you to delete, via the serial line link, ONLY the protocol part of the 
project. Without the protocol a panel cannot start in Operation Mode. 
  

Erase NiceFonts in Panel 

From the point of view of the panel Nice Fonts consist of files downloaded to the panel 
memory card. This command allows you to delete them via the serial line link. 

FW Rescue Mode 

EH-HMI panels use the boot file that resides inside the internal FLASH memory to load 
firmware code. When the internal boot file is corrupted or missing, the firmware file  cannot 
be loaded and the EH-HMI panel display will remain off.  
   
In this condition, it is necessary to use the FW Rescue Mode command to download a new 
copy of the boot file. 
  
Note:  Make sure that the Firmware Download flag on the Settings index tab within the Panel 
Setup dialog box is enabled.  Otherwise the FW Rescue Mode command will be hidden. 
  
After connecting the serial line of the EH-HMI panel to the computer, simply click on the FW 
Rescue Mode command from the Tools menu and follow the instructions that will appear on 
the computer. 
  
The rescue procedure will ask you to turn the EH-HMI panel off, then back on. 
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When communication is established, the rescue procedure will check the boot files that are 
inside the firmware directory on the computer and prompt you to begin downloading the most 
recent version. 
  
After completing these operations, the EH-HMI panel will restart. 
  

Validate Project Data 

Validate Project Data is a command introduced to verify the consistency of a Designer project 
file and automatically fix any known problem. When a not valid object is found and there is 
no way for an automatic fix, the object is deleted from the project. A detailed log file with the 
list of the changes applied to the project is also generated and stored as "ProjectFix.log" into 
the working folder. 
  
Warning: 
Be sure to save a backup copy of your project before run this command. 

Connect to Tags 

The Connect to Tags command connects the active project with the selected tags database. 
This command checks the controller reference of each field in the project and compare it with 
the logical addresses from the selected tag dictionary linking the first hit in the tag database. If 
the controller reference is not found in the tags database, then the field will not be tied to any 
tag. If the same controller reference is found in the tags database twice, the second instance 
will never be tied. 
  
Note: 
This command is active only when no tags database is already linked to the active project. 

Swap Protocols 

Swap Protocols command is available only when the current project is double protocol 
enabled. Using this command you can swap the order of the Primary and Secondary drivers. 
This will phisically resutl in a port swap on the panel between the two channels. 
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4.9.8 Replace Images 

The Replace Image dialog box provides an easy way to work with the images of the currently 
opened project. 
  

 
  
The user is provided with three toolbar buttons (i.e. Replace image, Replace all images, Edit 
Image)  in order to manipulate/replace  the images in the project. All the three commands can 
be invoked via context sensitive menu as shown below. 
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Replace image 
  
When only one image of the project has to be replaced with another image Replace image 
command can be used. Once this command is invoked the open file dialog is shown from 
which the user can select the new image. 
  
Replace all images 
  
By using this command the user can change all the images of the project at a single stretch. 
The Replace All command first  gets the image directory and once the directory is selected by 
the user the below Confirm Images dialog is shown. 
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 If there any discrepancy in images the concerned image can be individually replaced using 
Replace Image command. 
  
Note :- By checking the Des5 compatibility dithering option user can simulate the Des5 
dithering in EH-View.  
  

4.10 Window Menu 

4.10.1 Window Menu 

This chapter provides information about the Window menu. The Window menu provides 
choices in the appearance of project windows. 
  
o New Window 

   
o Cascade 

   
o Tile Horizontally 

   
o Tile Vertically 
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4.10.2 New Window 

The New Window command opens a new, blank window. This option is currently disabled. 
  

4.10.3 Cascade 

Selecting Cascade from the Window menu displays all open windows in an overlapping 
fashion, with each new window opening lower and to the right of the previous window.  
  

4.10.4 Tile Horizontally 

Choosing Tile Horizontally from the Window menu displays all open windows 
simultaneously on the same screen, with each new window displayed below the other open 
windows. 
  

4.10.5 Tile Vertically 

Choosing Tile Vertically from the Window menu displays all open windows simultaneously 
on the same screen, with each new window displayed beside the other open windows. 
  

4.11 Application Menu 

4.11.1 Application Menu 

This section provides information on the Application  menu. The Application menu is the one 
appearing when the user right-clicks on the title area and provides access to familiar 
Windows  commands for management the application itself. 
  
o Restore 

   
o Move 

   
o Size 

   
o Minimize 

   
o Maximize 

   
o Close 
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4.11.2 Restore 

The Restore command on the EH-View menu restores the project page to a previous 
appearance. 
  

4.11.3 Move 

The Move command on the EH-View menu makes it possible to move the EH-View project 
screen for placement on the overall EH-View screen. 
  

4.11.4 Size 

The Size command on the EH-View menu lets you easily resize the EH-View project screen 
within the overall EH-View screen. 
  

4.11.5 Minimize 

The Minimize command on the EH-View menu makes it possible to minimize the EH-View 
project screen to an icon within the overall EH-View screen. Minimize buttons in the top right 
corners of screens perform the same action. 
  

4.11.6 Maximize 

The Maximize command on the EH-View menu lets you maximize the EH-View project 
screen to take up all possible space within the overall EH-View screen. Maximize buttons in 
the top right corners of screens perform the same action. 
  

4.11.7 Close 

The Close command on the EH-View menu closes the current EH-View project. You will be 
prompted to save the project if necessary. Close buttons in the top right corners of screens 
perform the same action, as does simultaneously pressing the Ctrl+F4 keys. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 387 

5 Workspace 

5.1 Workspace 

The status bar to the left of the main EH-View screen provides information on project pages 
and lists various graphics and objects that can be placed in a project. 
  

 
  
If Workspace is checked in the View menu, the workspace will be visible. The Workspace is 
composed of three tabs: Graphics, Objects, and Project. 
  
The default position of the workspace is to the left of the main EH-View screen, however the 
workspace can be moved anywhere on the EH-View screen. To hide the workspace, uncheck 
it under the View menu. To make it visible again, simply check it again. 
  
Note:  Right-clicking in the frame of the workspace box brings up a number of options for 
viewing the workspace. Select Allow Docking to dock the workspace against any of the four 
sides of the application. If the check box is removed, then the workspace will act as a mini-
window, which can be placed anywhere and resized. On the other hand, clicking Float in 
main window causes the workspace to occupy the entire application window and minimize 
the graphics view. 
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5.2 Graphics 

 
  
The project workspace can display commonly used bitmap graphics that can be easily 
imported into a project. 
  
Click on the Graphics tab at the bottom of the workspace to view the graphics selections. 
Select a category of graphic (blowers, pipes, tanks, etc.) from the pull-down list at the top of 
the workspace. Commonly used graphics for that class of item will be shown in the 
workspace. Simply click on the selected item and drag it over to the place on the project page 
where it is to be inserted. 
  
As the graphic is dropped into place the Bitmap Settings dialog box appears so that any 
necessary changes can be made to the graphic. Upon clicking OK, the graphic will appear on 
the project page. Should any further changes be necessary, click on the graphic once to select 
it (if it is not already selected), then right-click on the graphic and select Edit to go to the 
Bitmap Editor. 
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5.3 Objects 

 
  
The project workspace can display commonly used objects that can be easily imported into a 
project. Click on the Objects tab at the bottom of the workspace to view various objects. 
Select a category of graphic (custom touch cells, dynamic graphics, meters, buttons, etc.) 
from the pull-down list at the top of the workspace.  
  
Commonly used objects for that class of item will be shown in the workspace. Simply click 
on the selected item and drag it over to the place on the project page where it is to be inserted. 
Should any changes to the object be necessary, click on the graphic once to select it (if it is 
not already selected), then right-click on the graphic to go to the appropriate Properties dialog 
box. 
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5.4 Project 

5.4.1 Project 

 
  
The project workspace can be used to display a tree of the currently open project. 
  
Click on the Project tab at the bottom of the workspace to view various all the pages in that 
project. All pages are listed by title. To open a page in the project, simply double -click on that 
page in the project workspace. 
  

5.4.2 Data Transfer 

The Data Transfer feature lets you exchange data between two controllers or between 
registers within a single controller. A job refers to one complete data transfer. The data 
transfer configuration allows you to set the job execution mode, the source and destination 
references, the number of words to transfer. 
  
Right click on Data Transfer item to add a new Data Transfer Job 
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Destination Reference 
Clicking the "..." button under Destination Reference brings up the Data Field Properties 
dialog box where you can specify the register to be written to. 
  
Job Execution Mode 
The Job Execution Mode box lets you select how the data is transferred, either On Request or 
In Cycles. 
  
Number of Words to Transfer 
The maximum number of words for each job is 30. 
  
Source Reference 
Clicking the "..." button under Source Reference brings up the Data Field Properties 
dialog box where you can specify the register to be read. 
  
To Delete a Data Transfer Job simply right click on Data Transfer item and select Delete Job 
from the contextual menu. 
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6 Basics 

6.1 Basics 

This section provides: 
  
o a Quick-Start tutorial, 

  
o a description of the EH-View screen, 

  
o instructions on how to configure EH-View to create a project, 

  
o instructions on how to create a new project using simple U/I elements and simple I/O 

fields, 
  

o instructions on setting up your project to generate a printed report, and 
  

o how to upload and download your project. 
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6.2 EH-View Screen 

6.2.1 EH-View Screen 

The EH-View software presents a screen that has elements familiar to anyone used to 
Windows -based software.  
  

 
  
A title bar across the top of the screen shows the program, file name, and page number. 
Below the title bar is a menu bar with pull-down menus. Below the menu bar are toolbars 
with various icons that are shortcuts to commonly-used commands. A workspace in the lower 
left provides a project overview. The project screen in the lower right is the working area 
where project pages are viewed during development. 
  
As is common for Windows -based software, there are Minimize, Maximize and Close 
buttons in the top right corner. 
  
The appearance of EH-View may be customized to your particular needs by using the 
commands in the View menu. 
  
o Menu Bar 

  
o Toolbars 

   
o Workspace 

  
o Project Screen 

  
o Status Bar 

   
o Right-Click Menus 
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o Tooltips 
  

o Getting Help 

6.2.2 Menu Bar 

The menu bar across the top of the EH-View screen lists the pull-down menus available in 
EH-View. 
  
These include File, Edit, View, Insert, Page, Project, Transfers, Tools, Window, and Help. 
Each of these menus and the commands contained under them are described in the reference 
material. 
  

 
  
A EH-View menu may also be present on the toolbar. Depending upon the selections made 
under the Windows menu, the EH-View menu may appear at the top of the individual project 
screen rather than with the other menu selections across the top of the EH-View screen. 
  
Various features will be enabled/disabled depending on the panel model and firmware version 
of the panel that you have selected for the project. When you start a new project the 
previously used panel (in the previous EH-View session) is used as default. 
Basically, menu items reflect the available functionality of the current panel for which you are 
defining a project. 
  

6.2.3 Toolbars 

Various toolbars may be displayed on the application area (in proximity of the borders). 
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These may include the following: 
  
o Primary toolbar 

  
Typically provides shortcuts to commonly used Windows -type commands. 
  
o Secondary toolbar 

  
Typically provides shortcuts to EH-View project-level commands. 
  
o Full Screen toolbar 

  
Typically provides shortcuts to viewing preferences. 
  
o Tools toolbar 

  
Typically provides shortcuts to user-specified tools. 
  
o TouchScreen toolbar 

  
Typically provides shortcuts to touchscreen-specific commands. 
  
The appearance of the toolbars may be changed using commands under View - Toolbar. 
As is normal with Windows  applications, toolbars can float or be docked. To undock a 
toolbar, click on the double bars on one edge of the toolbar (or simply double -click on the 
toolbar) and drag the toolbar to any position on the screen. To dock the toolbar, drag the 
toolbar so that the double bars on one edge touch the edge of the screen. 
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6.2.4 Project Screen 

 

 
  
The project screen is the main work area where project pages are created and modified. 
  

6.2.5 Right-Click Menus 

Right-click menus are available to keep commonly-used commands conveniently close at 
hand. Simply left-click on an item or object on a page to select it, then right-click to activate 
the right-click menu for that item or object. Menus are customized for the particular item or 
object selected, but common menu items include: 
  
o Cut 

  
The Cut command removes the selected item from the current page and places it on the 
Windows  clipboard. This action can also be activated by pressing the Ctrl+X keys. 
  
o Copy 

  
The Copy command makes a copy of the selected item from the current page and places it on 
the Windows  clipboard. This action can also be activated by pressing the Ctrl+C keys. 
  
o Paste 

  
The Paste command places items from the Windows  clipboard onto the current page at the 
current position of the cursor. This action can also be activated by pressing the Ctrl+V keys. 
  
o Select Covered Object 

   
If one object is on top of another, this command selects the object underneath. This is handy if 
it is difficult to left-click on the bottom item to select it. 
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o Order 

   
Sets the position of an object in relation to other objects that are covering it and/or covered by 
it 
  
o Align 

  
 If there are two or more currently selected objects/items, this command allows to align them. 
  
o Group / Ungroup 

  
If there are two or more currently selected objects/items, these command allow to respectively 
group / un-group them. Group will always be created in the current layer. The current layer 
name is always displayed in the edit control part of the active layer combo box. 
  
o Edit 

  
Brings up the Bitmap Editor. 
  
o Properties 

Brings up the Properties dialog box appropriate for that type of object or item, where settings 
for the object or item can be changed. 

6.2.6 Tooltips 

As part of the EH-View software's help system, help prompts are available to identify the 
various icons. These help prompts are called tooltips. 
  
To view a tooltip, simply place your cursor over an icon and hold it there for a few seconds 
without clicking. A small box will appear with a brief description of the icon. 
  
Tooltips are enabled by default. If you should need to disable or enable tooltips you may do 
so under Tools - Customize. On the Toolbars tab is a checkbox for Show Tooltips. 
  

6.2.7 Getting Help 

If you are unsure about the meaning of an item or unsure what to do next, help is never far 
away. Many dialog boxes include a Help button, which you can press to read information 
about that dialog box. 
  
Help text is also always available under the Help menu. 
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6.3 EH-View Setup 

6.3.1 EH-View Setup 

The first thing you should do upon starting the EH-View software is to configure EH-View to 
work with your particular panel and controller. 
  
In Panel Setup you input all the parameters such as panel model, firmware version, available 
memory, etc., before creating any projects. Then use Configure Controller to specify the type 
and model of controller to be used. 
  
Note:  The panel must be in Configuration Mode in order to communicate with the PC. 
    

6.3.2 Transfer Settings 

To verify the transfer settings between the PC and your panel, check under Transfers - 
Options - Serial ports for communication parameters between EH-View and the panel. 
  
All EH-HMI panels are capable of communicating with a PC at a speed of at least 9600 baud. 
However, several panels will communicate at speeds of 19,200 baud and 38,400 baud. With 
some Pentium-based computers, a speed of 19200 baud may prove to work more efficiently 
than 38400 baud. 
  
Set the baud rate, parity, data bits and stop bits to be used in communication between the 
panel and the PC. To change the settings, click on the selection arrows and pick a different 
setting from the pull-down lists  For further information on these options, see the Port 
Settings section. 
  
Note:  The communication parameters that you set up here need to match the communication 
parameters of your modem. 
  
Note:  Check the Use modem check box under Transfers - Options - Serial ports ONLY if you 
are using a modem to communicate between your PC and the panel. This is not necessary if 
you have a cable between the PC and panel, thus the Use modem box should not be checked. 
  
Note: Sometimes other programs will "take up" your PC communications port. For example, 
if you have a Palm Pilot, it automatically loads some files upon power up of your computer 
that "take up" the communications port. In the bottom right hand corner of your computer 
monitor, make sure that all programs that may take up a communication port are closed. 
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6.3.3 Controller Selection and Setup 

Controller Selection and Setup 

Before creating your first project using the EH-View software, it is worth checking the 
controller setup to make sure that it reflects the controller that you will be using. 
  
Using the Get Panel Resources command from the Transfers menu will most likely set the 
controller settings to be compatible with your system, but sometimes changes are necessary. 
  
o Configure Controller 

  
o Controller Setup 

Configure Controller 

Different controllers require different parameters in order to communicate properly with the 
operator interface panel. 
  
Verify that the controller family (i.e., Allen Bradley, Mitsubishi, etc.) matches that of your 
selected controller by choosing Configure Controller from the Project menu. Make sure that 
the listed controller is the type of controller driver that you will be using. If it is not, click the 
"..." button to select a different driver from a list. 
  

Controller Setup 

After selecting a controller by clicking the "..." button under Project - Configure Controller, 
you should verify that the controller model is correctly specified. This can be accomplished 
by clicking the Controller Setup button from the Select Controller dia log box. This will bring 
up the Controller Setup dialog box where you can select the specific controller model that is 
being used. 
  
The communication parameters are set automatically when the controller selection is made. 
However, if there is a need to change the default settings, you may press the Comm button in 
the Controller Setup dialog box (available for certain controllers). This will bring up the 
Communications Parameters Setup dialog box where you can check the parameters used in 
panel-to-controlle r communication, including baud rate, parity and stop bits. To change the 
settings, click on the selection arrows and pick a different setting from the pull-down lists. 
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6.3.4 Panel Selection and Setup 

Panel Selection and Setup 

Before you begin working on a particular project, you need to specify the type of display that 
your panel contains. The physical size of the screen, as well as its type (backlight LCD, 
passive color) must be specified. 
  
Failure to do this may result in the loss of text and data when you attempt to download the 
project file into the panel. This can be done automatically using the Get Panel Resources 
command from the Transfers menu, or manually using Panel Setup from the Project menu. 
  
  

Get Panel Resources 

The easiest way to set up EH-View to work with your panel is to use the Get Panel Resources 
command in the Transfers menu. This command prompts the EH-View software to 
automatically retrieve the configuration of the connected panel. This includes the physical 
size of the screen, as well as its type (backlight LCD, passive color). 
  
Note:  In order to use the Get Panel Resources feature, the target panel must be connected to 
the PC, the transfer parameters must be correctly set, and the panel must be in Configuration 
Mode. 
  

Panel Setup 

Panel Setup 

After using the Get Panel Resources feature, it is a good idea to verify the panel settings. 
Select Panel Setup from the Project menu (or click on the Panel Setup icon in the toolbar). 
This brings up the Panel Setup dialog box where you can configure the software for the panel 
that you are using. 
  
You can verify the panel model, memory, and firmware version, specify the time and date 
format that the panel will display, identify the address of an Ethernet board if one is in use, 
specify communication settings, set the panel up for remote passthrough, set time out periods, 
and set panel upload protection, if necessary. 
  
o Panel Model 

  
o Panel Time/Date Settings 

  
o Passthrough Settings 

  
o Miscellaneous Panel Settings 
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Panel Model 

If the correct panel mode l is not shown, you can choose a different panel model from the 
Panel Setup dialog box on the Project menu. 
  
From the Panel Model tab click on the down arrow located to the right of the Panel Model 
window. A drop-down list will appear that shows the available panels that can be selected. 
Single-click the left mouse button on the name of the panel that you will be using. The page 
editor workspace will change in order to reflect the available screen area on the selected 
model. Similarly, you can change the specified panel memory and firmware if necessary. 
  

Panel Time/Date Settings 

Click on the Settings tab in the Panel Setup dialog box to set the time and date formats. Pick 
the format that you prefer to use in your project from the pull-down lists. 
  

Passthrough Settings 

If you wish to be able to put your EH-HMI panel remotely into either Configuration Mode or 
Operation Mode via a modem, under Mode on the Passthrough tab (under Project - Panel 
Setup) click on the button for Remote Hardware passthrough. Otherwise select Hardware 
passthrough. 
In the Request boxes enter any commands necessary to start or stop remote passthrough 
mode, or to put the panel into Configuration Mode. Likewise, you can enter the response that 
you will receive back from the panel in the Response boxes. 
  
Note:  Your EH-HMI panel must contain firmware version 4.10 or later to use the Remote 
Hardware feature. 
  
Note:  Configuring Remote Hardware passthrough under Panel Setup enables the Remote 
passthrough command on the Transfers menu. 
  
Note:  When remote passthrough mode has been activated, the EH-HMI panel does not 
communicate with the controller and the dynamic data displayed on the screen may no longer 
be correct. It may be useful to inform the user when the passthrough option is active. To do 
so, create a numeric/ASCII, bargraph, or message data field under Insert - Data Fields. Set the 
Reference type as Variable, click the "..." button, and select the Control Variable Data Type 
as Passthrough Status. This variable can take on two values; zero meaning that passthrough is 
not active, one meaning that passthrough is active. 
  

Miscellaneous Panel Settings 

Under the Miscellaneous tab of the Panel Setup dialog box (in the Project menu) you can 
configure several different panel parameters. Selecting any of the checkboxes enables the 
entry boxes associated with those selections. 
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The Panel Upload Protection feature lets you password protect the project file so that 
unauthorized uploads cannot occur. You can enter a case-sensitive password of up to eight 
characters. 
  

6.4 Creating a Project 

6.4.1 Creating a Project 

Before starting a new file for a new panel, please make sure that you have configured EH-
View to work with the particular panel and controller that you will be using. See the sections 
on Transfer Settings, Controller Selection / Set Up, and Panel Selection / Set Up for 
instructions on performing these tasks. 
  
o Creating a New File  

  
o Selecting a Font 

  
o Inserting Page Objects 

  
o Saving a Project File  

  
o Memory Used by the Project File  

6.4.2 Creating a New File 

To create a new project, select New from the File menu, click on the New icon in the toolbar, 
or press the Ctrl+N keys. 
  
This opens the New File dialog box. Enter a name for the new project and select the file 
location on the PC where the project file  is to be stored. Click on an icon to identify the type 
of project file to be created. Click OK. 
  
Note:  Unless otherwise specified, EH-View files are assumed to have the .dpr extension. 
  

6.4.3 Selecting a Font 

To choose a new panel font, select the Panel Font icon from the toolbar or choose Edit - Fonts 
- Panel Font.  
  
The Select Font dialog box appears with a drop-down list showing the available fonts for the 
current panel. Click on name of the font to be used. Select a font size. 
  
Note:  When the area defined for a text box is small, only the sizes that can fit inside the 
selected area are enabled. 
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6.4.4 Inserting Page Objects 

Insert text on the page by clicking on the screen and typing the text. 
  
Data fields, touch cells, etc., can be placed on the page by using the commands on the Insert 
menu. 
  
Graphics and objects may be easily placed on the page by dragging them from the workspace. 
Simply click on a tab in the workspace, click on a graphic or object, and drag it onto the page. 
Once placed on the page, you may move it, align it, resize it using the "handles" around it, or 
edit it. 
  

6.4.5 Saving a Project File 

To save your new project, select Save from the File menu (or click on the Save icon in the 
toolbar). 
  
The cursor will be momentarily replaced with an hourglass while the file is being saved. If the 
application has not been named, the Save As dialog box will appear. 
  
The Save As dialog box can also be used to save your project under a different name. This 
dialog box shows the current directory path and the current filename. A new name and path 
may be entered, or the default parameters may be accepted. If the extension is omitted, ".dpr" 
is assumed. If a file of the same name already exists in the selected directory, you will be 
prompted to confirm the Save As operation in order to overwrite the existing file. 
  

6.4.6 Memory Used by the Project File 

You can determine how much memory is used by the current project file by selecting 
Memory Use from the Project menu. 
  
A dialog box will appear that contains information on the amount of memory that is used by 
the project file, how many bytes of recipe data are contained within the project file and the 
amount of memory used by the graphic information (bitmaps and touch cells) in the project 
file. 
  

6.5 Printing 

You can use EH-View to configure your EH-HMI panel to print reports either cyclically or 
upon a trigger event. You can define report formats and timetables upon which a report is 
printed, configure a key or touchcell to print a report, or request a printout by using the 
Interlock Mailbox. 
  
Note:  In order to use these print features, your panel must contain firmware version 4.10 or 
higher. 
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Information on  setting up a new printer, printing reports, and a printer setup example are 
provided. 
  

6.6 Project Upload and Download 

When your project is completely designed, you need to transfer it from your PC to your EH-
HMI panel. A data transfer from your PC to a EH-HMI panel is termed a download. 
  
To download data, select Download from the Transfers menu, click on the Download icon in 
the toolbar, or press the F2 key. 
  
Note:  The panel must be in Configuration Mode in order for the download procedure to 
work. 
  
It is also possible to download a project to an SSFDC memory card, if you have such a card 
installed in your system. To download to an SSFDC card, select Download to SSFDC from 
the Transfers menu or press the F6 key. 
  
From time to time, you may wish to transfer an existing application from a EH-HMI panel to 
your PC. This is termed an upload. To upload data, select Upload from the Transfers menu, 
click on the Upload icon in the toolbar, or press the F3 key. 
  

6.7 Simple Data Fields 

Data fields are those items that the EH-View software uses to display information from the 
controller. These dynamic data items come in the form of numeric fields (which can be 
displayed in numeric format or in ASCII format), bargraphs, message fields, attributes, 
dynamic graphics, time, and date fields. 
  
These fields can be created by either selecting one of the seven types of fields from the Data 
Fields submenu in the Insert menu or by clicking on the various data field icons in the toolbar. 
This brings up the data Field Properties dialog box for the appropriate data field type. 
  
For most data fields it is possible to specify the size and style of the data field, as well as the 
controller reference location. Depending upon the type of data field, it may be possible to 
specify the data format, the range, and whether not to apply scaling to the data. 
EH-View uses placeholders to indicate the presence of data fields on a project page. These 
placeholders include: 
  
Data Field Type Placeholder 
Numeric  9's 
ASCII A's 
Bargraphs sample bargraph 
Message Fields M's 
Attributes None 
Dynamic Graphics sample graphic  
Time Fields 24:00:00 (depending on time format) 
Date Fields dd/mm/yy (depending on date format) 
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A number of examples are available to help you better understand the data field creation 
process. 
  
o Numeric Data Field Example  

  
o ASCII Data Field Example  

   
o Bargraph Example  

  
o Message Field Example  

  
o Attribute Example  

   
o Dynamic Graphics Example 1 

  
o Dynamic Graphics Example 2 

  
o Time Data Field Example  

  
o Date Data Field Example  

6.8 Simple Touch Cells 

A touch cell allows a panel user to interact with the panel. The user is able to touch a panel in 
an indicated position and receive a visual cue. The various types of touch cells available and 
their functionality are: 
  
o Panel Key Button:  Used for creating a touch cell as a panel key (i.e., Enter). Panel keys 

represent all of the function keys, numeric keys, and arrow keys, as well as the help key, 
the clear key, the enter key, the +/- key, and the decimal point key. An example of 
creating a panel key button is provided. 
   

o ASCII Key Button:  Used for creating a touch cell as an ASCII character. An example of 
creating an ASCII key button is provided. 
   

o Push Button:  Used for creating a touch cell as a push button. These push buttons mimic 
mechanical push buttons in that one logic value represents open contacts and another 
logic value represents closed contacts. An example of creating a push button is provided. 
   

o Illuminated Push Button:  Used for creating a touch cell as an illuminated push button. 
The only difference between an illuminated pushbutton and a pushbutton is that the face 
of the illuminated pushbutton can reflect the status of a bit in the PLC. An example of 
creating an illuminated push button is provided. 
   

o Selector Switch:  Used for creating a touch cell as a 2, 3 or 4 position selector switch. An 
example of creating a selector switch is provided. 
   

o Indicator Light:  Used for creating an indicator lamp. An example of creating an 
indicator light is provided. 
  

o Generic Command Button:  Used for creating a touch cell as a panel key (i.e., Enter), 
macro command (i.e., show alarm list), or ASCII character. An example of creating a 
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generic command button is provided. 
  

o A touch cell can be used to write to a controller. Keyboard Macro Editor commands 
make this an easy task. An example of doing this is provided. 

  
To insert a touch cell click the appropriate touch cell icon on the toolbar or select a type of 
touch cell from the Touch Cells submenu in the Insert menu, then use the cursor to define the 
area in which the touch cell is to be placed. A dialog box will appear where the touch cell 
may be configured. 
  

7 Advanced 

7.1 Alarms 

7.1.1 Alarms 

Enhanced Mode alarms offer a maximum of 1024 alarms, which are broken into 4 blocks 
(there are some models which offer 256 total alarms in 4 blocks). The lower the numerical 
value assigned to the alarm, the higher its priority. Each block can be addressed to any 
register within the controller's memory. Each alarm is referenced to a bit in the controller. 
Whenever a bit goes high, the respective alarm message will be displayed. 
  
To use alarms, select Alarms from the Project menu. Instructions on configuring alarms, 
alarms and the Keyboard Macro Editor, alarms safety issues, and alarms examples are given. 
  
Note:  Compatibility Mode alarms are not supported in EH-View. 
  
Note:  Beginning with firmware version 4.22, you can define an alarm message up to 40 
characters in length for all EH-HMI operator interfaces that have a 20-character display. In 
these cases, the complete message associated with an alarm will take up three (3) lines on the 
display. The first line will be for time and date indication, the second and third lines will be 
for the alarm message itself. 
  

7.1.2 Configuring Alarms 

Alarms are configured using the Alarms command from the Project menu. 
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The Alarms dialog box allows you to set the alarm block options, enter alarm messages, and 
set alarm options. 
  
Each alarm is associated with a message and a trigger. You can specify whether alarms need 
to be acknowledged, displayed, or printed. 
  

7.1.3 Alarms and the Keyboard Macro Editor 

Alarm behaviour may be set using the Keyboard Macro Editor from the Project menu. 
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From the All Pages and Page n tabs the command Show Alarm List is available.  
  

 
  
The Alarms tab contains the following commands: 
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o Go to page 

   
o Write to Controller 

   
o Toggle relay 

   
o Wait  

   
o Page Mode 

   
o Acknowledge alarm 

   
o Scroll Up 

   
o Scroll Down 

   
o Print alarms 

   
o Go to alarm page 

   
o Step Control Variables 

   
o Acknowledge all alarms 

7.1.4 Alarms Safety Issues 

Alarms notify the panel user that a trigger event has occurred. This trigger event may also be 
linked to other control sensors or monitors. The following considerations should be kept in 
mind when dealing with alarm issues. 
  
Warning:  The EH-View alarm system should not be the primary warning system for 
circumstances that could result in physical injury or machine damage. 
  
Warning:  Care must be exercised so that alarm messages do not cover important areas of the 
panel and impede the user's understanding of the situation. 
  
Warning:  Emergency stop buttons and controls critical for safe operation of a system should 
not be placed on a screen where they may be inaccessible during emergency situations. These 
controls should always be hard-wired. 
  

7.2 Automatic Firmware Upgrade Procedure 

7.2.1 Automatic Firmware Upgrade Procedure 

New EH-HMI panels that contain the T2000 board (FW58 units) are able to accept new 
firmware files through the serial line or through the SSFDC memory card. 
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For these panel models, the firmware files can be stored in the SSFDC memory card.  There 
are four kinds of firmware files that can be stored in the SSFDC memory card.  They are 
called “Boot”, “Firmware”, “MIPS Code” and “MIPS service” files. 
  
A copy of the Boot and the Firmware files is also stored inside the internal panel FLASH 
memory.  Storing a copy of these files inside the SSFDC card is not mandatory, but it is 
necessary when the internal FLASH memory must be updated. 
  
A copy of the MIPS Code file must always be stored in the SSFDC memory card.  In fact, this 
code is always loaded from the SSFDC memory card when the EH-HMI panel switches from 
the Configuration Mode” state to the Operating Mode state. 
  
MIPS Service is not necessary for normal panel operation.  It is necessary only for running in 
Service Mode. 
  
Information is provided on the following topics: 
  
o Procedure to Upgrade the Internal Flash Memory 

  
o Check Firmware Versions 

  
o Firmware Files Directory 

  
o FW Rescue Mode 

7.2.2 Procedure to Upgrade the Internal Flash Memory 

To check the firmware versions that are stored inside the panel memory, it is necessary to put 
the panel in Configuration Mode and hold the Up-Arrow key for 2 seconds.  A table similar to 
the one shown below will appear: 
  
RELEASE.VERSION UPGRADE 
FLASHSSFDC 
Boot04.30W04.35D.0001 
Fw04.35D04.35D 
Press Enter to continue... 
The FLASH column shows the active firmware version.  The column SSFDC shows the 
version stored inside the SSFDC card.  After pressing the ENTER key, the message shown 
below will appear. 
Press Up Arrow to Update... 
...or wait to leave unchanged 
  
Pressing the Up Arrow key will cause the firmware upgrade procedure to start.  Waiting for 2 
seconds without pressing any keys will cause the procedure to abort without substituting the 
active firmware files. 

7.2.3 Check Firmware Versions 

EH-View will enable the download features, accessible from the Transfers menu, when a 
panel model with the T2000 board (FW58 unit) is detected.  Note that this menu item is not 
visible when the selected panel does not support the download features. 
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Download features can be enabled manually from the Settings index tab within the Panel 
Setup dialog box.  Manual settings are necessary when a real panel is not physically 
connected to the PC and a Get Panel Resources command cannot be executed. 
  
Correct setting of the Firmware Download flag is necessary to give EH-View the necessary 
information required to correctly calculate the SSFDC memory used, taking into account the 
size of the firmware files. 
  

 
  
After exchanging information with the panel to detect the version of the firmware files that 
are inside the SSFDC memory card, the above dialog box is displayed.  The left column 
displays the versions of the firmware files that are located in the SSFDC memory card.  The 
right column displays versions of firmware files ONLY if the user’s computer contains a 
newer version.  If a newer version is not detected, <Do not update> will be displayed. 
  
Update 
This will start the download procedure.  It does nothing when all of the EH-View fields 
contains the <Do not update> strings.  Please note that after updating the firmware files inside 
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the panel SSFDC memory, it will be necessary to upgrade the panel’s FLASH memory as 
previously described. 
  
Do not update 
Use this button to exit from this dialog box without updating the firmware files. 
  
Note: EH-View checks the firmware version before beginning any download operation.  
When an old firmware file version is detected inside the panel, the above dialog box is 
displayed to give the user a chance to upgrade the firmware file. 
  

7.2.4 EH-View Firmware Files Directory 

The setup procedure installs a Firmware subdirectory inside the EH-View working directory.  
This directory will contain all the necessary firmware files used by EH-View to check and 
update the panel SSFDC memory card. 
  
New firmware files have to be copied inside this directory to be accessible from EH-View. 
  

7.3 Double Protocol 

7.3.1 Double Protocol 

A single EH-HMI panel can communicate with Controllers simultaneously using different 
communication protocols. Configuring EH-HMI  panels to support such operation is easy. 
  
Multi-protocol support is provided by  the EH-View software, and is natural and easy to learn 
and use.  
  
Different controllers are connected to the EH-HMI panel in different ways. Some are 
connected through a serial line (either RS232, RS422, RS485 or current loop), other through 
an Ethernet-based LAN using UDP/IP or TCP/IP protocol stack, and still other can be 
connected to the EH-HMI only after a custom communication module is plugged into it. 
  
Most EH-HMI models are delivered with two serial ports. The PLC port supports RS232, 
RS422, RS485 and current loop communication. The PC/Printer port supports only RS232 
communication. 
  
The AUX port can be used for various purposes, depending on the type of the communication 
module plugged into the EH-HMI. If this is one of the Ethernet modules (TCM10, SCM11), 
the AUX port is used as the Ethernet port. But other communication modules can be plugged 
in, enabling connecting the EH-HMI to a wide diversity of controllers. 
  
Of course, except for the necessary hardware needed to establish communication to a 
particular controller, an adequate Controller Driver has to be present in the EH-View for 
Windows software. In the multi-protocol configuration case, drivers for both communication 
protocols will have to be available. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 413 

When the EH-HMI communicates with one or more controlle rs using only one 
communication protocol (single -protocol configuration), then, if this protocol is a serial 
protocol, the controllers are connected to the PLC port of the EH-HMI panel. Of course, if the 
protocol is a non-serial protocol (e.g. Ethernet), an adequate communication module must be 
plugged into EH-HMI and then the controllers must be connected to the AUX port. 
  
When configuring the EH-HMI to communicate with controllers using simultaneously two 
communication protocols (multi-protocol configuration), distinction must be made between 
the First Communication Driver (used to communicate using the First Protocol) and the 
Second Communication Driver (used to communicate using the Second Protocol). It is 
important to remember the following rules for serial drivers: 
  
o First Driver always communicates with the controllers over the PLC port 

  
o Second Driver always communicates with the controllers over the PC/Printer port. 

  
Of course, if any of the protocols is a non-serial protocol, its Driver will use the AUX port 
instead.  
  
Although not many, it can be seen that there must be some restrictions due to hardware 
reasons when two communication protocols are used: 
  
o If the Communication Driver is alone using both serial communication ports - the PLC 

and the PC/Printer port - it cannot be used in multi-protocol configurations. 
  

o If two Communication Drivers are both serial, there will be no ports left to connect the 
serial UniNET network. (You can still use the Ethernet-based UniNET, of course.) 
  

o Since only one communication module can be plugged into the Panel, a combination of 
two Communication Drivers, each requiring such a module, cannot be supported. 
   

o As the Ethernet protocol is also supported by a communication module, a combination of 
one Ethernet-based Communication Driver and a Driver requiring any other 
communication module cannot be supported either. 
  

  
Note: Two Ethernet-based Communication Drivers can normally be used simultaneously 
because they will both communicate through the same Ethernet communication module. 
Ethernet-based UniNET can also be used in addition to one or two Ethernet-based 
Communication Drivers. 
  
Information is provided on the following topics: 
  
o Enabling Multiple -Protocol Configuration 

  
o Controllers Setup 

  
o Placing Fields on a Page 

  
o Downloading Uploading and Getting Panel Resources 

  
o Configuring UniNET Networks 
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7.3.2 Enabling Multiple-Protocol Configuration 

After choosing the "Configure Controller..." menu option in the EH-View software, the 
Configure Controllers Dialog Box will pop up. It is used for selecting the communication 
drivers both in single protocol and multi-protocol configurations. 
  
To select the Second Driver check the “Enable Double Protocol” check box. A new text box 
and a button are shown. After selecting particular Driver from the list below, you simple click 
at the adequate “Set” button to set the First or the Second Driver. (To go back to the single 
protocol configuration case, simply uncheck the “Enable Double Protocol” check box.) 
  

 
  
It can be noted that once the “Enable Double Protocol” check box is checked, the contents of 
the list box showing all available drivers may be somewhat changed. After checking the 
check box, only drivers that have the multi-protocol capability enabled are shown in the list 
box. Thus, if there are such drivers installed that do not allow combining with other drivers 
into multi-protocol configurations, these will be excluded from the list and the list will be 
shortened. After un-checking the check box, all the drivers will be re-displayed in the list box. 
  
By pressing the “OK” button the configuration is accepted. The EH-View will issue a 
warning if an illegal combination is chosen and will not close the Dialog Box until an allowed 
configuration is selected. 
  
After the multi-protocol application is successfully configured, the status line of the EH-View 
main window shows the “Double protocol” string in the place where the driver name string is 
displayed in the single protocol case. (Limited space does not allow displaying both names.) 
  

 
  
If at least one of the drivers is a serial driver, the decision which Driver will be set as the 
First, and which one the Second is not completely unimportant. 
  
The First Driver will use the PLC port, and the Second Driver will use the PC/Printer port. So 
if one of drivers is using the current loop, it will be necessary to make it the First Driver and 
so ensure it uses the PLC port, because the current loop capability is only implemented on this 
serial port. Also, as the PC/Printer and the PLC port connectors are of different genders, 
selecting the First and the Second Driver smartly can make cabling easier and less expensive.  
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7.3.3 Controllers Setup 

The "Configure Controller..." menu option always displays the Configure Controllers Dialog 
Box. 
  

 
  
When pressing the "...” button associated to a given controller, the EH-View will show a list 
of controllers, with the associated controller in pre-selected status. 
  

 
  
From this list it is possible to open the Controller Setup Dialog Box, by pressing the 
Controller Setup button. 
  
It can be noted, that it is allowed to have PLC networks configured for both drivers (naturally, 
if both communication drivers are able of supporting PLC networks). Therefore, two 
independent PLC network branches can be connected to a single Panel. 
  

7.3.4 Placing Fields on a Page 

When the user in the EH-View chooses to put a field onto a page, the "Field Properties" 
dialog box is displayed. 
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When selecting "PLC" in the "Reference Section" and pressing the "..." button,  the "Data 
Field Properties" dialog box is displayed. In the "Network" tab the user can specify which 
controller is to be referred by the data field. 
  

 
  
This offers the user a very flexible approach. It is possible to put fields from all controllers 
next to each other on a single EH-HMI page, irrespective of the communication protocol they 
are using. Moreover, it is possible to scale a value from one controller with a value from the 
other. It also enables you to keep parts of RDA and recipes in different controllers. The same 
is with alarm triggers. The best of all, you can program data transfers from two totally 
different types of controllers or controller networks. 
  

7.3.5 Downloading Uploading and Getting Panel Resources 

There is almost no difference between downloading and uploading single protocol projects 
and multi-protocol projects. Only, as can be expected, first downloads of multi-protocol 
projects will last longer because two drivers must be downloaded instead of one. 
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The “Controller type” section of the Panel Resources Dialog Box is now two lines wide. In 
the first line there will be the name of the First Driver, and in the second one the name of the 
Second Driver. In the case of single protocol configuration, the second line will be empty. 
  

7.3.6 Configuring UniNET Networks 

There is no major difference in configuring UniNET network for single protocol applications 
and for multi-protocol applications. 
  
First two steps, choosing the network media and the network type, are the same. However, if 
one of the network types “Single Server, Multiple Clients” or “Multiple Server, Multiple 
Clients” is selected, it is worth noticing that all the EH-HMI network server nodes will inherit 
the current configuration of the project. In other words, if the project in which the network is 
being setup is currently configured for single protocol, all the EH-HMI node servers in the 
UniNET network will be configured to use only this protocol. If the project is configured for 
multi-protocol, all the EH-HMI node servers will again be configured to use both protocols. 
  
If the “Mixed Multiple Servers, Multiple Clients” network type chosen, the EH-View will pop 
up the “Network Configuration” Dialog Box. This is the way to configure the UniNET 
network completely freely. It is possible to configure EH-HMI nodes in different ways. Some 
EH-HMI nodes may stand for bare client network nodes having no controllers connected to 
them. Other nodes (server nodes) can be configured to communicate over one protocol 
(single-controller configuration) or two protocols (multi-protocol configuration), where any 
EH-HMI server be configured to support any allowed combination of drivers. 
  
The “Network Configuration” Dialog Box looks as in the illustration below. (Minor 
differences are possible depending on the selected network type.) 
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By selecting a node and requesting its properties (i.e. by pushing the "Properties") it is 
possible to have access to the Double Protocol configuration of that node. 
  
  

7.4 Interlock Mailbox 

7.4.1 Interlock Mailbox 

The EH-HMI Interlock Mailbox is designed to allow the operator interface panel to interact 
with the controller's ladder logic program. 
  
The Interlock Mailbox is simply a group of registers in the controller memory (from a 
minimum of 2 registers to a maximum of 20). The mailbox can be placed anywhere in the 
controller memory at an address you select. When the mailbox is enabled, the operator panel 
cyclically reads the contents of the mailbox from the controller.  
  
The controller can command the EH-HMI panel to perform certain tasks by placing data in 
the memory area used by the mailbox. When the panel detects that the controller has written 
data in the mailbox, it interprets the data as a numeric code for a required command. If the 
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panel recognizes the command, it immediately executes it. If the command requires a 
response from the panel, then the panel places the response back into the mailbox itself. 
  
Note:  The Interlock Mailbox offers a powerful way to control the operation of recipes from 
the controller. 
  
In general, the Interlock MailBox works by writing a command into the Command/Response 
Word. 
  
Available commands can be seen in the table of available mailbox commands. Depending 
upon the command, certain parameters may have to be entered. Once the parameters are 
entered, a code needs to be written to the Status Word. When the command written into the 
Command/Response Word is attempted/executed, a Response Word will be written into the 
Command/Response Word, indicating the status of the command. 
  
If you have the mailbox set up to be cyclically read, this is all that needs to be done. 
  
If bit C15 is active, then one additional step is necessary. Since this bit must be a logic high in 
order for the mailbox to be read, you need to write a value of 1 to this bit. Once it is "set", a 
"1" needs to be written to the Status Word to indicate a pending request in the mailbox. 
  
Details of enabling the Interlock Mailbox, the structure of the mailbox,  Interlock Mailbox 
commands, and mailbox programming are provided. 
  

7.4.2 Enabling the Internet Mailbox 

Enabling the Internet Mailbox 

To enable the Interlock Mailbox, select the Interlock Mailbox tab from the Panel Controller 
Interface dialog box under the Project menu. 
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The mailbox is disabled by default. To enable it, simply mark the checkbox entitled Enable. 
  
Details about the read cycle modes and the interlock reference are provided. 
  

7.4.3 Structure of the Mailbox 

Structure of the Mailbox 

The controller can issue different commands depending upon the values written to the 
mailbox. 
  
Some commands require parameters (which have a binary numeric format) to be included 
with the command, while other commands require the panel to respond with data. 
  
The structure of the mailbox in the controller memory is shown below. The Status Word and 
the Command/Response Word are always required for the mailbox. Parameter 0 - Parameter 
17 Words are only used if required by the particular mailbox command. 
  
You can determine the controller memory addresses of all the data elements in the mailbox by 
using the starting address of the mailbox area (set under Project - Panel Controller Interface - 
Interlock Mailbox) and the memory map shown below. 
  
The Interlock Reference is the address of the first Mailbox register in the controller memory. 
The address can be entered directly as a string or via the Data Field Properties dialog box 
displayed by clicking on the "…" button. 
  
Offset  Item 
0 Status Word 
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1 Command/Response Word 
2 Parameter 0 
3 Parameter 1 
... ... 
19 Parameter 17 
  
Note:  When entering the starting address, care must be taken to ensure that the controller 
memory used by the Mailbox does not overlap with the memory areas reserved for other 
panel functions such as alarms, I/O update, keyboard update, etc. 
  

Status Word 

The Status Word is the main handshaking register of the mailbox. Both the controller and the 
panel can write to this register. The status word contains a binary number, the meaning of 
which is described below. 
  
Code  Status  Written by 
0 No request, Mailbox is available  Controller 
1 Pending request Controller 
2 Mailbox busy Panel 
3 Error code:  Illegal command Panel 
4 Command completed Panel 
5 Panel restart Panel 
  

Command Response Word 

The controller specifies which mailbox command it wants to execute by placing the command 
code of the desired command in the Command/Response Word. 
  
The available mailbox commands and their command codes are given. 
  
The EH-HMI panel writes a binary value to the Command/Response Word when it has 
executed the command requested by the controller to indicate the result of the operation. 
  

Parameters 

The Parameter Words are used only when required by a specific command. 
  
Some commands do not require any parameters at all. The Interlock Mailbox Commands 
section describes how to use Parameter Words and which are required for each Command 
Word. 
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7.4.4 Interlock Mailbox Commands 

Interlock Mailbox Commands 

Command  Description 
1 Recipe Status 
2 Start Recipe Download 
3 Start Recipe Upload 
4 Set Parameter Set Number 
5 Get Parameter Set Number 
6 Get Recipe Transfer Priority 
7 Set Recipe Transfer Priority 
17 Request Data Entry Mode 
33 Password Status 
49 Start Controller to Controller Transfer With No Confirmation 
50 Start Controller to Controller Transfer With Confirmation 
81 Set the Real Time Clock (RTC) 
97 Clear Event List 
113 Start Report Printout 
114 Stop Report Printout 
129 Get Current Language 
130 Set Current Language 
145 Start Screen Saver 
146 Stop Screen Saver 
147 Enable Screen Saver Function in Alarm Mode 
148 Disable Screen Saver Function in Alarm Mode 
  

Recipe Status 

The controller can use this command to request information on the status of the recipes in the 
panel. 
  
Command code: 1 
  
No parameters are required by this command. The panel will respond with a code in the 
Command/Response Word.  The possible codes are listed below. 
  
Code  Description 
0 OK, Recipes contain valid data 
1 Error:  Recipes contain default data as defined in the project file  
2 Error:  There are no Recipes defined 
3 Error:  Error in project file  
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Start Recipe Download 

The controller can use this command to start a recipe download from the panel memory to the 
controller memory. 
  
Command code: 2 
  
Two parameters are required by this command: 
  
Parameter 0 Page number of required recipe (1 - max. page number in project file) 
Parameter 1 Parameter set number(1 - max. number of pre-defined parameter sets) 
  
The panel will respond back to the Command/Response Word with one of the codes listed 
below after performing the operation. 
  
Note:  A recipe transfer may take several seconds, depending mainly on the number of bytes 
that have to be transferred. 
  
Code  Description 
0 OK, Transfer completed successfully 
1 Error:  Recipes contain default data 
2 Error:  There are no Recipes defined 
3 Error:  Error in project file  
4 Error:  Illegal Page number has been requested 
5 Error:  Illegal number of parameter set has been requested 
6 Error:  The requested parameter set is locked (that is, it is being used by the 

operator panel for a data entry operation) 
7 Error:  A communication error occurred during the transfer 
  

Start Recipe Upload 

The controller can use this command to start a recipe upload from the controller memory to 
the panel memory. 
  
Command code: 3 
  
Two parameters are required by this command: 
  
Parameter 0 Page number of  required recipe (1 - max. page number in project file) 
Parameter 1 Parameter set number(1 - max. number of pre-defined parameter sets) 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Note:  A recipe transfer may take several seconds, depending mainly on the number of bytes 
that have to be transferred. 
  
Code  Description 
0 OK, Transfer completed successfully 
2 Error:  There are no Recipes defined 
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3 Error:  Error in project file  
4 Error:  Illegal Page number has been requested 
5 Error:  Illegal number of parameter set has been requested 
6 Error:  The requested parameter set is locked (that is, it is being used by the operator 

panel for a data entry operation) 
7 Error:  A communication error occurred during the transfer 
  

Set Parameter Set Number 

The controller can use this command to select a given recipe parameter set. 
  
Command code: 4 
  
Two parameters are required by this command: 
  
Parameter 0 Page Number(1 - max. number of pages in the project file) 
Parameter 1 Parameter Set Number(1 - max. number of pre-defined parameter sets) 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
2 Error:  Recipes not defined in project file  
3 Error:  Error in project file  
4 Error:  Illegal page number requested 
5 Error:  Illegal record number requested 
6 Error:  Requested record locked 
  
  

Get Parameter Set Number 

The controller can use this command to get the current recipe parameter set number. 
  
Command code: 5 
  
Only one parameter is required by this command: 
  
Parameter 0 Page Number(1 - max. number of pages in the project file) 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
2 Error:  Recipes not defined in project file  
3 Error:  Error in project file  
4 Error:  Illegal page number requested 
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Get Recipe Transfer Priority 

The controller can use this command to get the current recipe transfer priority level. 
Command code: 6 
   
This command requires no parameters. 
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 Normal 
1 Highest 
2 Error:  Recipes not defined in project file  
  
  

Set Recipe Transfer Priority 

The controller can use this command to set the current recipe transfer priority level. 
Command code: 7 
   
Only one parameter is required by this command: 
  
Parameter 0 Priority Level  (0=Normal, 1=Highest) 
   
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
2 Error:  Recipes not defined in project file  
3 Error:  Illegal priority setting requested 
  
  

Request Data Entry Mode 

The controller can use this command to switch the operator panel to Data Entry Mode. 
  
Command code: 17 
  
Two parameters are required by this command: 
  
Parameter 0 Index Number of required Page(1 - max. page number in project file) 
Parameter 1 Index Number of required Data Field (1 - max. number of data fields in the 

page) 
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After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  Illegal page number has been requested 
2 Error:  Illegal field number has been requested 
3 Error:  Panel is not ready for Data Entry Mode 
  
  

Password Status 

The controller can use this command to request information about the current password 
status. 
  
Command code: 33 
  
The command requires no parameters. 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 No passwords are defined in the project file  
1 No valid password has been entered 
2 A valid password has been entered 
3 The system default password (0007) has been entered 
  
If Code 2 is returned, the Parameter Words will contain additional information as follows: 
  
Parameter 0 Current password level 
Parameter 1 First character (ASCII coded) of the current password 
Parameter 2 Second character (ASCII coded) of the current password 
Parameter 3 Third character (ASCII coded) of the current password 
Parameter 4 Fourth character (ASCII coded) of the current password 
  

Start Controller to Controller Transfer with No Confirmation 

This feature allows the user to transfer data in two different manners: 
  

o Between two controllers.  In this case, the controllers can be connected by a 
controller network or with the UniNET network. 
  

o Between two registers located within the same controller. 
  

Note:  Deleting a job changes the position of subsequent jobs (if job 2 is deleted, then job 3 
will become job 2). 
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We will call one complete data transfer a "job". When the controller requests a job to be 
executed, the panel responds immediately back to the controller and executes the job as soon 
as possible. Therefore, the controller does not know when, or if, the requested job will be 
executed. 
  
To set up a transfer, select Project - Panel Controller Interface - Data Transfer. The Job No. 
field is used to select between the different jobs. Click on the Source Reference button to 
specify the register to be read. 
   
The fields will be slightly different depending on the controller that is being used. Use the 
fields to specify the type of data, format, and address of the register that is to be read. Once 
this information is entered, press OK to return to the Panel Controller Interface dialog box. 
Enter the number of words to be transferred in the appropriate box. Click on the Destination 
button brings up a dialog box in which you can enter the address to which the data is to be 
written. 
   
If the Job Execution Mode is set to In Cycles, the panel will automatically transfer the data on 
each cycle. The cycle period can be set between 1 second and 127 seconds. Remember that 
the faster the cycles, the faster the panel will transfer data, but this will slow down the rest of 
the system. If the Job Execution Mode is set to On Request, the controller must send a request 
to the Interlock Mailbox before the data will be transferred. After completely setting up the 
dialog box, click on OK. Now select the Interlock Mailbox tab from Project - Panel Controller 
Interface. Set up the mailbox as described within the section entitled Enabling the Interlock 
Mailbox. When the controller sends a request to the mailbox, the mailbox will read the 
command word and the parameter. The panel will then send a response word back to the 
controller and execute the command. 
  
Command code: 49 
  
This command requires only one parameter: 
  
Parameter 0 Job Number (1-255) 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  Controller to Controller not defined at all 
2 Error:  Illegal job number 
3 Error:  Queue is full 
  
  

Start Controller to Controller Transfer with Confirmation 

This command is set up in the same manner as the command Start Controller to Controller 
Transfer With No Confirmation. 
  
Command code: 50 
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This command requires only one parameter: 
  
Parameter 0 Job Number (1-255) 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  Controller to Controller not defined at all 
2 Error:  Illegal job number 
3 Error:  Not used 
4 Error:  Communication error while reading source data 
5 Error:  Communication error while writing destination data 
  

Set RTC (Real Time Clock) 

This command enables the controller to set the Real Time Clock (RTC) located within the 
panel. 
  
Command code: 81 
  
This command requires six parameters: 
  
Parameter 0 Day (1-31) 
Parameter 1 Month (1-12) 
Parameter 2 Year (94...99, 00....) 
Parameter 3 Hour (0-23) 
Parameter 4 Minute (0-59) 
Parameter 5 Second (0-59) 
   
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  RTC error 
2 Error:  Requested setting out of range 
  
  

Clear Event List from Controller Mailbox 

The controller can use this command to request that the EH-HMI panel clear its event list. 
  
Command code: 97 
   
The command requires no parameters. 
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After performing the operation, the panel will respond back to the Command/Response Word 
with a 0, indicating that the event list has been cleared. 
  

Start Report Printout 

This command is used to start a report printout. 
  
Command code: 113 
   
This command requires only one parameter: 
  
Parameter 0 Report Number 
  
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  Printer process already active (if START command is issued more than 

once)Error: Printer process already inactive (if CANCEL command is issued more 
than once) 

2 Error:  Illegal report number 
3 Error:  Activation queue is full 
  
  

Stop Report Printout 

This command is used to stop a report printout. 
  
Command code: 114 
  
This command requires no parameters. 
After performing the operation, the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error:  Printer process already inactive 
  
  

Get Current Language 

The controller can use this command to get the number of the currently active language from 
the panel. 
  
Command code: 129 
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This command requires no parameters. 
  
After performing the operation the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error, the project is not multilanguage. 
  
If Code 0 is returned, the Parameter Word 0 will contain the number of the active language. 
  

Set Current Language 

The controller can use this command to change the language in the operator panel. 
  
Command code: 130 
  
Parameter 0 Language number 
  
After performing the operation the panel will respond back to the Command/Response Word 
with one of the codes listed below. 
  
Code  Description 
0 OK 
1 Error, the project is not multilanguage. 
2 Error, illegal language number requested 
  
  

Start Screen Saver 

It is possible to activate the screen saver from the controller using this command. 
  
Command code: 145 
  
No parameters are required by this command. The panel will respond with a code in the 
Command/Response Word. The possible codes are listed below. 
  
Code  Description 
0 OK 
1 Error: screen saver not enabled in the project 
  

Stop Screen Saver 

It is possible to deactivate the screen saver from the controller using this command. 
  
Command code: 146 
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No parameters are required by this command. The panel will respond with a code in the 
Command/Response Word. The possible codes are listed below. 
  
Code  Description 
0 OK 
1 Error: screen saver not enabled in the project 
  

Enable Screen Saver Function in Alarm Mode 

The controller can use this command to enable the default behaviour of the screen saver in 
Alarm Mode. 
  
If EH-HMI is in Alarm Mode and the time for screen saver activation has elapsed, the screen 
saver function will start. Simply touch a key to stop screen saver activity. This command code 
can be used following command 148 to go back to the default setting. 
  
Command code: 147 
  
No parameters are required by this command. The panel will respond with a code in the 
Command/Response Word. The possible codes are listed below. 
  
Code  Description 
0 OK 
  

Disable Screen Saver Function in Alarm Mode 

It is possible to automatically reactivate the screen whenever an alarm has to be displayed. 
  
The controller can use this command to disable the screen saver function when EH-HMI is in 
Alarm Mode. 
  
If EH-HMI panel has the screen saver activated because of the elapsed programmed time and 
an alarm is activated, the EH-HMI panel will automatically turn off the screen saver and 
display the alarm page. The alarm page will be displayed until at least one alarm condition is 
active. 
  
Use command code 147 to go back to the default behaviour. 
  
Command code: 148 
  
No parameters are required by this command. The panel will respond with a code in the 
Command/Response Word. The possible codes are listed below. 
  
Code  Description 
0 OK 
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7.4.5 Mailbox Programming 

To use the mailbox successfully, the panel and the controller must interact tightly. 
  
The interaction between the panel and the controller can be thought of as a short conversation 
between two people. 
  
The first person (the controller) tries to start a conversation with the second person (the EH-
HMI panel) on a particular topic (the mailbox command code). After the first person has 
introduced himself and the topic of the conversation, the second person decides whether he 
feels competent enough to join in. If the second person decides not to join in the conversation, 
he politely informs the first person that he feels he does not know enough about that particular 
topic to make an informed comment and waits for a change in the topic of the conversation. If 
the second person does decide to enter into the conversation, he ponders the topic and then 
expresses his well-considered opinion. 
  
The vital ingredient in a successful conversation is that nobody is interrupted while they are 
talking. 
  
The flow chart below describes the program sequences that must be executed in parallel by 
both the EH-HMI panel and the controller ladder logic program to ensure a successful 
Mailbox session. 
  
The following important notes should be kept in mind: 
  
o At system start-up, the EH-HMI panel writes the special Status Code Panel Restart to 

inform the controller that the panel itself has been reset. 
  

o Both the panel and the controller can write to the Status Word and the 
Command/Response Word; however, they must not write at the same time to the same 
memory location. Proper operation of the mailbox is ensured if the sequence described in 
the figure is followed. 
  

o The controller program must always wait for the completion of the current Mailbox 
session before attempting to start a new one. 
  

o The controller program should always check the status returned by the EH-HMI panel on 
completion of a session. 
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7.5 Networks 

7.5.1 UniNET Networks 

The UniNET network is a feature of the operator panels that enables them to be connected 
together and to communicate with each other. 
  
This offers the ability to display on one panel either the data from the controller attached to 
the panel itself, or data from other controllers attached to other panels on the network. 
  
First the General Characteristics are introduced. Then the various, possible, Network 
Configurations and the two supported Network Types. Later detailed instructions on 
Connecting Panels to the Network and on the Network Setup are given. Finally a Network 
Example is given. 
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7.5.2 General Characteristics 

General Charatceristics 

This section presents the concepts of Clients and Servers and the common Technical Data of 
all Uninet Networks. The reader should be comfortable with the Graphic Symbols used 
throughout the chapter.  
  

Clients and Servers 

The operator panels attached to the UniNET Network can be classified in two categories, 
depending on the type of communication that they can support once they are placed in the 
network: Server type panels and Client type panels. 
  
o A panel is a Server when it is connected directly to a controller. It makes available to 

other panels in the network the data in the controller. It makes available to other panels 
in the network the data in the controller to which its attached. 
  

o A panel is a Client when it requests data from a controller attached to a Server on the 
network. 

  
Note: Some EH-HMI panel have only one serial connection (they do not have a PC/Printer 
port). So you can attach the panel via this serial connection either to a PLC or, as a client, to a 
UniNET Network. In case the panel has an optional communication module and is connected 
to the PLC via the Aux port of this communication module, then the panel can use its serial 
connection to become a UniNET Network server. 
  
A panel can be, in certain cases, both a Server and a Client. This means that the panel both 
satisfies the requests from other panels that require access to the data in the controller to 
which it is attached, and also requests data from the controllers attached to other Servers. 
  
The UniNET Networks supports two types of connectivity: 
  
o RS485 Connectivity 

  
o Ethernet Connectivity 
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The Single Server Configuration, using either the Serial Connectivity or the Ethernet 
Connectivity, allows many panels to access data from a single controller via a panel acting as 
the single Server. The client panels can perform all of the normal operations as if they were 
connected directly to the controller, including: displaying of variables, modifying of 
variables, handling of Recipes, handling of the Reserved Data Area, etc. 
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In the Multiple Servers Configuration, which may use Serial or Ethernet Connectivity, many 
controllers are accessed. The panels that are connected to a controller can function both as 
Servers and Clients. Therefore, they can read data from the controller to which they are 
directly attached and also from the controllers attached to other Servers. The Client panel can 
also read data from the controllers attached to the Servers. In this way, every single panel in 
the network has access to every single controller attached to the Servers in the network. 
  
Note: in the Serial Connectivity  an external RS-232 to RS-485 converter is required for each 
panel used as a Server. This is because Servers must be connected to the network using their 
PC/Printer port which, in the current hardware version, only has an RS-232 interface. The 
Client panels do not need an external converter to be attached to the UniNET network 
because they can be attached to the network using their PLC port which has an RS-485 
interface as well as an RS-232 interface. 
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The TSI01 Bus Terminal and Converter provides additional optical isolation between the 
panel and the UniNET network. If you are using a Client panel attached to the network 
through a simple TSI02 Bus Terminal, there is no optical isolation. Optical isolation is 
recommended whenever panels are to be operated in a noisy environment or powered by 
different power sources. A completely optically isolated network can be obtained using a 
TSI01 Bus Terminal and Converter for each panel attached to the network. 
  
Note: The network configuration shown in the above figure works even if the controllers are 
of different model types or if they are of different manufacturer brands. Designer allows the 
user to specify the addresses of the data items added to the project file using controller-
specific addressing. 
  
It is also possible to transfer data from one controller to another using the 'Data Transfer' 
feature supported by the operator panels. The transfer of data can be performed even if the 
controllers are of different manufacturer brands. The panels act as bridges connecting 
different controller worlds. 
  

UniNET Technical Data 

The UniNET network has been designed to pass information between operator interface 
panels operating on the plant floor.  
  
The UniNET network features are the following: 
  
o interconnection of up to 32 operator panels 

  
o multi-master capability 

  
o token-passing capability 

  
All operator panels connected to the network may initiate a message transfer. The network 
protocol uses a token passing algorithm to determine which initiator has the right to transmit. 
A node holding the token is allowed only one transmission each time it receives the token. 
After a node sends one message packet, it attempts to give the token to its successor by 
sending a "token pass" message. If no network activity occurs, the initiator will attempt to 
find a new successor. 
  
One of the main benefits of the token passing method is that every station on the network gets 
the chance to communicate, even in conditions of heavy communication load. 
  
The maximum node address that the initiator will search before wrapping to zero is the value 
of the configurable parameter Maximum Node Number. 
  
The main technical features of the UniNET Network are shown in the table below: 
 
   
Characteristic  Serial Connectivity Ethernet Connectivity 
Maximum speed 19200 baud 10 Mbps 
Physical interface RS-485 Half Duplex as per 10BaseT 
Connection cable  Shielded twisted pair Standard RJ45 Cable  
Maximum length 1200 m as per 10BaseT 
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Access control / protocol Token Passing UDP/IP 
Maximum number of stations 32 32 
  
  

Graphical Symbols 

The following symbols are used in this chapter. 
  

 

Bus Terminal and RS-232 to RS-485 converter without termination resistor 

 

Bus Terminal and RS-232 to RS-485 converter with termination resistor 

 Bus terminal without termination resistor 

 Bus terminal with termination resistor 

 

10BaseT Ethernet Adapter  

Network cable  
  
  

7.5.3 Network Configurations 

Network Configurations 

You may choose between three network configurations: 
  
o Single Server, Multiple Clients 

   
o Multiple Servers, Multiple Clients (same controller types) 

  
o Mixed Multiple Servers, Multiple Clients (different controller types) 
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Single Server Multiple Clients 

 
  
This network type consists of a single panel that is attached to a controller (the server) and 
one or more panels that are not attached to any controller (the clients). In this type of network, 
all of the clients and the server can read and write data to and from the single controller 
(attached to the single server). 
  
You will be prompted to enter the number of clients. The network is automatically configured 
based on the default settings for the type of network. In general, these default settings should 
be sufficient for most needs. However, if it is necessary to modify these default settings, you 
may do so by clicking the Configure button to access the Network Configuration dialog box. 
  

Multiple Servers Multiple Clients 
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This network type consists of several panels that are attached to controllers of the same 
manufacturer brand (the servers) and several panels that are not attached to a controller (the 
clients). In this type of network, all of the clients and all of the servers can read and write data 
from and to every controller that are attached to a server in the network. You are prompted for 
the number of clients and servers. 
  
The network is automatically configured based on the default settings for the type of network. 
In general, these default settings should be suffic ient for most needs. However, if it is 
necessary to modify these default settings, you may do so by clicking theConfigure button to 
access the Network Configuration dialog box. 
  

Mixed Multiple Servers Multiple Clients 

 
  
This advanced network type consists of more than one panel that is attached to controllers of 
different manufacturer brands (the servers) and one or more panels that are not attached to a 
controller (the clients). In this type of network, all of the clients and all of the servers can read 
and write data from and to every controller attached to a server in the network. 
  
With this type of network, you have full control and flexibility over the network configuration 
using the Network Configuration dialog box. This allows you to make full use of the powerful 
capabilities of the network such as adding multiple servers for different controller 
manufacturer brands. This complete control over the network is gained at the expense of 
having to explicitly specify all of the configuration parameters for the network. 
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7.5.4 Network Types 

Network Types 

The EH-View software supports two types of UniNET network: an RS485 network, or an 
Ethernet-based network. 
  

Ethernet 

TCM10 Board 

EH-HMI panels require an additional hardware module to connect to Ethernet networks. In an 
Ethernet network, panels are connected to a hub using standard UTP Ethernet patch cables. 
This network type is only available if the optional TCM10 board is built into the panel. 
  
When the TCM10 communication module is used to extend the UniNET connectivity 
capabilities, the network setup follows the basic concepts of a normal UniNET network. 
  
In addition, with the optional TCM10 card, you can implement a UniNET-over-Ethernet 
connection. The EH-HMI panel still communicates serially to the control device, but the 
communications between each EH-HMI are over a 10Base-T Ethernet connection. 
  
TCM10 is intended for connection to 10Base-T networks (10 Mbit, twisted-pair cables). The 
TCM10 requires an external network adapter. The network adapter must be plugged into the 
Aux port of the EH-HMI panel. The TCM10 external network adapter is equipped with a 
standard RJ45 connector. The TCM10 can be directly connected to a hub using standard 
Ethernet twisted-pair patch cables. 
  
The TCM10 external network adapter is equipped with a standard RJ45 connector. The 
TCM10 can be directly connected to a hub using standard Ethernet twisted-pair patch cables. 
  
The TCM10 external network adapter has two diagnostic LED indicators: 
  
LED  Description 
RED - Link When ON indicates that Ethernet link is missing. In this condition the 

GREEN LED is normally OFF. 
GREEN - Activity ON - No network activity for the EH-HMI panel 

Blink - Network activity detected for the EH-HMI panel 
  
Compatibility information for the TCM10 module is available, as is information on 
configuring an Ethernet network. 
  

Compatibility Information 

Units with firmware type FW 32, 38 and 39 are Ethernet compatible. 
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Configuring Ethernet 

When a TCM10 communication module is used to connect a EH-HMI panel to an Ethernet-
based PLC network, the EH-View configuration is fully dependent on the protocol type used 
over the network. From the EH-View point of view, the project needs to know the IP address 
of the TCM10 card and the IP addresses of the devices connected on the network with which 
the panel has to exchange information. 
  
Configure Controller from the Project menu will normally allow configuration of the IP 
address of the communication partners of the EH-HMI that are connected over the Ethernet 
network. The Access Multiple Controllers checkbox in the Controller Setup dialog box 
(accessed by clicking the "..." button in the Configure Controllers dialog box then clicking on 
the Controller Setup button from the Select Controller dialog box) can be used when 
connection to more than one device is required. 
  
Because the EH-HMI panel is a partner of the Ethernet network like all of the other devices, a 
proper IP address must be assigned to the panel. An IP address can be assigned to an Ethernet 
board from the External Devices tab in Panel Setup from the Project menu. 
  
The IP address used in Configure Controller and in Panel Setup - External Devices has to be 
chosen according to the overall Ethernet configuration. 
  

7.5.5 Connecting Panels to the Network 

Connecting Panels to the Network 

The way panels are connected to the network depends on the connectivity adopted by the 
UniNET Network, i.e. if panels are to be connected via an RS485 UniNET Network or via  an 
Ethernet UniNET Network. 
  

RS485 

Connecting Panels to an RS485 Network 

The following sections describe how to connect panels to an RS485  UniNET Network. 
  
o Pinout for the PLC Communications Port 

  
o Pinout for the PC/Printer Communications Port 

  
o The TSI01 Bus Terminal with RS-232 to RS-485 Converter 

  
o The TSI02 Bus Terminal 
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o RS-232 Cable to TSI01 Bus Terminal with Converter (Printer Port) 
  

o RS-232 Cable to TSI01 Bus Terminal with Converter (PLC Port) 
  

o RS-485 Cable to TSI02 Bus Terminal 
  
Information is also provided on installing the network cable. 
  

Pinout for the PLC Communications Port 

The PLC Communications port is used to connect client panels to the network using a bus 
terminal unit. The pinout of the PLC port is shown here for easy reference. 
  
Note:  Panels to be used as servers must have a dedicated PC/Printer port. 
  
Pin # Description  Pin # Description 
1 Frame Ground 9   
2 RXD 10 RTS 
3 TXD 11 CTS 
4 +5V 12   
5 Signal Ground 13   
6 CHA- 14 CHA+ 
7 CHB- 15 CHB+ 
8       
  

Pinout for the PC/Printer Communications Port 

Use the PC/printer communications port to connect server panels to the network using a bus 
terminal unit with an RS-232 to RS-485 converter. The pinout of the printer port is shown 
below. 
  
Pin # Description  Pin # Description 
1 Frame Ground  9   
2 RXD 10 RTS 
3 TXD  11 CTS 
4 +5V 12   
5 Signal Ground 13   
6   14   
7   15   
8       
  

RS232 Cable to TSI01 Bus Terminal with Converter (Printer Port) 

Use the cable CA74 to connect the Printer port of a Server panel to the TSI01 bus terminal 
with converter. The maximum length of the cable is 12m. 
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Panel connector: D-type 15P 
TSI02 connector: D-type 15S 
  

RS-232 Cable to TSI01 Bus Terminal with Converter (PLC Port) 

Use the cable CA73 to connect the PLC port of a client panel to the TSI01 bus terminal with 
converter. The maximum length of the cable is 12m. 
  

 
  
Panel connector: D-type 15S 
TSI01 connector: D-type 15S 

RS485 Cable to TSI02 Bus Terminal 

Use the cable CA75 to connect the PLC port of a client panel to the TSI02 bus terminal. The 
maximum length of the cable is 1 m. 
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Panel connector: D-type 15S 
TSI02 connector: D-type 15P 
  

TSI01 Bus Terminal with RS-232 to RS-485 Converter 

The TSI01 bus terminal is a special module designed for use in the UniNET network. It is an 
optically isolated RS-232 to RS-485 converter that can be directly connected to the Printer 
port of an operator panel. The power supply is derived from the panel connector; an on-board 
isolated DC/DC converter provides the power for the RS-485 section of the converter. The 
converter additionally provides the possibility of properly terminating the line with a simple 
switch. 
  
  
The pinout of the RS-232 connector of the converter is shown below.  The connector type is 
D-type 15 pin male. 
  
Pin # Description  Pin #  Description 
1 Frame Ground 9   
2 TXD  10 CTS 
3 RXD  11   
4 +5V external 12   
5 Signal Ground 13   
6   14   
7   15   
8       
  
The pinout of the RS-485 terminal block of the converter is shown in the following table. 
  
Pin # Description 
1 Frame Ground 
2 A (-) 
3 B (+) 
4 Shield 
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TSI02 Bus Terminal 

The TSI02 bus terminal is a special module designed for use in the UniNET network. The use 
of the TSI02 bus terminal makes it easier to wire a panel to the network and additionally 
provides the possibility of properly terminating the line by means of a switch. The TSI02 has 
been designed for connection to the PLC port of an operator panel equipped with RS-485 
interface. 
  
  
The pinout of the RS-485 connector of the converter is shown below. The connector type is 
D-type 15 pin female. 
  
Pin # Description  Pin # Description  
1 Frame Ground 9   
2   10   
3   11   
4   12   
5 Signal Ground 13   
6 CHA-  14 CHA+ 
7   15   
8       
  
  
The pinout of the RS-485 terminal block of the converter is shown in the following table. 
  
Pin # Description 
1 Frame Ground 
2 A (-) 
3 B (+) 
4 Shield 
  

Installing the Network Cable  

The UniNET communication cable consists of a number of cable segments daisy-chained 
together connecting all the network nodes. The total length of the cable segments cannot 
exceed 1200 m. It is recommended to use a shielded cable with one twisted pair. 
  
Note:  Only a daisy-chained network is recommended. Other connections, for example a star-
like connection, are not recommended. 
  
The bus terminals at both ends of the networks must have the termination resistance 
connected with the switch. This connects the termination impedance (120 Ohms) that is built 
in each bus terminal. Intermediate bus terminals must not have the termination connected. 
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Ethernet 

Connecting Panels to an Ethernet Network 

To connect a Panel, including the TCM10 module, the Ethernet Adapter ETAD01 is needed 
as shown in the following picture. 
  

 
  
The second picture here below shows the ETAD01 wire connections. 
  

 
  
The ETAD01 Adapter connects on one site to the Panel AUX Port and provides on the other 
site a standard RJ45 8 way connector. 
  
  
The following table shows the Pinout configuration. 
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Pin Signal 
1 TD out + 
2 TD out - 
3 RX in + 
6 RX in - 
  
  

7.5.6 Network Setup 

Network Setup 

It is easy to configure a UniNET network using EH-View. 
  
The configuration entails determining the type of network (RS-485 or Ethernet), specifying 
the number of clients and/or servers on the network, etc. The Network Protocol, Network 
Selection, and Network Configuration sections describe the steps necessary to configure the 
UniNET network. 
  
Select Network Setup from the Project menu (or click the Network Setup icon on the toolbar) 
to configure or modify the network for your application. If a network is not yet defined for the 
project, this brings up the Network Media & Protocol Selection dialog box. If a network is 
already defined for your project, selecting Network Setup takes you directly to the Network 
Configuration dialog box. 
  

Network Protocol 

The first step in configuring the network is selecting the network type. The EH-View software 
supports two types of UniNET network: an RS-485 network, or an Ethernet-based network. 
  
Select the type of network, click the Next> button, and the Network Selection dialog box 
appears. 
  

Network Selection 

Select the appropriate network configuration for your project. Choices include: 
  
o Single Server, Multiple Clients 

   
o Multiple Servers, Multiple Clients 

   
o Mixed Multiple Servers, Multiple Clients 

   
Once you have made your selection, click the Next> button. 
If you choose Single Server, Multiple Clients or Multiple Servers, Multiple Clients, you will 
be prompted to enter the number of clients and/or servers for your project. You will then be 
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prompted to click on the Configure button to bring up the Network Configuration dialog box, 
configured for the number of clients and servers specified. Check and set the remaining 
configuration parameters for the network. 
  
If you choose Mixed Multiple Servers, Multiple Clients you will be prompted to click on the 
Configure button to bring up the Network Configuration dialog box and specify all of the 
configuration parameters for the network. 
  

Network Configuration 

The parameters for the network are automatically configured if it is selected to be of either the 
Single Server, Multiple Client type or of the Multiple Server, Multiple Client (same controller 
types) type. However, EH-View lets you make modifications to the network parameters by 
using the Network Configuration dialog box. 
  
If you chose Mixed Mult iple Servers, Multiple Clients, you must specify all of the 
configuration parameters for the network. 
  
You can use the Import and Export buttons to share network configurations between multiple 
project files designed for the same network. 
  

7.5.7 Advanced Network Programming 

Advanced Network Programming 

The UniNET network fully supports the use of all panel Reserved Data Areas (RDA), 
including alarms and mailboxes. Recipes may be used in a UniNET network system. 
  
This section also provides information on Extending the Extending the Connectivity with the 
UniNET OPC Server. 
  

Reserved Data Area 

The UniNET network fully supports the use of all panel Reserved Data Areas (RDA), 
including alarms and mailboxes. These Reserved Data Areas can be placed in any controller 
attached to any server on the network. This is especially helpful since the RDA concept offers 
a simple and efficient method to have the controller program interact with the operator panel. 
  
Note:  Most RDA activities are carried out on a cyclical basis, so even with a small number of 
nodes in the network most of the network traffic may be for RDA updates. This may cause an 
exceedingly slow update time for displayed variables. 
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Network and Recipes 

Recipes may be used in a UniNET network system. A single recipe may contain data items 
for different controllers attached to different servers on the network. 
  
The following considerations should, however, be taken into account: 
  
o Recipe transfers may be considerably slower when they contain data items for controllers 

attached to other servers in the network than when they only contain data items for the 
controller attached directly to the operator panel. 
  

o The panels in the network can be configured so that they each store copies of the same 
recipe parameter set. In this case, special care must be taken to ensure the consistency of 
the parameter sets stored in the different nodes. It is recommended that in a network 
configuration, only one node be assigned for the storage of the recipe data. 

UniNET OPC Server 

Extending the connectivity with the UniNET OPC Server 

The implementation of the UniNET network using Ethernet technology allows for an easy 
extension of the connectivity options of the system.  One of the most important advantages of 
the Ethernet based technology is the availability of a UniNET Client for a computer. 
  
The UniNET Client for a computer consists of a software component designed to work as a 
Client in the network.  The software component is a program based on the OPC technology 
(OLE for Process Control) working as OPC Server.  Once the software component is installed 
on the computer, all of the OPC Client programs will have full access to data coming through 
the UniNET Network.  They can also fully interact with the Controllers connected to the 
UniNET Server panels. 
  
This section provides information on the UniNET OPC Server and shows how this server can 
be accessed via OPC Automation Clients. 
  

UniNET OPC Server 

The UniNET OPC Server is a program that is distributed separately from Designer.  The 
UniNET OPC Server program has the following minimum requirements: 
  
o Microsoft Windows 98, NT, ME or XP 

  
o 15MB of free hard disk space 

  
o Ethernet card 

  
The installation procedure of the UniNET OPC Server software components will 
automatically provide the registration of the Server at the system level.  It will make the 
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server visible to all of the OPC Clients that are already installed.  Likewise, any OPC clients 
that are installed after the UniNET OPC server software is installed will also “see” the server. 
  
The UniNET OPC Server main window appears as is shown here below. 
  

 
  
The OPC Server has to be properly configured in order to collect data coming from the EH-
HMI panels working as UniNET servers on the network.  The software uses the concepts of 
Device and Tag to identify the controllers connected to the server panels and the variables 
requested by them.  These variables will be available to any OPC Client that may require their 
values.  Please refer to specific OPC documentation for any additional detail regarding the 
theory of OPC technology. 
  
Note: OPC Client programs installed on the computer will only have access to the Data Sets 
configured in the OPC Server application. 
  
To create a new Device, select Add/New Device or click on the New Device icon.  The 
Device Properties dialog box will be displayed as is shown in the next figure. 
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Name 
Represents a mnemonic description of the Device. 
  
Device 
The list box contains the list of all available drivers for the different controller types.  Because 
OPC Server is a UniNET Client, the application needs to know the data structure of the 
controller connected to the EH-HMI UniNET Server panels. 
  
Timeout 
Period of time that the OPC server will wait to receive requested information before reporting 
a timeout error for the Device. 
  
TCP/IP Access 
Specifies if the UniNET network is Ethernet based.  When the TCP/IP checkbox is not 
marked, the OPC server can be used to prepare a configuration file usable with the Windows 
CE OPC Server.  Please refer to the specific documentation for further details. 
  
IP Address 
Represents the IP Address assigned to the EH-HMI Panel, working as UniNET Server, that is 
connect to the controller specified by the Device item.  Please refer to the Networking with 
Ethernet section for a detailed description. 
  
Socket Port 
Represents the number of the socket port used by the EH-HMI panel to relay requests coming 
through the Ethernet network. 
  
  
When the Device setup is completed, the OPC Server program has to be configured to read a 
certain amount of specific data from the UniNET network.  Only this data will be available to 
an eventual OPC Client connected to the UniNET OPC Server.  Required data from UniNET 
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can be specified by inserting the Tags definition for the Device.  To insert a Tag for the 
specific Device, use the Add/New tag menu or click on the New tag icon. The figure here 
below shows the Tag Properties dialog box. 
  

 
  
Name 
The mnemonic name used by the OPC Server to uniquely identify the variable. 
  
Description 
Allows for the user to explain exactly to what the Tag refers. 
  
Address 
The tag address in terms of the native data types of the controller specified in the Device list 
box of the Device Properties dialog box. 
  
Numeric Data 
When marked, this specifies that the tag is to be treated like a numeric variable.  When 
unmarked, it specifies that the variable is to be interpreted as the starting point of an ASCII 
string.  The ASCII data length specifies the length of the ASCII string.  If the ASCII 
representation is selected, the OPC Server program will retrieve an amount of bytes equal to 
the number of ASCII characters specified by the ASCII data length parameter from the  
UniNET network. 
  
The UniNET OPC Server program has a monitor function useful when a check of the 
Ethernet connection link is required.  Once the Device and the Tags are configured, select 
View/Monitor to activate the debug function.  The Value column of the main window (see 
Figure 39) displays the current value of each configured tag.  If the OPC Server program 
cannot retrieve the value from the network, it displays the string Bad. 
  
  

Interfacing Microsoft Excel with the UniNET OPC Server 

As an application example, it is important to consider a typical use of the UniNET OPC 
Server.  The program Microsoft Excel can be easily equipped with the OPC Automation 
software components that will allow connection to any OPC Server installed on the computer. 
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Hitachi has successfully tested a solution provided by FactorySoft that is downloadable free 
of charge from the following web site: http://www.factorysoft.com.  The Excel interface to 
the OPC Server consists in software components called OPC 2.0 Data Access Components.  
FactorySoft provides an Automation interface and a Server browser service. 
  
Automation 
FactorySoft wrote the Automation interface sample code for the OPC Foundation.  They 
provide a standard Automation component based on this code for redistribution.  An OPC 
Server vendor may use these components to provide its server. 
  
Server Browser 
This COM server returns OPC Servers by Component Category.  It can be  used to find Data 
Access 1.0 or 2.0 servers, in addition to future OPC servers.  Because this is a COM server 
that can be run remotely, clients can get access to remote servers without local registry 
entries. 
  
The FactorySoft OPC Data Access Components downloadable will install the Server 
Browser, the Data Access 2.0 proxy DLLs and the Automation DLL in the System directory. 
  
This installation is used to install the OPC components needed for the server and can be freely 
distributed with your products. 
  
Once the required software components are correctly installed, the VBA (Visual Basic for 
Application) interface available in Excel can be easily used to give access to the UniNET 
OPC Server. 
  
The read operation can be implemented using a simple form where a button is programmed to 
perform the following “Get OPC Data” subroutine. 
  
Private Sub GetOpcData_Click() 
  
'Get OPC Automation Reference 
Set opcauto = CreateObject("OPC.Automation.1") 
  
'Connect to the server 
opcauto.Connect ("EXOR.UniNETOPC") 
  
'Plays with groups and items 
Set groups = opcauto.OPCGroups 
Set group = groups.Add("Device1.Group") 
group.IsActive = True 
Set Items = group.OPCItems 
Set Item = Items.AddItem("Device1.Group.tag1", 1) 
Item.Read (1) 
value = Item.value 
  
'Display value 
Sheet1.Range("a1").value = value 
End Sub 
  
A working sample program is available on request. 
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7.5.8 Network Examples 

Network Example 

Most of the features of the UniNET Network can be tried by using a very simple 
configuration.  This example will describe the steps required to set up a simple UniNET 
network composed of a single server operator panel connected to a controller and two client 
operator panels that will access the controller data via the server through the network services. 
The complete network system is composed of three operator panels. Thus, we will have to 
create individual project files for each of the three panels. All three project files must include 
the same network configuration information in order for the three panels to exchange 
information. To ensure that the project files contain the same network configuration 
information, we will define the network configuration once in the first project file and save 
the configuration. Then we will import the configuration into the other two project files. 
   
The example is broken down into the following steps: 
  
o Setting Up the Network Configuration 

  
o Creating the Project File for the Server 

  
o Creating the Project File for the First Client 

  
o Creating the Project File for the Second Client 

  
o Running the Network 

Setting Up the Network Configuration 

o Select New from the File menu and create a new file. 
  

o Select the Configure Controller from the Project menu and choose the controller type 
required for the server. 

  
o Select Network Setup from the Project menu. 

  
o Select RS485 as the type of network. 

  
o Click Next>. 

   
o Choose the option Single Server, Multiple Clients. 

   
o Click Next>. 

   
o Enter 2 for the number of clients. 

  
o Click Next>. 
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o Click Configure to change the default node settings and complete the network 
configuration. 
  

o The Network Configuration dialog box appears, showing the network configuration with 
the list of nodes. 
  

o Click on the Enable UniNET Network checkbox. 
  

o A checkmark appears next to node number 1 indicating that it is the server. 
  

o Select node number 2. 
  

o Click Properties. 
   

o The Edit Panel Node dialog box opens. Select the controller for panel node 2 (a client), 
and set the other parameters as necessary. 
  

o Click OK. 
   

o A cautionary message appears. Click Yes. 
   

o Repeat steps 14-18 for panel node number 3. 
  

o Click on the Export button. 
  

o Give the network configuration file a name with the .net extension in a convenient 
folder. Click Save to save the file and return to the Network Configuration dialog box. 
  

o Click OK to close the Network Configuration dialog box. 
  

o Click the Finish button to complete the network setup process and close the Network 
Selection dialog box. 
  

(Continued in Creating the Project File for the Server) 
  

Creating the Project File for the Server 

 (Continued from Setting Up the Network Configuration) 
  
o Create a page for the application. Type some text on the page, then insert a numeric data 

field by selecting Insert - Data Fields - Numeric/ASCII. 
   

o Use the cursor to outline an area for the data field. 
  

o In the Numeric Field Properties dialog box click on the Range tab. Set the Access as 
Read/Write. 
   

o Click OK. 
   

o Save the file by selecting Save from the File menu. 
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o Close the file by selecting Exit from the File menu. 
  

o Connect the computer to the operator panel that is designated as the server and download 
the project. When the transfer is complete, detach the cable from the PC/Printer port of 
the panel and connect the RS-232/RS-485 converter. 

o   
Note:  Since the PLC port is used on the server to connect to the controller, the only available 
port for the network connection is the PC/Printer port (the AUX port cannot be used). The 
PC/Printer port only has a 232 interface, but the UniNET network is 485. Thus, the converter 
is required. 
  
(Continued in Creating the Project File For the First Client) 
  

Creating the Project File for the First Client 

 (Continued from Creating the Project File for the Server) 
  
o Repeat steps 1 through 11. 

  
o Click on the Import button in the Network Configuration dialog box. 

  
o Select the file created in step 21 and click Open. 

   
o The controller information is copied into this new file. 

  
o Check the Enable UniNET Network button. 

  
o Click OK to close the Network Configuration dialog box. 

  
o Click the Finish button to complete the network setup process and close the Network 

Selection dialog box. 
  

o Create a page for the application. Type some text on the page, then insert a numeric data 
field by selecting Insert - Data Fields - Numeric/ASCII. 
   

o Use the cursor to outline an area for the data field. 
  

o In the Numeric Field Properties dialog box click on the Range tab. Set the Access as 
Read/Write. 
   

o Click OK. 
   

o Save the file by selecting Save from the File menu. 
  

o Close the file by selecting Exit from the File menu. 
  

o Connect the computer to the operator panel that is designated as the first client and 
download the project. 

  
Note:  The panel may need to be attached to the network through its PLC port, depending 
upon the network port selected for the client in the project. 
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(Continued in Creating a Project File for the Second Client) 
  

Creating the Project File for the Second Client 

 (Continued from Creating the Project File for the First Client) 
  
o Repeat steps 1 through 11. 

  
o Click on the Import button in the Network Configuration dialog box. 

  
o Select the file created in step 21 and click Open. 

  
o The controller information is copied into this new file. 

  
o Check the Enable UniNET Network button. 

  
o Click OK to close the Network Configuration dialog box. 

  
o Click the Finish button to complete the network setup process and close the Network 

Selection dialog box. 
  

o Create a page for the application. Type some text on the page, then insert a numeric data 
field by selecting Insert - Data Fields - Numeric/ASCII. 
   

o Use the cursor to outline an area for the data field. 
  

o In the Numeric Field Properties dialog box click on the Range tab. Set the Access as 
Read/Write. 
   

o Click OK. 
   

o Save the file by selecting Save from the File menu. 
  

o Close the file by selecting Exit from the File menu. 
  

o Connect the computer to the operator panel that is designated as the second client and 
download the project. 
  

Note:  The panel may need to be attached to the network through its PLC port, depending 
upon the network port selected for the client in the project. 
  
(Continued in Running the Network) 
  

Running the Network 

 (Continued from Creating the Project File for the Second Client) 
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Once all three panels are in Operation Mode they should display the variable on the screen. In 
the case of the client panels, the variable is read from the controller after the server receives a 
request from the client to read the data. 
  
o Verify that none of the three panels report any communication errors. 

  
o The variable itself may be modified using the Data Entry Mode. Changing the value of 

the data from any operator panel will change the display on the other panels. 

7.6 Panel Fonts 

7.6.1 Panel Fonts 

It is possible to have up to 4 different panel fonts on certain EH-HMI panels. The Select Font 
dialog box lets you select a font from a pull-down list. 
  

 
  
Note:  If a project file contains panel font components, switching to a standard font (not an 
enhanced font) will erase all of the panel font components in the project. 
  
o Installing New Panel Fonts 

   
o Downloading Panel Fonts 

   
o Compressing Panel Fonts 

7.6.2 Installing New Panel Fonts 

Installing New Panel Fonts 

Panel fonts, as all of our standard fonts, are associated with the various display types. To add 
a new font, copy the .FON file inside the working directory that contains the EH-View.EXE 
file. You must also modify the DISPLAYS.INI file as described below. 
  
DISPLAYS.INI 
 [DTYPE25] 
 ... 
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 CharHeight=16 
 CharWidth=8 
 ... 
 [DTYPE25 Fonts] 
 ERL25X80=ERL25X80.FON 
 UniCOMIC=UniCOMIC.fon 
 Uni7SEG=Uni7SEG.fon 
 [Uni7SEG Font] 
 BargraphStart=226 
 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
 BigCharStart=128 
  

Character Size 

Panel Font Character Size 

Some panels use an 8x16 character size and other panels use an 8x15 character size. A font 
that has an 8x16 character size cannot be used on a EH-HMI that supports only an 8x15 
character size and vice versa.  
  
The panel characters size can be found inside the [DTYPEnn] section. The DTYPE code used 
for a particular panel can also be found by reading the panel database file. 
   
All new fonts must be declared inside the [DTYPEnn Fonts] section and a new [<Font 
Name> Font] section with  
the necessary graphic character codes must be added. The necessary graphic character codes 
to be used are shown below. 
  
Uni7Seg Font 
   
UniComic Font 
  

UniComic Font 

Normal:  Courier New (only first 127 characters) 
 Double:  Comic Scans MS 
 Large:  Comic Scans MS 
 Extra Large:  Comic Scans MS 
Basic font for 8x16 panel type:  ERL25x80.FON 
[UniComic Font] 
 BargraphStart=226 
 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
 BigCharStart=128 
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Basic font for 8x15 panel type: SH164015.FON 
[UniComi5 Font] 
 BargraphStart=226 
 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
 BigCharStart=128 
  

Uni7Seg Font 

Normal:  Courier New (only first 127 characters) 
 Double:  Ni7Seg 
 Large:  Ni7Seg 
 Extra Large:  Ni7Seg 
Basic font for 8x16 panel type:  ERL25x80.FON 
[Uni7SEG Font] 
 BargraphStart=226 
 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
 BigCharStart=128 
Basic font for 8x15 panel type:  SH164015.FON 
[Uni7SEG5 Font] 
 BargraphStart=226 
 
BoxChars=218,191,192,217,196,179,196,179,180,194,193;201,187,200,188,205,186,205,186
,0,0,0 
 BigCharStart=128 
  

7.6.3 Downloading Panel Fonts 

EH-View automatically downloads panel fonts along with the project file whenever panel 
fonts have been used. These fonts will be downloaded to the EH-HMI panel each time the 
project file is downloaded. 
  
If these fonts have already been downloaded, it is not necessary to re-download them. To save 
time, from the Transfer menu select Options. Click on the Transfer Advanced tab. 
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Uncheck the Download Fonts checkbox, and the panel fonts will not be downloaded. 
  

7.6.4 Compressing Panel Fonts 

In order to save memory in the EH-HMI panel, EH-View automatically compresses the panel 
font files that it downloads. 
  
If necessary, you can disable this optimization by selecting Transfer - Options. 
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Click on the Transfer Advanced tab and uncheck the Compress Fonts checkbox. 
  
  
Note:  Font optimization will be automatically disabled when PLC references in ASCII 
format are used. 
  

7.7 Printing 

7.7.1 Printer Setup 

To set up a serial printer, select Project - Report on Panel Printer - Printer Setup. This will 
display the Printer Setup dialog box. 
  
From this dialog box, you can choose the printer you will be using, set the communication 
parameters, and define the page size. 
  
If you will be using a printer that is not listed, you can use the Add button to add a new 
printer to the list of available printers. Doing so will bring up the Printer Properties dialog box 
in which you can define the parameters for the newly added printer. Similarly, you can use 
the Edit button to redefine the parameters for an existing printer. 
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Note:  If you will be printing reports, the paper height should be defined here before the 
report is defined. If you change the paper height with some reports already defined, the report 
layouts that have already been defined will not automatically be rearranged. 
  

7.7.2 Reports 

Reports 

A report is a collection of project file pages (or parts of project file pages). Each report is 
divided into two parts. One is a common part, such as the header and footer. These will be 
common to each and every page of the report. The second is the display page that is the body 
of the report. 
  
o Creating a New Report 

   
o Setting Up Report Headers & Footers 

   
o Advanced Report Parameters 

   
o Triggering a Report Printout 

Creating a New Report 

To define a report, select Project - Report on Panel Printer - Reports. Add a report by clicking 
the New button. You can rename the report with a more descriptive name if you wish by 
single-clicking on the report name, then typing in a new name. 
  
All of the pages of your project file will be shown on the General tab in an "Available Pages" 
box on the left. To add a page to the report you are creating, select the page and click on the 
Add-> button. Doing so will place the page name into the "Report Pages" box on the right. 
  
By selecting a page from the "Available Pages" box and pressing the Properties button, you 
can specify what part of the project file page to print and where to start printing on the page. 
  

Setting Up a Report Header and/or Footer 

The structure of the header and the footer are the same. It is possible to define the height of 
the header and the footer, and several predefined fields that can be inserted into the header or 
footer. 
  
Under the Header and Footer tabs you can specify the height of the header/footer, the fields 
that are inserted into the header/footer, where they are inserted at and how they are 
positioned. 
  
  



EH-VIEW (en) - July 2005 - 05/005 

Page 465 

Fields that can be inserted include the time and date, the page number, the report name and a 
label (which allows you to enter static text). 
  

Advanced Report Parameters 

Under the Advanced tab you can set up various parameters that are common for every page in 
the report.  
  
These include whether or not to wrap lines, the default font, how to transform various 
attributes, what to do with non-printable characters, etc. 
  

Triggering a Report Printout 

A report printout can be triggered in three different ways: 
  
o With a macro that is associated to a function key or a touch cell. 

  
o Cyclically at a specified time. 

  
o From a PLC request issued through the Interlock Mailbox. 

  
To set up a report to be printed when a function key or touch cell (use commands from the 
Insert menu to create the touch cell), select Keyboard Macro Editor from the Project menu. In 
the Macro Editor dialog box there is a macro command entitled Print Report. 
  
Select a tab to correspond to the page where you want the trigger to be placed. From the 
Commands toolbar, select the Print Report icon. The Choose Report dialog box appears, 
where you can select which report is to be printed when this key (or touch cell) is pressed. 
  
Any report can be printed cyclically in two different modes: any day at a specific time or 
cyclically after an interval of time. 
  
You can set a cyclical trigger by selecting Project - Report on Panel Printer - Triggers. 
  
The third way to start a report printout is to use the Interlock Mailbox. This can be accessed 
from Project - Panel Controller Interface, then selecting the Interlock Mailbox tab and using 
the mailbox command Start Report Printout. 
  
Use the command Stop Report Printout to stop printing. 
  

7.7.3 Printer Setup Example 

In this example we will add a new printer and set up a print sequence using the Keyboard 
Macro Editor. 
  
o Select Project - Report on Panel Printer - Printer Setup. 
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o Initially only a generic printer is listed, so we will add a new printer to the list. Press the 
Add button and the Printer Properties dialog box appears. 
  

o Enter a name for the new printer in the Printer name box. 
  

o Enter an escape sequence for the new printer in the Escape sequences box. 
  

o Click OK. 
   

o Enter a file name for the printer file. 
  

o Click OK. 
   

o Verify the communication parameters. 
  

o Set the page size. 
  

o Click OK. 
   

o Now we need to define a report to print. Select Project - Report on Panel Printer - 
Reports. 

o Add a report by clicking the New button. 
  

o Single-click on the report name, then type in a new, more descriptive, name. 
  

o Click on a report page on the left side of the General tab to select it. Press Add-> to add 
that page to the report list on the right side of the tab. 
  

o Click on the page name in the right-hand list and click on Properties. 
   

o Set the page properties such as spacing, fonts, etc. 
  

o Click OK. 
   

o Click on the Header tab. 
  

o Select several fields under Field Type to include on the page header. 
  

o Click on the Footer tab. 
  

o Select several fields under Field Type to include on the page header. 
  

o Click on the Advanced tab. 
  

o Verify the print settings, then click OK. 
   

o Next we program a macro to print the report when function key F22 is pressed. Select 
Keyboard Macro Editor from the Project menu. 
  

o In the Macro Editor dialog box on the All Pages tab select panel key F22. 
   

o Under Commands, select Print Report. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 467 

o Choose the report to be printed when key F22 is pressed. 
  

o Click OK to return to the Macro Editor. 
   

o Click OK to close the Macro Editor. 
   

o The project is now set up to print the selected report whenever panel key F22 is pressed. 

7.8 RDA 

7.8.1 RDA 

The UniNET network fully supports the use of all panel Reserved Data Areas (RDA), 
including Alarms and Mailboxes. 
  
These Reserved Data Areas can be placed in any controller attached to any server on the 
network.  
  
The RDA concept offers a simple and efficient method to have the controller program interact 
with the operator panel. 
  
See the RDA Setup section for additional information on the use of the RDA in EH-View. 
  
Note:  Since most RDA activities are carried out on a cyclical basis, even with a small 
number of nodes in the network the result may be that most of the network traffic will be for 
RDA updates. This may cause an exceedingly slow update time for displayed variables. 
  
Each EH-HMI panel may use up to three small reserved areas of controller memory to 
establish an interface with the controller. These three reference areas are:  Keys, Panel, and 
PLC. You can select the starting address of each of these areas. 
  
  
The figure below illustrates the flow of communication for each of the reserved data areas. 
  

 
  
A memory map of the entire reserved data area is shown below. 
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As shown in the two previous pictures, the four Reserved Data Areas are: 
  
o Keyboard Update Area 

  
o Panel Status Area 

  
o Controller Update Area 

  

7.8.2 Keyboard Update Area 

This reserved area is formatted to contain flags for each key on the panel and extended 
keyboard. These flags are set HIGH when a key is pressed and set LOW when released. Each 
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key status flag occupies one bit in the controller memory. These bits can be used by the 
controller to detect when a particular key has been pressed and then in turn perform a specif ic 
operation. It is recommended to use the Keyboard Macro Editor to program keys. This 
method is easier and more efficient than programming a key using ladder logic. 
  
Note: In the Keyboard Update Area of the RDA, the ENTER key is mapped to K1, the 
CLEAR key is mapped to K16, and the HELP key is mapped to K15. 
  

7.8.3 Panel Status Area 

7.8.4 Panel Status Area 

This reserved area is formatted to contain time and date information from the panel’s Real 
Time Clock, a two-byte Panel Status Word, and a Current Page Register. 
  

Real Time Clock 

The real time clock contains the time and date information. Depending upon the type of 
controller that is being used, this information will be stored in either binary or BCD. A listing 
of various PLCs and how the RTC is stored can be found in the EH-HMI Installation & 
Operation Guide 
  

Panel Status Word 

Panel Status Word 

The panel sets and resets bits S0-S8 and S13-S15 in the Panel Status Word to indicate its 
current status. Your application logic can monitor these bits to determine how and when it 
should interact with the panel.  The following table has a brief description of each status bit. 
  
Bit # Function 
S0 Link status monitor flag 
S1 Data entry active 
S2 Printing in progress 
S3 Printer status 
S4 Date and time update in progress 
S5 Attempt to access protected function 
S6 Battery low 
S7 Alarm active 
S8 Unacknowledged alarm active 
S12 Recipe and event backup in progress 
S13 Recipe upload in progress 
S14 Recipe download in progress 
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S15 Recipe file status 
  

S0 Link Status Monitor Flag 

Bit S0 in the Panel Status Word can be used by the controller to monitor the communication 
status between the panel and the controller. The value of this bit is changed by the panel with 
a cycle time of approximately one second. If a transition is not detected within one second, 
the controller should consider that the panel is either not connected or not operating properly. 
  
Note:  If the cycle time of the controller program is longer than one second or if there are 
numerous communication errors, one transition of the Link Status flag can go undetected. 
  

S1 Data Entry Active 

Bit S1 is set whenever the panel is in Data Entry Mode. 
  

S2 Printing in Progress 

Bit S2 is set whenever the panel is in the course of sending data to the printer. 
  

S3 Printer Status 

Bit S3 of the Panel Status Word contains the current logic state of the CTS (clear to send) 
line. This line is being driven by the printer and indicates the printer's readiness to accept 
data. 
  

S4 Date and Time Update in Progress 

Bit S4 in the Panel Status Word is used to synchronize access to the panel's real time clock 
(RTC).  
  
Before writing a new time and date record, the panel sets bit S4 in the Panel Status Word to 
indicate that it is about to update this data. The panel then writes the time and date 
information to the Reserved Data Area (RDA) and resets bit S4. The controller program 
should always check the update flag before reading the time and date record. If the bit is set, 
the controller should not use the time and date information. 
  
Note:  This bit is not set when the panel updates only the "seconds" field. 
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S5 Attempt to Access Protected Function 

Bit S5 of the Panel Status Word is set when the panel user tries to access a function that is not 
accessible with the current password. Since in this case no message is displayed by the panel 
itself, the controller can be used to check this status bit and notify the user that the function 
they are trying to access is protected. 
  

S6 Battery Low 

Bit S6 of the Panel Status Word is set when the backup batteries become weak. These 
batteries maintain recipe data as well as time and date information, which is stored in RAM. 
  

S7 Alarm Active 

Bit S7 of the Panel Status Word is set when at least one alarm is active. Bit S7 is reset when 
all alarm bits are reset to zero. 
  

S8 Unacknowledged Alarm Active 

Bit S8 of the Panel Status Word is set whenever there is at least one active alarm that requires 
acknowledgment. It is reset when all alarms have been acknowledged. 
  
Note:  Enabling the Operator ACK Required attribute when creating alarm messages 
guarantees that bit S8 will remain set until the alarm is acknowledged. It does not guarantee 
that the bit associated with the alarm in the RDA will remain set. Those alarm bits are 
controlled by application logic, not by the panel. 
  

S13 Recipe Upload in Progress 

Bit S13 is set whenever a recipe is being uploaded from the controller into the panel. It is 
reset whenever the upload process is complete. 
  

S12 Recipe and event backup in progress 

The S12 bit of the RDA area is used to communicate to the controller when a backup 
operation to flash memory is in process. The EH-HMI will set this bit to 1 just before the 
backup operation begins. When the backup operation is complete, EH-HMI will set this bit to 
0. 
  
Recipe/Event Backup: 
  
0 = Standby 
1 = Backup operation in progress 
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S14 Recipe Download in Progress 

Bit S14 is set whenever a recipe is being downloaded from the panel into the controller. It is 
reset whenever the download process is complete. 
  

S15 Recipe File Status 

Bit S15 displays the Recipe File Status. A "0" indicates that the recipes contain valid data. A 
"1" indicates that the recipe data is corrupt or still contains the default values defined in the 
project file. 
  

Current Page Register 

The panel writes the number of the currently displayed page into the CP register whenever the 
panel is in Page mode or Data Entry Mode. In all other modes, a zero is written into this 
register, indicating that page data is not currently being displayed. 
  
Note: Page numbers are stored in either binary or BCD format, depending on the controller 
being used. 
  

7.8.5 Controller Update Area 

Controller Update Area 

The Controller Update Area allows the controller to access and control certain aspects of the 
panel. All front panel LED’s can be controlled from this area to provide feedback to the 
operator. The controller may also request a specific page to be displayed by writing the 
appropriate value into the Page Request Register. The Controller Control Word allows the 
controller to request the printing of a page, disable data entry, select an alarm mode, or enable 
the mailbox function. 
  
All panels include a standard set of dedicated indicators that allow the user to monitor the 
status of the panel. Along with these dedicated indicators, certain models include a subset of 
user defined LED’s that can be monitored and controlled by your application logic. The 
control of these LED’s is carried out through the Controller Update Area. Each of the 
registers found there can be copied to bit address contacts so that the status bits can be 
referenced as control relays. 
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LED Control Bits 

LED Control Bits 

Bits L1 through L32 control the LED indicators that can be found on various panel models. 
The mappings of these bits are listed below 
  
Two tables show how LED's are mapped, the LED Map for All Panels Except Eight User 
LED's and the LED Map for Eight User LED's. For example, the F1 key is mapped to L1 and 
the 0 numeric key is mapped to L17. All of the panels except those that have eight user LED's 
are mapped according to this table. 
  

LED Map for All Panels 

LED Key 
L1 F1 
L2 F2 
L3 F3 
L4 F4 
L5 F5 
L6 F6 
L7 F7 
L8 F8 
L9 F9 
L10 F10 
L11 F11 
L12 F12 
L13 F13 
L14 F14 
L15 F15 
L16 F16 
L17 0 
L18 1 
L19 2 
L20 3 
L21 4 
L22 5 
L23 6 
L24 7 
L25 8 
L26 9 
L27 . 
L28 +/- 
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LED Map for Eight User LEDs 

The mapping in the following table represents panels that have eight user LED's.  
  
LED  KEY 
L1 F1 
L2 F2 
L3 F3 
L4 F4 
L5 F5 
L6 F6 
L7 F7 
L8 F8 
L9 F9 
L10 F10 
L11 F11 
L12 F12 
L13 F13 
L14 F14 
L15 F15 
L16 F16 
L25 USER LED 0 
L26 USER LED 1 
L27 USER LED 2 
L28 USER LED 3 
L29 USER LED 4 
L30 USER LED 5 
L31 USER LED 6 
L32 USER LED 7 
  

Page Request Register 

The page to be displayed can be selected either by the operator from the front panel keypad or 
by the controller itself. 
  
The controller selects the page to be displayed by writing the corresponding page number into 
the PR register in the Controller Update Area. Note that once the panel has changed to the 
corresponding page, the user needs to write a 0 back into the PR register in order to return 
control back to the keys on the panel. If this is not done, the user will be ‘stuck’ on that page. 
When the panel detects a page request from the controller, it checks the front panel keyboard 
and the Expanded Keyboard (if present). If no key has been pressed for the last three seconds, 
the page selected by the controller is displayed.  
  
While a controller page request is active (PR not 0), the operator will not be able to change 
pages using the arrow keys. 
  
Note: Page numbers are stored in either binary or BCD format, depending on the controller 
being used. 
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Controller Control Word 

Controller Control Word 

The bits of the Controller Control Word are set and reset by the controller according to the 
application logic. The panel responds to these bits as shown in the following table. 
  
  
Bit # Function 
C0 Print Screen 
C1 Disable Data Entry 
C2 Select Alarm Mode 
C15 Enable Mailbox 

C0 Print Screen 

When bit C0 in the Controller Control Word is set, the panel sends the currently displayed 
page to the printer. The bit must be reset to 0 before another print request can be processed. 
  
Note: If the current password enables the user to request printouts, the currently displayed 
page can be printed directly from the front panel by pressing the "Prt Scr" or "9 / PRT" keys 
(depending on the panel model). 
  

C1 Disable Data Entry 

When bit C1 in the Controller Control Word is set, the operator cannot enter the Data Entry 
Mode on the panel, even if the password otherwise enables them to do so. In this way, the 
controller can temporarily or permanently inhibit modification of variable values in a way 
defined by its program. 
  

C2 Select Alarm Mode 

When C2 is set, the display will NOT switch to Alarm mode automatically. Instead, the 
operator will have to select ALARM from the Panel Command menu with the proper 
keyboard actions. Once inside the ALARM menu, the user will be able to view and 
acknowledge any active alarms (If there are no pending alarms, the user will not be able to 
enter the ALARM menu). When the bit is reset to zero, the display will automatically switch 
to Alarm mode when at least one alarm is active. 
  
Note: Bit C2 only disables the automatic display of the alarm screen. Any alarm attributes 
that were set during project development remain active. 
  



EH-VIEW (en) - July 2005 - 05/005 

Page 476 

C15 Enable Mailbox 

Setting bit C15 enables the panel to cyclically read the data in the Mailbox. Note that the 
Mailbox must be configured prior to setting this bit (see Chapter 8). When this bit is not set, 
the panel will not read the data in the Mailbox, thus reducing communication time and 
increasing system performance. 
  

Buzzer handling 

The PLC Control Word of RDA block, bit C6 & C7 are used for buzzer control through PLC. 
By setting C6, buzzer control is given to PLC and the PLC switches the buzzer on/off using 
C7 bit. 
  
Two bits are used for this i.e.  
  
Enable bit: 
  
bit = 0 buzzer standard,  
bit = 1 control from PLC 
  
Control bit:  
  
if Enable bit = 1, then  
  
bit = 0 buzzer off, 
bit = 1 buzzer on 
  
  

7.9 Recipes 

7.9.1 Recipes 

Data may be stored inside a panel in data retentive memory. The available amount of data 
retentive memory varies depending on the EH-HMI model. This data retentive memory can 
be used to permanently store data for use by an attached controller. This data can be written to 
the controller, and, conversely, the data can be read from the controller and then placed in the 
data retentive memory. This concept is termed "Recipes" and offers a powerful way to extend 
the capabilities of the controlle r. This is especially true for controllers that have a limited 
amount of internal memory. 
  
Recipes are configured by adding the required controller data items to a page as recipe data 
fields. A recipe can be associated with a particular page and is composed of all the recipe data 
items on that page. Recipe data items contain all the information associated with normal 
controller data fields, but rather than the data being read and written directly to the controller 
during the course of normal operation, the data is instead read from and written to the EH-
HMI memory that is reserved for the data item. Only when the EH-HMI panel is explicitly 
asked to write the data to the controller is the data sent to the controller. Similarly, only when 
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the EH-HMI panel is explicitly asked to read the data from the controller is the data actually 
read from the controller. 
  
o Working with Recipes 

  
o Inserting Recipe Data Fields 

  
o Configuring Recipe Parameter Sets 

  
o Recipes and Control Variables 

  
o Recipes and the Keyboard Macro Editor 

  
o Recipe Menu 

  
o Recipes and the Interlock Mailbox 

  
o Multipage Recipe Support 

  
o Recipes and Events Backup in Flash 

  
o Recipe Examples 

7.9.2 Working with Recipes 

Setting up a recipe, although not particularly complex, does involve several steps. These 
include: 
  
o Inserting recipe data fields 

  
o Configuring recipe data fields 

  
o Creating a Recipe Menu 

  
o Programming the Recipe Menu using the Keyboard Macro Editor 

  
o Downloading the recipe to the panel 

7.9.3 Inserting Recipe Data Fields 

Before any other recipe actions can take place, a recipe data field must exist in a project. To 
add a recipe data field, use Insert - Data Fields to add a Numeric/ASCII, Bargraph, or 
Message Data Field and set the Reference type as Recipe. 
  
Before a recipe can be configured, a recipe data field must be inserted into a project. Recipe 
data fields can be added to a page from the Data Fields submenu under the Insert menu. From 
the Data Fields submenu, select either Numeric/ASCII, Bargraph, or Message. 
  
From the Data Field Properties dialog box, you can specify that the data field be of Reference 
type PLC, a panel Control Variable, Recipe data, or Index. The Control Variable offers a 
means of controlling and monitoring recipes. 
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Once a data field identified as a recipe type has been added to a project page, you can work 
with other recipe commands. 
  

7.9.4 Configuring Recipe Parameter Sets 

A recipe is associated with a particular page and is composed of all the recipe data fields on 
that page. However, there can be a number of different parameter sets for a recipe. 
  
A parameter set is a specific block of data within a recipe. A recipe parameter set is created 
by assigning particular values to the recipe data fields on a page. With EH-View, it is possible 
to create many different parameter sets within a single recipe. Depending upon the panel 
model, there can be up to 1024 parameter sets of a single recipe. Not only is a block of 
memory in the panel reserved for every recipe; separate blocks of memory are also reserved 
for each of the parameter sets contained within a particular recipe. All the parameter sets of a 
particular recipe always contain the same recipe data items but the values of these recipe data 
items vary between the different parameter sets. 
  
These different recipe parameter sets can control different processes. One set may be used to 
configure the controller to control the production of 2 mm screws, another set may be used to 
configure the controller to control the production of 5 mm screws, and yet another to control 
the production of 7 mm screws. Each set of parameters is stored in a different parameter set 
within the same recipe. 
  
You can specify the number of parameter sets to be contained within a recipe, as well as 
assign the initial values to the different parameter sets of a recipe. From the Page menu select 
Recipe Configuration. This brings up the Recipe Configure dialog box where initial values 
may be entered for recipe data items. These initial values will be in the format that was 
specified for that data field in the Data Field Properties dialog box. For example, if a 
numerical format of hexadecimal was entered in the Data Field Properties dialog box for a 
recipe data item, then all the subsequent values entered in the Recipe Configuration dialog 
box for this recipe data item will also be in hexadecimal. If you specify a numeric data format 
of hexadecimal for a recipe data item, and then enter a value of 10 in the Recipe 
Configuration dialog box, the 10 will be interpreted as 10 hexadecimal (base 16).     
  
Note:  Recipe data items must be defined on the current page before the Recipe Configuration 
dialog box can be activated. To do so, insert a Numeric/ASCII, Bargraph, or Message data 
field and select Recipe as the Reference. 
  
Note:  The recipe values section is in the form of a spreadsheet. Each row is associated with a 
particular recipe data field. The controller address of the recipe data item is displayed at the 
far left hand side of the row, enabling you to tell which row is associated with which recipe 
data item. Each column is associated with a particular parameter set of the recipe. Each 
parameter set is identified by a number. The first column corresponds to parameter set 1, the 
second column to parameter set 2, and so on. 
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7.9.5 Recipes and Control Variables 

Recipes and Control Variables 

Control variables offer a means of controlling and monitoring the Recipes. Control variables 
are special data fields that are stored in the EH-HMI panel memory. You can control certain 
operations of the panel by modifying the values held in these internal variables.  
  
There are six types of control variables that affect recipes:  Recipe File Status, Recipe 
Parameter Set Selection, Recipe Action, Data Entry Status, Data Entry Field Number, Recipe 
Page for Selection, and Recipe Key. 
  
Control variables can be added to the project in the same way as other data fields. Control 
variable data fields can be added to a page from the Data Fields submenu under the Insert 
menu. From the Data Fields submenu, select either Numeric/ASCII, Bargraph, or Message. In 
the Properties dialog box, set the Reference type as Variable. Click the "…" button to set the 
reference location, data type and format, page number, etc. in the Data Field Properties dialog 
box. 
  

7.9.6 Recipes and the Keyboard Macro Editor 

The Keyboard Macro Editor provides a way to configure panel keys to perform recipe 
functions. When doing so, use Page n mode (where n is the page on which the recipe of 
interest is located). 
  
Keyboard Macro Editor commands that pertain to recipes include: 
  
o Recipe Control - can be used to download, upload, or select a parameter set. 

  
o Go to Recipe Menu - can be used to jump to a page with a Recipe Menu. 

  
o Scroll Recipe Menu - can be used to scroll to a selection in the Recipe Menu. 

   
o Confirm Recipe Menu Selection - can be used to accept the selected parameter set name. 

  
o Recipes and Events Backup - can be used to back up recipe data, as well as the event list, 

into flash memory inside the panel. 
  

o Step Control Variables - can be used to assign a key or touch cell to toggle through the 
different parameter sets. 
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7.9.7 Recipe Menu 

Recipe Menu 

The Recipe Menu is a feature that simplifies recipe parameter set selection on EH-HMI 
panels through a user-friendly interface. It provides a menu-like field that can contain names 
to describe the parameter set instead of using numbers. Each name represents one recipe 
parameter set. 
  
Note:  A Recipe Name field must be defined to enable Recipe Menu support. 
  
o Recipe Names 

  
o Recipe Menu Support Fields 

  
o Creating a Recipe Menu Field 

  
o Recipe Menu Keyboard Macros 

Recipe Names 

Recipe Names 

A Recipe Name should be defined for all of the pages containing recipes that are going to be 
handled using the Recipe Menu, and also for pages that are referred to by Recipe Key fields. 
  
This is done by adding a Numeric/ASCII data field with an ASCII display style and Recipe 
type Reference on the page where the recipe is located and filling the Recipe Item values in 
the Recipe Configuration box with an ASCII name for each parameter set. 
  
This ASCII field is called a "Recipe Name" field. (This field is not a field type name; it only 
describes the field's purpose.) If the referred page has no Recipe Name field defined, the 
Recipe Key field will display asterisks ("*"). 
  
Note:  This ASCII field is not an internal variable in the panel memory. It needs to be 
addressed to a physical location in the PLC memory. The amount of memory required 
depends on the length of the ASCII string: one byte per character. 
  
A Recipe Name Example is provided. 
  

Recipe Name Example 

This example of creating a Recipe Name assumes that the current page is the page with 
defined recipes and that it is the page for which you want to add a Recipe Name. 
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o Create a new project file by selecting New from the File menu, or by clicking on the 
New icon on the toolbar. Name the new file and click OK. 
   

o Insert an ASCII data field by selecting Insert - Data Fields - Numeric/ASCII, or clicking 
on the Numeric Field icon on the toolbar. 
  

o Use the cursor crosshairs to define a data box on the page. 
  

o Select the data field style as ASCII, and set the Reference to be Recipe. 
  

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
   

o Click on the Range tab. Select Read/Write to make recipe names editable. 
  

o Click OK. A data field placeholder will appear using "R" as a placeholder for the actual 
recipe values. 
  

o From the Page menu choose Recipe Configuration. 
   

o Set the Number of Parameter Sets as appropriate. (For example, set to 4 to define four 
recipe parameter sets if you also plan to also enter four numeric style recipe data fields 
on the page.) 
  

o Find the Recipe Item with the location of the Recipe Name field. (This will normally be 
the row with empty boxes.) Fill in the boxes in the row for that Recipe Item with ASCII 
names for the recipe parameter set. 
  

o Select this Recipe Item by clicking on the button with the record number. The entire row 
highlights to indicate that it is selected. 
  

o Click on the Set As Recipe name button to set this Recipe Item to be the Recipe Name. 
An asterisk ("*") appears to the right of the Recipe Item to identify it as the Recipe 
Name. 
  

o Click on the OK button to accept the changes. 

Recipe Menu Support Fields 

There are three specific fields that support the Recipe Menu. They are the: 
  
o Recipe Menu field, 

  
o Recipe Page For Selection field, and 

  
o Recipe Key field. 

  
  
The Recipe Menu field is the actual field that displays the menu with recipe names. The 
currently selected recipe parameter set is indicated using user defined attribute combinations 
(blink, highlight, reverse). 
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The Recipe Page For Selection field shows the number of the page containing the actual 
recipe data referred to by the Recipe Menu. 
  
The Recipe Key field is not directly connected with Recipe Menus. It is a less user-friendly 
way of selecting a recipe parameter set by name. In order to choose a recipe parameter set, 
you have to edit the field and type the desired recipe name (instead of being able to select it 
from a menu). It can also be used to show the currently selected Recipe Parameter Set name 
for a specific page. The Recipe Key field must refer to a specific page with a defined Recipe 
Name. 
  
These fields do not depend on each other and can be freely put on any page in the project in 
any combination. 
  

Creating a Recipe Menu Field 

Creating a Recipe Menu Field 

The Recipe Menu field is the field that displays the menu with the parameter set names. It 
displays recipe names for the page number specified by the Recipe Page For Selection 
internal EH-HMI variable. The value of this variable can be displayed and changed using the 
Recipe Page For Selection field. Its value can be automatically set by the Go To Recipe Menu 
macro command. 
  
The currently selected recipe name is indicated with a user-defined attribute combination 
(blink, highlight, reverse). 
  
Note:  A Recipe Name field must be defined to enable Recipe Menu support. 
  
Note:  The only field on the page needed for displaying a Recipe Menu is the Recipe Menu 
field. Other fields can show additional information but are not necessary. 
  
Note:  If Recipe Page For Selection contains the page number of a page without a Recipe 
Name field defined, the Recipe Menu field will display asterisks ("*"). 
  
A Recipe Menu example is provided. 
  

Recipe Menu Example 

The following procedure describes how to add a Recipe Menu field. 
  
o Create a new project file by selecting New from the File menu, or by clicking on the 

New icon on the toolbar. Name the new file and click OK. 
   

o Insert a numeric data field by selecting Insert - Data Fields - Numeric/ASCII, or clicking 
on the Numeric/ASCII icon on the toolbar. 
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o Use the cursor crosshairs to define a data box on the page. 
  

o Select the data field style as Numeric, and set the Reference to be Recipe. 
  

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
   

o Click OK again. A data field placeholder will appear using "R" as a placeholder for the 
actual recipe values. 
  

o Select Insert - Recipe Menu, or click on the Recipe Menu icon on the toolbar. 
  

o Use the cursor crosshairs to define a box on the page. This area will contain the Recipe 
Menu field. 
  

o The Recipe Menu dialog box appears. 
o   
o Adjust the Width and Height of the Recipe Menu field if necessary. 

  
o Choose the attribute combination (blink, highlight, and/or reverse) for indicating the 

selected recipe name. 
  

o Check Show Record Numbers if you want to show the record number (which is just the 
parameter set number) along with the recipe name. 
  

o Click on the OK button. 

Recipe Menu Keyboard Macros 

Three special keyboard macros support Recipe Menus. They are: 
  
o Go to Recipe Menu - can be used to jump to a page with a Recipe Menu. 

  
o Scroll Recipe Menu - can be used to scroll to a selection in the Recipe Menu. 

  
o Confirm Recipe Menu Selection - can be used to accept the selected parameter set name. 

7.9.8 Recipes and the Interlock Mailbox 

The Interlock Mailbox offers a powerful way to control the operation of recipes from the 
controller. There are seven mailbox commands available to function with recipes: 
  
o Start Recipe Download 

   
o Start Recipe Upload 

   
o Recipe Status 

   
o Get Parameter Set Number 

   



EH-VIEW (en) - July 2005 - 05/005 

Page 484 

o Set Parameter Set Number 
   

o Get Recipe Transfer Priority 
   

o Set Recipe Transfer Priority 
   

The mailbox commands allow the choice of the recipe page and also of the parameter set. All 
mailbox commands related to recipes return a completion code describing the results of the 
operation. The mailbox interface to recipes is particularly useful if it is necessary to transfer a 
sequence of recipes to and/or from the panel. 
  

7.9.9 Multipage Recipe Support 

Multipage Recipe Support 

Data which are logically part of a single recipe can be scattered over several project pages and 
still be selected, downloaded or uploaded with a single command. A recipe spanning several 
pages is called "Multipage Recipe". 
  
Note:  Multipage recipes are supported by EH-HMI firmware versions 4.20 and later. 
  
o Multipage Organization 

  
o Multipage Configuration 

  
o Recipe Menu for Multipage Recipes 

Multipage Organization 

You can define one multipage recipe and as many standard, single -page recipes as you wish 
per project. The multipage recipe can contain any number of pages, even all the pages in the 
project. 
  

Multipage Configuration 

To enable the Multipage recipe feature in the EH-View software, define the desired number 
of single page recipes in your project and for each of these pages check the Multipage recipe 
checkbox in the Recipe Configuration dialog box. 
  
Marking the checkboxes links all multipage recipe pages together and any recipe-related 
action (parameter set selection, upload and download) done in run-time (i.e., on the EH-HMI 
panel) on any linked page will result in the same action being done for all the pages. In other 
words, parameter set selection, upload, and download process can be done by referring to any 
page contained in the multipage recipe. 
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The Multipage recipe checkbox must be checked for all pages belonging to the multipage 
recipe. For any recipe page not contained in the multipage recipe, simply leave the checkbox 
unchecked, as it is by default. 
  
The recipe name should be defined in only one page of the multipage recipe. If you want to 
display names in the recipe menu for the multipage recipe, the Recipe Page for Selection field 
must refer to the page that contains the ASCII field declared as the Recipe Name. 
  
Note:  The definition of parameter set numbers and values for a multipage recipe is still done 
one page at a time, as it is for standard, single -page recipes. 
  
Note:  An equal number of parameter sets in all pages belonging to the multipage recipe 
should be defined, otherwise recipe upload and/or download may be aborted in the middle. In 
addition, make sure that the variables on the pages of a multipage recipe are different. 
Otherwise, you could have problems in data integrity during download and upload operations. 
  

Recipe Menu for Multipage Recipes 

Recipe Menu features are enabled on multipage recipes in the same way as single page 
recipes. 
  
Make sure that the recipe name is defined in only one page of the multipage recipe. If you 
want to display names in the recipe menu for the multipage recipe the Recipe Page for 
Selection field must refer to the page that contains the ASCII field declared as the Recipe 
Name. 
  

7.9.10 Recipes and Events Backup in Flash 

Recipes and Event Backup in Flash 

On some of the EH-HMI panels, it is now possible to back up recipe data, as well as the event 
list, into flash memory inside the EH-HMI. This means that even the EH-HMI loses power 
AND the backup battery is discharged or missing, the recipe data and the event list will be 
preserved. 
  
To use this feature, select the two checkboxes entitled Recipe Backup and Events Backup by 
selecting Project – Panel Setup and clicking on the Settings index tab. Please note that 
selecting these features uses memory within the EH-HMI that is normally reserved for the 
project file. Therefore, the amount of memory available for the project file is reduced by the 
amount of memory reserved for the entire backup of both recipe data and the event list, which 
is 128 KB. 
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Panel Startup Sequence 
  
With this feature enabled, the following sequence is performed on power-up of the EH-HMI: 
  
o Check the data inside RAM. If the data is valid, it will be used. 

  
o If the data inside RAM is invalid, the data in flash memory is checked.  If the data inside 

the flash memory is valid, it will be used. 
  
o If the data in the flash memory is not valid, the recipe memory and the event list will be 

initialized with no data. 
  
Recipes and Events Run-Time Backup 
  

Recipes and Events Run-time Backup 

Recipes and Events backup implementation is slightly different depending on the EH-HMI 
Firmware version. 
  
Using EH-HMI Firmware version V4.40, when this feature is enabled, recipes are copied to 
flash memory automatically from the EH-HMI after any recipe backup or recipe upload 
operation. The event list is copied to flash memory any time one event happens. A new macro 
command can be used to perform a manual backup operation. 
  
Using EH-HMI Firmware version V4.44 or higher, the memory backup is activated only by 
the manual  of the corresponding macro command.  
  
If the Recipes&Events backup flags in Panel Setup are disabled, the macro command does not 
have any effect.  
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If the flags are enabled, the data backup is performed. 
  

 
  
For the duration of the write operation to the Flash memory the panel LED #65 will be on to 
indicate that a write operation is in progress. Some EH-HMI models do not have this LED.  
For those EH-HMI panels that do not have this LED, the control variable Recipe/Event 
Backup can be used to give feedback to the operator on the status of the backup operation.  
This control variable takes the values listed below. 
  
Recipe/Event Backup: 
  
0 = Standby 
1 = Backup operation in progress 
  
The S12 bit of the RDA area is used to inform the controller that a backup operation to Flash 
memory is in progress.  The EH-HMI will set this bit to 1 just before the backup operation 
begins.  When the backup operation is complete, EH-HMI will reset the bit to 0. 
  
Note: When EH-HMI goes from Operation Mode to Configuration Mode, the content of the 
Event List stored in RAM is erased; when EH-HMI goes back to Operation Mode if a valid 
list is stored in Flash, this is retrieved and copied to RAM; if the Flash memory does not 
contain any valid data, the Event list will be  empty. 
  
The use of the “Clear Event List” macro commands erases the content of the Event list stored 
in  RAM and in Flash memory. 
  

7.9.11 Recipe Example 

Recipe Examples 

Two examples are provided to experiment with recipes. One is a straightforward example of 
defining and downloading a simple recipe, while the other uses a more complex 
configuration. 
  

Simple Recipe Example 

It is not necessary to create a complex project to try recipes. This example will illustrate how 
to define a very simple recipe. 
  
o Make sure that the panel is in Configuration Mode. 

  
o Connect the panel to the PC and the controller using the correct cables. 
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o Start the EH-View software. 
  

o Create a new project file by selecting New from the File menu, or by clicking on the 
New icon on the toolbar. Name the new file and click OK. 
  

o Click on the page and insert text (PLC Data, Recipe, Temperature and Pressure) to 
resemble the figure below. 
  

 
  
o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon on the 

toolbar. 
  

o Use the cursor crosshairs to define a data box under "PLC Data" for "Temperature". 
  

o Select the data field style as Numeric, and set the Reference to be PLC. 
   

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
  

o Click OK again. A numeric data field placeholder will appear using "9" as a placeholder 
for the actual numeric values. 

o Repeat steps 6 through 10 for "Pressure" under "PLC Data". 
  

o Select Insert - Data Fields - Numeric/ASCII, or click on the Numeric Field icon on the 
toolbar. 
  

o Use the cursor crosshairs to define a data box under "Recipe" for "Temperature". 
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o Select the data field style as Numeric, and set the Reference to be Recipe. 
  

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
   

o Click OK again. A recipe data field placeholder will appear using "R" as a placeholder 
for the actual recipe values. 
  

o Select Recipe Menu from the Insert menu and click OK. 
   

o Select the option Recipe Configuration from the Page menu. This will bring up the 
dialog box shown in below. 
  

 
  
o Enter 4 for the Number of Parameter Sets. 

   
o Enter the recipe values as shown above. Note that the Recipe Item addresses are the 

reference addresses of the fields that were defined earlier. 
  

o Click OK to confirm the operation. 
  

o From the Project menu select the Keyboard Macro Editor. 
   

o On the Page 1 tab, click on F1. It will display a different color from the other keys to 
show that it is selected. 
  

o For Key States select Pressed. 
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o From the Commands bar select the command Recipe Control. (Click the arrow to view 
additional commands if this command is not visible on the command bar.) 
  

o In the Recipe Upload / Download / Select parameter set dialog box, click Download. For 
Parameter set insert 1. 
  

o Repeat steps 24 and 25 for Parameter sets 2, 3, and 4. 
  

o Click OK. 
   

o Download the project to the panel by pressing the F2 key on the computer keyboard, by 
selecting the Download icon on the toolbar, or by choosing Download from the Transfers 
menu. 
  

o When the download is finished, the panel will go into Operation Mode. The variables in 
the left column represent the content of the controller memory. The column on the right 
will represent the content of the first recipe parameter set once the F1 key is pressed. 
  

o Press the F1 key to make the panel start downloading the current recipe parameter set 
(which is parameter set 1). After a few seconds, the operation will be completed and the 
content of the controller memory will show the same values as those that are stored in 
parameter set 1. 

Complex Recipe Example 

o Create a new project file by selecting New from the File menu, or by clicking on the 
New icon on the toolbar. Name the new file and click OK. 
   

o Insert a numeric data field by selecting Insert - Data Fields - Numeric/ASCII, or clicking 
on the Numeric Field icon on the toolbar. 
  

o Use the cursor crosshairs to define a data box on the page. 
  

o Select the data field style as Numeric, and set the Reference to be Recipe. 
  

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
   

o Click OK again. A data field placeholder will appear using "R" as a placeholder for the 
actual recipe values. 
  

o Insert an ASCII data field by selecting Insert - Data Fields - Numeric/ASCII, or clicking 
on the Numeric Field icon on the toolbar. 
  

o Use the cursor crosshairs to define a data box on the page. 
  

o Select the data field style as ASCII, and set the Reference to be Recipe. 
   

o Click on the "…" button to set the Reference value. Verify the Data Field Properties 
settings, or change if necessary. Click OK. 
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o Click on the Range tab. Select Read/Write to make recipe names editable. 
  

o Click OK. A data field placeholder will appear using "R" as a placeholder for the actual 
recipe values. 
  

o From the Page menu choose Recipe Configuration. 
   

o Set the Number of Parameter Sets to 4 to define four recipe parameter sets. 
  

o Enter parameter set values as shown below. 
  

 
  
o Select the Recipe Item for the second row by clicking on the button with the record 

number 2. The entire row highlights to indicate that it is selected. 
  

o Click on the Set As Recipe name button to set this Recipe Item to be the Recipe Name. 
An asterisk ("*") appears to the right of the Recipe Item to identify it as the Recipe 
Name. 
   

o Click on the OK button to accept the changes. 
  

o Select Insert Page from the Page menu. 
  

o From the new page, select Insert - Recipe Menu, or click on the Recipe Menu icon on the 
toolbar. 
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o Use the cursor crosshairs to define a box on the page. This area will contain the Recipe 
Menu field. 
  

o The Recipe Menu dialog box appears. 
  

o Adjust the Width and Height of the Recipe Menu field if necessary. 
  

o Choose the attribute combination (blink, highlight, and/or reverse) for indicating the 
selected recipe name. 
  

o Check Show Record Numbers if you want to show the record number (which is just the 
parameter set number) along with the recipe name. 
  

o Click on the OK button. 
  

o Select Project - Keyboard Macro Editor, or click on the Keyboard Macro Editor icon. 
  

o From the Page 1 tab select the command Scroll recipe menu. 
   

o Specify the step size as 1 in the Scroll recipe menu dialog box. 
  

o Select the command Confirm recipe menu selection. 
   

o Click OK. 
   

o Go back to Page 2 (the first page that you created). 
  

o From Page 2, select Project - Keyboard Macro Editor, or click on the Keyboard Macro 
Editor icon. 
  

o Repeat steps 32 and 33 for Parameter sets 2, 3, and 4. 
  

o Click OK. 
   

o Make sure that the panel is in Configuration Mode. 
   

o Download the project to the panel by pressing the F2 key on the computer keyboard, by 
selecting the Download icon on the toolbar, or by choosing Download from the Transfers 
menu. 
  

o When the download is finished, the panel will go into Operation Mode. The variables 
represent the content of the first recipe parameter set once the F1 key is pressed. 
  

o Press the F1 key to make the panel start downloading the current recipe parameter set 
(which is parameter set 1). After a few seconds, the operation will be completed and the 
content of the controller memory will show the same values as those that are stored in 
parameter set 1. 
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7.10 Tags 

7.10.1 Tags 

Tags allow mnemonic reference to PLC variables. Tags in a project can be imported from a 
description file generated outside EH-View. 
  
To use tags, the Enable Tags box must be checked under Project - Configure Tag 
Dictionaries. 
  
Once enabled, you can select a tag name instead of filling in the PLC address for a field in the 
project. When a tag name is selected, the PLC Reference information will be automatically 
filled in with the reference information associated with the tag name. 
  
Discussions about tag dictionaries, using the Tag Editor, using tags in EH-View, and tag 
validation are provided, as is a tag example. 
  
Note:  When a tag name is selected, the PLC Reference information will be filled in with the 
reference information from the tag and the PLC Reference dialog controls will be disabled. 
You will only be able to change tag information from the Tag Editor in the Tools menu. 
  
Note:  Tag support is available for internal controllers as selected under Project - Configure 
Controller. Tag definition for an external controller is allowed only if the external PLC 
supports tag definitions. Please refer to Hitachi Technical Documentation for further 
information about drivers that support tag definition. 
  

7.10.2 Tag Dictionaries 

Tag Dictionaries 

A tag dictionary is a database of file format *.mdb. These databases may be imported to or 
exported from EH-View. 
  
The file to be used as the project tag dictionary is set under Project - Configure Tag 
Dictionaries. (This is also where you can set the Enable Tags checkbox.) Click on the "…" 
button to select the location of the tag database file of choice. Tag dictionaries are tied to 
controller brands and models. If you do not have a tag dictionary, the Tag Editor in the Tools 
menu allows you to create one. 
  
A tag dictionary is associated with each project and defines the model and attributes of the 
PLC. You can select a dictionary for your project when you enable the tag feature in the 
project for the first time. 
  
You can create multiple tag dictionaries inside a tag database and add tags to each dictionary. 
Each dictionary is configured for a specific PLC controller and model name. Each project is 
assigned to a dictionary. 
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You can create multiple dictionaries in a database in order to support a project that has a PLC 
Network and/or UniNET Network. To be able to use tags for a project that supports the 
UniNET/PLC Network, at least one dictionary must exist in the database for each of the 
nodes in the network. 
  
Note:  If a project supports a UniNET/PLC network, each UniNET node/ PLC Node must be 
tied to a tag Dic tionary in the database. You will be required to assign a tag dictionary for all 
the nodes during the configuration of UniNET/PLC network. Each node must have at least 
one dictionary in the database.  If PLC network is enabled and you change the PLC Node, the 
Tag Name controls will be initialized with the tags from the dictionary tied to the current PLC 
Node. 
  
Additional information is available on: 
  
o Tags and the UniNET & PLC Networks 

  
o Multiple Project Support 

Tags and the UniNET and PLC Networks 

With the UniNET network and a PLC network, different PLC drivers can be assigned to 
different fields in the project. Because of this, EH-View must support multiple tag 
dictionaries for a project. When assigning a tag name to a network field, EH-View will query 
the tag database for the tag dictionary associated with the network node's PLC driver. You 
will then be able to select the tag name from the list of tags in the associated tag dictionary. 
  
Note:  You will only be able to select a tag from a dictionary that is assigned to the given PLC 
node. This is necessary since the format of the address associated with a tag is dependent on 
the PLC. 
  

Multiple Project Support 

Typically, one tag database file will be used for each EH-View project. The tag database 
resides in the same directory as the project file. If you want to copy the project data, you must 
also copy the tag database with the project. 
  
In some instances, however, you may want to create a tag database that contains tags for 
multiple projects. As a result, the tag database has been designed such that multiple projects 
can exist in the same database. For these situations, you can set the location of the tag 
database in EH-View (if it is not in the same directory as the project file) and EH-View will 
access only the tags that are associated with the active project. 
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7.10.3 Tag Editor 

Tag Editor 

Use the Tag Editor to create dictionaries and tags in databases that can be used in one or more 
projects. The Tag Editor allows you to easily work with a large number of tags by creating a 
tag database for your project. It provides the capability to add, delete and modify tags as well 
as assign PLC addresses to each tag, plus it includes import and export capabilities to 
exchange tags with external applications. You can create a list of tag names in the Tag Editor 
and then assign the tag names to various fields of the EH-View project by simply selecting a 
tag name. 
  
The Tag Editor uses a grid-like user interface. Features of the Tag Editor include:   
  
o Add, delete and edit tags. 

  
o Enter the name, address, data type and a comment for each tag. 

  
o Create one or more Tag Dictionaries for tags associated with a PLC. 

  
o Assign group names to tags. 

  
o Import and export tags to and from external data sources. 

  
Cut/copy/paste tags using the Windows  clipboard. 
Drag and drop tags between the Tag Editor and other applications. 
Import project-specific information using a network file and assign dictionaries to each node. 
  
You can create a list of tag names in the Tag Editor and then assign the tag names to the fields 
of your project by simply selecting a tag name in the Data Field Properties dialog box. 
  
Using the Tag Editor, you can assign a tag name to fields such as Numeric, Text, Alarm 
blocks, etc. When the Data Field Properties dialog box is displayed, a box is included listing 
the available tag names. You can select a tag name from the box and the field address will 
automatically be set to the PLC address associated with the tag. 
  
When a tag is displayed in the Define Field dialog box, the tag data is retrieved from the tag 
database. As such, if you change the PLC reference for a tag in the Tag Editor, the PLC 
reference information displayed in the Define Field dialog box will be up to date. 
  
You can also change the tag dictionary for the project. When the tag dictionary is changed, 
the address for the tags in the project will be automatically updated based on the new tag 
dictionary information. 
  
Additional information is available on the following topics. 
  
o Tag Groups 

  
o Tag Editor Synchronization 

  
o Importing and Exporting Tags 
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Tag Groups 

A Group field is provided for categorizing tags. The group name is assigned when creating 
the tag and used to more easily manage large groups of tags. For example, you may want to 
group tags according to a PLC program. The program name can be inserted into the Group 
field and you will be able to sort tags by program name. 
  

Tag Editor Synchronization 

At start up, after a project upload and before a project download, EH-View will synchronize 
the project tag data with the tag database. To perform the synchronization, EH-View will scan 
the fields of the project and verify that the tag addresses in the project file match the tag 
addresses in the tag database. If there are any differences between the project data and the tag 
database, a dialog box will be displayed. This dialog box will include a list of the tags that are 
different between the tag database and the project data and provide options to update the 
project data, update the tag database, or leave the tag information unchanged.  
  
The tag data between EH-View and the tag database is also synchronized when the Define 
Field dialog box is displayed. When the Define Field dialog box is displayed for fields that 
have tag names, the tag database will be queried to retrieve the field address information. The 
address information for the database is then updated in the field and displayed in the dialog 
box. 
Using this approach, the latest information in the tag database will always be displayed in the 
EH-View project. 
  

Importing and Exporting Tags 

The Tag Editor provides the capability to import and export tags to and from external data 
sources. When the Import menu item is selected, an "Open File" type dialog box is displayed 
and you can select the desired data source from which to import tags. After the tags are 
imported, the tag names and logical addresses are displayed in the Tag Editor grid. When the 
Export menu item is selected, a Save As dialog box is displayed and you can select the 
desired export format and enter the file name to which to export the tag data. 
  
The Import and Export operations are dependent on the format of the data being imported or 
exported. 
  

7.10.4 Using Tags in EH-View 

Once you have a tags dictionary set up for a project, there are a few additional steps necessary 
to configure the project to work with the tags. The controller for the project (Project - 
Configure Controller) should be the same controller specified in the tag dictionary. 
  
From the Project menu select Configure Tag Dictionaries. Click the Enable Tags box and 
select the tag database you created for this project. 
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Then, for any applicable field (Numeric/ASCII data field, meter instrument, etc.) click "…" 
under Reference to bring up the Data Field Properties dialog box. In the Data Field Properties 
box check Enable Tags and select the tag dictionary to be associated with the reference. 
You may wish to use the Tag Validation feature in the Project menu before downloading the 
project. 
  

7.10.5 Tag Validation 

Tag Validation 

Tag Validation allows you to switch from one tag dictionary, referring to one set of PLC 
addresses, to a different dictionary, referring to different set of PLC addresses in the same 
controller, and update all the fields in the project without needing to update the individual 
PLC addresses used in the whole project. 
Also, you can switch from one tag dictionary, referring to Controller A to a different 
dictionary, referring to controller B and update all the fields in the project without updating 
the individual PLC addresses used in the whole project.  
  
This feature can also validate the PLC addresses used in a project with respect to the PLC 
addresses used in the tag dictionary, and finds and lists any discrepancy items with all details 
such as location, etc. 
This feature supports updating the tag database (with regard to PLC Address used in the 
project) and updating the project field (with regard to PLC Address used in the tag 
dictionary). 
  
See also Changing PLC Drivers. 
  

Changing PLC Drivers 

A tag name represents an address for a particular PLC. As such, when the PLC Driver is 
changed in the project, the tag dictionary and the tag names must be invalidated. To minimize 
the impact of changing the PLC driver, EH-View will attempt to match the tag names from 
the previous dictionary to the tag names in the new dictionary associated with the new PLC 
driver. 
  
When the PLC Driver is changed, you will be required to assign a new tag dictionary for the 
new PLC driver. EH-View will then iterate through the list of tags in the project and replace 
the field address associated with the tag with the address information found from the new 
dictionary. The field address associated with each tag will then be validated based on the new 
dictionary. If the tag name does not exist in the new dictionary, the address information for 
the tag will be set to a default address of the new PLC.   
  
With this approach, it is possible to change from one PLC driver to another PLC driver 
without having to reset the tag name for each field, as long as the tag dictionaries for each 
driver contain the same tag names. 
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7.10.6 Tag Example 

Tag Example 

This tag example is composed of four parts: 
  
o Setting Up a Tag Dictionary 

  
o Configuring a Project to Use Tags 

  
o Tag Validation, and 

  
o Testing Tag Validation 

Setting Up a Tag Dictionary 

Note:  If you already have a tag database and dictionary you may skip to step 4. 
  
o Select Tag Editor from the Tools menu. The Tag Editor application opens. 

  
o Select File - New from the Tag Editor to create a new tag database. Enter a name for the 

new database, specify its location, and click OK. 
   

o The database you just created appears in the Tag Editor workspace. Right-click on the 
new database and select New Dictionary, or select New Dictionary from the File menu. 
  

o Enter a name for the new tag dictionary in the Tag Dictionary box. 
  

o Select the controller driver to be used from the list under Controller Driver. 
   

o Select the particular model of that controller driver from the list under Driver Model. 
   

o Click OK. 
   

o The New group dialog box appears. Fill in the grid with tag names, comments, and any 
other necessary information. 
  

o To specify the logical addresses associated with the various tags, click on the 
Logical_address box and an arrow appears. Click on the arrow to bring up a Data Field 
Properties dialog box. Complete this box for the particular reference address and click 
OK. The information appears in the Logical_address box. The Data_Format box will 
also be automatically completed. 
  

o When the grid is completed, select Save As from the File menu to save the dictionary. 
  

o Close the New group dialog box and select File - Exit to close the Tag Editor. 
  
(Continued in Configuring a Project to Use Tags) 
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Configuring a Project to Use Tags 

 (Continued from Setting Up a Tag Dictionary) 
  
o From the Project menu, select Configure Controller. Make sure that the controller 

specified for the project is the same as the controller specified for the tag dictionary. 
Click OK. 
   

o Select Configure Tag Dictionaries from the Project menu if the Change/Select Tag 
Dictionary dialog box does not automatically appear. 
  

o Click in the Enable Tags box. 
  

o Under Database click on the "…" button. Select the tag database you created and click 
Open. 
   

o Click OK to confirm the tags and controller information and close the Change/Select Tag 
Dictionary dialog box. 
  

o Create a field or object on the project page, such as a Numeric/ASCII data field, a push 
button, or a meter instrument. 
  

o Set the Reference as PLC and click the "…" button to bring up the Data Field Properties 
dialog box where you can specify the PLC address for the field or object as per the tags 
from the tag dictionary. Click the Enable Tag checkbox. (Note:  If the Enable Tag 
checkbox does not appear in a Data Field Properties dialog box when you wish to use 
tags, start again from step 12 to ensure that the controller is properly set and that tags are 
enabled in the Tag Dictionary dialog box.) 
  

o Select the group and tag. To change any tag information, click on the Edit Tags button. 
Make the necessary changes and click OK to return to the Data Field Properties dialog 
box. 
  

o Click OK to close the Data Field Properties dialog box. 
  

o Click OK to close the field or object properties box. 
  

o Save the project by selecting Save from the File menu. 
  

(Continued under Tag Validation) 
  

Tag Validation 

(Continued from Configuring a Project to Use Tags) 
  
o Select Tag Validation from the Project menu. 

  
o If the data field PLC addresses in the project match the PLC addresses used in the 

dictionary, then the message "All the tags match with the field address values" will 
appear. Click OK. You may safely download your project. 
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(Continued under Testing Tag Validation) 
  

Testing Tag Validation 

 (Continued from Tag Validation) 
  
o If the data field PLC addresses in the project do not match the PLC addresses used in the 

dictionary, the tag validation dialog box appears with a list of the tags having a 
discrepancy. 
  

o To test this feature, simulate the following changes. 
  

o Select Project - Configure Tag Dictionaries. Click on the entry under Dictionary. A list 
of dictionaries will appear. Select a different dictionary. Click OK. 
   

o Select Project - Tag Validation. A list of address discrepancies appears.  
  

o To modify the PLC addresses, right click on an item. A menu appears allowing you to 
choose to update the field with database values, update the database with field values, or 
copy to a clipboard. 
  

o Select Update Field or Update Database, then click OK. 
   

o Select Project - Tag Validation again to verify that all tags match. Save the project and it 
may be safely downloaded. 

7.11 Trends 

7.11.1 Trends 

Trending is divided into two main parts: trend acquisition and trend viewing. Trend 
acquisition (Project - Trend Buffers) collects the data into a database. The trend viewer (Insert 
- Trend Window) displays the data from this database in a graphical format. 
  
o Trend Buffer 

  
o Trend Window 

  
o Internal Panel Control Variables 

  
o Trend Macros 

  
o Trend Printing 

  
o Mailbox 

  
o Trend Limitations 
o   
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7.11.2 Trend Buffer 

Trend Buffer 

The first step in creating a trend is to create a trend buffer. 
  
For this, you need to define two items: the PLC variable that is to be sampled, and the method 
by which the variable is to be sampled. 
  
The variable can be sampled from the EH-HMI panel or directly from the PLC. If the variable 
is sampled from the EH-HMI panel, all of the data from the trend buffer will be stored within 
the memory of the EH-HMI panel. If the variable is sampled directly from the PLC, the data 
from the trend buffer will be stored in the memory of the PLC.  In the latter case, the only 
duty of the EH-HMI will be to graphically display the trend buffer data from the PLC. 
  
o Configuring a Trend Buffer 

  
o Sampling Methods 

Configuring a Trend Buffer 

Configuring a Trend Buffer 

Trend buffers are configured under Project - Trend Buffers. Click the New (Insert) icon to 
define a new trend buffer name. Give the trend buffer a name, then select the Reference that is 
to be sampled. 
  
To remove a previously defined trend buffer, select the name of the buffer from the trend 
buffer list and click the Delete icon. 
  
o Buffer Types 

  
o Scaling 

Buffer Types 

Under the General tab of the Configure Trend Buffers dialog box you should select the size 
(number of samples that will be kept during the background sampling) and type of buffer to 
be defined. Trends can be sampled in three different ways. The first option (All Pages) is to 
continuously sample the trend buffer, regardless of whether or not the trend associated with 
the trend buffer is being displayed. The second option (Current Page) is to sample the trend 
buffer only when the page where the trend associated with the trend buffer is being displayed. 
The third option (On Page) is to sample the trend buffer only when a particular page is being 
displayed. 
  
Note:  The number of trends that can be sampled in background is limited. 
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Note:  When a trend is sampled in the background (All Pages), the sample size reflects the 
number of old samples that will be shown when the page that contains the trend associated 
with the trend buffer is displayed. When a trend is sampled in real time (Current Page), you 
will never see any old samples because sampling begins when the page that contains the trend 
is displayed. In this configuration the sample size is useful only when using the macros to 
scroll the trend along the X-axis. If these macros will not be used, you can save EH-HMI 
memory by setting the sample size to 1. 
  

Scaling 

Scaling allows for a linear transformation of the data being sampled. This allows you to scale 
the data before storing it inside the trend buffer. 
  

Sampling Methods 

The Sampling tab in the Configure Trend Buffers dialog box allows you to define when the 
trend samples will be taken, and the buffer is cleared.  
  
Samples may be collected from the trend buffer stored inside the memory of the PLC, from 
the memory of the EH-HMI on a cyclical basis, or one a time, when a variable changes value. 
Or, data can be sampled only when the defined variable does not contain a value of zero. 
  
Use the Stop Sampling checkbox to stop the sampling when the trend buffer is full. This is a 
first-in first-out (FIFO) buffer. Once the buffer is full, older sample values will be erased to 
allow the new sample values to be stored. 
  
You can choose to clear the trend buffer upon panel startup, when the trend buffer becomes 
full, or when the selected variable changes value. You can also choose to never automatically 
clear the trend buffer. However if the Stop when buffer is full checkbox is not selected, the 
oldest sample is removed and the newest sample is stored when the buffer is filled. 
  

7.11.3 Trend Window 

Trend Window 

The trend window is the area used to display the trend buffer. To create a trend window, 
select Insert - Trend Window or click on the Trend Window icon on the toolbar. Click and 
drag to define an area on the project screen. The Trend Window Properties dialog box will 
appear. 
  
Note:  A trend buffer must be defined under Project - Trend Buffers before you can access the 
Trend Window Properties dialog box. If a trend buffer has not already been established, you 
will be prompted to create one. 
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o Y-Axis 
  

o X-Axis 
  
o Layout 

Y-Axis 

The Y-Axis index tab of the Trend Window Properties dialog box allows you to select the 
trend buffers (curves) to be displayed. Use the Add and Delete buttons to add or remove trend 
buffers. 
  
For any curve, you can choose visualization properties such as line type, style, size and color. 
  
Note:  Once a curve is added to the trend viewer, you will only be able to add additional 
curves of the same sampling method to that particular trend window. 
  
EH-View creates three new variables for every curve defined. These variables are internal 
panel control variables that can be used to display properties of the trend on the EH-HMI in 
alphanumeric  format. 
  
The Y-cursor displays the value of the curve at a point on the Y-axis. Use the trend macros to 
activate the trend cursor. 
  
The Y-axis minimum and Y-axis maximum variables contain the minimum and maximum 
values of the defined Y-axis. On the right of the dialog box, you can define the default value 
(Y-axis range) that will be used when the trend window is displayed. If these internal panel 
control variables are on the EH-HMI as read/write fields, their values can be modified on-
line, allowing you to dynamically change the Y-axis range. 
  

X-Axis 

X-Axis 

Under the X-Axis index tab you can define the X-axis properties of the trend window. The 
format of the X-Axis (Time, Samples or On PLC) is defined from the curves that are inside 
the trend window. When no curves are defined, all of these radio buttons are disabled. After 
adding one or more curves, only the appropriate radio button is enabled. 
  
Note:  A single X-Axis exists for all of the curves that have been inserted inside the same 
trend viewer window. 
  
The X-axis range can be defined three different ways. 
  
o Time defined - when the trend buffers inside the trend viewer are sampled cyclically 

from the EH-HMI. 
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o Defined by a maximum number of samples - enabled when the trend buffers inside the 
trend viewer are sampled on PLC events. 

  
o Defined on the PLC - the number of samples must be defined inside the PLC memory. 

  
Automatic scroll control is available so that a trend window can shift when it becomes full. 
How much the trend viewer will be shifted upon each scroll operation can be a fixed amount 
of time or a fixed number of samples. The scroll direction defines the direction of the curve. 
The curve can be drawn Left to Right, Right to Left, Up to Down or Down to Up. 
  
The X-cursor displays the value of the curve at a point on the X-axis. Use the trend macros to 
activate the trend cursor. 
  
The X-axis minimum and X-axis maximum variables contain the minimum and maximum 
values of the defined X-axis. 
  
o Trend Buffers on PLC 

  
o PLC Memory Area 

Trend Buffers on PLC 

Samples can be collected and stored inside the trend buffer of the EH-HMI panel or in the 
memory of the PLC. This section describes how to set up and organize trend buffers that are 
sampled inside the PLC. 
  
Note:  Trend buffers on PLC are available  only on a few selected communication drivers. 
Please enquire for availability. 
  
To enable a trend buffer in PLC memory, select the On PLC radio button on the X-Axis tab of 
the Trend Window Properties dialog box.  
  

PLC Memory Area 

To properly sample and store the data in the PLC, the trend buffer needs to be defined as a 
consecutive number of words with the following structure: 
  
Word 00 Trend buffer identify (counter). Identification number of the trend buffer being 

displayed. The EH-HMI will erase its internal copy of samples when it detects a change 
in the value of this word. 

Word 01 Max number of samples (size of the trend window). Size of the trend window displayed 
on the EH-HMI as a number of samples. The uses this information each time a page of 
the project file is initialized. 

Word 02 Number of samples available to be displayed in the PLC memory. Number of active 
samples inside the PLC memory. The EH-HMI will draw a trend based on the number 
of samples entered in this memory location. When this value is increased, a new piece 
of the trend will be drawn. Likewise, when this value is decreased, a portion of the 
trend will be removed. If you want to "freeze" the trend, enter a value of zero in this 
memory location. To erase the entire trend from the EH-HMI, this value must be set to 
zero AND the value of Word 00 must be changed. 
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Word 03 Sample #01 
Word 04 Sample #02 
Word 05 Sample #03 
Word 06 Sample #04 
Word nn  Sample #(nn-2) 
  
  
  
The address of the first PLC word (Word 00) needs to be entered in the Reference field under 
Project - Configure Trend Buffers. 
  
The settings to initialize the PLC operation mode are: 
  
Initialization 
  
Word 00 0 
Word 01 <Buffer width in samples> 
Word 02 0 
  
  
Sampling (loop) 
  
Word 03/nn Add samples 
Word 02 Update the number of ready samples 
  
  
New trend 
  
Word 02 Set to 0 to invalidate the PLC trend 

buffer (EH-HMI can continue to use 
and display the samples already 
displayed, but it cannot display new 
samples)  

Word 03/nn Add new samples  
Word 00 +1 (EH-HMI detects this change and 

erases the trend)  
Word 02 Update the number of ready samples  
  
  

Layout 

From the Layout index tab of the Trend Window Properties dialog box you can define the 
main trend viewer properties such as the title, colors, border, grid, etc. Options in the Title 
section define the visual appearance of the trend viewer window title. Options in the Window 
section define the appearance of the trend viewer window. 
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7.11.4 Internal Panel Control Variables 

Internal panel control variables associated with trending can be defined and used from the 
trend viewer. Alphanumeric values of these variables can be displayed on the EH-HMI. To 
access these variables, it is necessary to switch EH-View into Control Variables mode and 
create a numeric field. You will need to select a EH-HMI variable from Insert - Data Fields. 
The Variable name control will show the list of variables that have already been defined. The 
meaning of these variables can be found inside the trend window. 
  

7.11.5 Trend Macros 

There are two icons in the Macro Editor (under Project - Keyboard Macro Editor) that are 
associated with trending. 
  
The first macro, Trend buffer print, gives you the ability to print the trend buffer in 
alphanumeric format. The "buffer to print" parameter shows all of the active trend buffers that 
can be printed. This macro can be defined as a global macro and is thus defined on the All 
Pages index tab. 
  
The second macro, Trend window, can be defined only on a local basis and must be defined 
from the Page n index tab. This macro allows for manipulation of the trend currently being 
viewed. 
  

7.11.6 Trend Printing 

Trend buffers can be printed in either alphanumeric format or in graphic format. To print a 
trend buffer in alphanumeric format use the Trend buffer print macro (under Project - 
Keyboard Macro Editor - All Pages). To print in graphic mode, use EH-View's report features 
(under Project - Report on Panel Printer - Reports). To do this, it is necessary to first create a 
page that contains the trend window. 
  

7.11.7 Mailbox 

You can start a trend buffer printout by issuing a mailbox command.  
The Mailbox command used to print a trend buffer is 0x00A1. The first mailbox parameter is 
the trend ID number. You can find the ID number assigned to the trend buffer by looking 
under Project - Trend Buffers. 
  
The mailbox command response codes are: 
  
0 OK Command executed successfully 
1 ERROR Printer is busy (another print job in execution) 
2 ERROR Invalid trend buffer ID 
  
  
An example of using a mailbox command to start a trend buffer print is shown below: 
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DB10, DB01 <- 161 (0x00A1) Write the mailbox command code 
DB10, DB02 <- 1 Write the trend ID 
DB10, DB00 <- 1 Start the mailbox command 
  
  

7.11.8 Trend Limitations 

Some limitations of using trends are listed below. In addition, the available memory area in 
the PLC that can be used to store trend buffers is limited to 60 bytes. 
  
Max number of trend windows inside the same page 10 
Max number of curves inside the same trend window 10 
Total number of curves that can be use inside the same page 20 
Max number of global trend buffers sampled in background 20 
Cyclical sampling period 1-9999 sec 
The total memory reserved for trend buffer 20 KB 
   

7.12 Working with Graphics 

7.12.1 Working with Graphics 

This section provides information on the new EH-View graphics features. 
  
These features can be divided into three major categories: 
  
o Simple Shapes 

  
o Graphics Libraries 

  
o Object Libraries 

  
  
Additional information is provided on using Color Boxes. 
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7.12.2 Simple Shapes 

 
  
EH-View enables its user to insert in their project simple vector graphics, simple shapes. 
  
Once these simple shapes are created, it is possible to change their properties by right-clicking 
on them. 
  
Alignment 
When two or more simple shapes are selected, it is possible to align them. 
To activate this function, select the Align command from the Edit menu. 
  
Size Adjustment 
In the same way it is possible to alter the size of a group of shapes. 
To activate this function, select the Make Same Size command from the Edit menu. 
  
Grouping 
Finally when two or more simple shapes are selected, it is possible to group them. 
To activate this function, right-click on the shapes and select the Group command. 
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7.12.3 Graphics Libraries 

 
  
EH-View is distributed with a rich set of predefined graphic symbols. 
  
To use these symbols just select one of them from the right category (e.g. Arrows, Banners, 
Blowers, Callouts, FlowMeters, etc...) and drag-and-drop it on the Project Screen. 
  
If necessary a BitMap Settings dialog box will pop up and allow you to adjust the symbol's 
graphic attributes to the panel currently selected inside the project. 
  
By right-clicking on the "Graphics" area a set of commands are displayed. They are divided 
into the following categories: 
  
EDIT  COMMANDS 
  
Copy 
Allows to copy the graphic symbol into the clip-board so that it can be pasted into the Project 
Screen. 
  
Remove 
Removes the graphic symbol from the catalogue. 
  
Rename 
Changes the name of the graphic symbol. 
  
  
CATALOGUE COMMANDS 
  
New Catalogue 
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Creates a new catalogue 
  
Open Catalogue 
Opens an already existing catalogue 
  
Close Catalogue 
Closes the currently selected catalogue 
  
  
IMAGE COMMANDS 
  
Export 
Exports the currently selected graphic symbol into a file (a picture) on the system. 
  
Import 
Imports a file (a picture) in the currently selected catalogue. 
  
  
ICON COMMANDS 
  
View 
Allows to select how the graphic symbols are represented inside the catalogue (icons and 
names, icons only, names only) 
  
Icon 
Allows to change or to edit the icon of the currently selected graphic symbol. 
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7.12.4 Objects Libraries 

 
  
EH-View is distributed with a rich set of predefined objects. 
  
Objects are a something more than graphic symbols. Contrary to plain graphic symbols, 
objects may contain behaviour, objects may respond to user actions. Example of objects are 
Buttons, Lights, Switches, etc...   
  
To use these objects  just select one of them from the right category and drag-and-drop it on 
the Project Screen. 
  
If necessary a BitMap Settings dialog box will pop up and allow you to adjust the symbol's 
graphic attributes to the panel currently selected inside the project. 
  
Once the object has been put in the Project Screen area, if the object is active and possess a 
given behaviour, by right-clicking on the standard properties dialog box is displayed, as 
shown here below. 
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By right-clicking on the "Objects" area a set of commands are displayed. They are divided 
into the following categories: 
  
EDIT  COMMANDS 
  
Copy 
Allows to copy the currently selected object into the clip-board so that it can be pasted into 
the Project Screen. 
  
Paste 
Allows to paste into the currently selected catalogue an object previously copied into the clip-
board. 
  
Note: this feature is not available for graphics libraries. 
  
Note: The union, via grouping, of one or more entities in the Project Screen is considered an 
Object. 
  
Remove 
Removes the object from the catalogue. 
  
Rename 
Changes the name of the object. 
  
  
CATALOGUE COMMANDS 
  
New Catalogue 
Creates a new catalogue 
  
Open Catalogue 
Opens an already existing catalogue 
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Close Catalogue 
Closes the currently selected catalogue 
  
  
IMAGE COMMANDS 
  
Export 
Exports the currently selected object into a file on the system. 
  
Import 
Imports a file in the currently selected catalogue. 
  
  
ICON COMMANDS 
  
View 
Allows to select how the objects are represented inside the catalogue (icons and names, icons 
only, names only) 
  
Icon 
Allows to change or to edit the icon of the currently selected object. 
  

7.12.5 Color Boxes 

By selecting the icon shown here below 
  

 
  
the user can insert a Color Box in the Project Screen area. 
  
By right-clicking on the Color Box it is possible to change its properties. 
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Color Box are useful to create backgrounds of a given color. 
  

7.13 Multilanguage 

7.13.1 Overview 

Multilanguage (Code Page support) features are available for EH-View 6.03 or higher. 
  
The Multilanguage feature can handle different code pages for the different languages. A 
code page (or a script file) is a collection of letter shapes used inside each language.  
  
The tables below, for example, show the different letter shapes for the Cyrillic and the Greek 
character sets used in various European languages. 
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Setting the appropriate code page for each language you can have the correct character set 
(Cyrillic, Hebrew, etc.) available inside the Touch Cell objects. 
  
Note: The letter shapes collection for a particular code page defined inside a font file is called 
a script. In this document we use indifferently the terms  “code page” and  “script file”. 
  

7.13.2 Code Pages 

The Code Page selection can be done from the Configure Language dialog box. For each 
language you can define the associated script file (character set) and the font file that will 
contain the selected script. 
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If you are defining new languages for an existing project file and you want to update all touch 
cell objects as for the new Multilanguage definition, you can set the “Update all Object with 
Multilanguage Font” checkbox. When you confirm the command with the OK button, EH-
View will set the Multilanguage font parameter inside each touch cell in the project file (the 
check box is automatically reset after completing the operation). 
  
Please, note that you are not forced to use the same script file defined globally for all your 
touch cells. If necessary you can associate a different font and script file to a specific touch 
cell. This can be useful, for example, when the Symbol font is used. 
  

 
  
  
The Layout panel of all Touch Cell types includes the Multilanguage radio button. Please, 
note that when the Multilanguage option has been selected the font dialog box does not give 
you the possibility to change the Font and the Script file selection because global parameters 
are used instead. 
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Note: When you select the Fixed or Custom radio buttons, the same font and the same script 
file is used for all the languages defined (you cannot have Cyrillic for one language and 
Greek for another). These choices can be useful for symbol fonts. Using the Multilanguage 
selection, instead, the different font and script files defined inside the global Configure 
Language dialog box are used. 
  

7.14 Ethernet Connectivity 

7.14.1 Assigning IP Address to Panel 

Every device in an Ethernet Network must have a unique IP address.  
  
A EH-HMI operator panel with Ethernet connection capability must be assigned an IP address 
before it can communicate with a computer running the EH-View software. EH-HMI is 
providing the users with the maximum flexibility in the assignment of the IP address. In fact 
there are several methods to do it and some well defined priority rules to sort which way will 
be the one active at a certain time. 
  
The available methods to assign an IP address to a panel are:  
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o Manual definition of the address when the panel is in Configuration Mode 
o Definition of IP address from EH-View and UniDataExchanger when the panel is in 

Configuration Mode  
o Automatic assignment of IP address from DHCP server  
o Definition of IP address in the project file  

  
The IP address is a number in the usual form nnn.nnn.nnn.nnn where nnn is a number from 0 
to 255. 
  
Two parameters need to be defined by the user in addition to the IP address: 
  
Subnet Mask: it is a number in the form nnn.nnn.nnn.nnn where nnn is a number with value 
either 0 or 255 
  
Gateway IP: it is the address of the router that allows connection to other network segments. 
It is a number in the usual form nnn.nnn.nnn.nnn where nnn is a number from 0 to 255. 
  
A detailed description of these address input methods is given below. 
  
The EH-HMI show the IP address and the other Ethernet settings when it is in Configuration 
mode. 
  
The following is the information shown in panel when in Configuration Mode. 
  

 

Manual Definition of IP Address 

When the panel is in the Configuration Mode, the user can manually enter the value of the IP 
address and other network parameters. The activation of the manual address entry procedure 
depends on the type of the HMI. 
  
o Touchscreen 

 If the HMI has a touchscreen, just touch the address you want to edit. The HMI will 
show the address entry page. When the introduction is complete, confirm with the Enter 
button. The procedure can be aborted pressing the Clear button. 
  

o Keypad 
 If the HMI has a keypad, you can enter the address entry mode pressing the two arrow 
keys Up and Down at the same time. Pressing the two arrow keys multiple time will 
cycle the data entry focus through all the available parameters. When the introduction is 
complete, confirm with the Enter key. The procedure can be aborted pressing the Clear 
key 
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The new IP address (or Subnet Mask or Gateway IP) becomes immediately effective when 
the data entry is confirmed with Enter. 
  
The address assigned defined manually in Configuration Mode is persistent, once the IP 
address has been defined, it will be used by the panel until a new address is defined by the 
user. To remove a manually defined IP address, define the IP address 0.0.0.0. 
  
Note: Before assigning an IP address to the panel, make sure it is a unique address in the 
network. Duplicate IP addresses will cause network errors. 
  

Address Definition with Keypad 

The procedure to define manually an IP address using the keypad is the following: 
  
o Digits must be entered one by one 
o Use Up/Down arrow keys to select the value of each digit 
o Use Left/Right arrow keys to move from one digit to next 

  
Please remind that the maximum value for each element of the IP address is 255. There is no 
address consistency check in the manual IP address definition procedure. 
  

Definition of IP Address using Pick Panel in EH-View 

You can modify the IP address of the panel also using EH-View. 
  
Open the Pick Panel dialog box (you can use either the icon in the toolbar or the item Pick 
Panel in the Transfer menu) and select the Change IP Address Properties icon. 
  
Please refer Pick Panel: The Ethernet Control Panel for the detailed description of Pick Panel. 
  
The address assigned defined using Pick Panel in Configuration Mode is persistent: once the 
IP address has been defined, it will be used by the panel until a new address is defined with an 
higher priority address definition method. 
  
To remove an address defined with Pick Panel, enter the IP address 0.0.0.0 with Pick Panel or 
manually from the panel touchscreen/keypad. 
  

Assignment of IP Address from DHCP Server 

EH-HMI contains an implementation of the DHCP client protocol and can receive its IP 
address from a DHCP server, if this is present in the network.  
  
The panel will use the IP address assigned by the DHCP server unless another address has 
been defined using a method having higher priority than DHCP assignment. 
  
The address assigned by DHCP is persistent, that is, once the IP address has been assigned, it 
will be used by the panel even id the DHCP server is no longer present in the network. An IP 
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address assigned by DHCP can be canceled either defining an address using a method that has 
higher priority. 
  

Definition of IP Address in the Project File 

You can define the IP address of the panel in the project file. To define the IP address open 
Panel Setup and select the External Devices tab. 
  
The Ethernet Settings dialog box is shown in the figure below. 
  

 
  
Note that the IP address defined in the project file will be active only when the panel is in 
Operation Mode. 
  
When the panel will switch to Configuration Mode, it may change its IP address depending 
on previous settings. 
  
o IP Address 

 The current IP address of the panel. You can enter here an IP address in the form 
nnn.nnn.nnn.nnn where nnn is a number from 0 to 255. 
  

o Subnet Mask 
 It is a number in the form nnn.nnn.nnn.nnn where nnn is a number with value either 0 or 
255. 
  

o Default Gateway 
 it is the address of the router that allows connection to other network segments. It is a 
number in the usual form nnn.nnn.nnn.nnn where nnn is a number from 0 to 255. 

  
If you do not want to define an IP address in the project file, enter the IP Address 0.0.0.0 in 
the Ethernet Settings dialog box. If you do so, when the panel will be in Operation Mode, it 
will use either the address assigned by DHCP or the address defined manually by the user. 

Priority of IP Address Definition Methods 

There is a fixed priority scheme defining which IP address will be valid under all conditions. 
This priority scheme is necessary because there are multiple independent methods to define 
the IP address in the panel. 
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The EH-HMI panel will use the address that has been defined by the method with the highest 
priority, if present. 
  

 

Example 1 

A brand new panel with Ethernet interface is connected to a network that has a DHCP server. 
While the panel is in Configuration Mode it will receive the IP address by DHCP. The IP 
address assigned by DHCP will be shown on the display. 
  
If the user wants to change this address, or the Subnet Mask, can activate the IP address edit 
mode and enter the new address manually. 
  
Once the IP address has been defined manually, it will be persistent and will be maintained 
even when the power is cycled. 
  
The only way to reset the manual definition and return to DHCP is to enter the IP address 
0.0.0.0. 
  

Example 2 

A brand new panel with Ethernet interface is connected to a network that has no DHCP 
server.  While the panel is in Configuration Mode it will show the on the display the IP 
address 0.0.0.0. 
  
Start EH-View and recall the Pick Panel dialog box. 
  
The Pick Panel dialog box will show one panel in the list, the Physical Address will be 
present but there will be no IP Address. 
  
Select Change IP Address Properties and enter a valid IP Address. The new address will be 
define in the panel when you will press the confirmation button. 
  
Once the IP address has been defined by EH-View, it will be persistent and will be 
maintained even when the power is cycled. 
  
The only way to reset the manual definition and return to DHCP is to enter the IP address 
0.0.0.0. 
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7.14.2 Selecting Ethernet Communication in EH-View 

To select Ethernet communication in EH-View, select Transfer/Options and choose Ethernet 
Port as shown in the figure below. 
  

 
  
You can enter manually the IP address of the panel you want to connect to EH-View. If you 
do not know the IP address of the panel, open the Pick Panel dialog box and select one of the 
panels in the list. 
  
Note: If you want to communicate with a certain panel you must enter its IP address. Unlike 
the normal seria l communication between EH-View and panels, Ethernet connectivity allows 
you to have multiple panels networked with EH-View and you need to select the one you 
want to program. 

7.14.3 Pick Panel: The Ethernet Control Panel 

Pick Panel is the tool provided by EH-View to efficiently manage EH-HMI panels connected 
to an Ethernet network. Using Pick Panel you can: 
  
o Select one panel in the network 
o Change the IP address, the Subnet Mask and the Default Gateway of the panel you have 

selected 
o Change the mode of the panel from Configuration to Operation or from Operation to 

Configuration  
  

Selecting Panels in the Ethernet Network 

Pick Panel will search the network for EH-HMI panels and will show them in a list. Note that 
Pick Panel will not show all network nodes but only EH-HMI panels. 
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For each panel in the list, Pick Panel will show: 
  
o IP Address 

 It is the IP address assigned to the panel. If no IP address has been assigned to the panel, 
this field will show 0.0.0.0 

  
o Physical Address 

 It is the MAC identification number of the Ethernet interface in the panel. This is a fixed 
parameter and it is unique for each panel. 

  
o Hw 

 Hardware type of the panel. This is not enough to identify the panel model but it is a 
useful information. 

  
o Mode 

 Current operating mode of the panel. It can be either Configuration or Operation. 

Changing the Operating Mode of Panels 

Using Pick Panel you can change the operating mode of the panel you have selected. You 
can: 
  
o Switch to Configuration Mode 

 If the panel is in Operation Mode, it will be changed to Configuration Mode. This 
command is only available using Ethernet and is not available using serial 
communication with the panel. Changing the panel to Configuration Mode may take a 
few seconds. 

  
o Switch to Operation Mode 

 If the panel is in Configuration Mode and if it contains a valid project file, it will be 
changed to Operation Mode. Changing the panel to Operation Mode may take a few 
seconds. 
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Warning: Please note that the Switch to Configuration Mode command will work whatever is 
the current status of the panel. The panel will change to Configuration Mode even if it is 
showing alarms or even if it is in the middle of a data entry session. Special care is needed if 
the panel connected via Ethernet is not visible from the operator using the EH-View software 
and it all cases it is operating any kind of machinery. 
  

Definition of IP Address 

Pick Panel allows you to change online the IP address and its properties. From the Pick Panel 
dialog box, select the Change IP Address Properties icon. The dialog box shown in the figure 
below will appear. 
  

 
  
The dialog box includes the following elements: 
  
o Physical Address 

 MAC ID of the Ethernet hardware in the panel. This number cannot be changed by the 
user. 

  
o IP Address 

 The current IP address of the panel. You can enter here a new IP address in the form 
nnn.nnn.nnn.nnn where nnn is a number from 0 to 255. 

  
o Subnet Mask 

 it is a number in the form nnn.nnn.nnn.nnn where nnn is a number with value either 0 or 
255. 

  
o Default Gateway 

 it is the address of the router that allows connection to other network segments. It is a 
number in the usual form nnn.nnn.nnn.nnn where nnn is a number from 0 to 255. 

  
  
If you want to reset an IP address that has been defined manually in the pane, enter the IP 
Address 0.0.0.0 in the IP field in the dialog box. If you do so, the panel will use the IP address 
assigned by DHCP (if available) or the IP address eventually defined in the project file. 
  
The address assigned defined using Pick Panel in Configuration Mode is persistent: once the 
IP address has been defined, it will be used by the panel until a new address is defined with an 
higher priority address definition method. 
  
To remove an address defined with Pick Panel, enter the IP address 0.0.0.0 with Pick Panel or 
manually from the panel touchscreen/keypad. 
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7.14.4 Clock Synchronization with the SNTP Protocol 

EH-HMI supports the standard SNTP protocol for clock synchronization. 
  
If the network contains a time server, the panel will connect to the server and will synchronize 
its real time clock with the server.  
  
This is a simple and powerful method to ensure that all the clocks of the panels in the network 
are synchronized. 

7.14.5 Using UniDataExchanger  

UniDataExchanger is a simple but powerful tool that allows you to access data in the panels 
as well as downloading firmware updates. 
  
UniDataExchanger supports both Ethernet and serial communication, please note, however, 
that some options are only available if the panel is connected via Ethernet. 
  

Download Recipe Data 

This command is available both with serial and Ethernet connection. When the panel is 
connected via Ethernet, however, the command has been enhanced and recipe data can be 
transferred also when the panel is in Operation Mode. 
  

Upload Recipe Data 

This command is available both with serial and Ethernet connection. When the panel is 
connected via Ethernet, however, the command has been enhanced and recipe data can be 
transferred also when the panel is in Operation Mode. 
  

Upload Trend Data 

This command is available both with serial and Ethernet connection. When the panel is 
connected via Ethernet, however, the command has been enhanced and trend data can be 
transferred also when the panel is in Operation Mode. 
  

Upload Event List 

The command Upload Event List allows UniDataExchanger to retrieve the Event List from 
the panel. 
  
o This command is available only with the Ethernet connection. 
o The Event List data will be saved to a disk file in .csv format. 
o The content of the file will be as shown in the figure below. 
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Upload Alarm List 

The command Upload Alarm List allows UniDataExchanger to retrieve the Alarm List from 
the panel.  
  
o This command is available only with the Ethernet connection. 
o The Alarm List data will be saved to a disk file in .csv format. 
o The content of the file will be as shown in the figure below. 

  

 
  
The following is the meaning of the various fields.  
  
Static Flags 
Attribute of alarms as defined in the project file.  
  
ALUSED 
Alarm Enabled 
  
ALCLR 
Alarm requires acknowledgement 
  
ALPRON 
Print Alarm on Event 
  
ALPROF 
Print Alarm off Event 
  
ALPRAC 
Print Alarms Acknowledgement. 
  
ALWARN 
"Message Only Alarm" (does not turn on Alarm LED) 
  
ALLOGEV 
Events for this alarm  
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Dynamic Flags 
Current Status of the alarm at the moment of the upload. 
  
ALON 
Alarm is ON 
  
ALACK 
Alarm requires Acknowledgement. 
  
ALSILENT 
Silent Alarm (set for "events only" alarms) 
  
On time 
Time when the alarm went on. 
  
Off time 
Time when the alarm went off. 
  
Value 
Not used 
  
Link Flags 
Specifies if the alarm is linked to an help screen. 
  
0 
Alarm non linked to alarm page 
  
1 
Alarm linked to alarm page 
  
Log Flags 
Not used 
  
Fg/Bg Colors 
Foreground/Background colors defined for the alarm, 00/00 means no colors used.  
  
Fg/Bg ACK colors 
Foreground/Background colors defined for the alarm when acknowledge is required,  00/00 
means no colors used. 
  

Selecting Ethernet Communication in UniDataExchanger 

To select Ethernet communication in UniDataExchanger, select Options > Communication 
and choose Ethernet Port as shown in the figure below. 
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You can enter manually the IP address of the panel you want to connect to 
UniDataExchanger. If you do not know the IP address of the panel, open the Pick Panel 
dialog box and select one of the panels in the list. 
  
Note: If you want to communicate with a certain panel you must enter its IP address. Unlike 
the normal serial communication between UniDataExchanger and panels, Ethernet 
connectivity allows you to have multiple panels networked with UniDataExchanger and you 
need to select the one you want to connect. 

7.14.6 Basic Ethernet Diagnostic with Ping 

EH-HMI supports the Ping protocol as a very simple network diagnostic method. 
  
Just enter the Ping command, followed by the IP address of the panel, from any node in the 
network. If the panel can be reached, it will respond to Ping. 
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